kdebindings-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720
  1. %define csharp 1
  2. %define falcon 0
  3. %define php 1
  4. %define ruby 1
  5. %define smoke 1
  6. %define java 0
  7. %define pykde4_akonadi 1
  8. %define pyqt4_version 4.7
  9. # Qt4 version auto-detection -- inagaki
  10. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
  11. %define mono_dir %{_prefix}/lib/mono
  12. #if 0%{?ruby}%{?smoke}
  13. #define devel 1
  14. #endif
  15. %global ruby_lib %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')
  16. %global ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
  17. %global ruby_sitelib %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
  18. %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  19. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  20. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  21. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  22. Name: kdebindings
  23. Summary: KDE bindings to non-C++ languages.
  24. Summary(ja): C++ 言語以外の KDE バインディング集
  25. Version: 4.6.4
  26. Release: 1%{?_dist_release}
  27. # http://techbase.kde.org/Policies/Licensing_Policy
  28. License: LGPLv2+
  29. Group: System Environment/Libraries
  30. URL: http://www.kde.org/
  31. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebindings-%{version}.tar.bz2
  32. ## upstreamable patches
  33. Patch50: kdebindings-4.5.1-RUBY_VERSION.patch
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: akonadi-devel >= 1.4.0
  36. BuildRequires: kdebase-workspace-devel >= %{version}
  37. # okular bindings
  38. BuildRequires: kdegraphics4-devel >= %{version}
  39. BuildRequires: kdelibs4-devel >= %{version}
  40. BuildRequires: kdepimlibs-devel >= %{version}
  41. BuildRequires: kdesdk-devel >= %{version}
  42. # kdebindings does not support polkit-qt-1 yet
  43. %if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
  44. BuildRequires: polkit-qt-devel
  45. %endif
  46. BuildRequires: python-devel
  47. BuildRequires: PyQt4-devel >= %{pyqt4_version}
  48. BuildRequires: qimageblitz-devel
  49. BuildRequires: qscintilla-devel >= 2.4
  50. BuildRequires: soprano-devel
  51. %if %{csharp}
  52. BuildRequires: mono-core
  53. BuildRequires: mono-devel
  54. %endif
  55. %if %{falcon}
  56. BuildRequires: Falcon-devel >= 0.8.12
  57. %endif
  58. %if %{php}
  59. BuildRequires: php5-devel
  60. %endif
  61. %if %{ruby}
  62. BuildRequires: ruby-devel
  63. BuildRequires: ruby
  64. %endif
  65. %if %{java}
  66. # TODO: kross-java is a mess, not sure what it needs to build
  67. # CMakeLists.txt is also not portable (only gcj and i486 hardcoded)
  68. # -- mathstuf
  69. BuildRequires: java-1.6.0-openjdk-devel
  70. %endif
  71. Requires: kdelibs4 >= %{version}
  72. Conflicts: kdebindings < 4
  73. %description
  74. KDE bindings to non-C++ languages
  75. %description -l ja
  76. C++ 言語以外の KDE バインディング集です.
  77. %package devel
  78. Summary: Development files for kdebindings.
  79. Summary(ja): kdebindings の開発用ファイル
  80. Group: Development/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: kdelibs4-devel
  83. Conflicts: kdebindings-devel < 4
  84. %description devel
  85. Development files for the KDE bindings.
  86. Install kdebindings-devel if you want to develop non-KDE applications
  87. that talk to KDE.
  88. %package -n PyKDE4
  89. Summary: Python bindings for KDE4
  90. Summary(ja): KDE4 の Python バインディング
  91. Group: Development/Languages
  92. Requires: kdelibs4 >= %{version}
  93. Requires: PyQt4 >= %{pyqt4_version}
  94. %description -n PyKDE4
  95. %{summary}.
  96. %package -n PyKDE4-akonadi
  97. Summary: Akonadi runtime support for PyKDE4
  98. Summary(ja): PyKDE4 の Akonadi サポート
  99. Group: Development/Languages
  100. Requires: PyKDE4 = %{version}-%{release}
  101. Requires: kdepimlibs-akonadi >= %{version}
  102. %description -n PyKDE4-akonadi
  103. %{summary}.
  104. %package -n PyKDE4-devel
  105. Summary: Files needed to build PyKDE4-based applications
  106. Summary(ja): PyKDE4 を使用するアプリケーションのビルドに必要なファイル集
  107. Group: Development/Libraries
  108. Requires: PyQt4-devel
  109. Requires: PyKDE4 = %{version}-%{release}
  110. Requires: PyKDE4-akonadi = %{version}-%{release}
  111. %description -n PyKDE4-devel
  112. %{summary}.
  113. # C# bindings
  114. %if %{csharp}
  115. %package -n kimono
  116. Summary: C# bindings for KDE4
  117. Summary(ja): KDE4 の C# バインディング
  118. Group: Development/Languages
  119. Requires: kdelibs4 >= %{version}
  120. Requires: qyoto = %{version}-%{release}
  121. Provides: kimono4 = %{version}-%{release}
  122. %description -n kimono
  123. %{summary}.
  124. %package -n qyoto
  125. Summary: C# bindings for Qt4
  126. Summary(ja): Qt4 の C# バインディング
  127. Group: Development/Languages
  128. Requires: qt4 >= %{qt4_version}
  129. Provides: qyoto4 = %{version}-%{release}
  130. %description -n qyoto
  131. %{summary}.
  132. %package -n qyoto-devel
  133. Summary: Development files for qyoto
  134. Summary(ja): qyoto の開発用ファイル
  135. Group: Development/Libraries
  136. Requires: qyoto = %{version}-%{release}
  137. Requires: mono-devel
  138. Provides: qyoto4-devel = %{version}-%{release}
  139. %description -n qyoto-devel
  140. %{summary}.
  141. %endif
  142. # Ruby
  143. %if %{ruby}
  144. %package -n korundum
  145. Summary: Ruby bindings for KDE4
  146. Summary(ja): KDE4 の Ruby バインディング
  147. Group: Development/Languages
  148. Requires: kdelibs4 >= %{version}
  149. Requires: QtRuby = %{version}-%{release}
  150. Provides: korundum4 = %{version}-%{release}
  151. %description -n korundum
  152. %{summary}.
  153. %package -n korundum-devel
  154. Summary: Development files for korundum
  155. Summary(ja): korundum の開発用ファイル
  156. Group: Development/Libraries
  157. Requires: QtRuby-devel
  158. Requires: korundum = %{version}-%{release}
  159. Provides: korundum4-devel = %{version}-%{release}
  160. %description -n korundum-devel
  161. %{summary}.
  162. %package -n QtRuby
  163. Summary: Ruby bindings for Qt4
  164. Summary(ja): Qt4 の Ruby バインディング
  165. Group: Development/Languages
  166. Requires: qt4 >= %{qt4_version}
  167. Provides: QtRuby4 = %{version}-%{release}
  168. %description -n QtRuby
  169. %{summary}.
  170. %package -n QtRuby-devel
  171. Summary: Development files for QtRuby
  172. Summary(ja): QtRuby の開発用ファイル
  173. Group: Development/Libraries
  174. Requires: QtRuby = %{version}-%{release}
  175. Provides: QtRuby4-devel = %{version}-%{release}
  176. %description -n QtRuby-devel
  177. %{summary}.
  178. %endif
  179. %if %{php}
  180. %package -n php-qt
  181. Summary: PHP bindings for Qt4
  182. Summary(ja): Qt4 の PHP バインディング
  183. Group: Development/Languages
  184. Requires: qt4 >= %{qt4_version}
  185. Provides: php-qt4 = %{version}-%{release}
  186. %description -n php-qt
  187. %{summary}.
  188. %package -n php-qt-devel
  189. Summary: Development files for php-qt
  190. Summary(ja): php-qt の開発用ファイル
  191. Group: Development/Libraries
  192. Requires: php-qt = %{version}-%{release}
  193. Provides: php-qt4-devel = %{version}-%{release}
  194. %description -n php-qt-devel
  195. %{summary}.
  196. %endif
  197. %package -n kross-python
  198. Summary: Kross plugin for python
  199. Summary(ja): Python 向け Kross プラグイン
  200. Group: Development/Languages
  201. Requires: kdelibs4 >= %{version}
  202. Provides: kross(python) = %{version}-%{release}
  203. %description -n kross-python
  204. Python plugin for the Kross archtecture in KDE4.
  205. %description -n kross-python -l ja
  206. KDE 4 の Kross アーキテクチャ向け python プラグインです.
  207. %if %{ruby}
  208. %package -n kross-ruby
  209. Summary: Kross plugin for ruby
  210. Summary(ja): Ruby 向け Kross プラグイン
  211. Group: Development/Languages
  212. Requires: ruby
  213. Requires: kdelibs4 >= %{version}
  214. Provides: kross(ruby) = %{version}-%{release}
  215. %description -n kross-ruby
  216. Ruby plugin for the Kross archtecture in KDE4.
  217. %description -n kross-ruby -l ja
  218. KDE 4 の Kross アーキテクチャ向け ruby プラグインです.
  219. %endif
  220. %if %{falcon}
  221. %package -n kross-falcon
  222. Summary: Kross plugin for falcon
  223. Summary(ja): Falcon 向け Kross プラグイン
  224. Group: Development/Languages
  225. Requires: Falcon >= 0.8.12
  226. Requires: kdelibs4 >= %{version}
  227. Provides: kross(falcon) = %{version}-%{release}
  228. %description -n kross-falcon
  229. Falcon plugin for the Kross archtecture in KDE4.
  230. %description -n kross-falcon -l ja
  231. KDE 4 の Kross アーキテクチャ向け falcon プラグインです.
  232. %endif
  233. %prep
  234. %setup -q -n kdebindings-%{version}
  235. #patch50 -p1 -b .RUBY_VERSION
  236. %build
  237. mkdir -p %{_target_platform}
  238. pushd %{_target_platform}
  239. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  240. %cmake \
  241. -DCMAKE_BUILD_TYPE=release \
  242. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  243. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  244. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  245. -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
  246. -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
  247. -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
  248. %if %{csharp}
  249. -DENABLE_QYOTO=ON \
  250. %else
  251. -DBUILD_csharp=OFF \
  252. %endif
  253. %if %{falcon}
  254. -DENABLE_KROSSFALCON=ON \
  255. %else
  256. -DBUILD_falcon=OFF \
  257. %endif
  258. %if %{php}
  259. -DENABLE_PHP-QT=ON \
  260. %else
  261. -DBUILD_php=OFF \
  262. %endif
  263. %if %{ruby}
  264. -DRUBY_SITE_LIB_DIR:PATH=%{ruby_sitelib} \
  265. -DRUBY_SITE_ARCH_DIR:PATH=%{ruby_sitearch} \
  266. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
  267. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
  268. %else
  269. -DBUILD_ruby=OFF \
  270. %endif
  271. %if %{smoke}
  272. -DENABLE_SMOKE=ON \
  273. -DDISABLE_Attica=TRUE \
  274. %else
  275. -DBUILD_smoke=OFF \
  276. %endif
  277. %if %{java}
  278. -DENABLE_KROSSJAVA=ON \
  279. %else
  280. -DBUILD_java=OFF \
  281. %endif
  282. -DCMAKE_SKIP_RPATH:BOOL=OFF \
  283. -DBUILD_perl=OFF \
  284. ..
  285. popd
  286. # -DRUBY_INCLUDE_PATH:PATH=%{ruby_arch} \
  287. # smp build not recommended (upstream)
  288. make -C %{_target_platform}
  289. %install
  290. rm -rf $RPM_BUILD_ROOT
  291. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  292. # HACK: fix multilb conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
  293. rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  294. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
  295. $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  296. ln -s %{_bindir}/pykdeuic4 \
  297. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
  298. # install pykde4 examples under correct dir
  299. #mkdir -p %{buildroot}%{_docdir}
  300. #rm -f %{buildroot}%{_datadir}/kde4/apps/pykde4/examples/*.py?
  301. #mv %{buildroot}%{_datadir}/kde4/apps/pykde4 %{buildroot}%{_docdir}/
  302. # bz#551534 - qyoto doesn't pull mono in
  303. %if %{csharp}
  304. find %{buildroot} -name \*.dll -not -type l | xargs chmod ugo+x
  305. %endif
  306. %clean
  307. rm -rf $RPM_BUILD_ROOT
  308. %post -p /sbin/ldconfig
  309. %postun -p /sbin/ldconfig
  310. %pre -n PyKDE4-devel
  311. if [ -d %{_bindir}/pykdeuic4 ]; then
  312. rm -rf %{_bindir}/pykdeuic4/
  313. fi
  314. %if %{csharp}
  315. %post -n qyoto -p /sbin/ldconfig
  316. %postun -n qyoto -p /sbin/ldconfig
  317. %endif
  318. %files
  319. %defattr(-,root,root)
  320. %doc AUTHORS ChangeLog COPYING NEWS README
  321. %if %{smoke}
  322. %{_libdir}/libsmoke*.so.*
  323. %endif
  324. %files devel
  325. %defattr(-,root,root)
  326. %if %{smoke}
  327. %{_bindir}/smoke*
  328. %{_includedir}/smoke.h
  329. %{_includedir}/smoke
  330. %{_includedir}/smokegen
  331. %{_libdir}/libcppparser.so
  332. %{_libdir}/libsmoke*.so
  333. %dir %{_libdir}/smokegen
  334. %{_libdir}/smokegen/*.so
  335. %{_datadir}/smokegen
  336. %endif
  337. %files -n PyKDE4
  338. %defattr(-,root,root,-)
  339. %doc COPYING
  340. %{python_sitearch}/PyKDE4
  341. %{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
  342. %dir %{_datadir}/kde4/apps/pykde4
  343. %{_libdir}/kde4/kpythonpluginfactory.so
  344. %exclude %{python_sitearch}/PyKDE4/akonadi.so
  345. %files -n PyKDE4-akonadi
  346. %defattr(-,root,root,-)
  347. %{python_sitearch}/PyKDE4/akonadi.so
  348. %files -n PyKDE4-devel
  349. %defattr(-,root,root,-)
  350. %{_bindir}/pykdeuic4
  351. %{python_sitearch}/PyQt4/uic/pykdeuic4.py*
  352. %{_datadir}/kde4/apps/pykde4/examples/
  353. %{_datadir}/sip/PyKDE4
  354. %if %{csharp}
  355. %files -n kimono
  356. %defattr(-,root,root,-)
  357. %{_libdir}/kde4/kimonopluginfactory.so
  358. %{_libdir}/libakonadi-sharp.so
  359. %{_libdir}/libkhtml-sharp.so
  360. %{_libdir}/libkimono.so
  361. %{_libdir}/libktexteditor-sharp.so
  362. %{_libdir}/libnepomuk-sharp.so
  363. %{_libdir}/libphonon-sharp.so
  364. %{_libdir}/libplasma-sharp.so
  365. %{_libdir}/libqimageblitz-sharp.so
  366. %{_libdir}/libqscintilla-sharp.so
  367. %{_libdir}/libsoprano-sharp.so
  368. %{mono_dir}/qyoto/qimageblitz.dll
  369. %{mono_dir}/qyoto/akonadi.dll
  370. %{mono_dir}/qyoto/kde-dotnet.dll
  371. %{mono_dir}/qyoto/khtml-dll.dll
  372. %{mono_dir}/qyoto/ktexteditor-dotnet.dll
  373. %{mono_dir}/qyoto/nepomuk-dll.dll
  374. %{mono_dir}/qyoto/phonon.dll
  375. %{mono_dir}/qyoto/plasma-dll.dll
  376. %{mono_dir}/qyoto/qscintilla.dll
  377. %{mono_dir}/qyoto/soprano.dll
  378. %{mono_dir}/gac/akonadi
  379. %{mono_dir}/gac/kde-dotnet
  380. %{mono_dir}/gac/khtml-dll
  381. %{mono_dir}/gac/ktexteditor-dotnet
  382. %{mono_dir}/gac/nepomuk-dll
  383. %{mono_dir}/gac/phonon
  384. %{mono_dir}/gac/plasma-dll
  385. %{mono_dir}/gac/qscintilla
  386. %{mono_dir}/gac/soprano
  387. %{mono_dir}/gac/qimageblitz
  388. %{_datadir}/kde4/apps/plasma_scriptengine_kimono
  389. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  390. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  391. %files -n qyoto
  392. %defattr(-,root,root,-)
  393. %{_libdir}/libqtscript-sharp.so
  394. %{_libdir}/libqttest-sharp.so
  395. %{_libdir}/libqtuitools-sharp.so
  396. %{_libdir}/libqtwebkit-sharp.so
  397. %{_libdir}/libqyoto.so.*
  398. %{mono_dir}/qyoto/qt-dotnet.dll
  399. %{mono_dir}/qyoto/qtscript.dll
  400. %{mono_dir}/qyoto/qttest.dll
  401. %{mono_dir}/qyoto/qtuitools.dll
  402. %{mono_dir}/qyoto/qtwebkit.dll
  403. %{mono_dir}/gac/qt-dotnet
  404. %{mono_dir}/gac/qtscript
  405. %{mono_dir}/gac/qttest
  406. %{mono_dir}/gac/qtuitools
  407. %{mono_dir}/gac/qtwebkit
  408. %files -n qyoto-devel
  409. %defattr(-,root,root,-)
  410. %{_bindir}/csrcc
  411. %{_bindir}/uics
  412. %{_includedir}/qyoto
  413. %{_libdir}/libqyoto.so
  414. %{_libdir}/pkgconfig/*
  415. %endif
  416. %if %{ruby}
  417. %files -n korundum
  418. %defattr(-,root,root,-)
  419. %{_bindir}/krubyapplication
  420. %{ruby_lib}/KDE/
  421. %{ruby_lib}/akonadi/
  422. %{ruby_lib}/khtml/
  423. %{ruby_lib}/kio/
  424. %{ruby_lib}/ktexteditor/
  425. %{ruby_lib}/okular/
  426. %{ruby_lib}/phonon/
  427. %{ruby_lib}/qscintilla/
  428. %{ruby_lib}/solid/
  429. %{ruby_lib}/soprano/
  430. %{ruby_lib}/nepomuk/
  431. %{ruby_arch}/akonadi.so
  432. %{ruby_arch}/kate.so
  433. %{ruby_arch}/khtml.so
  434. %{ruby_arch}/kio.so
  435. %{ruby_arch}/korundum4.so
  436. %{ruby_arch}/ktexteditor.so
  437. %{ruby_arch}/okular.so
  438. %{ruby_arch}/phonon.so
  439. %{ruby_arch}/plasma_applet.so
  440. %{ruby_arch}/solid.so
  441. %{ruby_arch}/soprano.so
  442. %{ruby_arch}/nepomuk.so
  443. %{ruby_arch}/qscintilla.so
  444. %{_libdir}/kde4/krubypluginfactory.so
  445. %{_datadir}/applications/kde4/dbpedia_references.desktop
  446. %{_datadir}/kde4/apps/dbpedia_references
  447. %files -n korundum-devel
  448. %defattr(-,root,root,-)
  449. %{_bindir}/rbkconfig_compiler4
  450. %{_includedir}/qtruby/
  451. %exclude %{_libdir}/libqtruby4shared.so
  452. %files -n QtRuby
  453. %defattr(-,root,root,-)
  454. %{ruby_lib}/Qt/
  455. %{ruby_lib}/Qt*.rb
  456. %{ruby_lib}/qtdeclarative/
  457. %{ruby_lib}/qtscript/
  458. %{ruby_lib}/qttest/
  459. %{ruby_lib}/qtuitools/
  460. %{ruby_lib}/qtwebkit/
  461. %{ruby_arch}/qt*.so
  462. %{_libdir}/libqtruby4shared.so.2
  463. %{_libdir}/libqtruby4shared.so.2.0.0
  464. %files -n QtRuby-devel
  465. %defattr(-,root,root,-)
  466. %{_bindir}/rbqtapi
  467. %{_bindir}/rbrcc
  468. %{_bindir}/rbuic4
  469. %{_libdir}/libqtruby4shared.so
  470. %endif
  471. %if %{php}
  472. %files -n php-qt
  473. %defattr(-,root,root,-)
  474. %{_libdir}/php5/php_qt.so
  475. %files -n php-qt-devel
  476. %defattr(-,root,root,-)
  477. %{_bindir}/phpuic
  478. %endif
  479. %files -n kross-python
  480. %defattr(-,root,root,-)
  481. # unversioned library
  482. %{_libdir}/kde4/krosspython.so
  483. %if %{ruby}
  484. %files -n kross-ruby
  485. %defattr(-,root,root,-)
  486. %{_libdir}/kde4/krossruby.so
  487. %endif
  488. %if %{falcon}
  489. %files -n kross-falcon
  490. %defattr(-,root,root,-)
  491. %{_libdir}/kde4/krossfalcon.so
  492. %endif
  493. %changelog
  494. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  495. - new upstream release
  496. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  497. - updated to 4.6.1
  498. - added BR: kdesdk-devel
  499. - disabled attica plugins temporaly
  500. - rebuilt with mono-2.10.1
  501. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  502. - rebuilt with rpm-4.8.1 for pkg-config
  503. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  504. - new upstream release
  505. - added Patch50
  506. - added more japanese summaries
  507. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  508. - new upstream release
  509. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  510. - new upstream release
  511. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  512. - new upstream release
  513. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  514. - new upstream release
  515. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  516. - new upstream release
  517. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  518. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  519. - built with new toolchain
  520. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  521. - new upstream release
  522. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  523. - merged 4.3.1-2 %changelog
  524. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  525. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  526. - use %%{_prefix}/lib for mono-dll (for x86_64)
  527. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  528. - new upstream release
  529. - built with PyQt4-4.6
  530. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  531. - define %%{mono_dir} to specify mono library install path
  532. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  533. - new upstream release
  534. - fixed ruby modules installation path
  535. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  536. - new upstream release
  537. - spilt sub package based on Fedora
  538. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  539. - applied new versioning policy
  540. - added Patch1
  541. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  542. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  543. - added --with-qt-libraries option
  544. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  545. - rebuild for VineSeed
  546. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  547. - new upstream release
  548. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  549. - rebuild for VineSeed
  550. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  551. - new upstream release
  552. - update Patch0
  553. - drop Patch1
  554. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  555. - new upstream release
  556. - add Patch1
  557. - add --enable-libsuffix option
  558. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  559. - rebuild for VineSeed
  560. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  561. - new upstream release
  562. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  563. - rebuild for VineSeed
  564. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  565. - new upstream release
  566. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  567. - rebuild for VineSeed
  568. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  569. - new upstream release
  570. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  571. - rebuild for VineSeed
  572. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  573. - new upstream release
  574. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  575. - rebuild for VineSeed
  576. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  577. - new upstream release
  578. - renew BuildPrereq and build section
  579. - renew %%files
  580. - enable python
  581. - change spec to make main and devel package
  582. - add BuildPrereq: ruby ruby-devel
  583. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  584. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  585. - build for VineSeed
  586. - disable python and mozilla
  587. - objprelink (i386 only)
  588. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  589. - 2.2.2
  590. - build kmozilla binding only on x86/alpha
  591. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  592. - Make sure %%{name}-kmozilla isn't built on ia64
  593. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  594. - Move python bindings to separate package
  595. - Add perl bindings
  596. - Shut up rpmlint
  597. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  598. - 2.1
  599. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  600. - initial RPM