ffmpeg-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. #% define enable_avconv 1
  8. %global prebuild_doc 1
  9. %global major_version 1.2
  10. Summary: Digital VCR and streaming server
  11. Name: ffmpeg
  12. Version: %{major_version}.3
  13. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  14. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  15. ## prebuilt man pages
  16. %{?prebuild_doc:Source10: %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz}
  17. %if 0%{?_with_amr:1}
  18. License: GPLv3+
  19. %else
  20. License: GPLv2+
  21. %endif
  22. Group: Applications/Multimedia
  23. URL: http://ffmpeg.org/
  24. BuildRequires: bzip2-devel
  25. BuildRequires: celt-devel
  26. ##BuildRequires: dirac-devel
  27. BuildRequires: freetype2-devel
  28. ##BuildRequires: frei0r-devel
  29. BuildRequires: gnutls-devel
  30. BuildRequires: gsm-devel
  31. BuildRequires: imlib2-devel
  32. BuildRequires: libdc1394-devel
  33. BuildRequires: libogg-devel
  34. BuildRequires: libass-devel
  35. %{!?_without_cdio:BuildRequires: libcdio-devel}
  36. #libcrystalhd is currently broken
  37. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  38. BuildRequires: libraw1394-devel
  39. BuildRequires: librtmp-devel >= 2.3
  40. BuildRequires: libtheora-devel
  41. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  42. BuildRequires: libvdpau-devel
  43. BuildRequires: libvorbis-devel
  44. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.7}
  45. BuildRequires: libXvMC-devel
  46. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  47. %{!?_without_openal:BuildRequires: openal-soft-devel}
  48. %{?_with_opencv:BuildRequires: opencv-devel}
  49. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  50. ##BuildRequires: schroedinger-devel
  51. BuildRequires: SDL-devel
  52. BuildRequires: speex-devel
  53. ##BuildRequires: texi2html
  54. BuildRequires: zlib-devel
  55. BuildRequires: yasm
  56. # *-devel packages provided by other self-build-* should only be listed
  57. # in self-build-%{name}.spec as PreReq.
  58. #BuildRequires: a52dec-devel
  59. #BuildRequires: faac-devel
  60. #BuildRequires: lame-devel
  61. #BuildRequires: libdca-devel
  62. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  63. #BuildRequires: xvidcore-devel
  64. Requires: %{name}-libs = %{version}-%{release}
  65. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  66. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  67. %description
  68. FFMpeg is a complete and free Internet live audio and video
  69. broadcasting solution for Linux/Unix. It also includes a digital
  70. VCR. It can encode in real time in many formats including MPEG1 audio
  71. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  72. %package libs
  73. Summary: Libraries for %{name}
  74. Group: System Environment/Libraries
  75. %description libs
  76. FFMpeg is a complete and free Internet live audio and video
  77. broadcasting solution for Linux/Unix. It also includes a digital
  78. VCR. It can encode in real time in many formats including MPEG1 audio
  79. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  80. This package contains the libraries for %{name}.
  81. %package devel
  82. Summary: Development package for %{name}
  83. Group: Development/Libraries
  84. Requires: %{name}-libs = %{version}-%{release}
  85. Requires: pkgconfig
  86. %description devel
  87. FFMpeg is a complete and free Internet live audio and video
  88. broadcasting solution for Linux/Unix. It also includes a digital
  89. VCR. It can encode in real time in many formats including MPEG1 audio
  90. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  91. This package contains development files for %{name}.
  92. %prep
  93. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  94. %{?prebuild_doc:%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1}
  95. %build
  96. %ifarch ppc
  97. # compile with -mlongcall on ppc/ppc64 (rf804)
  98. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  99. %endif
  100. ./configure \
  101. --prefix=%{_prefix} \
  102. --incdir=%{_includedir}/%{name} \
  103. --shlibdir=%{_libdir} \
  104. --libdir=%{_libdir} \
  105. --mandir=%{_mandir} \
  106. --arch=%{_target_cpu} \
  107. %ifarch %{ix86}
  108. --cpu=%{_target_cpu} \
  109. %endif
  110. %ifarch ppc
  111. --cpu=g3 \
  112. --enable-pic \
  113. %endif
  114. --enable-runtime-cpudetect \
  115. --extra-cflags="$RPM_OPT_FLAGS" \
  116. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  117. --enable-bzlib \
  118. %{!?_with_crystalhd:--disable-crystalhd} \
  119. --enable-zlib \
  120. %{?_with_frei0r:--enable-frei0r} \
  121. --enable-gnutls \
  122. --enable-libass \
  123. %{!?_without_cdio:--enable-libcdio} \
  124. --enable-libcelt \
  125. --enable-libdc1394 \
  126. %{?_with_libdirac:--enable-libdirac} \
  127. %{?with_faac:--enable-libfaac --enable-nonfree} \
  128. --enable-libfreetype \
  129. --enable-libgsm \
  130. --enable-libmp3lame \
  131. %{!?_without_openal:--enable-openal} \
  132. %{?_with_opencv:--enable-libopencv} \
  133. %{?_with_openjpeg:--enable-libopenjpeg} \
  134. --enable-librtmp \
  135. --enable-libspeex \
  136. --enable-libtheora \
  137. --enable-libvorbis \
  138. %{?with_libvpx:--enable-libvpx} \
  139. --enable-libx264 \
  140. --enable-libxvid \
  141. \
  142. --enable-x11grab \
  143. --enable-avfilter \
  144. --enable-postproc \
  145. --enable-pthreads \
  146. --disable-static \
  147. --enable-shared \
  148. --enable-gpl \
  149. %{?prebuild_doc:--disable-doc} \
  150. --disable-debug \
  151. --disable-stripping \
  152. \
  153. %{?enable_avconv:--enable-avconv} \
  154. ;
  155. %__make %{?_smp_mflags}
  156. %__make alltools
  157. %install
  158. %__make install DESTDIR=$RPM_BUILD_ROOT
  159. ## install tool/qt-faststart
  160. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  161. ## install man
  162. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  163. %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  164. %clean
  165. %{__rm} -rf $RPM_BUILD_ROOT
  166. %post libs -p /sbin/ldconfig
  167. %postun libs -p /sbin/ldconfig
  168. %files
  169. %defattr(-,root,root,-)
  170. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  171. %{?enable_avconv:%{_bindir}/avconv}
  172. %{_bindir}/ffmpeg
  173. %{_bindir}/ffplay
  174. %{_bindir}/ffprobe
  175. %{_bindir}/ffserver
  176. %{_bindir}/qt-faststart
  177. %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  178. %{_mandir}/man1/ffmpeg.1*
  179. %{_mandir}/man1/ffplay.1*
  180. %{_mandir}/man1/ffprobe.1*
  181. %{_mandir}/man1/ffserver.1*
  182. %{_datadir}/ffmpeg
  183. %files libs
  184. %defattr(-,root,root,-)
  185. %{_libdir}/lib*.so.*
  186. %files devel
  187. %defattr(-,root,root,-)
  188. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  189. %{_includedir}/ffmpeg
  190. %{_libdir}/pkgconfig/lib*.pc
  191. %{_libdir}/lib*.so
  192. %changelog
  193. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
  194. - new upstream release
  195. * Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
  196. - new upstream release
  197. - added man pages
  198. - added Source10: ffmpeg-1.2.1-doc.tar.xz
  199. * Thu Apr 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  200. - new upstream release
  201. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  202. - new upstream release
  203. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  204. - libvpx >= 0.9.7
  205. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  206. - new upstream release /x264-0.129
  207. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  208. - new upstream release
  209. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  210. - new upstream release
  211. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  212. - new upstream release
  213. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  214. - new upstream release
  215. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  216. - new upstream release
  217. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  218. - new upstream release
  219. - enable CELT decoding via libcelt
  220. - enable FreeType support
  221. - drop faad2 support (dropped upstream)
  222. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  223. - change release to sync with self-build-ffmpeg-vl.spec
  224. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  225. - new upstream release
  226. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  227. - new upstream release
  228. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  229. - required latest x264 build
  230. - added BuildRequires: librtmp-devel >= 2.3
  231. - build PIC objects on PPC
  232. #- add qt-faststart tool
  233. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  234. - new upstream release
  235. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  236. - change release to sync with self-build-ffmpeg-vl.spec
  237. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  238. - added BuildRequires: libvpx-devel >= 0.9.1
  239. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  240. - new upstream release
  241. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  242. - bumped version to pre-0.6
  243. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  244. - updated source snapshot 20100410
  245. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  246. - change release to sync with self-build-ffmpeg-vl.spec
  247. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  248. - change release to sync with self-build-ffmpeg-vl.spec
  249. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  250. - updated source snapshot 20100401
  251. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  252. - updated source snapshot 20100326
  253. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  254. - change release to sync with self-build-ffmpeg
  255. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  256. - updated source snapshot 20100216
  257. - rebuild with recent x264-devel
  258. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  259. - added BuildRequires: libvdpau-devel
  260. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  261. - change release to sync with self-build-ffmpeg
  262. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  263. - change release to sync with self-build-ffmpeg
  264. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  265. - applied ffmpeg-0.5-disable-texi2html.patch
  266. - dropped BuildRequires: texi2html
  267. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  268. - change release to sync with self-build-ffmpeg
  269. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  270. - corrected release number
  271. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  272. - new upstream release
  273. - added BuildRequires:
  274. - speex-devel
  275. - bzip2-devel
  276. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  277. - 20090227 snapshot
  278. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  279. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  280. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  281. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  282. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  283. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  284. - 20090202 snapshot
  285. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  286. - 20090110 snapshot
  287. - dropped some patches
  288. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  289. - source updated (r15488)
  290. - fixed License: GPLv2+
  291. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  292. - added BuildRequires: yasm (only %%ix86)
  293. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  294. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  295. - spec in utf8
  296. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  297. - change release to sync with self-build-ffmpeg
  298. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  299. - drop "Patch100: ffmpeg-vine.patch".
  300. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  301. - build with new versioning policy
  302. - change to use svn export from svn checkout on post install
  303. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  304. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  305. - [self-build-ffmpeg.spec]
  306. For all pre-required package that is provied by self-build,
  307. changed to its self-build package
  308. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  309. - initial build for Vine Linux 4.2
  310. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  311. ### end of file