mjpegtools-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. # -*- coding: utf-8-unix -*-
  2. Name: mjpegtools
  3. Version: 2.0.0
  4. Release: 3%{?_dist_release}
  5. Summary: Tools to manipulate MPEG data
  6. Summary(ja): MPEG データを操作するツール集
  7. Group: Applications/Multimedia
  8. License: GPLv2
  9. URL: http://mjpeg.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
  11. Patch0: mjpegtools-2.0.0-no-config-in-public-header.h
  12. Patch1: mjpegtools_gcc470.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Obsoletes: mjpegtools < %{version}, mjpegtools-devel < %{version}
  15. BuildRequires: libjpeg-devel
  16. BuildRequires: nasm
  17. BuildRequires: libdv-devel
  18. BuildRequires: SDL-devel >= 1.1.3
  19. BuildRequires: SDL_gfx-devel
  20. #BuildRequires: libquicktime-devel >= 0.9.8
  21. #BuildRequires: self-build-libquicktime >= 0.9.8
  22. BuildRequires: libpng-devel
  23. BuildRequires: gtk2-devel >= 2.4.0
  24. # mencoder for lav2avi.sh
  25. #Requires: mencoder
  26. #Requires: self-build-mplayer
  27. # ffmpeg main package, y4mscaler and which for anytovcd.sh
  28. #Requires: ffmpeg
  29. #Requires: self-build-ffmpeg
  30. #Requires: y4mscaler
  31. Requires: which
  32. Requires(post): /sbin/install-info
  33. Requires(preun): /sbin/install-info
  34. %description
  35. The mjpeg programs are a set of tools that can do recording of videos
  36. and playback, simple cut-and-paste editing and the MPEG compression of
  37. audio and video under Linux.
  38. %description -l ja
  39. mjpegtools は、Linux 上でビデオ録画や再生、
  40. 簡単なカット&ペーストの編集、オーディオやビデオの MPEG 圧縮ができる
  41. ツール集です。
  42. %package devel
  43. Summary: Development files for mjpegtools libraries
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: pkgconfig
  47. %description devel
  48. The mjpeg programs are a set of tools that can do recording of videos
  49. and playback, simple cut-and-paste editing and the MPEG compression of
  50. audio and video under Linux. This package contains development files
  51. for building applications that use mjpegtools libraries.
  52. %prep
  53. %setup -q
  54. %patch0 -p1
  55. %patch1 -p1
  56. %__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
  57. %__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
  58. for f in docs/yuvfps.1 ; do
  59. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  60. done
  61. %build
  62. %configure --disable-dependency-tracking --disable-static
  63. %__make # %{?_smp_mflags}
  64. %install
  65. %__rm -rf $RPM_BUILD_ROOT
  66. %__make install DESTDIR=$RPM_BUILD_ROOT
  67. %__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
  68. # too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
  69. %__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
  70. %clean
  71. %__rm -rf $RPM_BUILD_ROOT
  72. %post
  73. /sbin/ldconfig
  74. /sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  75. %postun
  76. /sbin/ldconfig
  77. %preun
  78. [ $1 -eq 0 ] && \
  79. /sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
  83. %{_bindir}/*
  84. %{_mandir}/man1/*.1*
  85. %{_mandir}/man5/yuv4mpeg.5*
  86. %{_infodir}/mjpeg-howto.info*
  87. ## gui
  88. %doc README.glav
  89. #%{_bindir}/glav
  90. # lavplay and yuvplay won't save -libs/console util users from X11 and SDL
  91. # dependencies as long as liblavplay is in -libs, but they're inherently
  92. # GUI tools -> include them here
  93. #%{_bindir}/lavplay
  94. #%{_bindir}/y4mhist
  95. #%{_bindir}/yuvplay
  96. #%{_mandir}/man1/lavplay.1*
  97. #%{_mandir}/man1/yuvplay.1*
  98. ## libs
  99. %{_libdir}/lib*.so.*
  100. %files devel
  101. %defattr(-,root,root,-)
  102. %{_includedir}/%{name}
  103. %{_libdir}/lib*.so
  104. %{_libdir}/pkgconfig/%{name}.pc
  105. %changelog
  106. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
  107. - rebuild
  108. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
  109. - rebuild
  110. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  111. - new upstream release
  112. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  113. - new upstream release
  114. * Fri Sep 3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
  115. - Fix a memleak which is causing issues for LiVES
  116. * Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
  117. - Update to upstream 1.9.0 final release
  118. * Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
  119. - rebuild for new F11 features
  120. * Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
  121. - initial build
  122. * Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
  123. - Release bump for rpmfusion
  124. - Sync with freshrpms (no changes)
  125. * Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
  126. - Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
  127. * Tue Dec 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
  128. - 1.9.0rc3.
  129. * Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
  130. - Requires: which
  131. * Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
  132. - License: GPLv2
  133. * Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
  134. - Rebuild.
  135. * Fri Jun 8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
  136. - 1.9.0rc2.
  137. * Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
  138. - Split GUI utilities into -gui subpackage.
  139. - Don't ship mpegtranscode, it's broken/outdated.
  140. - Require mencoder for lav2avi.sh.
  141. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
  142. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  143. * Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
  144. - Specfile cleanup.
  145. * Sun Jun 4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
  146. - Get rid of undefined non-weak symbols in liblav*.
  147. - Apply upstream fix for compiling with libquicktime 0.9.8.
  148. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  149. - switch to new release field
  150. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  151. - add dist
  152. * Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
  153. - Include license text in -libs, it can be installed without the main package.
  154. - Convert yuvfps man page to UTF-8.
  155. - Fix -devel Group tag.
  156. * Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
  157. - Added patch to compile with gcc 4.1
  158. - Dropped 0 Epoch
  159. * Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
  160. - 1.8.0.
  161. * Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
  162. - 1.6.3-rc3, Altivec fixes applied upstream.
  163. * Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
  164. - 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
  165. - Fix Altivec build, kudos to upstream.
  166. * Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
  167. - 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
  168. * Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
  169. - PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
  170. * Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
  171. - Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
  172. - Require pkgconfig in -devel.
  173. * Wed Feb 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
  174. - Add corrected -fPIC tweak from Thorsten.
  175. * Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
  176. - Include PNG input support.
  177. - Remove no-op $RPM_OPT_FLAGS setting from %%build.
  178. - Remove bogus optimization settings from configure script.
  179. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
  180. - CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
  181. option --with-pic is not enough
  182. * Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
  183. - Disabling static libraries building
  184. * Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
  185. - Include quicktime support.
  186. - Apply patch from ALT Linux to fix info pages, fix typo in %%post.
  187. - Require /sbin/install-info.
  188. - Add "--without static" rpmbuild option to work around an issue with FC3 strip
  189. - Always enable SIMD accelerations, CPU capabilities detected at runtime.
  190. - Always disable use of cmov.
  191. * Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
  192. - Added patch to fix gcc3.4 build
  193. - Detected race condition in Makefiles (disabling _smp_mflags use)
  194. - Added info files & scriptlets
  195. - Dropped patch0 and patch1
  196. * Tue Jun 8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
  197. - Updated to 1.6.2
  198. * Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
  199. - Removed comment after scriptlets
  200. * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
  201. - buildroot -> RPM_BUILD_ROOT
  202. * Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
  203. - Applied upstream patches to fix build on gcc3.3 systems
  204. * Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
  205. - Now test arch for configure options (from Ville)
  206. - Removed ImageMagick-devel BuildRequires
  207. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
  208. - Added missing BuildRequires
  209. - Added post/postun scriplets for libs package
  210. * Wed Apr 23 2003 Dams <anvil[AT]livna.org>
  211. - Initial build.