self-build-mjpegtools-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151
  1. %define pkgname mjpegtools
  2. %define name self-build-%{pkgname}
  3. %define version 2.0.0
  4. %define release 3%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source100: mjpegtools-2.0.0-no-config-in-public-header.h
  13. Source101: mjpegtools_gcc470.patch
  14. License: GPLv2+
  15. Group: Restricted Software
  16. Obsoletes: mjpegtools < %{version}, mjpegtools-devel < %{version}
  17. Obsoletes: self-build-mjpegtools < %{version}-%{release}
  18. # Requires(posttrans) not yet implemented. So we use (post) instead.
  19. Requires(post): self-build-setup >= 0.9.0
  20. Requires(post): libjpeg-devel
  21. Requires(post): nasm
  22. Requires(post): libdv-devel
  23. Requires(post): SDL-devel >= 1.1.3
  24. Requires(post): SDL_gfx-devel
  25. Requires(post): self-build-libquicktime >= 1.2.0
  26. Requires(post): libpng-devel
  27. Requires(post): gtk2-devel >= 2.4.0
  28. Requires(post): self-build-mplayer >= 1.1
  29. Requires(post): self-build-ffmpeg >= 1.1.0
  30. #Requires(post): y4mscaler
  31. Requires: which
  32. Requires(post): /sbin/install-info
  33. Requires(preun): /sbin/install-info
  34. BuildArch: noarch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. Packager: munepi
  37. %description
  38. The mjpeg programs are a set of tools that can do recording of videos
  39. and playback, simple cut-and-paste editing and the MPEG compression of
  40. audio and video under Linux.
  41. If you install this package, it automaticaly downloads source
  42. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  43. And the created rpm packages are automatically installed
  44. if installation is executed by apt-get command or synaptic
  45. package manager.
  46. [Note]
  47. This package requires many other packages to compile
  48. targetsoftware. So it consume more disk space than usual.
  49. Also installation takes logner time because of compilation.
  50. (This will take a few minutes to quarter or half of an hour,
  51. depends on building environment)
  52. [About self-build package]
  53. For some kind of software, distributing of binary package
  54. may viorate the patent or law. Therefore we chose self-build
  55. packge, create binary package on your machine, for such kind
  56. of softwares instead of distributing binary package.
  57. Please obey the national law when you use the created binary
  58. packages. And if you want to use the softwares using patented
  59. thechnology, it may be required to get a permission, make an
  60. agreement or purchas a license. Please consider it with your
  61. purpose or way of use and take appropriate action.
  62. %description -l ja
  63. mjpegtools は、Linux 上で
  64. ビデオ録画や再生、
  65. 簡単なカット&ペーストの編集、
  66. オーディオやビデオの MPEG 圧縮
  67. ができるツール集です。
  68. このパッケージをインストールすると、自動的にソースコードを
  69. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  70. の rpm パッケージを作成します。
  71. また apt-get コマンドや synaptic パッケージマネージャから実行
  72. した場合は、作成された rpm パッケージのインストールも自動的に
  73. 行います。
  74. [注意]
  75. コンパイルに必要な多くの関連パッケージを要求するので通常より
  76. ディスクの領域を多く消費します。
  77. またインストール時にコンパイルを行うため、通常より時間がかか
  78. る場合があります。(環境にもよりますが数分から数十分程度)
  79. [self-build パッケージについて]
  80. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  81. 違反する可能性があるものがあります。その為、このような問題が
  82. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  83. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  84. ジという方法を採っています。
  85. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  86. アのライセンス、および利用する国の各種法令に従ってください。
  87. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  88. センスの購入などが必要となる場合がありますので、利用する目的
  89. や形態に応じて各自で判断し適切な対応を取ってください。
  90. %prep
  91. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  92. %install
  93. %{__rm} -rf ${RPM_BUILD_ROOT}
  94. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE100} %{SOURCE101} \
  97. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %clean
  99. %{__rm} -rf ${RPM_BUILD_ROOT}
  100. %posttrans
  101. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 172000
  102. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  103. %{pkgname}-devel-%{version}-%{release}
  104. %files
  105. %defattr(-,root,root)
  106. %{_datadir}/%{name}/*
  107. %changelog
  108. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
  109. - rebuild
  110. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
  111. - rebuild
  112. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  113. - new upstream release
  114. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  115. - initial build
  116. ### end of file