mplayer-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. #% global with_ffmpeg 1
  5. %global ffmpegver 0.11.4
  6. #% global svndate 20120525
  7. #% global dvbappver 0.98
  8. %define codecdir %{_libdir}/codecs
  9. %global ttfontdir %{_datadir}/fonts
  10. %global ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  11. TrueType-sazanami-gothic/sazanami-gothic
  12. Summary: The Movie Player
  13. Summary(ja): 動画プレイヤー
  14. Name: mplayer
  15. Version: 1.1.1
  16. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  17. Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
  18. #Source0: mplayer-export-%{svndate}.tar.xz
  19. Source1: http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
  20. Source10: mplayer-snapshot-vine.sh
  21. Source11: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
  22. Source12: http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
  23. Source13: http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
  24. Source14: http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
  25. # ## DVB app.
  26. # ## 0.9.8
  27. # Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0799.zip
  28. # set defaults for Vine Linux
  29. #Patch2: %{name}-config.patch
  30. #Patch2: %{name}-config-20120525-vine.patch
  31. Patch2: %{name}-1.1.1-config-vine.patch
  32. # use roff include statements instead of symlinks
  33. Patch8: %{name}-1.1.1-manlinks.patch
  34. # erase any trace of libdvdcss
  35. Patch14: %{name}-1.1.1-nodvdcss.patch
  36. # use system FFmpeg libraries
  37. Patch18: %{name}-1.1.1-ffmpeg.patch
  38. ## Vine
  39. %if 0%{!?_without_amr:1}
  40. License: GPLv3+
  41. %else
  42. License: GPLv2+
  43. %endif
  44. Group: Applications/Multimedia
  45. URL: http://www.mplayerhq.hu/
  46. BuildRequires: SDL-devel
  47. BuildRequires: aalib-devel
  48. BuildRequires: alsa-lib-devel
  49. BuildRequires: cdparanoia-devel
  50. BuildRequires: desktop-file-utils
  51. ##!!BuildRequires: em8300-devel
  52. BuildRequires: libdvdnav-devel
  53. BuildRequires: enca-devel
  54. BuildRequires: fontconfig-devel
  55. BuildRequires: freetype2-devel >= 2.0.9
  56. BuildRequires: fribidi-devel
  57. BuildRequires: giflib-devel
  58. BuildRequires: gtk2-devel
  59. BuildRequires: mesa-libGL-devel
  60. BuildRequires: libXinerama-devel
  61. BuildRequires: libXScrnSaver-devel
  62. BuildRequires: libXv-devel
  63. BuildRequires: libXvMC-devel
  64. BuildRequires: libXxf86dga-devel
  65. BuildRequires: libXxf86vm-devel
  66. BuildRequires: libass-devel
  67. BuildRequires: libpng-devel
  68. BuildRequires: libjpeg-devel
  69. BuildRequires: libdvdread
  70. BuildRequires: libmpcdec-devel >= 1.2.1
  71. BuildRequires: librtmp-devel >= 2.3
  72. BuildRequires: speex-devel >= 1.1
  73. %{?with_vaapi:BuildRequires:libva-devel}
  74. BuildRequires: libvdpau-devel
  75. BuildRequires: libvorbis-devel
  76. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  77. BuildRequires: lzo-devel >= 2
  78. BuildRequires: pulseaudio-lib-devel
  79. BuildRequires: speex-devel >= 1.1
  80. BuildRequires: twolame-devel
  81. BuildRequires: xorg-x11-devel
  82. BuildRequires: yasm
  83. BuildRequires: zlib-devel
  84. # *-devel packages provided by other self-build-* should only be listed
  85. # in self-build-%{name}.spec as PreReq.
  86. ##Requires: self-build-mplayer-codecs
  87. ##BuildRequires: self-build-libdvdcss
  88. ##BuildRequires: self-build-lame
  89. ##BuildRequires: self-build-libdca
  90. ##BuildRequires: self-build-x264 >= 0.129
  91. ##BuildRequires: self-build-xvidcore >= 0.9.2
  92. ##BuildRequires: self-build-faad2 >= 2.6.1
  93. ##BuildRequires: self-build-libmpeg2
  94. Requires: TrueType-vlgothic
  95. Requires: mesa-libGL
  96. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  97. Obsoletes: mplayer < %{version}-%{release}
  98. %description
  99. MPlayer can play most standard video formats out of the box and almost
  100. all others with the help of external codecs.
  101. MPlayer currently works best from the command line, but visual feedback
  102. for many functions is available from its onscreen status display (OSD),
  103. which is also used for displaying subtitles.
  104. MPlayer also has a GUI with skin support and several unofficial alternative
  105. graphical frontends are available.
  106. MEncoder is a command line video encoder for advanced users that can
  107. be built from the MPlayer source tree. Unofficial graphical frontends
  108. exist but arenot included.
  109. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  110. support for some newer codecs are not yet inpmlemented.
  111. You should install mplayer-codecs package if you want to play videos
  112. using those new codecs.
  113. %description -l ja
  114. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  115. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  116. で再生できます。
  117. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  118. 多くの操作は字幕と同様に、
  119. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  120. MPlayer には スキンを変更できる GUI も用意されていますし、
  121. また複数の非公式なフロントエンドも利用できます。
  122. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  123. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  124. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  125. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  126. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  127. をインストールする必要があります。
  128. %prep
  129. #% setup -q -n mplayer-export-%{svndate}
  130. %setup -q -n MPlayer-%{version}
  131. %__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
  132. %patch2 -p1 -b .vine
  133. %patch8 -p1 -b .manlinks
  134. %patch14 -p1 -b .nodvdcss
  135. %{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
  136. # ## apply the DVB app. patches
  137. # unzip %{SOURCE100}
  138. # patch -p1 < mplayer-patches-%{dvbappver}/0014-check-the-decoded-result-of-PCE.patch || exit 1
  139. %build
  140. ./configure \
  141. --prefix=%{_prefix} \
  142. --bindir=%{_bindir} \
  143. --datadir=%{_datadir}/mplayer \
  144. --mandir=%{_mandir} \
  145. --confdir=%{_sysconfdir}/mplayer \
  146. --libdir=%{_libdir} \
  147. --codecsdir=%{codecdir} \
  148. \
  149. --extra-cflags="$RPM_OPT_FLAGS" \
  150. --language=ja,en \
  151. --enable-joystick \
  152. --enable-gui --enable-menu \
  153. --enable-radio --enable-radio-capture \
  154. --enable-runtime-cpudetection \
  155. --enable-unrarexec \
  156. \
  157. --disable-dvdread-internal \
  158. --disable-libdvdcss-internal \
  159. --disable-nemesi \
  160. \
  161. %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
  162. %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
  163. %{!?with_faac:--disable-faac} \
  164. --disable-libmpeg2-internal \
  165. --disable-libopenjpeg \
  166. \
  167. --disable-bitmap-font \
  168. --disable-dga1 --disable-dga2 \
  169. --disable-directfb \
  170. --disable-svga \
  171. --disable-termcap \
  172. --enable-xvmc \
  173. --with-xvmclib=XvMCW \
  174. \
  175. --disable-arts --disable-esd --disable-jack --disable-openal \
  176. --disable-live \
  177. ;
  178. %{__make} V=1 %{?_smp_mflags}
  179. %install
  180. %{__rm} -rf ${RPM_BUILD_ROOT}
  181. %{__make} install INSTALLSTRIP= \
  182. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  183. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  184. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  185. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  186. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  187. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  188. ;
  189. ## install some default config files
  190. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  191. %{__install} -pm 644 etc/example.conf \
  192. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  193. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  194. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  195. # # Icons
  196. # for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
  197. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
  198. # install -pm 644 etc/mplayer$iconsize.png \
  199. # $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
  200. # done
  201. # install skins and set the default skin
  202. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  203. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  204. for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
  205. %__tar xf ${x} || exit 1
  206. done
  207. %__ln_s Blue default || exit 1
  208. popd
  209. # make sybolic link to ttf font for subtitle
  210. for i in %{ttfontlist}; do
  211. if [ -e %{ttfontdir}/$i.ttf ];then
  212. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  213. break;
  214. fi;
  215. done
  216. ## install TOOLS
  217. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  218. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  219. done
  220. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  221. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  222. done
  223. for file in vobshift.py ; do
  224. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  225. done
  226. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  227. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  228. %clean
  229. %{__rm} -rf ${RPM_BUILD_ROOT}
  230. %post
  231. touch --no-create %{_datadir}/icons/hicolor
  232. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  233. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  234. fi
  235. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  236. %postun
  237. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  238. touch --no-create %{_datadir}/icons/hicolor
  239. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  240. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  241. fi || :
  242. %files
  243. %defattr(-,root,root)
  244. #%doc AUTHORS Changelog Copyright LICENSE README
  245. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  246. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  247. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  248. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  249. %{_bindir}/mplayer
  250. %{_bindir}/gmplayer
  251. %{_bindir}/mencoder
  252. %{_datadir}/mplayer/skins/default
  253. %{_datadir}/mplayer/skins/Blue
  254. %{_datadir}/mplayer/skins/Blue-small
  255. %{_datadir}/mplayer/skins/OSX-Mod
  256. %{_datadir}/mplayer/skins/standard
  257. %{_datadir}/mplayer/subfont.ttf
  258. %{_datadir}/applications/mplayer.desktop
  259. %{_datadir}/icons/hicolor/*/apps/mplayer.png
  260. %{_mandir}/man1/mplayer.1*
  261. %{_mandir}/man1/mencoder.1*
  262. ## TOOLS
  263. %{_bindir}/aconvert
  264. %{_bindir}/calcbpp
  265. %{_bindir}/countquant
  266. %{_bindir}/divx2svcd
  267. %{_bindir}/dvd2divxscript
  268. %{_bindir}/mencvcd
  269. %{_bindir}/midentify
  270. %{_bindir}/mpconsole
  271. %{_bindir}/qepdvcd
  272. %{_bindir}/subsearch
  273. %{_bindir}/vobshift
  274. %{_datadir}/mplayer/*.fp
  275. %changelog
  276. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  277. - updated to 1.1.1
  278. - build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
  279. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
  280. - rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
  281. * Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
  282. - updated to 1.1
  283. - built with ffmpeg-0.11.1
  284. - added some skins
  285. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  286. - updated snapshot 20120525 with ffmpeg 0.11
  287. * Tue Jan 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
  288. - updated snapshot 20120102
  289. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
  290. - updated snapshot 20111217 (with ffmpeg 0.9)
  291. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  292. - s/self-build-libdvdnav/libdvdnav/
  293. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  294. - updated %%SOURCE1
  295. - update to 1.8
  296. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  297. - dropped BuildRequires: esound-devel
  298. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  299. - new upstream release
  300. - ready for Vine Linux 6
  301. - revived support for Vine Linux 5
  302. - added BuildRequires:
  303. - libass-devel
  304. - librtmp-devel >= 2.3
  305. - speex-devel >= 1.1
  306. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  307. - added BuildRequires:
  308. - aalib-devel
  309. - enca-devel
  310. - lzo-devel
  311. - speex-devel
  312. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  313. - updated fixed %{name}-config.patch
  314. - applied %{name}-config-20100709-vine.patch
  315. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  316. - change release to sync with self-build-mplayer
  317. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  318. - updated source snapshot 20100709
  319. - renamed %%Source10 to mplayer-snapshot-vine.sh
  320. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  321. - added BuildRequires: libvpx-devel >= 0.9.1
  322. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  323. - updated source snapshot 20100621
  324. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  325. - updated source snapshot 20100615
  326. - added BuildRequires: libXinerama-devel
  327. - dropped vl4 support
  328. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  329. - updated source snapshot 20100410
  330. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  331. - updated source snapshot 20100401
  332. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  333. - updated source snapshot 20100326
  334. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  335. - updated source snapshot 20100317
  336. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  337. - updated source snapshot 20100216
  338. - moved scripts from TOOLS
  339. - added --disable-libopenjpeg in configure options
  340. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  341. - updated source snapshot 20100201
  342. - dropped obsolete patches
  343. - added BuildRequires:
  344. - libvdpau-devel
  345. - libXScrnSaver-devel
  346. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  347. - update mplayer-config-20091215-vine.patch
  348. - update mplayer-20091215-x86_32-compile.patch
  349. - added --enable-runtime-cpudetection in configure options
  350. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  351. - source snapshot 20091031
  352. - updated mplayer-20091031-x86_32-compile.patch
  353. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  354. - source snapshot 20091003
  355. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  356. - change release to sync with self-build-mplayer
  357. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  358. - source snapshot 20090905
  359. - added settings for vl6
  360. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  361. - source snapshot 20090821
  362. - replaced BR: libungif-devel with BR: giflib-devel
  363. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  364. - source snapshot 20090722
  365. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  366. - source snapshot 20090702
  367. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  368. - source snapshot 20090611
  369. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  370. - added Requires: TrueType-vlgothic
  371. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  372. - source snapshot 20090522
  373. - build with x264 >= 0.0.0-9.20090522
  374. - updated mplayer-20090522-nodvdcss.patch
  375. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  376. - change release to sync with self-build-mplayer
  377. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  378. - source snapshot 20090502
  379. - updated mplayer-20090503-x86_32-compile.patch
  380. - updated mplayer-20090502-nodvdcss.patch
  381. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  382. - applied mplayer-config-vine.patch
  383. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  384. - source snapshot 20090327
  385. - updated mplayer-20090327-x86_32-compile.patch
  386. - updated mplayer-20090325-nodvdcss.patch
  387. - dropped gmplayer-about-vine.patch
  388. - install some default config files
  389. - added configure options:
  390. - --disable-termcap
  391. - --enable-xvmc
  392. - --with-xvmclib=XvMCW
  393. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  394. - fixed %%files for *.conf
  395. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  396. - source snapshot 20090305
  397. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  398. - source snapshot 20090227
  399. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  400. - source snapshot 20090216
  401. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  402. - source snapshot 20090206
  403. - dropped mplayer-man-zh_CN.patch
  404. - updated mplayer-20090206-nodvdcss.patch
  405. - changed to PreReq: self-build-faad2 from faad2-devel
  406. - added PreReq: self-build-libmad
  407. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  408. - source snapshot 20090131
  409. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  410. - change release to sync with self-build-mplayer
  411. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  412. - source snapshot
  413. - update mplayer-20090122-nodvdcss.patch
  414. - added BuildRequires:
  415. - faad2-devel
  416. - libmpcdec-devel
  417. - twolame-devel
  418. - yasm
  419. - faac-devel (as PreReq in self-build-%{name})
  420. - lame-devel (as PreReq in self-build-%{name})
  421. - libdca-devel (as PreReq in self-build-%{name})
  422. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  423. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  424. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  425. - source snapshot
  426. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  427. --disable-faad-internal in configure options
  428. - dropped gmplayer-add-flv-extension.patch
  429. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  430. - source snapshot
  431. - fixed License
  432. - added some patches from RPM Fusion
  433. - updated gmplayer-about-vine.patch for 20081001 snapshot
  434. - added BuildRequires: libdvdread
  435. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  436. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  437. in configure options
  438. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  439. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  440. - fixed License
  441. - added some devel packages to support OpenGL
  442. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  443. - spec in utf8
  444. - fix sybolic link of subfont for vl5
  445. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  446. - add "Patch105: CVE-2008-1558.patch".
  447. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  448. - build with new versioning policy.
  449. - fix Source[01] URLs.
  450. - add "Patch200: gmplayer-about-vine.patch".
  451. - add "Patch201: gmplayer-add-flv-extension.patch".
  452. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  453. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  454. CVE-2008-0629, CVE-2008-0630)
  455. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  456. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  457. - change source download URL. <BTS:VineLinux:603>
  458. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  459. - fix CONFDIR for make install. <BTS:wishes:33>
  460. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  461. - initial build for Vine Linux