acpica-tools-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354
  1. Name: acpica-tools
  2. Version: 20140424
  3. Release: 1%{?_dist_release}
  4. Summary: ACPICA tools for the development and debug of ACPI tables
  5. Group: Development/Languages
  6. License: GPLv2
  7. URL: https://www.acpica.org/
  8. Source0: https://acpica.org/sites/acpica/files/acpica-unix2-%{version}.tar.gz
  9. Source1: https://acpica.org/sites/acpica/files/acpitests-unix-%{version}.tar.gz
  10. Source2: README.Fedora
  11. Source3: iasl.1
  12. Source4: acpibin.1
  13. Source5: acpidump.1
  14. Source6: acpiexec.1
  15. Source7: acpihelp.1
  16. Source8: acpinames.1
  17. Source9: acpisrc.1
  18. Source10: acpixtract.1
  19. Source11: badcode.asl.result
  20. Source12: grammar.asl.result
  21. Source13: run-misc-tests.sh
  22. Source14: COPYING
  23. Patch0: debian-big_endian.patch
  24. Patch1: debian-unaligned.patch
  25. Patch2: name-miscompare.patch
  26. Patch3: aapits-linux.patch
  27. Patch4: asllookup-miscompare.patch
  28. Patch5: aapits-makefile.patch
  29. Patch6: re-enable-big-endian.patch
  30. BuildRequires: bison patchutils flex
  31. # The previous iasl package contained only a very small subset of these tools
  32. # and it produced only the iasl package listed below; further, the pmtools
  33. # package -- which provides acpidump -- also provides a /usr/sbin/acpixtract
  34. # that we don't really want to collide with
  35. Provides: acpixtract >= 20120913-7
  36. Provides: iasl = %{version}-%{release}
  37. Obsoletes: iasl < 20120913-8
  38. # The pmtools package provides an obsolete and deprecated version of the
  39. # acpidump command from lesswatts.org which has now been taken off-line.
  40. # ACPICA, however, is providing a new version and we again do not want to
  41. # conflict with the command name.
  42. Provides: acpidump >= 20100513-5
  43. Provides: pmtools = %{version}-%{release}
  44. Obsoletes: pmtools < 20100513-6
  45. %description
  46. The ACPI Component Architecture (ACPICA) project provides an OS-independent
  47. reference implementation of the Advanced Configuration and Power Interface
  48. Specification (ACPI). ACPICA code contains those portions of ACPI meant to
  49. be directly integrated into the host OS as a kernel-resident subsystem, and
  50. a small set of tools to assist in developing and debugging ACPI tables.
  51. This package contains only the user-space tools needed for ACPI table
  52. development, not the kernel implementation of ACPI. The following commands
  53. are installed:
  54. -- iasl: compiles ASL (ACPI Source Language) into AML (ACPI Machine
  55. Language), suitable for inclusion as a DSDT in system firmware.
  56. It also can disassemble AML, for debugging purposes.
  57. -- acpibin: performs basic operations on binary AML files (e.g.,
  58. comparison, data extraction)
  59. -- acpidump: write out the current contents of ACPI tables
  60. -- acpiexec: simulate AML execution in order to debug method definitions
  61. -- acpihelp: display help messages describing ASL keywords and op-codes
  62. -- acpinames: display complete ACPI name space from input AML
  63. -- acpisrc: manipulate the ACPICA source tree and format source files
  64. for specific environments
  65. -- acpixtract: extract binary ACPI tables from acpidump output (see
  66. also the pmtools package)
  67. This version of the tools is being released under GPLv2 license.
  68. %prep
  69. %setup -q -n acpica-unix2-%{version}
  70. %setup -q -T -D -a 1 -n acpica-unix2-%{version}
  71. gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
  72. %patch0 -p1 -b .debian-big_endian
  73. %patch1 -p1 -b .debian-unaligned
  74. %patch2 -p1 -b .name-miscompare
  75. %patch3 -p1 -b .aapits-linux
  76. %patch4 -p1 -b .asllookup-miscompare
  77. %patch5 -p1 -b .aapits-makefile
  78. %patch6 -p1 -b .re-enable-big-endian
  79. cp -p %{SOURCE2} README.Fedora
  80. cp -p %{SOURCE3} iasl.1
  81. cp -p %{SOURCE4} acpibin.1
  82. cp -p %{SOURCE5} acpidump.1
  83. cp -p %{SOURCE6} acpiexec.1
  84. cp -p %{SOURCE7} acpihelp.1
  85. cp -p %{SOURCE8} acpinames.1
  86. cp -p %{SOURCE9} acpisrc.1
  87. cp -p %{SOURCE10} acpixtract.1
  88. cp -p %{SOURCE11} badcode.asl.result
  89. cp -p %{SOURCE12} grammar.asl.result
  90. cp -p %{SOURCE13} tests/run-misc-tests.sh
  91. chmod a+x tests/run-misc-tests.sh
  92. cp -p %{SOURCE14} COPYING
  93. # spurious executable permissions on text files in upstream
  94. chmod a-x changes.txt
  95. chmod a-x source/compiler/new_table.txt
  96. %build
  97. make OPT_CFLAGS="%{optflags}"
  98. %install
  99. # Install the binaries
  100. mkdir -p %{buildroot}%{_bindir}
  101. install -pD generate/unix/bin*/* %{buildroot}%{_bindir}/
  102. mv %{buildroot}%{_bindir}/acpidump %{buildroot}%{_bindir}/acpidump-acpica
  103. mv %{buildroot}%{_bindir}/acpixtract %{buildroot}%{_bindir}/acpixtract-acpica
  104. # Install the man pages
  105. mkdir -p %{buildroot}%{_mandir}/man1
  106. install -pDm 0644 -p -D *.1 %{buildroot}%{_mandir}/man1/
  107. mv %{buildroot}%{_mandir}/man1/acpixtract.1 \
  108. %{buildroot}%{_mandir}/man1/acpixtract-acpica.1
  109. mv %{buildroot}%{_mandir}/man1/acpidump.1 \
  110. %{buildroot}%{_mandir}/man1/acpidump-acpica.1
  111. %check
  112. cd tests
  113. # ASL tests
  114. ./aslts.sh # relies on non-zero exit
  115. [ $? -eq 0 ] || exit 1
  116. # API tests
  117. cd aapits
  118. make
  119. cd asl
  120. ASL=%{buildroot}%{_bindir}/iasl make
  121. cd ../bin
  122. ./aapitsrun
  123. [ $? -eq 0 ] || exit 1
  124. cd ../..
  125. # misc tests
  126. ./run-misc-tests.sh %{buildroot}%{_bindir} %{version}
  127. # Template tests
  128. cd templates
  129. make
  130. if [ -f diff.log ]
  131. then
  132. if [ -s diff.log ]
  133. then
  134. exit 1 # implies errors occurred
  135. fi
  136. fi
  137. cd ..
  138. %post
  139. alternatives --install %{_bindir}/acpixtract acpixtract \
  140. %{_bindir}/acpixtract-acpica 120 \
  141. --slave %{_mandir}/man1/acpixtract.1.gz acpixtract.1.gz \
  142. %{_mandir}/man1/acpixtract-acpica.1.gz
  143. alternatives --install %{_bindir}/acpidump acpidump \
  144. %{_bindir}/acpidump-acpica 120 \
  145. --slave %{_mandir}/man1/acpidump.1.gz acpidump.1.gz \
  146. %{_mandir}/man1/acpidump-acpica.1.gz
  147. %postun
  148. if [ ! -e %{_bindir}/acpixtract-acpica ]
  149. then
  150. alternatives --remove acpixtract %{_bindir}/acpixtract-acpica
  151. fi
  152. if [ ! -e %{_bindir}/acpidump-acpica ]
  153. then
  154. alternatives --remove acpidump %{_bindir}/acpidump-acpica
  155. fi
  156. %files
  157. %doc changes.txt source/compiler/new_table.txt
  158. %doc README.Fedora COPYING
  159. %{_bindir}/*
  160. %{_mandir}/*/*
  161. %changelog
  162. * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140424-1
  163. - initial build for Vine Linux
  164. * Fri Jun 6 2014 Dan Horák <dan[at]danny.cz> - 20140424-3
  165. - refresh the big endian patch so it applies correctly, fixes build on big endians
  166. * Thu May 22 2014 Al Stone <ahs3@redhat.com> - 20140424-2
  167. - Add ppc64le as a 64-bit arch in run-misc-tests.sh. Closes BZ#1098614.
  168. - Re-enable big-endian support in iasl.
  169. * Wed May 7 2014 Al Stone <ahs3@redhat.com> - 20140424-1
  170. - Update to latest upstream. Closes BZ#1091189.
  171. * Fri Apr 4 2014 Al Stone <ahs3@redhat.com> - 20140325-1
  172. - Update to latest upstream. Closes BZ#1080791.
  173. - Incorporated patch to fix broken symlinks. Closes BZ#1074256.
  174. - Add patch to fix missing .o files in aapits tests.
  175. * Wed Feb 26 2014 Al Stone <ahs3@redhat.com> - 20140214-1
  176. - Update to latest upstream. Closes BZ#1053396.
  177. - Remove temporary patch so that AAPITS will build and run.
  178. - Add patch to print asllookup.c warning properly on big endian;
  179. Closes BZ#1069178.
  180. * Tue Jan 21 2014 Al Stone <ahs3@redhat.com> - 20140114-1
  181. - Update to latest upstream. Closes BZ#1053396.
  182. - Remove temporary patch to add Makefile missing from upstream tarball.
  183. - Add temporary patch so that AAPITS will build and run.
  184. * Tue Jan 7 2014 Al Stone <ahs3@redhat.com> - 20131218-1
  185. - Update to latest upstream. Closes BZ#1044951.
  186. - Add temporary patch to add Makefile missing from upstream tarball.
  187. * Mon Nov 25 2013 Al Stone <ahs3@redhat.com> - 20131115-1
  188. - Update to latest upstream. Closes BZ#1031255.
  189. - Add a little code to workaround build problems that can occur (the tests
  190. will fail) when a build starts before midnight, but ends after midnight
  191. - Remove patch to include Makefile.config that was missing from tarball.
  192. * Wed Oct 09 2013 Al Stone <ahs3@redhat.com> - 20130927-1
  193. - Update to latest upstream. Closes BZ#1013090.
  194. - Add temporary patch to include Makefile.config being missing from tarball.
  195. * Fri Sep 13 2013 Michael Schwendt <mschwendt@fedoraproject.org> - 20130823-5
  196. - correct iasl obs_ver
  197. * Tue Sep 10 2013 Dean Nelson <dnelson@redhat.com> - 20130823-4
  198. - Fix run-misc-tests.sh script to properly set the number of BITS to 64
  199. when run on a s390x system.
  200. * Tue Sep 10 2013 Michael Schwendt <mschwendt@fedoraproject.org> - 20130823-3
  201. - correct pmtools obs_ver
  202. * Tue Aug 27 2013 Al Stone <ahs3@redhat.com> - 20130823-2
  203. - Add in a copy of the GPLv2 text in order to comply with the requirement
  204. to always redistribute the terms of the license.
  205. * Mon Aug 26 2013 Al Stone <ahs3@redhat.com> - 20130823-1
  206. - Update to latest upstream source.
  207. * Tue Aug 20 2013 Al Stone <ahs3@redhat.com> - 20130725-2
  208. - Fix several rpmlint items (listed below)
  209. - Add versions to explicit provides for acpixtract, acpidump
  210. - Not all setup steps used -q
  211. - Setup executable test script (run-misc-tests.sh) differently
  212. - Removed unneeded commented out line with macros in it
  213. - Removed mixed use of spaces and tabs (all spaces now)
  214. - Corrected source URLs (upstream moved)
  215. * Sun Aug 18 2013 Al Stone <ahs3@redhat.com> - 20130725-1
  216. - Update to latest upstream source.
  217. * Wed Jul 24 2013 Al Stone <ahs3@redhat.com> - 20130626-1
  218. - Update to latest upstream source.
  219. - Move acpidump to acpidump-acpica so it be an alternative properly
  220. - Add basic man page for acpidump
  221. - Enable use of AAPITS tests during the check step
  222. * Sun Jun 02 2013 Al Stone <ahs3@redhat.com> - 20130517-2
  223. - Correct an oversight: we provide an acpidump in conflict with the
  224. version in pmtools (which appears to be dead upstream) but had not
  225. made it an alternative before
  226. * Tue May 28 2013 Al Stone <ahs3@redhat.com> - 20130517-1
  227. - Update to latest upstream source.
  228. - Remove acpica-tools-config.patch -- now in upstream
  229. - Remove iasl-signed-char.patch -- now in upstream
  230. - Updated debian-big_endian.patch
  231. - Updated debian-unaligned.patch
  232. * Mon May 13 2013 Al Stone <ahs3@redhat.com> - 20130328-1
  233. - Update to latest upstream source.
  234. * Wed Mar 20 2013 Al Stone <ahs3@redhat.com> - 20130214-2
  235. - Incorporate use of optflags macro in the build.
  236. - Remove extraneous rm -rf of buildroot.
  237. - Remove extraneous use of defattr in the files section.
  238. - Incorporate use of parallel make.
  239. - Remove extraneous use of the clean section.
  240. - Use simpler globbing in the files section.
  241. - Use simpler globbing in the install section.
  242. - Remove obsolete git notes from README.Fedora.
  243. - Remove ExcludeArch restrictions.
  244. * Mon Feb 18 2013 Al Stone <ahs3@redhat.com> - 20130214-1
  245. - New upstream.
  246. - Remove most of the config file patch; still need to remove -m{32,64}.
  247. - Clarify the licensing; this source is dual-licensed and is being released
  248. under the GPLv2 as allowed by the original Intel license.
  249. - Redo the misc tests so they compare results properly.
  250. * Wed Feb 06 2013 Al Stone <ahs3@redhat.com> - 20130117-6
  251. - Added a zero-fill to a date used in comparing testing results so that the
  252. comparison would be correct on days numbered < 10.
  253. * Thu Jan 31 2013 Al Stone <ahs3@redhat.com> - 20130117-5
  254. - Simplify versioning scheme and revert to the original scheme in use by
  255. iasl, which is use the latest official tarball date (2013017) as the
  256. version and 1%{?dist} as the release, to be incremented for packaging
  257. and bug fixes as needed.
  258. * Wed Jan 30 2013 Al Stone <ahs3@redhat.com> - 20130117-4
  259. - Do a little reset: go back to using just the original upstream tarball
  260. instead of the latest git; the snapshot approach was more complicated
  261. than needed.
  262. - Upstream tarballs split commands from test suites, so had to add the
  263. test suite back in as another Source: file.
  264. - Change versioning scheme to include the APCI specification level (5.0),
  265. the latest official tarball date (2013017) and a revision level (the
  266. .1 at the end) for packaging and bug fixes as needed.
  267. - Changed the License field to reflect the source tarball change; the release
  268. tarball is dual-licensed, Intel ACPI or GPLv2.
  269. - Updated patches to apply cleanly as needed.
  270. - Corrected Obsoletes and Provides version numbers.
  271. * Mon Jan 28 2013 Al Stone <ahs3@redhat.com> - 20130117-3
  272. - Reconcile Fedora and Debian patches to be as alike as possible
  273. * Mon Jan 28 2013 Al Stone <ahs3@redhat.com> - 20130117-2
  274. - Verify ExcludeArch restrictions -- the architectures excluded can have
  275. no use for these tools. Hardware support for ACPI is simply not
  276. implemented for them.
  277. - Corrected versioning to note this source came from a git pull.
  278. - Add License file as upstream has not yet provided one (and has not for
  279. many years).
  280. - Insert properly versioned Provides and Obsoletes for iasl.
  281. - Corrected files to use man.1* (vs man.1.gz) to allow flexibility in the
  282. compression being used.
  283. * Wed Jan 23 2013 Al Stone <ahs3@redhat.com> - 20130117-1
  284. - Clone from the current iasl package, with the intent of replacing it
  285. - Update source to latest upstream
  286. - NB: ACPICA documentation would normally be included in a source tarball.
  287. But, since it is not clearly redistributable, it is not included in the
  288. source RPM for this package.
  289. - Build all ACPICA tools, not just iasl (and hence the package replacement)
  290. - Add in brief man pages
  291. - Set up acpixtract from this package as an alternative to the same command
  292. in the pmtools package
  293. - Run the check step once built