cvs-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. %define version 1.12.13
  2. Summary: A version control system.
  3. Summary(ja): バージョン管理システム
  4. Name: cvs
  5. Version: %{version}
  6. Release: 6%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.cvshome.org/
  10. Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
  11. Source100: filter-requires-getopts-pl.sh
  12. Patch2: cvs-1.12.13-authserver.patch
  13. Patch3: cvs-1.11.2-cvspass.patch
  14. Patch5: cvs-1.11.2-install.patch
  15. Patch101: can-2005-2693.patch
  16. Patch102: cvs-1.12.13_CVE-2012-0804.patch
  17. Requires(pre): install-info
  18. Prefix: %{_prefix}
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. Requires: perl, zlib
  21. BuildRequires: zlib-devel
  22. BuildRequires: openssl-devel
  23. BuildRequires: vim
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. # for perl
  27. %define __find_requires %{SOURCE100}
  28. %description
  29. CVS (Concurrent Version System) is a version control system which can
  30. record the history of your files (usually, but not always, source
  31. code). CVS only stores the differences between versions, instead of
  32. every version of every file you've ever created. CVS also keeps a log
  33. of who, when and why changes occurred.
  34. CVS is very helpful for managing releases and controlling the
  35. concurrent editing of source files among multiple authors. Instead of
  36. providing version control for a collection of files in a single
  37. directory, CVS provides version control for a hierarchical collection
  38. of directories consisting of revision controlled files. These
  39. directories and files can then be combined together to form a software
  40. release.
  41. Install the cvs package if you need to use a version control system.
  42. #'
  43. %description -l ja
  44. CVS (Concurrent Version System) はバージョン管理システムで,
  45. ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
  46. 変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
  47. 保存しておくのではなく,バージョン間の変更差分だけを保存します.
  48. CVS はまた誰が何故変更を行ったのかのログも記録します.
  49. CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
  50. 非常に役立ちます.
  51. バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
  52. %prep
  53. %setup -q
  54. %patch2 -p1 -b .authserver
  55. %patch3 -p1 -b .cvspass
  56. %patch5 -p1 -b .install
  57. %patch101 -p1 -b .can-2005-2693
  58. %patch102 -p1 -b .CVE-2012-0804
  59. %build
  60. %configure --with-external-zlib
  61. make %{?_smp_mflags}
  62. make -C doc info
  63. %install
  64. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  65. %{makeinstall}
  66. gzip %{buildroot}%{_infodir}/cvs* || true
  67. %clean
  68. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  69. %post
  70. /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
  71. /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
  72. %preun
  73. if [ $1 = 0 ]; then
  74. /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
  75. /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
  76. fi
  77. %files
  78. %defattr(-,root,root)
  79. %doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
  80. %doc doc/*.pdf
  81. %{_bindir}/cvs
  82. %{_bindir}/cvsbug
  83. %{_bindir}/rcs2log
  84. %{_mandir}/man1/cvs.1*
  85. %{_mandir}/man5/cvs.5*
  86. %{_mandir}/man8/cvsbug.8*
  87. %{_infodir}/cvs*
  88. %{_datadir}/cvs
  89. %changelog
  90. * Fri Jan 3 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.12.13-6
  91. - build with current VineSeed
  92. * Fri Feb 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>1.12.13-5vl6
  93. - add patch102 for fix CVE-2012-0804 (heap overflow in the CVS client)
  94. - add Vendor / Distri Tags
  95. * Sat Apr 2 2011 IWAI, Masaharu <iwai@alib.jp> 1.12.13-4vl6
  96. - build with krb5-libs 1.8.2
  97. - add doc/*.pdf in %%doc
  98. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-3
  99. - rebuild with openssl-1.0.0c
  100. - add BuildRequires: openssl-devel, vim
  101. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-2
  102. - spec in utf-8
  103. * Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
  104. - rebuild with perl-5.10.0-1vl5
  105. - add filter-requires-getopts-pl.sh (Source100)
  106. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
  107. - new upstream release
  108. - drop Patch100 which are merged in upstream.
  109. * Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
  110. - rebuilt with VineSeed
  111. * Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
  112. - added a security patch for CAN-2005-2693 (CVS temporary file issue).
  113. * Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
  114. - added a security patch for can-2005-0753 (Buffer Overflow and DoS).
  115. * Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
  116. - remove unneeded dependency
  117. - change Prereq: info to install-info
  118. - add %%{_smp_mflags} to make option
  119. * Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
  120. - new upstream release
  121. - security update
  122. This release fixes several serious security issues in the CVS server
  123. executable. It also contains one minor bug fix and the cvs log' and cvs ls'
  124. commands now output times in the client's local timezone.
  125. * Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
  126. - new upstream release
  127. - security update
  128. This release fixes a serious security issue in the CVS server executable.
  129. * Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
  130. - fixed typo in description
  131. * Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
  132. - new upstream release
  133. - security update
  134. This release fixes serious security issues in both the client and
  135. server executables. It also contains many bug fixes and support for
  136. accessing CVS pservers via intervening HTTP proxies.
  137. - fixed broken description
  138. - changed Source0 URL
  139. * Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
  140. - fixed typo in changelog
  141. * Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
  142. - new upstream release
  143. - added "--with-external-zlib2" to configure option
  144. -- dropped patch4
  145. * Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
  146. - new upstream release
  147. - security update
  148. pserver can no longer be configured to run as root via the
  149. $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
  150. longer leads directly to a root hack. Attempts to root will also be logged
  151. via the syslog.
  152. * Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
  153. - new upstream release
  154. - security update
  155. This release fixes a security issue with no known exploits that could cause
  156. previous versions of CVS to attempt to create files and directories in the
  157. filesystem root.
  158. * Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
  159. - new upstream release
  160. * Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
  161. - updated to new upstream release (security update)
  162. * Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
  163. - new upstream version
  164. -- Some minor changes to allow the code to compile on Windows platforms.
  165. -- NEWS: Add dummy entry for since 1.11.3.
  166. -- configure.in: Update to dev version 1.11.3.
  167. -- configure: Regenerated.
  168. * Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
  169. - new upstream version
  170. -- When waiting for another user's lock, the message timestamps are now
  171. in UTC rather than the server's local time.
  172. -- The options.h file is no longer used. This fixes a bug that occurred when 1.11.2 was compiled on Windows platforms.
  173. -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
  174. - dropped kbr4 patch
  175. * Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
  176. - clean up patch files
  177. - added some documents files
  178. * Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
  179. - updated cvs-1.11.2
  180. -- updated cvs-1.11.2-mktemp.patch
  181. * Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
  182. - paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
  183. The most notable feature is: build with an external zlib
  184. * Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
  185. - updated cvs-1.11.1p1
  186. - removed some patches
  187. - changed contrib dir to /usr/share from /usr/lib
  188. * Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  189. - 1.11-0vl2
  190. - rebuilt with new %%{_mandir} definition
  191. - added Japanese summary and description
  192. * Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
  193. - updated 1.11
  194. - removed auth.patch
  195. - added errno.patch from rawhide's cvs-1.11-1
  196. - partially used rpmmacros
  197. * Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  198. - 1.10.8-0vl3
  199. - fixed %post and %preun section
  200. - 1.10.8-0vl2
  201. - removed gzip and strip in %install
  202. * Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  203. - updated 1.10.8
  204. - switch to using the system's zlib instead of built-in
  205. - removed kerberos
  206. * Wed Mar 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  207. - make kerberos support conditional at build-time
  208. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  209. - integrate kerberos support into main tree
  210. * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  211. - build with gssapi auth (--with-gssapi, --with-encryption)
  212. - apply patch to update libs to krb5 1.1.1
  213. * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
  214. - fix the damn info pages too while we're at it.
  215. - fix description
  216. - man pages are compressed
  217. - make sure %post and %preun work okay
  218. * Sun Jan 9 2000 Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
  219. - update to 1.10.7.
  220. * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
  221. - add the patch to make 1.10.6 usable
  222. (http://www.cyclic.com/cvs/dev-known.html).
  223. * Tue Jun 1 1999 Jeff Johnson <jbj@redhat.com>
  224. - update to 1.10.6.
  225. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  226. - auto rebuild in the new build environment (release 2)
  227. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  228. - updated text in spec file.
  229. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  230. - update to 1.10.5.
  231. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  232. - update to 1.10.4.
  233. * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
  234. - update to 1.10.3.
  235. * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
  236. - update to 1.10.2.
  237. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  238. - remove trailing characters from rcs2log mktemp args
  239. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  240. - update to 1.10.1
  241. * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
  242. - fix race conditions in cvsbug/rcs2log
  243. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  244. - update to 1.10.
  245. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  246. - update to 1.9.30.
  247. * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
  248. - translations modified for de, fr
  249. * Mon Jun 8 1998 Jeff Johnson <jbj@redhat.com>
  250. - build root
  251. - update to 1.9.28
  252. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  253. - translations modified for de, fr, tr
  254. * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
  255. - added install-info stuff
  256. - added changelog section