libgpod-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243
  1. %define with_mono 1
  2. Summary: Library to access the iPod
  3. Summary(ja): iPod にアクセスするためのライブラリ
  4. Name: libgpod
  5. Version: 0.8.3
  6. Release: 3%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.gtkpod.org/libgpod.html
  10. Source: %{name}-%{version}.tar.bz2
  11. Buildroot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: docbook-style-xsl
  13. BuildRequires: glib2-devel
  14. BuildRequires: gtk2-devel
  15. BuildRequires: gettext
  16. BuildRequires: intltool
  17. BuildRequires: libimobiledevice-devel >= 1.1.4
  18. BuildRequires: libplist-devel >= 1.0
  19. BuildRequires: libusb1-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: libxslt
  22. BuildRequires: libffi-devel
  23. BuildRequires: perl(XML::Parser)
  24. BuildRequires: pygobject-devel
  25. BuildRequires: python-devel
  26. BuildRequires: python-mutagen
  27. BuildRequires: sg3_utils-devel
  28. BuildRequires: sqlite3-devel
  29. BuildRequires: taglib-devel
  30. BuildRequires: swig
  31. %if %{with_mono}
  32. BuildRequires: mono-devel
  33. BuildRequires: gtk-sharp2-devel
  34. %endif
  35. Requires: udev
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: daisuke
  39. %description
  40. libgpod is a library meant to abstract access to an iPod content. It
  41. provides an easy to use API to retrieve the list of files and playlist
  42. stored on an iPod, to modify them and to save them back to the iPod.
  43. %description -l ja
  44. libgpod は iPod のコンテンツにアクセスするためのライブラリです。
  45. iPod に格納されているファイルリストやプレイリストを取得し、変更し、
  46. iPod に書き戻すための API が提供されています。
  47. %package devel
  48. Summary: Support files necessary to compile applications with libgpod.
  49. Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
  50. Group: Development/Libraries
  51. Requires: libgpod = %{version}-%{release}
  52. Requires: glib2-devel
  53. Requires: gtk2-devel
  54. %description devel
  55. Libraries, headers, and support files necessary to compile applications
  56. using libgpod.
  57. %description -l ja devel
  58. libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
  59. ヘッダファイルなどが含まれています.
  60. %package -n python-gpod
  61. Summary: Python module to access iPod content
  62. Summary(ja): iPod にアクセスするための Python モジュール
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: python-mutagen
  66. %description -n python-gpod
  67. A python module to access iPod content. This module provides bindings
  68. to the libgpod library.
  69. %if %{with_mono}
  70. %package sharp
  71. Summary: C#/.NET library to access iPod content
  72. Summary(ja): iPod にアクセスするための C#/.NET ライブラリ
  73. Group: System Environment/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. %description sharp
  76. C#/.NET library to access iPod content. Provides bindings to the libgpod
  77. library.
  78. %package sharp-devel
  79. Summary: Development files for libgpod-sharp
  80. Summary(ja): libgpod-sharp の開発用ファイル
  81. Group: Development/Libraries
  82. Requires: %{name}-sharp = %{version}-%{release}
  83. Requires: pkgconfig
  84. %description sharp-devel
  85. C#/.NET library to access iPod content. Provides bindings to the libgpod
  86. library.
  87. This package contains the files required to develop programs that will use
  88. libgpod-sharp.
  89. %endif
  90. %prep
  91. %setup -q
  92. chmod -x bindings/python/examples/*.py
  93. %build
  94. %configure \
  95. --without-hal \
  96. --enable-udev \
  97. --with-temp-mount-dir=%{_localstatedir}/run/%{name}
  98. make %{?_smp_mflags}
  99. %install
  100. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  101. make DESTDIR=%{buildroot} install
  102. %find_lang %{name}
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  104. rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
  105. %clean
  106. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  107. %post -p /sbin/ldconfig
  108. %postun -p /sbin/ldconfig
  109. %files -f %{name}.lang
  110. %defattr(-, root, root, 0755)
  111. %doc AUTHORS ChangeLog COPYING README
  112. %{_bindir}/*
  113. %{_libdir}/lib*.so.*
  114. %dir %{_localstatedir}/run/%{name}
  115. /lib/udev/iphone-set-info
  116. /lib/udev/ipod-set-info
  117. /lib/udev/rules.d/*.rules
  118. %files devel
  119. %defattr(-, root, root, 0755)
  120. %{_libdir}/lib*.so
  121. %{_libdir}/pkgconfig/*.pc
  122. %{_includedir}/gpod-1.0/
  123. %{_datadir}/gtk-doc/html/%{name}
  124. %files -n python-gpod
  125. %defattr(-, root, root, 0755)
  126. %doc COPYING bindings/python/README bindings/python/examples
  127. %{python_sitearch}/gpod
  128. %if %{with_mono}
  129. %files sharp
  130. %defattr(-, root, root, 0755)
  131. %{_libdir}/%{name}/%{name}-sharp*
  132. %files sharp-devel
  133. %defattr(-, root, root, 0755)
  134. %{_libdir}/pkgconfig/%{name}-sharp.pc
  135. %endif
  136. %changelog
  137. * Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-3
  138. - moved sharp subpackage to System Environment/Libraries Group
  139. - moved sharp-devel subpackage to Development/Libraries Group
  140. * Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
  141. - rebuild with new libplist, libimobiledevice
  142. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  143. - new upstream release
  144. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
  145. - rebuild with libimobiledevice-1.1.5
  146. * Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
  147. - update to 0.8.2
  148. - remove Patch0
  149. - add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
  150. - create sharp and sharp-devel package
  151. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
  152. - rebuild with libimobiledevice-1.1.4
  153. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
  154. - rebuild with python-2.7.2
  155. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  156. - rebuild with libimobiledevice-1.1.1
  157. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
  158. - update to 0.8.0
  159. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
  160. - rebuilt with rpm-4.8.1 for pkg-config
  161. * Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
  162. - new upstream release
  163. - add configure option (disable hal, enable udev, specify temp mount dir)
  164. - add python subpackage
  165. - add BR:
  166. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  167. - new upstream release
  168. - remove static library
  169. * Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
  170. - added BuildRequires: libffi-devel
  171. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
  172. - spec in utf-8
  173. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
  174. - applied new versioning policy
  175. * Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
  176. - new upstream release
  177. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
  178. - for VineSeedPlus
  179. - new upstream release
  180. - built with new toolchain
  181. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  182. - new upstream release
  183. - build with dbus-0.62
  184. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  185. - new upstream release
  186. - build with dbus-0.61
  187. * Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  188. - initial package