libuser-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513
  1. %define WITH_SELINUX 0
  2. %define python %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: libuser
  4. Version: 0.60
  5. Release: 1%{?_dist_release}
  6. Summary: A user and group account administration library.
  7. Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
  8. Group: System Environment/Base
  9. License: LGPL
  10. URL: https://fedorahosted.org/libuser/
  11. Source: libuser-%{version}.tar.xz
  12. Patch0: libuser-selinux.patch
  13. BuildRoot: %{_tmppath}/%{name}-root
  14. BuildRequires: pam-devel
  15. BuildRequires: popt
  16. BuildRequires: python-devel
  17. BuildRequires: gtk-doc
  18. BuildRequires: linuxdoc-tools
  19. BuildRequires: pkgconfig
  20. BuildRequires: glib2-devel
  21. BuildRequires: popt-devel
  22. #BuildPrereq: cyrus-sasl-devel, openldap-devel
  23. %description
  24. The libuser library implements a standardized interface for manipulating
  25. and administering user and group accounts. The library uses pluggable
  26. back-ends to interface to its data sources.
  27. Sample applications modeled after those included with the shadow password
  28. suite are included.
  29. %package devel
  30. Group: Development/Libraries
  31. Summary: Files needed for developing applications which use libuser.
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The libuser-devel package contains header files, static libraries, and other
  35. files useful for developing applications with libuser.
  36. %prep
  37. %setup -q
  38. %if %{WITH_SELINUX}
  39. #SELinux
  40. %patch0 -p1 -b .selinux
  41. %endif
  42. %build
  43. CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
  44. %configure \
  45. --with-python-version=%{python} \
  46. --with-python-path=%{_includedir}/python%{python} \
  47. --with-html-dir=%{_datadir}/gtk-doc/html \
  48. --with-pic
  49. make
  50. %clean
  51. rm -fr $RPM_BUILD_ROOT
  52. %install
  53. rm -fr $RPM_BUILD_ROOT
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  56. LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
  57. export LD_LIBRARY_PATH
  58. # Verify that all python modules load, just in case.
  59. pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
  60. python%{python} -c "import libuser"
  61. popd
  62. # remove .la
  63. rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
  64. rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
  65. %find_lang %{name}
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files -f %{name}.lang
  69. %defattr(-,root,root)
  70. %doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
  71. %config(noreplace) %{_sysconfdir}/libuser.conf
  72. %attr(0755,root,root) %{_bindir}/*
  73. %attr(0755,root,root) %{python_sitearch}/*.so
  74. %attr(0755,root,root) %{_libdir}/*.so.*
  75. %dir %attr(0755,root,root) %{_libdir}/%{name}
  76. %attr(0755,root,root) %{_libdir}/%{name}/*.so
  77. #%attr(0644,root,root) %{_libdir}/%{name}/*.la
  78. %attr(0755,root,root) %{_sbindir}/*
  79. %files devel
  80. %defattr(-,root,root)
  81. %attr(0755,root,root) %dir %{_includedir}/libuser
  82. %attr(0644,root,root) %{_includedir}/libuser/*
  83. #attr(0644,root,root) %{_libdir}/*.la
  84. %attr(0755,root,root) %{_libdir}/*.so
  85. #%attr(0644,root,root) %{_mandir}/man3/*
  86. %attr(0644,root,root) %{_mandir}/man5/*
  87. %attr(0644,root,root) %{_libdir}/pkgconfig/*
  88. %{_datadir}/gtk-doc/html/*
  89. %{_mandir}/man1/*
  90. %changelog
  91. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.60-1
  92. - new upstream release
  93. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
  94. - rebuild with python-2.7.2
  95. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
  96. - rebuild with rpm-4.8.1 for pkg-config file
  97. * Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
  98. - add BuildRequires: pkgconfig, glib2-devel, popt-devel
  99. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
  100. - rebuild for python-2.6
  101. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
  102. - new upstream release
  103. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
  104. - rebuilt with python-2.5.2
  105. - removed *.la
  106. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
  107. - applied new versioning policy
  108. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
  109. - new upstream release
  110. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
  111. - rebuild with python-2.4.1-0vl1
  112. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
  113. - rebuild with python-2.3.3-0vl1
  114. * Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
  115. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  116. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
  117. - resync to fedora
  118. * Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
  119. - initial build for Vine Linux
  120. * Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
  121. - degrade gracefully
  122. - build with --with-pic and -fPIC
  123. - remove unpackaged man page
  124. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
  125. - translation updates
  126. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
  127. - doc updates -- cvs tree moved
  128. - language updates
  129. - disallow weird characters in account names
  130. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  131. - automated rebuild
  132. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
  133. - files: ignore blank lines in files
  134. - libuser: disallow creation of accounts with names containing whitespace,
  135. control characters, or non-ASCII characters
  136. * Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
  137. - refresh translations
  138. - fix a heap-corruption bug in the python bindings
  139. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
  140. - bump version
  141. - refresh translations
  142. * Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
  143. - ldap: cache an entity's dn in the entity structure to try to speed things up
  144. * Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
  145. - rebuild in new environment
  146. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
  147. - add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
  148. - translation refresh
  149. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
  150. - fix python bindings of enumerateFull functions
  151. - adjust prompter wrapping to not error out on successful returns
  152. * Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
  153. - be more careful about printing error messages
  154. - fix refreshing after adding of accounts
  155. - ldap: try to use a search to convert names to DNs, and only fall back to
  156. guessing if it turns up nothing
  157. - files: fix an off-by-one in removal of entries
  158. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
  159. - refresh translations
  160. - fix admin() constructor comments in the python module
  161. * Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
  162. - automatically refresh entities after add, modify, setpass, removepass,
  163. lock, and unlock operations
  164. - remove debug spewage when creating and removing mail spools
  165. - files: fix saving of multi-valued attributes
  166. - rename MEMBERUID attribute for groups to MEMBERNAME
  167. * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
  168. - files: fix bug in removals
  169. - ldap: revert attempts at being smart at startup time, because it makes UIs
  170. very messy (up the three whole dialogs just to start the ldap stuff!)
  171. * Sat Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
  172. - fix thinko in dispatch routines
  173. * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
  174. - lgroupmod: fix thinko
  175. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
  176. - rebuild in new environment
  177. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
  178. - move shadow initialization for groups to the proper callback
  179. - rework locking in the files module to not require that files be writable
  180. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
  181. - expose lu_strerror()
  182. - add various typedefs for types used by the library
  183. * Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
  184. - add removepass() functions
  185. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
  186. - lchfn,lchsh,lpasswd - reorder PAM authentication calls
  187. - include API docs in the package
  188. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
  189. - ldap: finish port to new API
  190. - sasl: finish port to new API (needs test)
  191. - libuser: don't commit object changes before passing data to service
  192. functions which might need differing data sets to figure out what to
  193. change (for example, ldap)
  194. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
  195. - bind the internal mail spool creation/removal functions for python
  196. * Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
  197. - renamed the python module
  198. - revamped internals to use gobject's gvalues and gvaluearrays instead of
  199. glists of cached strings
  200. - add enumeration-with-data functions to the C library
  201. * Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  202. - require linuxdoc-tools instead of sgml-tools for rawhide
  203. * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  204. - fixup build files to allow building for arbitrary versions of python
  205. * Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
  206. - link the python module against libpam
  207. - attempt to import the python modules at build-time to verify dependencies
  208. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
  209. - fix a file-parsing bug that popped up in 0.29's mmap modifications
  210. * Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
  211. - quotaq: fix argument order when reading quota information
  212. - user_quota: set quota grace periods correctly
  213. - luseradd: never create home directories for system accounts
  214. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  215. - add da translation files
  216. - update translations
  217. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
  218. - add an explicit build dependency on jade (for the docs)
  219. * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  220. - HUP nscd on modifications
  221. - userutil.c: mmap files we're reading for probable speed gain
  222. - userutil.c: be conservative with the amount of random data we read
  223. - docs fixes
  224. * Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
  225. - apps: print usage on errors
  226. - lnewusers.c: initialize groups as groups, not users
  227. - lnewusers.c: set passwords for new accounts
  228. - luseradd.c: accept group names in addition to IDs for the -g flag
  229. - luseradd.c: allow the primary GID to be a preexisting group
  230. * Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
  231. - add ko translation files
  232. - files.c: fix a heap corruption bug in lock/unlock (#51750)
  233. - files.c: close a memory leak in reading of files
  234. * Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  235. - files.c: remove implementation limits on lengths of lines
  236. * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
  237. - lusermod: change user name in groups the user is a member of during renames
  238. - lgroupmod: change primary GID for users who are in the group during renumbers
  239. - ldap.c: handle new attributes more gracefully if possible
  240. - add ru translation files
  241. * Tue Aug 7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
  242. - rename the quota source files to match the library, which clears up a
  243. file conflict with older quota packages
  244. - add ja translation files
  245. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  246. - add lu_ent_clear_all() function
  247. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
  248. - close up some memory leaks
  249. - add the ability to include resident versions of modules in the library
  250. * Wed Aug 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
  251. - fix incorrect Py_BuildValue invocation in python module
  252. * Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
  253. - stop leaking descriptors in the files module
  254. - speed up user creation by reordering some checks for IDs being in use
  255. - update the shadowLastChanged attribute when we set a password
  256. - adjust usage of getXXXXX_r where needed
  257. - fix assorted bugs in python binding which break prompting
  258. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
  259. - install sv translation
  260. - make lpasswd prompt for passwords when none are given on the command line
  261. - make sure all user-visible strings are marked for translation
  262. - clean up some user-visible strings
  263. - require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
  264. * Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  265. - print uids and gids of users and names in lid app
  266. - fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
  267. - implement enumerate_by_group and enumerate_by_user in ldap module
  268. - fix id-based lookups in the ldap module
  269. - implement islocked() method in ldap module
  270. - implement setpass() method in ldap module
  271. - add lchfn and lchsh apps
  272. - add %%d substitution to libuser.conf
  273. * Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
  274. - finish adding a sasldb module which manipulates a sasldb file
  275. - add users_enumerate_by_group and groups_enumerate_by_users
  276. * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  277. - luserdel: remove the user's primary group if it has the same name as
  278. the user and has no members configured (-G disables)
  279. - fixup some configure stuff to make libuser.conf get generated correctly
  280. even when execprefix isn't specified
  281. * Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
  282. - only call the auth module when setting passwords (oops)
  283. - use GTrees instead of GHashTables for most internal tables
  284. - files: complain properly about unset attributes
  285. - files: group passwords are single-valued, not multiple-valued
  286. - add lpasswd app, make sure all apps start up popt with the right names
  287. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
  288. - actually make the new optional arguments optional
  289. - fix lu_error_new() to actually report errors right
  290. - fix part of the python bindings
  291. - include tools in the binary package again
  292. - fixup modules so that password-changing works right again
  293. - add a "key" field to prompt structures for use by apps which like to
  294. cache these things
  295. - add an optional "mvhomedir" argument to userModify (python)
  296. * Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
  297. - finish home directory population
  298. - implement home directory moving
  299. - change entity get semantics in the python bindings to allow default values for .get()
  300. - add lu_ent_has(), and a python has_key() method to Entity types
  301. - don't include tools in the binary package
  302. - add translated strings
  303. * Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
  304. - lib/user.c: catch and ignore errors when running stacks
  305. - lusermod: fix slightly bogus help messages
  306. - luseradd: when adding a user and group, use the gid of the group
  307. instead of the user's uid as the primary group
  308. - properly set the password field in user accounts created using
  309. auth-only auth modules (shadow needs "x" instead of "!!")
  310. - implement home directory removal, start on population
  311. * Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  312. - fix group password setting in the files module
  313. - setpass affects both auth and info, so run both stacks
  314. * Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  315. - make the testbed apps noinst
  316. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  317. - fix errors due to uninitialized fields in the python bindings
  318. - add kwargs support to all python wrappers
  319. - add a mechanism for passing arguments to python callbacks
  320. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  321. - stub out the krb5 and ldap modules so that they'll at least compile again
  322. * Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  323. - don't bail when writing empty fields to colon-delimited files
  324. - use permissions of the original file when making backup files instead of 0600
  325. * Fri Jul 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  326. - finish implementing is_locked methods in files/shadow module
  327. - finish cleanup of the python bindings
  328. - allow conditional builds of modules so that we can build without
  329. all of the prereqs for all of the modules
  330. * Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  331. - add error reporting facilities
  332. - split public header into pieces by function
  333. - backend cleanups
  334. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  335. - make %%{name}-devel require %%{name} and not %%{name}-devel
  336. * Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  337. - clean up quota bindings some more
  338. - finish most of the ldap bindings
  339. - fix a subtle bug in the files module that would show up when renaming accounts
  340. - fix mapping methods for entity structures in python
  341. * Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
  342. - get bindings for prompts to work correctly
  343. - clean up some of the add/remove semantics (set source on add)
  344. - ldap: implement enumeration
  345. - samples/enum: fix the argument order
  346. * Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  347. - clean up python bindings for quota
  348. * Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
  349. - finish up python bindings for quota support
  350. * Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  351. - finish up quota support libs
  352. * Fri Jun 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  353. - start quota support library to get some type safety
  354. * Thu Jun 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  355. - start looking at quota manipulation
  356. * Wed Jun 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  357. - add functions for enumerating users and groups, optionally per-module
  358. - lusermod.c: -s should specify the shell, not the home directory
  359. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
  360. - finish the python bindings and verify that the file backend works again
  361. * Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  362. - remove a redundant check which was breaking modifications
  363. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  364. - finish adding setpass methods
  365. * Wed May 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
  366. - get a start on some Python bindings
  367. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
  368. - make binary-incompatible change in headers
  369. * Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
  370. - add doxygen docs and a "doc" target for them
  371. * Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
  372. - add a "quiet" prompter
  373. - add --interactive flag to sample apps and default to using quiet prompter
  374. - ldap: attempt a "self" bind if other attempts fail
  375. - krb5: connect to the password-changing service if the user principal has
  376. the NULL instance
  377. * Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  378. - the great adding-of-the-copyright-statements
  379. - take more care when creating backup files in the files module
  380. * Wed Jan 3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
  381. - add openldap-devel as a buildprereq
  382. - krb5: use a continuous connection
  383. - krb5: add "realm" config directive
  384. - ldap: use a continuous connection
  385. - ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
  386. - ldap: actually finish the account deletion function
  387. - ldap: don't send cleartext passwords to the directory
  388. - fix naming attribute for users (should be uid, not gid)
  389. - refine the search-by-id,convert-to-name,search-by-name logic
  390. - fix handling of defaults when the config file is read in but contains no value
  391. - implement an LDAP information store
  392. - try to clean up module naming with libtool
  393. - luseradd: pass plaintext passwords along
  394. - luseradd: use symbolic attribute names instead of hard-coded
  395. - lusermod: pass plaintext passwords along
  396. - lgroupadd: pass plaintext passwords along
  397. - lgroupmod: pass plaintext passwords along
  398. - add libuser as a dependency of libuser-devel
  399. * Tue Jan 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
  400. - initial packaging