libqb-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598
  1. Name: libqb
  2. Version: 0.17.1
  3. Release: 2%{?_dist_release}
  4. Summary: An IPC library for high performance servers
  5. Summary(ja): 高性能サーバー用のプロセス間通信ライブラリ
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://clusterlabs.github.io/libqb/
  9. Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildRequires: libtool doxygen procps check-devel automake
  12. %description
  13. libqb provides high performance client server reusable features.
  14. Initially these are IPC and poll.
  15. %package devel
  16. Summary: Development files for %{name}
  17. Summary(ja): %{name} の開発用ファイル
  18. Group: Development/Libraries
  19. Requires: %{name} = %{version}-%{release}
  20. Requires: pkgconfig
  21. %description devel
  22. The %{name}-devel package contains libraries and header files for
  23. developing applications that use %{name}.
  24. %prep
  25. %setup -q
  26. # Make sure the timestamps are correct
  27. find . -exec touch \{\} \;
  28. %build
  29. %configure --disable-static
  30. make %{?_smp_mflags}
  31. %check
  32. make -j1 check
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make install DESTDIR=$RPM_BUILD_ROOT
  36. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  37. rm -rf $RPM_BUILD_ROOT/%{_docdir}/*
  38. %clean
  39. rm -rf $RPM_BUILD_ROOT
  40. %post -p /sbin/ldconfig
  41. %postun -p /sbin/ldconfig
  42. %files
  43. %defattr(-,root,root,-)
  44. %doc COPYING
  45. %{_sbindir}/qb-blackbox
  46. %{_libdir}/libqb.so.*
  47. %files devel
  48. %defattr(-,root,root,-)
  49. %doc COPYING README.markdown
  50. %{_includedir}/qb/
  51. %{_libdir}/libqb.so
  52. %{_libdir}/pkgconfig/libqb.pc
  53. %{_mandir}/man3/qb*3*
  54. %{_mandir}/man8/qb-blackbox.8.gz
  55. %changelog
  56. * Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.17.1-2
  57. - Initial build for Vine Linux
  58. * Tue Aug 26 2014 David Vossel <dvossel@redhat.com> - 0.17.1-1
  59. Fix: ipcs: Correctly allocate receive buffer size
  60. Fix: ipc_socket: Signalhandler must be resetted to Default, use only cleanup_sigpipe to return from qb_ipc_dgram_sock_setup.
  61. Fix: trie: allow modifying the trie map during the notify callback
  62. Fix: fix invalid option when run 'ipcclient -h'
  63. Fix: epoll: don't miss poll events under high load
  64. Fix: ipc_shm: fix error handling in qb_ipcs_shm_connect()
  65. Fix: ringbuffer: fix size in qb_rb_create_from_file()
  66. Fix: ringbuffer: fix qb_rb_open_2() debug format string
  67. Fix: trie: fixes regression caused by ref count refactoring
  68. Fix: ipcc: Properly timeout during recv when timeout value is provided
  69. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17.0-4
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  71. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17.0-3
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  73. * Thu Feb 20 2014 David Vossel <dvossel@redhat.com> - 0.17.0-2
  74. Fix testsuite timing values
  75. * Wed Feb 19 2014 David Vossel <dvossel@redhat.com> - 0.17.0-1
  76. Fix: build: Allow 'make rpm' to work with lightweight tags for release candidates
  77. Fix: spec: reference correct url in spec file
  78. Doc: update broken doxygen link to something that exists
  79. Bump version to 0.17.0
  80. Low: ipc_socket: further optimize max msg size calculations for fbsd portability tests
  81. Low: ipc_socket: Allow socket max msg size to be calculated more accurately
  82. Fix: fixes travis compile time error
  83. Low: tests: Fixes compile time issue with make check
  84. High: ipcs: Prevent ipc server use after free.
  85. Low: ipc: Remove ipc connection reference given to dispatch functions
  86. High: ipc: Fixes memory leak in server connection accept when client partially connects
  87. IPC: Increase the listen backlog of IPC server
  88. Low: ipcs: Clarifications to the ipcs server callback documentation.
  89. Fix rb.test to avoid overwriting memory during reading.
  90. Low: example: Update client/server example to use server enforced buffer size
  91. Low: Client side buffer retrieval regression test
  92. Feature: New api function to retrieve client buffer size
  93. Low: check_ipc.c: Verify server enforced buffer sizes work
  94. Feature: Enforce buffer size limits on the server side
  95. Low: regession tests for regex log filters
  96. Feature: Filter logs using regex patter on function, format, or filename
  97. ipc_setup: Set SO_PASSCRED on listener socket
  98. Fix: log: Filtering by function and file must match exactly, no substring matches
  99. Low: blackbox: Abort blackbox logging on ringbuffer overwrite reclaim error
  100. High: ipcs: Api function allowing server to retrieve client connection's ipc buffer size
  101. Low: ringbuffer: Abort during chunk reclaim if OVERWRITE flag is set and reclaim fails.
  102. High: blackbox: unique blackbox ringbuffer files per pid
  103. Low: ipc_socket: Fixes fd leak in socket ipc client disconnection
  104. Use sizeof to get the correct size of the sockaddr_un sun_path member in a portable way. Fixes corosync on Mac OS X.
  105. Detect the max signal value that can be used using NSIG macro
  106. Avoid double-decrement of level->todo
  107. * Thu Aug 1 2013 David Vossel <dvossel@redhat.com> - 0.16.0-1
  108. Bump version to 0.16.0 ... do not use version 0.15.0
  109. Update release gpg sign key
  110. Bump the version to 0.15.0
  111. Merge pull request #83 from davidvossel/master
  112. Low: ipc_socket: Output send event failure as debug instead of error
  113. Low: ipcserver.c: Fix example server's glib mainloop implementation
  114. High: ipc_socket.c: Detect EOF connection on connection STREAM socket
  115. Merge pull request #81 from davidvossel/dgram_max_msg
  116. Low: tests: Add dgram max size detection test
  117. Low: ipc_socket.c: Handle the unlikely event of an EAGAIN or EINTR during dgram max size detection
  118. Merge pull request #82 from davidvossel/master
  119. Fixes detect disconnect on send for tcp example
  120. Fixes sem leak
  121. Fixes less-than-zero comparision of unsigned int
  122. fixes double close
  123. Fixes double close
  124. Fixes double fd close
  125. Fixes fd leak
  126. Prevent use after free in benchmark util
  127. Fixes use ater free in shm disconnect
  128. Fixes use after free during ipcs client disconnect
  129. Remove dead code
  130. Low: check_ipc.c: Verify dgram max size during tests
  131. High: ipcc: Add abilty to verify dgram kernel buffer size meets max msg value
  132. Fixes travis build error
  133. Merge pull request #80 from davidvossel/master
  134. Low: check_ipc.c: fix debug message to only display once.
  135. High: ringbuffer: Make max_size of ringbuffer accurate so shm ipc max msg size value is honored
  136. Low: ipcs: For shm ipc, always retry outstanding notifications when next event is sent
  137. Low: tests: Added test to verify sending ipc msg equal to max size succeeds
  138. Merge pull request #79 from davidvossel/master
  139. Merge pull request #78 from davidvossel/master
  140. Fix: ipcs: Fixes compile time issue reported by travis
  141. Merge pull request #77 from davidvossel/stress_tests_fixes
  142. Low: loop_pool_kqueue: remove potentially noisy dbug statement
  143. Low: tests: rework bulk event msg ipc test
  144. Account for fbsd ENOBUFS during stress test
  145. Low: tests: Adds ipc event stress test to testsuite
  146. Low: ipc_socket: In fbsd send() returns ENOBUFS when dgram queue is full, this should be treated similar to EAGAIN
  147. High: kqueue: Properly enable kqueue filter in poll loop
  148. Low: ipcs: Attempt to resend outstanding event notifications during event send
  149. Merge pull request #75 from davidvossel/ref_count_cleanup
  150. Low: qbipcs.h: update ipcs connection iterator documentation
  151. Merge pull request #74 from davidvossel/ref_count_cleanup
  152. Fix: ipcs: Disconnect shm ipc connection when poll socket returns error on msg receive
  153. Fix: ipcs: Properly disconnect client connection on POLLNVAL or any other error causing connection removal from mainloop.
  154. Simplify internal ipcs ref counting, add comments and document api behavior
  155. Simplifies connection ref counting without changing behavior
  156. Low remove ref-count error in example ipcserver.
  157. Merge pull request #73 from davidvossel/ref_count_cleanup
  158. Merge pull request #72 from davidvossel/master
  159. Low: tests: Verify reading valid blackbox file works
  160. Fix: refcount leak
  161. Fix: ringbuffer: Add file header version field and detect reading corrupted blackbox files using hash value
  162. Fix: tests: On some platforms -ECONNRESET is returned rather than -ENOTCONN after server failure
  163. Fix: tests: Make blackbox_segfault.sh not depend on bash
  164. Hopefully this is the last travis link fix
  165. Fix travis icon (travis is case sensitive)
  166. Fix the github links
  167. Merge pull request #70 from yuusuke/fix_logging
  168. fix a problem when the character string beyond the number of the maximum characters is passed
  169. Merge pull request #68 from r1mikey/upstream
  170. Add a IPC service context pointer and accessors from both the connection and service level.
  171. Enable distcheck on the travis tests
  172. Add atomic_int.h to noinst_HEADERS
  173. Use the new atomic ops in the ringbuffer
  174. Add internal support for the new __atomic gcc builtins
  175. Rename the configure macros from atomic to sync
  176. ringbuffer: use atomic ops on ringbuffer chunk magic
  177. Remove some test code mistakenly committed to the example program.
  178. IPC: make each connection ref the owning service
  179. Indicate when/why qb_rb_force_close() fails to remove share memory files
  180. Typo fixed in configure
  181. Fix "make srpm"
  182. Remove doxygen from travis deps to try and get the job working.
  183. Fix make distcheck
  184. Merge pull request #60 from t-matsuo/fix-makefile-of-tests
  185. add file_change_bytes into check_PROGRAMS and fix a typo
  186. Deal better with corrupt blackbox files.
  187. Merge pull request #58 from inouekazu/fix_connection_state_checking
  188. IPC: fix the connection state checking
  189. LOG: copy the function/filename for dynamic callsites
  190. Deal with /dev/shm issue on Travis builders
  191. Properly discover SO_NOSIGPIPE and MSG_SIGNAL
  192. IPC: fix call to QB_SUN_LEN
  193. list: don't splice empty lists onto the head.
  194. rpl_sem: make destroy more compliant
  195. test: fix unused-but-set-variable warning
  196. test: fix missing-format-attribute warning
  197. RB: make the "sem" abstraction into a notifier
  198. IPC: clean up the connection state checking
  199. Use dgram sockets for message oriented communications
  200. IPC: don't interpret EMSGSIZE and ENOMSG as a disconnect
  201. POLL: prevent a spin if the fd is not removed from the mainloop
  202. add TAGS and ~ files to .gitignore
  203. docs: install qb-blackbox.8 if doxygen is not available.
  204. IPC: seperate ipc_us.c into 2 files
  205. IPC: move utility functions to unix.c
  206. IPC: make sure we return a consistent error when the message is too big.
  207. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  209. * Thu Jan 17 2013 Angus Salkeld <asalkeld@redhat.com> - 0.14.4-1
  210. LOG: prevent the last char of the blackbox message from getting lost.
  211. Example: make the blackbox example more practical.
  212. Add the processing which remove notifier at skiplist_destroy function
  213. Add the processing which remove hash node and notifier at hashtable_destroy function
  214. Unify to QB_TRUE/QB_FALSE a boolean value
  215. Document the default prefix in INSTALL
  216. Unify the list processing with qb_list function
  217. Add travis link to the readme.
  218. Fix return code which is an error occurred at pthread function
  219. TEST: add a progam to compare the speed of vsnprintf and qb_vsnprintf_serialize
  220. LOG: add a test for a padded hex int.
  221. Fedora's splint has a strange syntax error, don't fail on it.
  222. LOG: fix truncation in some messages that get padded.
  223. Fix the blackbox formatter when specifing the string len/precision
  224. Fix strlcpy and strlcat functions
  225. IPC: don't over log on disconnect
  226. Make sure we don't use the format string whilst it is getting changed.
  227. ptrie: deref the current node in trie_iter_free()
  228. LOG: fix the format comparison to avoid generating multiple entries.
  229. LOG: set the return code when calloc fails
  230. IPC: call poll if we are mid message and get EAGAIN
  231. Remove extra ";"
  232. IPC: set the error more correctly when qb_sys_mmap_file_open() fails.
  233. Make sure that mmap'ed files smaller than a page size are written to.
  234. example/test: check for error in qb_ipc_run()
  235. example: check for error in qb_ipc_run()
  236. TEST: fix typo s/,/; in check_ipc.c
  237. * Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-2
  238. Fix test code highlighted by new check version
  239. Remove the call to autogen.sh - not needed anymore.
  240. * Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-1
  241. IPC: Pass the timeout to poll() if the recv function returns EAGAIN
  242. LOG: make the format comparison safe and sane
  243. LOG: don't break on empty callsites, just ignore them
  244. LOG: use the array callback to register new callsites
  245. array: add a mechanism to get a callback when a bin is allocated
  246. Solaris based operating systems don't define MSG_NOSIGNAL and SO_NOSIGPIPE.
  247. Make sure atomic's are initialized (for non-gcc atomic).
  248. * Wed Sep 12 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.2-2
  249. Fix a crash in ptrie if you iterate over the map in the deleted notifier.
  250. * Mon Sep 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.2-1
  251. Get libqb building on cygwin.
  252. ipc_us: slightly more robust cmsg handling
  253. ipc_us: on Linux, set SO_PASSCRED on the sending socket too
  254. ipc_us: clear request unused fields
  255. TEST: Include writing and reading the blackbox in the log_long_msg test
  256. LOG: fix qb_vsnprintf_deserialize()
  257. blackbox: fix 64-bit big-endian issues
  258. Remove IPC_NEEDS_RESPONSE_ACK and turn off shm ipc on solaris
  259. Define unix path max for openbsd
  260. Only turn on ipc_needs_response_ack=yes for solaris
  261. Some improvements to kqueue usage.
  262. kqueue: drop log message to trace.
  263. Fix splint warning
  264. openbsd requires netinet/in.h before arpa/inet.h
  265. Avoid strcpy() use strlcpy() instead.
  266. Fix kqueue complile warnings
  267. openbsd doesn't have EBADMSG
  268. openbsd has a different UNIX_PATH_MAX
  269. LOG: change qb_vsprintf_serialize() into qb_vsnprintf_serialize()
  270. TEST: increase timeout to 6 secs as the recv timeout is 5 secs
  271. TEST: get the logic right - grrr.
  272. Turn off attribute_section on netbsd
  273. Some missing pshared semaphore checks
  274. Cleanup the checks for pshared semaphores
  275. Add a config check for pthread_mutexattr_setpshared
  276. Remove uses of timersub and use qb_util_stopwatch
  277. RB: change the #error to ENOTSUP if no usable shared process sem
  278. LOOP-KQUEUE: fix reference before assignment.
  279. build: fix libqb.pc creation and make maintainer-clean
  280. LOG: Make sure the semaphores are initialized.
  281. build: remove bashism in cc support check
  282. Catch disconnected sockets on Solaris
  283. Don't free rb->shared_hdr in qb_rb_create_from_file()
  284. Check error return of qb_ipcs_uc_recv_and_auth()
  285. Fix removal of automatically installed doc files when building rpms
  286. Add the mailing list to the travis email notifications.
  287. Work around debian not setting the arch path in splint.
  288. Remove color-tests and parallel-tests automake options.
  289. Add travis continuous integration config
  290. LOG: Invoke custom log filter function if tag changes
  291. tests/rbwriter: don't ignore write failure
  292. ipcs: avoid use-after-free for size-0 || disconnect-request
  293. * Wed Jul 18 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.1-1
  294. RB: set the new read pointer after clearing the header (#839605).
  295. RB: improve the debug print outs
  296. RB: be more explicit about the word alignment
  297. RB: cleanup the macros for wrapping the index
  298. RB: use sem_getvalue as a tie breaker when read_pt == write_pt
  299. RB: if read or peek don't get the message then re-post to the semaphore
  300. RB: convert the rb_peek() status into a recv like status.
  301. RB: use internal reclaim function
  302. IPC: use calloc instead of malloc to fix valgrind warnings
  303. Upgrade the doxygen config.
  304. Fix a valgrind error.
  305. * Sun Jun 24 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.0-1
  306. LOG: fix threaded logging.
  307. Add user control of the permissions that are set on the shared mem files
  308. LOG: Restrict string trucation during serialization to when a precision is specified
  309. LOG: Gracefully fail when the caller exceeds QB_LOG_MAX_LEN
  310. LOG: Observe field widths when serializing string arguments
  311. RB: use the same mechanism in reclaim as read/peek to detect end-of-ring
  312. Add needs_response_ack option to ./check
  313. RB: fix wrong sem_flg IPC_NOWAIT option
  314. TESTS: fix warning about unused functions
  315. Remove D_FORTIFY_SOURCE from check.
  316. Open shared mem file in /dev/shm only for linux
  317. Don't use msg_flags on solaris (recvmsg).
  318. Turn off attribute_section on solaris
  319. ipc example: add -e (events) option
  320. IPC: if the server returns EAGAIN or ETIMEOUT the check the connection
  321. LOG: make it possible to fsync() on each file log.
  322. IPC: make sure that the created callback happens before dispatches
  323. LOG: fix the printing of %p in the blackbox
  324. IPC: On bsd's use the notifier for responses
  325. IPC: interpret ECONNRESET and EPIPE as ENOTCONN
  326. cleanup some warnings
  327. config: use newer AC_COMPILE_IFELSE()
  328. blackbox: fix %p formatting
  329. LOG: put all fields in the blackbox (added priority and tags)
  330. example: make the priority uint8_t
  331. Remove strerror out of check_funcs
  332. RB: fix compiler warning.
  333. Add replacement function stpcpy
  334. Add missing AC_TYPE_UINT16_T to configure.ac
  335. Use AC_FUNC_STRERROR_R and STRERROR_R_CHAR_P
  336. Add stpcpy strcasecmp to the check_funcs
  337. Move some conditional defines into code (from the configure script)
  338. Remove some unused configure checks
  339. Remove message queues
  340. Check for union semun properly
  341. Blackbox: provide more space for log messages when reading from the blackbox.
  342. Add the blackbox reader manpage to the spec file
  343. Enable error logging for the blackbox reader
  344. RB: Read the file size into an initialized variable of the correct size
  345. Add a tool to dump the blackbox.
  346. RB: to be safer save the read and write pointers at the top of the blackbox
  347. avoid unwarranted use of strncpy: use memcpy instead
  348. blackbox: fix the print_from_file()
  349. RB: add an option to not use any semaphores
  350. LOG: tweak the blackbox format string
  351. LOG: accept NULL strings into the blackbox
  352. LOG: protect close and reload from calling log
  353. Add benchmark option (-b) to examples/ipcclient
  354. TEST: make rbreader/writer more like the other benchmarking apps
  355. IPC: log the connection description in all logs
  356. TEST: re-organise the ipc test suites
  357. IPC: only modify the dispatch if we get EAGAIN
  358. Correctly display timestamp in blackbox
  359. * Thu May 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.13.0-1
  360. - Remove unneccessary __attribute__ ((aligned(8))) from internal headers
  361. - IPC: add a new function to get (and alloc) the extended stats.
  362. - Revert "Add the event queue length to the connection stats."
  363. - IPC: cleanup better on a failed client connect.
  364. - IPC(soc): be more consistent with control struct size
  365. - IPC: kill a compiler warning
  366. - IPC(soc): pass in the correct size into munmap()
  367. - TEST: Use /bin/sh not /bin/bash
  368. - TEST: check for lost shared mem on bsd too
  369. - rb: cleanup the semaphores
  370. - Fix some small issues in ./check
  371. - Cleanup the .gitignore files
  372. - configure.ac tweaks
  373. - Remove HZ and use sysconf instead.
  374. - SUN_LEN() macro is present if __EXTENSIONS__ is defined on Illumos
  375. - PF_UNIX is a POSIX standard name
  376. - Test for log facility names
  377. - IPC: drop log message to debug.
  378. - IPC: fix retrying of partial recv's and sends.
  379. - IPC: initialize enough shared mem for all 3 one way connections.
  380. - IPC: keep retrying to recv the socket message if partially recv'ed (part 2)
  381. - IPC: keep retrying to recv the socket message if partially recv'ed
  382. - IPC: handle the server shutdown better
  383. - IPC: handle a connection disconnect from the server better
  384. - IPC: make it possible to send events in the connected callback.
  385. - Add the event queue length to the connection stats.
  386. - IPC: add a is_connected client side function.
  387. - Fix typo in ./check
  388. - docs: clarify the need to use request/response headers
  389. - Remove unused local variable
  390. - IPC: change the socket recv function to read the response header.
  391. - Add some special commands into the ipc example
  392. - TEST: improve the tracing in the ipc tests.
  393. - Make "make (s)rpm" work more reliably
  394. - TEST: add a test to confirm we get the events we send.
  395. - TEST: reuse send_and_check for events.
  396. - IPC: make it possible for a root client to talk to a non-root server.
  397. - Run ./Lindent in the examples directory
  398. - Add some debug code to the ipcclient example
  399. - IPC: make sure ipc (socket) clients can connect to a server running as root.
  400. - IPC: allow qb to bump the max_message_size
  401. - IPC: check for a sane minimum max_message_size
  402. - add rpl_sem.h loop_poll_int.h to noinst_headers
  403. - Handle errors more consistently
  404. - call recv_ready on socket types
  405. - Handle a recv of size 0
  406. - make bsd shm path better by default.
  407. - Fix kqueue on freebsd.
  408. - Get the example socket includes right.
  409. - Fix kqueue compiling.
  410. - POLL: seperate out the poll/epoll and add kqueue
  411. - Test existence of getpeer* functions
  412. - Add inet header to tcpclient example
  413. - Don't link with setpshared if unavailable
  414. - NetBSD doesn't have semun defined
  415. - Use MADV_NOSYNC only on systems where available
  416. - Use SCHED_BATCH only on platforms where available
  417. - Fix a bug introduced by the bsd patch.
  418. - Cleanup the selection of semaphores to use
  419. - Fix some leaks in the logging.
  420. - Try and improve the portability on bsd variants.
  421. * Sun Mar 11 2012 Angus Salkeld <asalkeld@redhat.com> - 0.11.1-1
  422. - configue libqb to not use epoll as it seems broken (#800865)
  423. - LOOP: remove some old timerfd code.
  424. - TEST: add a test to check the order of the jobs
  425. - LOOP: when new jobs are added they are added to the head instead of the tail.
  426. - LOG: Now the array is self locking we can make the lookup array dynamic
  427. - Add locking to the array when growing.
  428. - IPC: make the _request_q_len_get() function more obvious.
  429. - IPC: fix multiple receives from qb_ipc_us_recv()
  430. - IPC: make sure that the wrong union member is not written to.
  431. - TIMER: check for null timer handle
  432. Wed Mar 7 2012 Angus Salkeld <asalkeld@redhat.com> - 0.11.0-1
  433. - ARRAY: cleanup the pointer sizeof()
  434. - LOG: turn off __attribute__(section) for powerpc (not working)
  435. - TESTS: move the util tests into "slow-tests" (i.e. optional)
  436. - TEST: make the test_priority the same type as in the callsite
  437. - LOG: make the log arrays manually grow-able since we need to lock the calls.
  438. - RB: fix test failure on ppc
  439. - RB: change the name of the size to word_size to be more clear
  440. - TEST: add some more signal tests.
  441. - LOOP: fix deletion of signal handlers when they are pending
  442. - LOOP: signal handlers were always added as high priority.
  443. - TEST: deal with mac's limited sed
  444. - check: add debugging to the configure options and remove unused options
  445. - TEST: properly clear the filters
  446. - LOG: expose the mechanism to get a dynamic callsite.
  447. - Revert part of my COARSE grained timer commit
  448. - Remove timerfd usage and go back to timelist.
  449. - UTIL: if possible use COARSE resolution clocks - they are much faster.
  450. - ARRAY: save memory (in the bins array) and allow holes in the array
  451. - LOOP: add qb_loop_timer_is_running()
  452. - LOOP: allow stop() and run() to be called with NULL loop instance.
  453. - LOOP: fix doxygen parameter comment
  454. - LOG: add stdout target
  455. - LOOP: add a function to delete jobs
  456. - LOG: remove debug printf's
  457. - LOG: remove an old/incorrect doxygen comment.
  458. - LOG: add a hostname %H format specifier.
  459. - LOG: Add qb_log_filter_fn_set()
  460. * Tue Feb 14 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.1-1
  461. - Fix "make distcheck" add include path to AM_CPPFLAGS
  462. - Bump the version to 0.10.1
  463. - clang: Remove unused code
  464. - TEST: make the ipc failure test closer to corosync's case.
  465. - RB: add a debug message if trying to read a message of the wrong size
  466. - IPC: split up the recv into chuncks of 2 seconds. (#788742)
  467. - Be more consistent with the internal logs.
  468. - LOOP: make it possible to pass in NULL as the default loop instance
  469. - RB: use the proper struct not the typedef in the implementation.
  470. - RB: Fix potential mem leak
  471. - Don't mix enums (QB_TRUE/TRUE)
  472. - use random() not rand()
  473. - Remove dead code
  474. - set umask before calling mkstemp()
  475. - Use safer versions of string functions (strcpy -> strlcpy)
  476. - Increase the coverity aggressiveness
  477. - TEST: make the loop ratelimit test more forgiving.
  478. * Tue Feb 07 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.0-1
  479. - LOOP: handle errors from the poll function
  480. - LOOP: make the item type applicable to jobs too.
  481. - LOOP: fix the todo calculations.
  482. - TEST: check for a single job causing a cpu spin
  483. - LOOP: prevent jobs from consuming too much cpu.
  484. - Get coverity to ignore this warning.
  485. - Change example code to use fgets instead of gets
  486. - LOG: pass the result of qb_log_thread_start() back to the user
  487. - Fix some issues found by clang
  488. - Add clang-analyzer check
  489. - Add a split timer to the stopwatch.
  490. - IPC: merge common code into new function
  491. - IPC: better handle a disconnect been called from within connection_created()
  492. - IPC: fix scary typo
  493. - IPC: fix server error handling
  494. * Mon Feb 06 2012 Angus Salkeld <asalkeld@redhat.com> - 0.9.0-2
  495. - Fix a spin in the mainloop when a timer or poll gets removed
  496. When in the job queue (#787196).
  497. * Fri Jan 27 2012 Angus Salkeld <asalkeld@redhat.com> - 0.9.0-1
  498. - Rebased to 0.9.0
  499. * Tue Jan 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.8.1-2
  500. - fix qb_timespec_add_ms()
  501. * Thu Jan 5 2012 Angus Salkeld <asalkeld@redhat.com> - 0.8.1-1
  502. - Rebased to 0.8.1 (#771914)
  503. * Wed Nov 17 2011 Angus Salkeld <asalkeld@redhat.com> - 0.7.0-1
  504. - Rebased to 0.7.0 (#754610)
  505. * Thu Sep 1 2011 Angus Salkeld <asalkeld@redhat.com> - 0.6.0-2
  506. - LOG: fix the default syslog filter
  507. * Tue Aug 30 2011 Angus Salkeld <asalkeld@redhat.com> - 0.6.0-1
  508. - Rebased to 0.6.0 which includes (#734457):
  509. - Add a stop watch
  510. - LOG: serialize the va_list, don't snprintf
  511. - LOG: change active list into array access
  512. - atomic: fix qb_atomic_pointer macros
  513. - LOG: allow the thread priority to be set.
  514. - Fix splint warning on ubuntu 11.04
  515. * Mon Jul 18 2011 Angus Salkeld <asalkeld@redhat.com> - 0.5.1-1
  516. - Rebased to 0.5.1 which includes:
  517. - LOOP: make the return more consistent in qb_loop_timer_expire_time_get()
  518. - LOG: add string.h to qblog.h
  519. - Add a qb_strerror_r wrapper.
  520. - don't let an invalid time stamp provoke a NULL dereference
  521. - LOG: move priority check up to prevent unnecessary format.
  522. - rename README to README.markdown
  523. * Wed Jun 8 2011 Angus Salkeld <asalkeld@redhat.com> - 0.5.0-1
  524. - Rebased to 0.5.0 which includes:
  525. - new logging API
  526. - support for sparc
  527. - coverity fixes
  528. * Tue Feb 8 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.1-2
  529. - SPEC: improve devel files section
  530. - SPEC: remove global variables
  531. * Mon Jan 31 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.1-1
  532. - SPEC: add procps to BuildRequire
  533. - SPEC: remove automake and autoconf from BuildRequire
  534. - SPEC: remove call to ./autogen.sh
  535. - SPEC: update to new upstream version 0.4.1
  536. - LOOP: check read() return value
  537. - DOCS: add missing @param on new timeout argument
  538. - BUILD: only set -g and -O options if explicitly requested.
  539. - BUILD: Remove unneccessary check for library "dl"
  540. - BUILD: improve the release build system
  541. * Fri Jan 14 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.0-2
  542. - remove "." from Summary
  543. - Add "check-devel to BuildRequires
  544. - Add "make check" to check section
  545. - Changed a buildroot to RPM_BUILD_ROOT
  546. - Document alphatag, numcomm and dirty variables.
  547. * Sun Jan 09 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.0-1
  548. - Initial release