nginx-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.13.9
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.4.2
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  48. %define nginx_accept_language_module_version 2f69842
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 5.2.1
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version a18b409
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. %define nginx_dav_ext_module_version 0.1.0
  58. Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
  59. # removes -Werror in upstream build scripts. -Werror conflicts with
  60. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  61. Patch0: nginx-auto-cc-gcc.patch
  62. # to fix https://svn.boost.org/trac/boost/ticket/8731
  63. Patch100: boost-changeset_84950.diff
  64. # to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
  65. Patch101: gnosek-nginx-upstream-fair-pull-23.patch
  66. # to fix compile error with C++11.
  67. Patch1000: passenger-5.0.28-boost.patch
  68. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  69. %if "%{_dist_release}" > "vl6"
  70. BuildRequires: libboost-devel
  71. %endif
  72. BuildRequires: pcre-devel
  73. BuildRequires: zlib-devel
  74. BuildRequires: openssl-devel
  75. BuildRequires: gd-devel
  76. BuildRequires: perl
  77. BuildRequires: perl(ExtUtils::Embed)
  78. BuildRequires: libxml2-devel
  79. BuildRequires: libxslt-devel
  80. BuildRequires: curl-devel
  81. %if %{with geoip}
  82. BuildRequires: GeoIP-devel
  83. %endif
  84. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  85. # for /usr/sbin/useradd
  86. Requires(pre): shadow-utils
  87. Requires(post): chkconfig
  88. # for /sbin/service
  89. Requires(preun): chkconfig, initscripts
  90. Requires(postun): initscripts
  91. %if "%{_dist_release}" > "vl6"
  92. Requires(pre): www-common
  93. %endif
  94. Provides: webserver
  95. Vendor: Project Vine
  96. Distribution: Vine Linux
  97. Packager: daisuke
  98. %description
  99. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  100. proxy server written by Igor Sysoev.
  101. %description -l ja
  102. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  103. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  104. - HTTP(S) サーバ
  105. - HTTP(S) リバースプロキシサーバ
  106. - IMAP/POP3 プロキシサーバ
  107. %package passenger
  108. Summary: Nginx with mod_passenger support
  109. Summary(ja): Passenger サポート入りの Nginx
  110. Group: System Environment/Daemons
  111. BuildRequires: ruby, rubygem-rake
  112. Requires: ruby, rubygem-rake
  113. %if "%{_dist_release}" >= "vl7"
  114. BuildRequires: ruby-devel, ruby-rubygems
  115. Requires: ruby-rubygems
  116. %else
  117. BuildRequires: rubygems
  118. Requires: rubygems
  119. %endif
  120. Requires: nginx
  121. %description passenger
  122. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  123. This package contains nginx server with passenger support.
  124. %description -l ja passenger
  125. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  126. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  127. - HTTP(S) サーバ
  128. - HTTP(S) リバースプロキシサーバ
  129. - IMAP/POP3 プロキシサーバ
  130. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  131. %prep
  132. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
  133. %patch0 -p0
  134. # pushd passenger-%{passenger_version}/ext/
  135. # %patch100 -p2
  136. # popd
  137. pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
  138. %patch101 -p1
  139. popd
  140. %if %{?_dist_release} == "vl7"
  141. pushd passenger-%{passenger_version}
  142. #% patch1000 -p1
  143. popd
  144. %endif
  145. %build
  146. # nginx does not utilize a standard configure script. It has its own
  147. # and the standard configure options cause the nginx configure script
  148. # to error out. This is is also the reason for the DESTDIR environment
  149. # variable. The configure script(s) have been patched (Patch1 and
  150. # Patch2) in order to support installing into a build environment.
  151. export DESTDIR=%{buildroot}
  152. CONFIGOPTS="\
  153. --user=%{nginx_user} \
  154. --group=%{nginx_group} \
  155. --prefix=%{nginx_datadir} \
  156. --sbin-path=%{_sbindir}/%{name} \
  157. --conf-path=%{nginx_confdir}/%{name}.conf \
  158. --error-log-path=%{nginx_logdir}/error.log \
  159. --http-log-path=%{nginx_logdir}/access.log \
  160. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  161. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  162. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  163. --pid-path=%{_localstatedir}/run/%{name}.pid \
  164. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  165. --with-file-aio \
  166. --with-ipv6 \
  167. --with-http_ssl_module \
  168. --with-http_v2_module \
  169. --with-http_realip_module \
  170. --with-http_addition_module \
  171. --with-http_xslt_module \
  172. --with-http_image_filter_module \
  173. %if %{with geoip}
  174. --with-http_geoip_module \
  175. %endif
  176. --with-http_sub_module \
  177. --with-http_dav_module \
  178. --with-http_flv_module \
  179. --with-http_mp4_module \
  180. --with-http_gunzip_module \
  181. --with-http_gzip_static_module \
  182. --with-http_auth_request_module \
  183. --with-http_random_index_module \
  184. --with-http_secure_link_module \
  185. --with-http_degradation_module \
  186. --with-http_stub_status_module \
  187. --with-http_perl_module \
  188. --with-mail \
  189. --with-mail_ssl_module \
  190. --with-stream \
  191. --with-stream_ssl_preread_module \
  192. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  193. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  194. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  195. %if %{with wsgi}
  196. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  197. %endif
  198. --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
  199. %ifarch i686
  200. --with-cpu-opt=pentiumpro \
  201. --with-zlib-asm=pentiumpro \
  202. --with-md5-asm \
  203. --with-sha1-asm \
  204. %endif
  205. "
  206. ## build with passenger
  207. ./configure \
  208. $CONFIGOPTS \
  209. --with-cc-opt="%{optflags}" \
  210. --add-module=passenger-%{passenger_version}/src/nginx_module
  211. make %{?_smp_mflags}
  212. mv objs/nginx objs/nginx.passenger
  213. ## build without passenger
  214. ./configure \
  215. $CONFIGOPTS \
  216. --with-cc-opt="%{optflags}"
  217. make %{?_smp_mflags}
  218. %install
  219. rm -rf %{buildroot}
  220. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  221. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  222. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  223. find %{buildroot} -type f -empty -exec rm -f {} \;
  224. find %{buildroot} -type f -exec chmod 0644 {} \;
  225. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  226. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  227. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  228. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  229. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  230. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  231. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  232. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  233. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  234. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  235. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  236. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  237. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  238. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  239. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  240. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  241. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  242. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  243. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  244. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  245. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  246. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  247. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  248. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  249. %if %{with wsgi}
  250. %{__install} -p -m 0644 \
  251. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  252. %{buildroot}%{nginx_confdir}
  253. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  254. %endif
  255. # upstream fair module document
  256. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  257. # document for nginx-dav-ext-module
  258. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
  259. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
  260. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  261. # convert to UTF-8 all files that give warnings.
  262. for textfile in CHANGES
  263. do
  264. mv $textfile $textfile.old
  265. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  266. rm -f $textfile.old
  267. done
  268. %clean
  269. rm -rf %{buildroot}
  270. %post
  271. if [ $1 == 1 ]; then
  272. /sbin/chkconfig --add %{name}
  273. fi
  274. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  275. %post passenger
  276. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  277. %preun
  278. if [ $1 = 0 ]; then
  279. /sbin/service %{name} stop >/dev/null 2>&1
  280. /sbin/chkconfig --del %{name}
  281. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  282. fi
  283. %preun passenger
  284. if [ $1 = 0 ]; then
  285. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  286. fi
  287. %postun
  288. if [ $1 == 2 ]; then
  289. /sbin/service %{name} upgrade || :
  290. fi
  291. %files
  292. %defattr(-,root,root,-)
  293. %doc LICENSE CHANGES README LICENSE.dav-ext-module
  294. %doc README.upstream_fair
  295. %doc README.dav-ext-module.rst
  296. %doc %{?with_wsgi:README.mod_wsgi}
  297. %{nginx_datadir}/
  298. %{_sbindir}/%{name}.normal
  299. %{_mandir}/man3/%{name}.3pm.gz
  300. %{_initrddir}/%{name}
  301. %dir %{nginx_confdir}
  302. %dir %{nginx_confdir}/conf.d
  303. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  304. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  305. %config(noreplace) %{nginx_confdir}/sites.d/*
  306. %config(noreplace) %{nginx_confdir}/win-utf
  307. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  308. %config(noreplace) %{nginx_confdir}/mime.types.default
  309. %config(noreplace) %{nginx_confdir}/fastcgi_params
  310. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  311. %config(noreplace) %{nginx_confdir}/koi-win
  312. %config(noreplace) %{nginx_confdir}/koi-utf
  313. %config(noreplace) %{nginx_confdir}/%{name}.conf
  314. %config(noreplace) %{nginx_confdir}/mime.types
  315. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  316. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  317. %config(noreplace) %{nginx_confdir}/scgi_params
  318. %config(noreplace) %{nginx_confdir}/scgi_params.default
  319. %config(noreplace) %{nginx_confdir}/uwsgi_params
  320. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  321. %if %{with wsgi}
  322. %config(noreplace) %{nginx_confdir}/wsgi_vars
  323. %endif
  324. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  325. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  326. %dir %{perl_vendorarch}/auto/%{name}
  327. %{perl_vendorarch}/%{name}.pm
  328. %{perl_vendorarch}/auto/%{name}/%{name}.so
  329. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  330. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  331. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  332. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  333. %files passenger
  334. %defattr(-,root,root,-)
  335. %doc passenger-%{passenger_version}/doc/*.md
  336. %doc passenger-%{passenger_version}/doc/*.txt
  337. %doc passenger-%{passenger_version}/doc/*.html
  338. %doc passenger-%{passenger_version}/doc/templates
  339. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  340. %doc passenger-%{passenger_version}/doc/images
  341. %{_sbindir}/%{name}.passenger
  342. %changelog
  343. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
  344. - updated to 1.13.9.
  345. - updated ngx-fancyindex to 0.4.2.
  346. - updated nginx-accept_language_module to git HEAD.
  347. - updated nginx-upstream-fair to git HEAD.
  348. - updated passenger to 5.2.1.
  349. - added Source2010 (nginx-dav-ext-module).
  350. - enabled --with-stream and --with-stream_ssl_preread_module.
  351. * Fri Sep 8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
  352. - updated to 1.13.5
  353. - updated passenger to 5.1.8
  354. * Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
  355. - updated to 1.13.4
  356. - updated passenger to 5.1.7
  357. * Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
  358. - updated to 1.13.3
  359. * Sat Jul 1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
  360. - updated to 1.13.2
  361. * Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
  362. - updated to 1.13.1
  363. - updated passenger to 5.1.5
  364. * Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
  365. - updated to 1.13.0
  366. * Wed Apr 5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
  367. - updated to 1.11.13
  368. * Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
  369. - updated to 1.11.12
  370. * Tue Mar 7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
  371. - updated to 1.11.10
  372. - updated passenger to 5.1.2
  373. * Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
  374. - updated to 1.11.9
  375. * Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
  376. - updated to 1.11.8
  377. * Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
  378. - updated to 1.11.6
  379. - applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
  380. * Mon Sep 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
  381. - updated to 1.11.3
  382. - updated passenger to 5.0.30
  383. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  384. - rebuild with gcc-5.4.0
  385. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  386. - updated to 1.10.1.
  387. - updated passenger to 5.0.28.
  388. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  389. - updated to 1.9.15
  390. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  391. - updated to 1.9.14
  392. - updated passenger to 5.0.27
  393. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  394. - new upstream release
  395. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  396. - updated to 1.9.12.
  397. - updated passenger to 5.0.26.
  398. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  399. - new upstream release
  400. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  401. - update to 1.9.10
  402. - update passenger to 5.0.24
  403. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  404. - update passenger to 5.0.23
  405. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  406. - new upstream release
  407. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  408. - new upstream release
  409. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  410. - new upstream release
  411. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  412. - new upstream release
  413. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  414. - update to 1.9.3
  415. - update passenger to 5.0.11
  416. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  417. - updated Source4 (ssl.conf).
  418. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  419. - update to 1.9.2
  420. - update passenger to 5.0.10
  421. - update ngx-fancyindex to 0.3.5
  422. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  423. - update to 1.6.2
  424. - update passenger to 4.0.52
  425. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  426. - new upstream release
  427. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  428. - rebuild with new environment
  429. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  430. - update passenger to 4.0.45
  431. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  432. - update to 1.6.0 (stable)
  433. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  434. - update fancyindex to 0.3.3
  435. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  436. - update to 1.5.10
  437. - update passenger to 4.0.37
  438. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  439. - rebuilt with GeoIP-1.6.0.
  440. - added Patch100.
  441. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  442. - update to 1.5.6
  443. - update passenger to 4.0.21
  444. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  445. - rebuilt with gd-2.1.0.
  446. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  447. - update to 1.4.1
  448. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  449. - update to 1.4.0
  450. - enable SPDY module
  451. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  452. - new upstream release
  453. - update passenger to 3.0.19
  454. - update ngx-fancyindex to upstream git master
  455. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  456. - new upstream release
  457. - update passenger to 3.0.17
  458. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  459. - rebuild with pcre-8.31
  460. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  461. - added http_geoip_module.
  462. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  463. - update to 1.2.4
  464. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  465. - update to 1.2.2
  466. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  467. - update to 1.2.1
  468. - change nginx user from nginx to www-data
  469. - R(pre): www-common
  470. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  471. - update to 1.2.0
  472. - update passenger to 3.0.12
  473. - drop http_upstream_keepalive
  474. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  475. - new upstream release
  476. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  477. - update to 1.0.12
  478. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  479. - update to 1.0.11
  480. - update passenger to 3.0.11
  481. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  482. - update to 1.0.10
  483. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  484. - update passenger to 3.0.9
  485. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  486. - update to 1.0.6
  487. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  488. - update to 1.0.4
  489. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  490. - add gnosek-nginx-upstream-fair module
  491. - add ngx_http_upstream_keepalive module
  492. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  493. - add nginx-passenger sub pakckage
  494. - use alternatives to choose nginx with or without passenger
  495. - add BR: ruby, rubygems, rubygem-rake
  496. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  497. - update to 1.0.2
  498. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  499. - update to 1.0.1
  500. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  501. - add bcond_with wsgi for mod_wsgi
  502. - add bcond_with passenger
  503. - you need to install rake.gem to build with this option.
  504. - add Provides: webserver
  505. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  506. - new upstream release 1.0.0!
  507. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  508. - rebuild with perl-5.12.3
  509. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  510. - update to 0.8.54
  511. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  512. - update to 0.8.53
  513. - add nginx_accept_language_module
  514. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  515. - update to 0.8.50
  516. - update ngx-fancyindex to 0.3
  517. - add BR: libxml2-devel, libxslt-devel
  518. - add scgi_params* and uwsgi_params* to %%files
  519. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  520. - update to 0.8.35 (development version)
  521. - add sites.d/ to store vitualhost settings
  522. - split out default server settings to sites.d/default
  523. - add fancyindex module
  524. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  525. - new upstream release
  526. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  527. - update to 0.7.62 (included security fix: VU#180065)
  528. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  529. - fix typo
  530. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  531. - add translated descriptions
  532. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  533. - update 404.html/50x.html to use powered by vine logo.
  534. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  535. - initial build for Vine Linux
  536. - update to 0.7.61
  537. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  538. - init script updates from Gena Makhomed
  539. - remove nginx-upstream-fair
  540. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  541. - update to 0.6.36
  542. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  543. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  544. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  545. - rebuild
  546. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  547. - update to 0.6.35
  548. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  549. - rebuild with new openssl
  550. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  551. - update to 0.6.34
  552. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  553. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  554. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  555. - update to 0.6.33
  556. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  557. - update to 0.6.32
  558. - nginx now supports DESTDIR so removed the patches that enabled it
  559. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  560. - init script fixes
  561. - resolve 'listen 80 default' [#447873]
  562. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  563. - update to 0.6.31
  564. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  565. - upate to new upstream stable branch 0.6
  566. - added 3rd party module nginx-upstream-fair
  567. - added default webpages
  568. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  569. - update init script to match recommended guidelines
  570. - add /etc/nginx/conf.d support [#443280]
  571. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  572. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  573. - add Requires for versioned perl (libperl.so)
  574. - drop silly file Requires
  575. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  576. - Autorebuild for GCC 4.3
  577. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  578. - update to 0.5.35
  579. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  580. - update to 0.5.34
  581. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  582. - Rebuild for deps
  583. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  584. - update to 0.5.33
  585. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  586. - updated to 0.5.32
  587. - fixed rpmlint UTF-8 complaints.
  588. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  589. - added --with-http_stub_status_module build option.
  590. - added --with-http_sub_module build option.
  591. - added use of pcre-config --cflags
  592. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  593. - Update to 0.5.31
  594. - specify license is BSD
  595. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  596. - Add BuildRequires: perl-devel - fixing rawhide build
  597. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  598. - Update to 0.5.30
  599. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  600. - Update to 0.5.29
  601. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  602. - Update to 0.5.28
  603. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  604. - Update to 0.5.27
  605. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  606. - Update to 0.5.26
  607. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  608. - Update to 0.5.19
  609. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  610. - Update to 0.5.17
  611. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  612. - Update to 0.5.16
  613. - add ownership of /usr/share/nginx/html (#233950)
  614. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  615. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  616. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  617. - fixed package review bugs (#233522) given by kevin@tummy.com
  618. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  619. - create patches to assist with building for Fedora
  620. - initial packaging for Fedora