rust-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615
  1. %bcond_with bootstrap
  2. %define _unpackaged_files_terminate_build 1
  3. # Only x86_64 and i686 are Tier 1 platforms at this time.
  4. # https://forge.rust-lang.org/platform-support.html
  5. %global rust_arches x86_64 i686
  6. # The channel can be stable, beta, or nightly
  7. %{!?channel: %global channel stable}
  8. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  9. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  10. # or nightly wants some beta-YYYY-MM-DD
  11. %global bootstrap_rust 1.22.1
  12. %global bootstrap_cargo 0.23.0
  13. %global bootstrap_channel %{bootstrap_rust}
  14. %global bootstrap_date 2017-10-12
  15. # Only the specified arches will use bootstrap binaries.
  16. %if %{with bootstrap}
  17. %global bootstrap_arches %%{rust_arches}
  18. %endif
  19. # We generally don't want llvm-static present at all, since llvm-config will
  20. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  21. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  22. # *want* static we'll have to force it with "llvm-config --link-static".
  23. # See also https://github.com/rust-lang/rust/issues/36854
  24. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  25. %bcond_with llvm_static
  26. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  27. # is insufficient. Rust currently requires LLVM 3.7+.
  28. %bcond_with bundled_llvm
  29. # LLDB only works on some architectures
  30. %ifarch %{arm} aarch64 %{ix86} x86_64
  31. # LLDB isn't available everywhere...
  32. %bcond_without lldb
  33. %else
  34. %bcond_with lldb
  35. %endif
  36. Name: rust
  37. Version: 1.23.0
  38. Release: 1%{?_dist_release}
  39. Summary: The Rust Programming Language
  40. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  41. # ^ written as: (rust itself) and (bundled libraries)
  42. URL: https://www.rust-lang.org
  43. ExclusiveArch: %{rust_arches}
  44. %if "%{channel}" == "stable"
  45. %global rustc_package rustc-%{version}-src
  46. %else
  47. %global rustc_package rustc-%{channel}-src
  48. %endif
  49. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  50. Patch1: rust-1.22.0-45566-option-checking.patch
  51. # Get the Rust triple for any arch.
  52. %{lua: function rust_triple(arch)
  53. local abi = "gnu"
  54. if arch == "armv7hl" then
  55. arch = "armv7"
  56. abi = "gnueabihf"
  57. elseif arch == "ppc64" then
  58. arch = "powerpc64"
  59. elseif arch == "ppc64le" then
  60. arch = "powerpc64le"
  61. end
  62. return arch.."-unknown-linux-"..abi
  63. end}
  64. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  65. %if %defined bootstrap_arches
  66. # For each bootstrap arch, add an additional binary Source.
  67. # Also define bootstrap_source just for the current target.
  68. %{lua: do
  69. local bootstrap_arches = {}
  70. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  71. table.insert(bootstrap_arches, arch)
  72. end
  73. local base = rpm.expand("https://static.rust-lang.org/dist/%{bootstrap_date}"
  74. .."/rust-%{bootstrap_channel}")
  75. local target_arch = rpm.expand("%{_target_cpu}")
  76. for i, arch in ipairs(bootstrap_arches) do
  77. print(string.format("Source%d: %s-%s.tar.gz\n",
  78. i, base, rust_triple(arch)))
  79. if arch == target_arch then
  80. rpm.define("bootstrap_source "..i)
  81. end
  82. end
  83. end}
  84. %endif
  85. %ifarch %{bootstrap_arches}
  86. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  87. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  88. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  89. %else
  90. BuildRequires: cargo >= %{bootstrap_cargo}
  91. BuildRequires: %{name} >= %{bootstrap_rust}
  92. BuildConflicts: %{name} > %{version}
  93. %global local_rust_root %{_prefix}
  94. %endif
  95. BuildRequires: cmake
  96. BuildRequires: make
  97. BuildRequires: gcc
  98. BuildRequires: gcc-c++
  99. BuildRequires: ncurses-devel
  100. BuildRequires: zlib-devel
  101. BuildRequires: python
  102. BuildRequires: curl
  103. %if %{with bundled_llvm}
  104. BuildRequires: cmake
  105. Provides: bundled(llvm) = 4.0
  106. %else
  107. %if %defined llvm
  108. %global llvm_root %{_libdir}/%{llvm}
  109. %else
  110. %global llvm llvm
  111. %global llvm_root %{_prefix}
  112. %endif
  113. BuildRequires: %{llvm}-devel >= 3.7
  114. %if %{with llvm_static}
  115. BuildRequires: %{llvm}-static
  116. BuildRequires: libffi-devel
  117. %else
  118. # Make sure llvm-config doesn't see it.
  119. BuildConflicts: %{llvm}-static
  120. %endif
  121. %endif
  122. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  123. BuildRequires: procps
  124. # debuginfo-gdb tests need gdb
  125. BuildRequires: gdb
  126. # TODO: work on unbundling these!
  127. Provides: bundled(hoedown) = 3.0.5
  128. Provides: bundled(jquery) = 2.1.4
  129. Provides: bundled(libbacktrace) = 6.1.0
  130. Provides: bundled(miniz) = 1.14
  131. # Virtual provides for folks who attempt "dnf install rustc"
  132. Provides: rustc = %{version}-%{release}
  133. Provides: rustc%{?_isa} = %{version}-%{release}
  134. # Always require our exact standard library
  135. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  136. # The C compiler is needed at runtime just for linking. Someday rustc might
  137. # invoke the linker directly, and then we'll only need binutils.
  138. # https://github.com/rust-lang/rust/issues/11937
  139. Requires: /usr/bin/cc
  140. # ALL Rust libraries are private, because they don't keep an ABI.
  141. %global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
  142. %global __provides_exclude ^(%{_privatelibs})$
  143. %global __requires_exclude ^(%{_privatelibs})$
  144. %global __provides_exclude_from ^%{_docdir}/.*$
  145. %global __requires_exclude_from ^%{_docdir}/.*$
  146. # While we don't want to encourage dynamic linking to Rust shared libraries, as
  147. # there's no stable ABI, we still need the unallocated metadata (.rustc) to
  148. # support custom-derive plugins like #[proc_macro_derive(Foo)]. But eu-strip is
  149. # very eager by default, so we have to limit it to -g, only debugging symbols.
  150. %if 0%{?fedora} >= 27
  151. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  152. %global _find_debuginfo_opts --keep-section .rustc
  153. %else
  154. %global _find_debuginfo_opts -g
  155. %undefine _include_minidebuginfo
  156. %endif
  157. # Use hardening ldflags.
  158. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  159. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  160. # https://github.com/rust-lang/rust/issues/40717
  161. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  162. %endif
  163. %description
  164. Rust is a systems programming language that runs blazingly fast, prevents
  165. segfaults, and guarantees thread safety.
  166. This package includes the Rust compiler and documentation generator.
  167. %package std-static
  168. Summary: Standard library for Rust
  169. %description std-static
  170. This package includes the standard libraries for building applications
  171. written in Rust.
  172. %package debugger-common
  173. Summary: Common debugger pretty printers for Rust
  174. BuildArch: noarch
  175. %description debugger-common
  176. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  177. %package gdb
  178. Summary: GDB pretty printers for Rust
  179. BuildArch: noarch
  180. Requires: gdb
  181. Requires: %{name}-debugger-common = %{version}-%{release}
  182. %description gdb
  183. This package includes the rust-gdb script, which allows easier debugging of Rust
  184. programs.
  185. %if %{with lldb}
  186. %package lldb
  187. Summary: LLDB pretty printers for Rust
  188. # It could be noarch, but lldb has limited availability
  189. #BuildArch: noarch
  190. Requires: lldb
  191. Requires: python-lldb
  192. Requires: %{name}-debugger-common = %{version}-%{release}
  193. %description lldb
  194. This package includes the rust-lldb script, which allows easier debugging of Rust
  195. programs.
  196. %endif
  197. %package doc
  198. Summary: Documentation for Rust
  199. # NOT BuildArch: noarch
  200. # Note, while docs are mostly noarch, some things do vary by target_arch.
  201. # Koji will fail the build in rpmdiff if two architectures build a noarch
  202. # subpackage differently, so instead we have to keep its arch.
  203. %description doc
  204. This package includes HTML documentation for the Rust programming language and
  205. its standard library.
  206. %package src
  207. Summary: Sources for the Rust standard library
  208. BuildArch: noarch
  209. %description src
  210. This package includes source files for the Rust standard library. It may be
  211. useful as a reference for code completion tools in various editors.
  212. %prep
  213. %ifarch %{bootstrap_arches}
  214. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  215. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  216. --prefix=%{local_rust_root} --disable-ldconfig
  217. test -f '%{local_rust_root}/bin/cargo'
  218. test -f '%{local_rust_root}/bin/rustc'
  219. %endif
  220. %setup -q -n %{rustc_package}
  221. # We're disabling jemalloc, but rust-src still wants it.
  222. # rm -rf src/jemalloc/
  223. %if %without bundled_llvm
  224. rm -rf src/llvm/
  225. %endif
  226. # extract bundled licenses for packaging
  227. cp src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
  228. sed -e '/*\//q' src/libbacktrace/backtrace.h \
  229. >src/libbacktrace/LICENSE-libbacktrace
  230. # This tests a problem of exponential growth, which seems to be less-reliably
  231. # fixed when running on older LLVM and/or some arches. Just skip it for now.
  232. sed -i.ignore -e '1i // ignore-test may still be exponential...' \
  233. src/test/run-pass/issue-41696.rs
  234. %if %{with bundled_llvm} && 0%{?epel}
  235. mkdir -p cmake-bin
  236. ln -s /usr/bin/cmake cmake-bin/cmake
  237. %global cmake_path $PWD/cmake-bin
  238. %endif
  239. %if %{without bundled_llvm} && %{with llvm_static}
  240. # Static linking to distro LLVM needs to add -lffi
  241. # https://github.com/rust-lang/rust/issues/34486
  242. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  243. src/librustc_llvm/lib.rs
  244. %endif
  245. %global _default_patch_fuzz 1
  246. #%patch1 -p1 -b .option-checking
  247. # The configure macro will modify some autoconf-related files, which upsets
  248. # cargo when it tries to verify checksums in those files. If we just truncate
  249. # that file list, cargo won't have anything to complain about.
  250. find src/vendor -name .cargo-checksum.json \
  251. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  252. %build
  253. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  254. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  255. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  256. # We're going to override --libdir when configuring to get rustlib into a
  257. # common path, but we'll fix the shared libraries during install.
  258. %global common_libdir %{_prefix}/lib
  259. %global rustlibdir %{common_libdir}/rustlib
  260. %ifarch %{arm}
  261. # full debuginfo is exhausting memory; just do libstd for now
  262. # https://github.com/rust-lang/rust/issues/45854
  263. %define enable_debuginfo --enable-debuginfo --enable-debuginfo-only-std --disable-debuginfo-lines
  264. %else
  265. %define enable_debuginfo --enable-debuginfo --disable-debuginfo-only-std --disable-debuginfo-lines
  266. %endif
  267. %configure \
  268. --enable-full-bootstrap \
  269. --disable-option-checking \
  270. --libdir=%{common_libdir} \
  271. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  272. --enable-local-rust --local-rust-root=%{local_rust_root} \
  273. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
  274. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  275. --disable-jemalloc \
  276. --disable-rpath \
  277. %{enable_debuginfo} \
  278. --enable-vendor \
  279. --release-channel=%{channel}
  280. %ifarch x86_64
  281. RUST_BACKTRACE=1 ./x.py build
  282. %else
  283. RUST_BACKTRACE=1 ./x.py build -i
  284. %endif
  285. ./x.py doc
  286. %install
  287. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  288. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  289. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  290. DESTDIR=%{buildroot} ./x.py install
  291. DESTDIR=%{buildroot} ./x.py install src
  292. # Make sure the shared libraries are in the proper libdir
  293. %if "%{_libdir}" != "%{common_libdir}"
  294. mkdir -p %{buildroot}%{_libdir}
  295. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  296. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  297. %endif
  298. # The shared libraries should be executable for debuginfo extraction.
  299. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  300. -exec chmod -v +x '{}' '+'
  301. # The libdir libraries are identical to those under rustlib/. It's easier on
  302. # library loading if we keep them in libdir, but we do need them in rustlib/
  303. # to support dynamic linking for compiler plugins, so we'll symlink.
  304. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  305. find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
  306. -exec ln -v -f -s -t . '{}' '+')
  307. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  308. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  309. # FIXME: __os_install_post will strip the rlibs
  310. # -- should we find a way to preserve debuginfo?
  311. # Remove unwanted documentation files (we already package them)
  312. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  313. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  314. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  315. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  316. # Sanitize the HTML documentation
  317. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  318. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  319. %if %{without lldb}
  320. rm -f %{buildroot}%{_bindir}/rust-lldb
  321. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  322. %endif
  323. %check
  324. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  325. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  326. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  327. # The results are not stable on koji, so mask errors and just log it.
  328. ./x.py test --no-fail-fast || :
  329. %post -p /sbin/ldconfig
  330. %postun -p /sbin/ldconfig
  331. %files
  332. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  333. %license src/libbacktrace/LICENSE-libbacktrace
  334. %license src/rt/hoedown/LICENSE-hoedown
  335. %doc README.md
  336. %{_bindir}/rustc
  337. %{_bindir}/rustdoc
  338. %{_libdir}/*.so
  339. %{_mandir}/man1/rustc.1*
  340. %{_mandir}/man1/rustdoc.1*
  341. %dir %{rustlibdir}
  342. %dir %{rustlibdir}/%{rust_triple}
  343. %dir %{rustlibdir}/%{rust_triple}/lib
  344. %{rustlibdir}/%{rust_triple}/lib/*.so
  345. %files std-static
  346. %dir %{rustlibdir}
  347. %dir %{rustlibdir}/%{rust_triple}
  348. %dir %{rustlibdir}/%{rust_triple}/lib
  349. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  350. %files debugger-common
  351. %dir %{rustlibdir}
  352. %dir %{rustlibdir}/etc
  353. %{rustlibdir}/etc/debugger_*.py*
  354. %files gdb
  355. %{_bindir}/rust-gdb
  356. %{rustlibdir}/etc/gdb_*.py*
  357. %if %with lldb
  358. %files lldb
  359. %{_bindir}/rust-lldb
  360. %{rustlibdir}/etc/lldb_*.py*
  361. %endif
  362. %files doc
  363. %docdir %{_docdir}/%{name}
  364. %dir %{_docdir}/%{name}
  365. %dir %{_docdir}/%{name}/html
  366. %{_docdir}/%{name}/html/*/
  367. %{_docdir}/%{name}/html/*.html
  368. %{_docdir}/%{name}/html/*.css
  369. %{_docdir}/%{name}/html/*.js
  370. %{_docdir}/%{name}/html/*.woff
  371. %license %{_docdir}/%{name}/html/*.txt
  372. %files src
  373. %dir %{rustlibdir}
  374. %{rustlibdir}/src
  375. %changelog
  376. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  377. - Update to 1.23.0 (stable).
  378. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  379. - initial build for Vine Linux.
  380. - Update to 1.23.0-beta.
  381. - built a bootstrap rpm.
  382. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  383. - Update to 1.22.1.
  384. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  385. - Update to 1.21.0.
  386. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  387. - ABI fixes for ppc64 and s390x.
  388. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  389. - Update to 1.20.0.
  390. - Add a rust-src subpackage.
  391. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  392. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  393. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  394. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  395. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  396. - Use find-debuginfo.sh --keep-section .rustc
  397. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  398. - Update to 1.19.0.
  399. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  400. - Update to 1.18.0.
  401. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  402. - Move shared libraries back to libdir and symlink in rustlib
  403. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  404. - Update to 1.17.0.
  405. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  406. - Make rust-lldb arch-specific to deal with lldb deps
  407. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  408. - Limit rust-lldb arches
  409. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  410. - Update to 1.16.0.
  411. - Use rustbuild instead of the old makefiles.
  412. - Update bootstrapping to include rust-std and cargo.
  413. - Add a rust-lldb subpackage.
  414. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  415. - Update to 1.15.1.
  416. - Require rust-rpm-macros for new crate packaging.
  417. - Keep shared libraries under rustlib/, only debug-stripped.
  418. - Merge and clean up conditionals for epel7.
  419. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  420. - Rebuild without bootstrap binaries.
  421. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  422. - Update to 1.14.0.
  423. - Rewrite bootstrap logic to target specific arches.
  424. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  425. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  426. - Update to 1.13.0.
  427. - Use hardening flags for linking.
  428. - Split the standard library into its own package
  429. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  430. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  431. - Update to 1.12.1.
  432. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  433. - Rebuild with LLVM 3.9.
  434. - Add ncurses-devel for llvm-config's -ltinfo.
  435. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  436. - Rebuild with llvm-static, preparing for 3.9
  437. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  438. - Rebuild with fixed eu-strip (rhbz1380961)
  439. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  440. - Rebuild without bootstrap binaries.
  441. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  442. - Bootstrap aarch64.
  443. - Use jemalloc's MALLOC_CONF to work around #36944.
  444. - Apply pr36933 to really disable armv7hl NEON.
  445. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  446. - Protect .rustc from rpm stripping.
  447. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  448. - Update to 1.12.0.
  449. - Always use --local-rust-root, even for bootstrap binaries.
  450. - Remove the rebuild conditional - the build system now figures it out.
  451. - Let minidebuginfo do its thing, since metadata is no longer a note.
  452. - Let rust build its own compiler-rt builtins again.
  453. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  454. - Rebuild without bootstrap binaries.
  455. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  456. - Bootstrap armv7hl, with backported no-neon patch.
  457. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  458. - Update to 1.11.0.
  459. - Drop the backported patches.
  460. - Patch get-stage0.py to trust existing bootstrap binaries.
  461. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  462. - Use --local-rust-root to make sure the right bootstrap is used.
  463. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  464. - Rebuild without bootstrap binaries.
  465. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  466. - Initial import into Fedora (#1356907), bootstrapped
  467. - Format license text as suggested in review.
  468. - Note how the tests already run in parallel.
  469. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  470. - Don't let checks fail the whole build.
  471. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  472. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  473. - Update -doc directory ownership, and mark its licenses.
  474. - Package and declare licenses for libbacktrace and hoedown.
  475. - Set bootstrap_base as a global.
  476. - Explicitly require python2.
  477. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  478. - Initial package, bootstrapped