curl-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.20.1
  6. Release: 3%{?_dist_release}
  7. License: MIT/X
  8. Group: Applications/Internet
  9. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
  10. URL: http://curl.haxx.se/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: openssl-devel libidn-devel zlib-devel
  13. BuildRequires: openldap-devel gnutls-devel
  14. Requires: openssl libidn zlib
  15. %description
  16. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  17. Dict servers, using any of the supported protocols. cURL is designed
  18. to work without user interaction or any kind of interactivity. cURL
  19. offers many useful capabilities, like proxy support, user
  20. authentication, FTP upload, HTTP post, and file transfer resume.
  21. %package devel
  22. Summary: Files needed for building applications with libcurl.
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. Requires: openssl-devel libidn-devel zlib-devel
  26. %description devel
  27. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  28. Dict servers, using any of the supported protocols. The curl-devel
  29. package includes files needed for developing applications which can
  30. use cURL's capabilities internally.
  31. #'
  32. ## to build compat32 for x86_64 architecture support
  33. %package -n compat32-%{name}
  34. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  35. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  36. Group: System Environment/Libraries
  37. %description -n compat32-%{name}
  38. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  39. Dict servers, using any of the supported protocols. cURL is designed
  40. to work without user interaction or any kind of interactivity. cURL
  41. offers many useful capabilities, like proxy support, user
  42. authentication, FTP upload, HTTP post, and file transfer resume.
  43. %package -n compat32-%{name}-devel
  44. Summary: Files needed for building applications with libcurl.
  45. Group: Development/Libraries
  46. %description -n compat32-%{name}-devel
  47. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  48. Dict servers, using any of the supported protocols. The curl-devel
  49. package includes files needed for developing applications which can
  50. use cURL's capabilities internally.
  51. #'
  52. %prep
  53. %setup -q
  54. %build
  55. %configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
  56. %ifarch alpha
  57. make %{?_smp_mflags} CFLAGS=""
  58. %else
  59. make %{?_smp_mflags}
  60. %endif
  61. %install
  62. rm -rf $RPM_BUILD_ROOT
  63. make DESTDIR=$RPM_BUILD_ROOT install
  64. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %files
  70. %defattr(-,root,root)
  71. %doc CHANGES COPYING README
  72. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  73. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  74. %doc docs/TheArtOfHttpScripting docs/TODO
  75. %{_bindir}/curl
  76. #{_datadir}/curl/*
  77. %{_libdir}/*.so.*
  78. %{_mandir}/man1/curl.1*
  79. %files devel
  80. %defattr(-,root,root)
  81. %{_bindir}/curl-config
  82. %{_includedir}/curl
  83. %{_libdir}/*.so
  84. %{_libdir}/pkgconfig/*.pc
  85. %{_mandir}/man1/curl-config.1*
  86. %{_mandir}/man3/*
  87. ## to build compat32 for x86_64 architecture support
  88. %if %{build_compat32}
  89. %files -n compat32-%{name}
  90. %defattr(-,root,root)
  91. %{_libdir}/*.so.*
  92. %files -n compat32-%{name}-devel
  93. %defattr(-,root,root)
  94. %{_libdir}/*.so
  95. %{_libdir}/pkgconfig/*.pc
  96. %endif
  97. %changelog
  98. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  99. - rebuild with openssl-1.0.0c
  100. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  101. - rebuilt with rpm-4.8.1 for pkg-config
  102. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  103. - new upstream release
  104. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  105. - new upstream release with security fix
  106. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  107. - added compat32 subpackages
  108. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  109. - new upstream release
  110. - use "_smp_mflags" flag
  111. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  112. - rebuild with openldap-2.4.11
  113. - add BR: openldap-devel
  114. - remove static library
  115. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  116. - new upstream release with security fix (CVE-2009-0037)
  117. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  118. - new upstream release
  119. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  120. - new upstream release
  121. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  122. - new upstream release
  123. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  124. - new upstream release
  125. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  126. - new upstream release
  127. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  128. - rebuilt with openssl-0.9.8e
  129. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  130. - new upstream release
  131. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  132. - new upstream release
  133. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  134. - new upstream release
  135. - add pkgconfig file to devel package
  136. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  137. - new upstream release
  138. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  139. - new upstream release
  140. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  141. - new upstream release
  142. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  143. - added libidn, zlib in Requires
  144. - added libidn-devel, zlib-devel in BuildPrereq
  145. - added zlib-devel in curl-devel's Requires
  146. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  147. - added openssl-devel, libidn-devel in curl-devel's Requires
  148. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  149. - new upstream release
  150. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  151. - new upstream release
  152. - rebuild with openssl-0.9.7d
  153. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  154. - upstream release
  155. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  156. - add %%{_datadir}/curl/* to %%files section
  157. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  158. - source upgrade
  159. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  160. - source upgrade
  161. - add PreReq: ldconfig
  162. - add %%{_libdir}/*.la to %%files devel section
  163. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  164. - build for VineSeed
  165. - add Requires: openssl
  166. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  167. - automated rebuild
  168. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  169. - 7.9.2
  170. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  171. - include curl-config in curl-devel
  172. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  173. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  174. - added openssl-devel build req
  175. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  176. - built for the distro
  177. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  178. - upgrade to curl-7.7.2.
  179. - enable IPv6.
  180. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  181. - rebuilt against openssl-0.9.6-1
  182. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  183. - fixed mising ldconfigs
  184. - updated to 7.5.2, bug fixes
  185. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  186. - updated to 7.5.1
  187. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  188. - update to 7.4.1 to fix bug #20337, problems with curl -c
  189. - not using patch anymore, it's included in the new source. Keeping
  190. for reference
  191. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  192. - fix bogus req in -devel package
  193. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  194. - devel package needed defattr so that root owns the files
  195. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  196. - update to 7.3
  197. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  198. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  199. - enable SSL support
  200. - fix packager tag
  201. - move buildroot to %%{_tmppath}
  202. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  203. - fixed vendor tag for bug #15028
  204. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  205. - rebuilt
  206. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  207. - workaround alpha build problems with optimizations
  208. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  209. - rebuilt
  210. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  211. - put man pages in correct place
  212. - use %%makeinstall
  213. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  214. - updated to 6.5.2
  215. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  216. - updated sources to 6.2
  217. - gzip man page
  218. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  219. - changed group
  220. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  221. - changelog started
  222. - general cleanups, changed prefix to /usr, added manpage to files section
  223. - including in Powertools