R-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571
  1. %define pkg_name R
  2. %define pkg_version 3.4.1
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
  13. # Patch0: R-release.diff.gz
  14. # To avoid 'make check error'
  15. Patch1: reg-tests-3.R.patch
  16. Patch2: reg-tests-3.Rout.save.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gcc-c++
  19. BuildRequires: gcc-gfortran libgfortran
  20. BuildRequires: texinfo
  21. %if %{?_dist_release} == "vl6"
  22. BuildRequires: R-pcre-devel
  23. BuildRequires: tcl85-devel tk85-devel
  24. %endif
  25. %if %{?_dist_release} >= "vl7"
  26. BuildRequires: pcre-devel
  27. BuildRequires: tcl-devel tk-devel
  28. %endif
  29. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  30. BuildRequires: readline-devel ncurses-devel
  31. BuildRequires: zlib-devel bzip2-devel xz-devel
  32. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  33. BuildRequires: cairo-devel pango-devel
  34. BuildRequires: libicu-devel
  35. BuildRequires: curl-devel
  36. BuildRequires: texlive-common
  37. BuildRequires: texlive-collection-basic
  38. BuildRequires: texlive-collection-latexextra
  39. BuildRequires: texlive-collection-fontsextra
  40. %if %{?_dist_release} == "vl6"
  41. BuildRequires: texlive-collection-texinfo
  42. %endif
  43. %if %{?_dist_release} >= "vl7"
  44. BuildRequires: texlive-collection-plaingeneric
  45. BuildRequires: texlive-collection-fontsrecommended
  46. %endif
  47. BuildRequires: java-devel
  48. Requires: gcc-gfortran
  49. Requires: libgfortran
  50. Requires: libicu
  51. %if %{?_dist_release} == "vl6"
  52. Requires: tcl85 tk85
  53. Requires: R-pcre
  54. %endif
  55. %if %{?_dist_release} >= "vl7"
  56. Requires: tcl tk
  57. %endif
  58. Conflicts: R-devel < %{version}-%{release}
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. Packager: ara_t
  62. %description
  63. 'GNU S' - A language and environment for statistical computing and
  64. graphics. R is similar to the award-winning S system, which was
  65. developed at Bell Laboratories by John Chambers et al. It provides
  66. a wide variety of statistical and graphical techniques (linear and
  67. nonlinear modelling, statistical tests, time series analysis,
  68. classification, clustering, ...).
  69. R is designed as a true computer language with control-flow
  70. constructions for iteration and alternation, and it allows users to
  71. add additional functionality by defining new functions.
  72. For computationally intensive tasks, C, C++ and Fortran code
  73. can be linked and called at run time.
  74. %description -l ja
  75. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  76. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  77. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  78. 幅広い統計解析・視覚化手法を提供する。
  79. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  80. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  81. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  82. 使用することができる。
  83. %package -n libRmath
  84. Summary: standalone math library from the R project
  85. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  86. Group: System Environment/Libraries
  87. %description -n libRmath
  88. A standalone library of mathematical and statistical functions derived
  89. from the R project. This packages provides the shared libRmath library.
  90. %description -l ja -n libRmath
  91. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  92. 共有ライブラリを提供する。
  93. %package -n libRmath-devel
  94. Summary: standalone math library from the R project
  95. Summary(ja): libRmathの開発ライブラリ
  96. Group: Development/Libraries
  97. Requires: libRmath = %{version}-%{release}
  98. %description -n libRmath-devel
  99. A standalone library of mathematical and statistical functions derived
  100. from the R project. This packages provides the header files.
  101. %description -l ja -n libRmath-devel
  102. libRmathのヘッダファイル(Rmath.h)
  103. %package -n libRmath-static
  104. Summary: Static R Standalone math library
  105. Summary(ja): libRmath の静的ライブラリ
  106. Group: Development/Libraries
  107. Requires: libRmath-devel = %{version}-%{release}
  108. %description -n libRmath-static
  109. A standalone library of mathematical and statistical functions derived
  110. from the R project. This package provides the static libRmath library.
  111. %prep
  112. %{__rm} -rf ${RPM_BUILD_ROOT}
  113. %setup -q
  114. # %patch0 -p1
  115. %patch1
  116. %patch2
  117. cat > R.desktop <<EOF
  118. [Desktop Entry]
  119. Name=GNU R
  120. Comment=A language for data analysis and graphics
  121. TryExec=/usr/bin/R
  122. Exec=/usr/bin/R
  123. Icon=/usr/share/icons/logo.jpg
  124. Terminal=true
  125. Type=Application
  126. Categories=Education;Science;
  127. StartupNotify=false
  128. EOF
  129. %build
  130. export R_PDFVIEWER="%{_bindir}/xdg-open"
  131. export R_PRINTCMD="lpr"
  132. export R_BROWSER="%{_bindir}/xdg-open"
  133. %if %{?_dist_release} == "vl6"
  134. export LD_LIBRARY_PATH=%{_libdir}/R/lib
  135. %endif
  136. %{configure} --enable-R-shlib --with-tcltk \
  137. %if %{?_dist_release} == "vl6"
  138. --with-tcl-config=%{_libdir}/tclConfig85.sh \
  139. --with-tk-config=%{_libdir}/tkConfig85.sh \
  140. CPPFLAGS="-I%{_libdir}/R/include" \
  141. LDFLAGS="-L%{_libdir}/R/lib"
  142. %endif
  143. %{__make} %{?_smp_mflags}
  144. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  145. %{__make} pdf
  146. %install
  147. %{make_install}
  148. %{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
  149. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  150. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  151. # Install libRmath files
  152. (cd src/nmath/standalone; %{make_install})
  153. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  154. echo "%{_libdir}/R/lib" > \
  155. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  156. # Fix lication of R_HOME_DIR in shell wrapper
  157. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  158. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  159. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  160. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  161. > ${RPM_BUILD_ROOT}%{_bindir}/R
  162. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  163. # add R into menu
  164. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  165. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  166. %{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
  167. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  168. # move manuals
  169. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  170. %{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
  171. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  172. %check
  173. export TZ="Asia/Tokyo"
  174. LANG=C %{__make} check
  175. %clean
  176. %{__rm} -rf ${RPM_BUILD_ROOT}
  177. %post -p %{_syssbindir}/ldconfig
  178. %postun -p %{_syssbindir}/ldconfig
  179. %post -n libRmath -p %{_syssbindir}/ldconfig
  180. %postun -n libRmath -p %{_syssbindir}/ldconfig
  181. %files
  182. %defattr(-, root, root)
  183. %{_bindir}/R
  184. %{_bindir}/Rscript
  185. %{_libdir}/R
  186. %{_datadir}/applications/*
  187. %{_datadir}/icons/*
  188. %{_mandir}/man1/*
  189. %{_docdir}/%{name}-%{version}
  190. %{_sysconfdir}/ld.so.conf.d/*
  191. %files -n libRmath
  192. %defattr(-, root, root)
  193. %{_libdir}/libRmath.so
  194. %files -n libRmath-devel
  195. %defattr(-, root, root)
  196. %{_libdir}/pkgconfig/*.pc
  197. %{_includedir}/Rmath.h
  198. %files -n libRmath-static
  199. %defattr(-, root, root)
  200. %{_libdir}/libRmath.a
  201. %changelog
  202. * Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
  203. - left %%{_libdir}/R/doc
  204. * Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
  205. - Updated to 3.4.1
  206. - rebuild under R-pcre (pcre-8.39) for Vine6
  207. - add Requires: gcc-gfortran
  208. - change to BuildRequires: texlive-collection-plaingeneric
  209. - delete unnecessary descriptions
  210. * Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  211. - Updated to 3.4.0
  212. - add Patch1 and Patch2 to avoid 'make check' error
  213. - add export TZ="Asia/Tokyo" to avoid 'make check' error
  214. - delete descrption about info
  215. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
  216. - Updated to 3.3.3
  217. * Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
  218. - use tcl-8.5/tk-8.5 for Vine6.5
  219. - BuildRequires to tcl85-devel/tk85-devel
  220. - Requires to tcl85/tk85
  221. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
  222. - merge SPEC file for Vine6
  223. - drop devel package
  224. - move PDF manuals to /usr/share/doc/R-%%{version}
  225. - revert logo of menu item to logo.jpg
  226. * Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
  227. - Updated to 3.3.2
  228. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  229. - Updated to 3.3.1
  230. - delete BuildRequires: texlive-collection-lang*
  231. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  232. - add BuildRequires: texlive-collection-lang*
  233. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  234. - Updated to 3.3.0
  235. - add BuildRequires: pcre-devel xz-devel
  236. - change logo of menu item to Rlogo.svg
  237. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  238. - correct SPEC file
  239. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  240. - Updated to 3.2.4-revised
  241. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  242. - Updated to 3.2.4
  243. - fixed build error in src/extra/xz
  244. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  245. - add BuildRequires: curl-devel
  246. - add BuildRequires: libgomp
  247. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  248. - Updated to 3.2.3
  249. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  250. - rebuild with icu-56.1
  251. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  252. - Updated to 3.2.2
  253. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  254. - add configure options: --with-tcltk
  255. - add BuildRequires: tcl-devel tk-devel
  256. - add Requires: tcl tk
  257. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  258. - Updated to 3.2.1
  259. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  260. - add "LIBS=-lbz2" to configure option
  261. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  262. - Updated to 3.2.0
  263. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  264. - Updated to 3.1.3
  265. - added BuildRequires: texlive-collection-fontsextra for Vine6
  266. - changed option "make check-all" to "make check"
  267. - to avoid error in checking of mgcv package
  268. - changed orders of BuildRequires
  269. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  270. - rebuild with icu-54.1
  271. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  272. - Updated to 3.1.2
  273. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  274. - Updated to 3.1.1
  275. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  276. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  277. - add patch (2014-04-26)
  278. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  279. - Updated to 3.1.0
  280. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  281. - Updated to 3.0.3
  282. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  283. - rebuild current VineSeed
  284. - add patch (2014-01-06)
  285. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  286. - add Requires: libicu
  287. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  288. - combine spec files Vine6 and VineSeed
  289. - correct the days of the week in changelog
  290. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  291. - delete BuildRequires: texlive-collection-texinfo
  292. - add BuildRequires: texlive-collection-plainextra
  293. - add BuildRequires: texlive-collection-latexextra
  294. - add BuildRequires: texlive-collection-fontsrecommended
  295. - for VineSeed
  296. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  297. - Updated to 3.0.2
  298. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  299. - Updated to 3.0.1
  300. - add BuildRequires: java-1.6.0-openjdk-devel
  301. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  302. - Updated to 3.0.0
  303. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  304. - Updated to 2.15.3
  305. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  306. - use BuildRequires ncurses-devel instead of libtermcap-devel
  307. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  308. - Updated to 2.15.2
  309. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  310. - changed group to Applications/Edutainment
  311. - added R to menu
  312. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  313. - Updated to 2.15.1
  314. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  315. - Updated to 2.15.0
  316. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  317. - Updated to 2.14.2
  318. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  319. - Updated to 2.14.1
  320. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  321. - Updated to 2.14.0
  322. - add BuildRequires: texlive-collection-fontsextra
  323. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  324. - Updated to 2.13.2
  325. - add BuildRequires: texlive-common
  326. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  327. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  328. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  329. - synchronized to VinePlus/5 package
  330. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  331. - Updated to 2.13.1
  332. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  333. - Updated to 2.13.0
  334. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  335. - Updated to 2.12.2
  336. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  337. - add BuildRequires: libicu-devel
  338. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  339. - synchronized to VinePlus/5 package
  340. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  341. - Updated to 2.12.1
  342. - added --enable-R-shlib option to %%configure
  343. - added static subpackage
  344. - use BR: texlive instead of tetex on VineSeed
  345. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  346. - rebuilt with rpm-4.8.1 for pkg-config
  347. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  348. - recompiled because tcl/tk were not linked
  349. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  350. - Updated to 2.11.0
  351. - added Requires: libgfortran
  352. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  353. - Updated to 2.10.1
  354. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  355. - patched to 2.10.0
  356. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  357. - spec in UTF-8
  358. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  359. - Updated to 2.10.0
  360. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  361. - Updated to 2.9.2
  362. - deleted BuildRequires: lapack-devel blas-devel
  363. - rewrote SPEC file
  364. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  365. - Updated to 2.5.1
  366. - added BuildRequires: gcc-gfortran for VineSeed
  367. - added BuildRequires: lapack-devel blas-devel
  368. v- fixed %preun script
  369. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  370. - Updated to 2.4.1
  371. - Added INFO option
  372. - Exclude Japanese Rprofile.site
  373. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  374. - Updated to 2.4.0
  375. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  376. - Added optimization flags
  377. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  378. - Packaged for VineLinux3.2
  379. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  380. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  381. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  382. - Packaged for VineLinux3.2
  383. - Slipped texinfo
  384. - Fixed preun error
  385. - Preset Japanese fonts
  386. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  387. - Packaged for VineLinux3.2
  388. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  389. - Restored CAPABILITIES file lost in 2.2.1beta
  390. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  391. - Configure uses --without-blas by default.
  392. - Install pdf manuals.
  393. - All toplevel documentation files are installed into _libdir/R
  394. as they may be required by R (qv note on AUTHORS and THANKS below).
  395. - Legacy scripts for rebuilding package indices removed.
  396. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  397. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  398. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  399. - The files AUTHORS and THANKS need to be installed into _libdir/R
  400. as they are required by the function contributors(). Previously
  401. they were installed only as documentation files.
  402. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  403. - Corrected date error in SPEC file.
  404. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  405. - Dropped support for Red Hat boxed set.
  406. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  407. including support for shared R library.
  408. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  409. with the default optimization flags, so there is a temporary work-around.
  410. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  411. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  412. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  413. - Install R-data.info file as well.
  414. - Make info processing conditional on texinfo version, not platform release,
  415. so that if a new enough version is installed, we will build and install info.
  416. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  417. - Built R 2.1.0. R now supports internationalization, so the patch
  418. to set the locale to "C" is now dropped.
  419. - install.packages() exits gracefully with a helpful message if
  420. the file INSTALL is not present, so this is now included in the
  421. R-devel package.
  422. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  423. - Added support for Scientific Linux (http://www.scientificlinux.org)
  424. A distribution based on RHEL. Thanks to Jon Peatfield.
  425. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  426. - Fixed file ownership in R-devel and libRmath packages
  427. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  428. - R-devel package is now a stub package with no files, except a documentation
  429. file (RPM won't accept sub-packages with no files). R now conflicts
  430. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  431. - Created libRmath subpackage with shared library.
  432. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  433. - Created R-devel and libRmath-devel subpackages
  434. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  435. - Built R 2.0.1
  436. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  437. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  438. gives "lpr".
  439. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  440. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  441. - Info support is now conditional on the macro Rinfo, which is only
  442. defined for Fedora 1 and 2.
  443. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  444. - Built R 2.0.0
  445. - There is no longer a BUGS file, so this is not installed as a
  446. documentation file.