ghc-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. %define pkg_name ghc
  2. %define pkg_version 7.10.3
  3. %define pkg_subversion b
  4. %define pkg_release 2%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define rpmarch i386
  7. %endif
  8. %ifarch x86_64
  9. %define rpmarch x86_64
  10. %endif
  11. Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
  12. Name: %{pkg_name}
  13. Version: %{pkg_version}
  14. Release: %{pkg_release}
  15. License: BSD-like
  16. Group: Applications/Languages
  17. URL: https://www.haskell.org/ghc
  18. Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: ghc-bootstrap
  21. # BuildRequires: ghc
  22. BuildRequires: gmp-devel
  23. BuildRequires: libffi-devel
  24. BuildRequires: ncurses-devel readline-devel freeglut-devel
  25. BuildRequires: gtk2-devel
  26. BuildRequires: dblatex
  27. BuildRequires: texlive-collection-bibtexextra
  28. BuildRequires: texlive-collection-fontutils
  29. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  30. BuildRequires: hscolour
  31. Requires: libffi
  32. Requires: freeglut
  33. Obsoletes: ghc-bootstrap
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: ara_t
  37. %description
  38. The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
  39. compiler and interactive environment for the functional language Haskell.
  40. Highlights:
  41. - GHC supports the entire Haskell 2010 language plus a wide variety of
  42. extensions.
  43. - GHC has particularly good support for concurrency and parallelism,
  44. including support for Software Transactional Memory (STM).
  45. - GHC generates fast code, particularly for concurrent programs.
  46. - Take a look at GHC's performance on The Computer Language Benchmarks Game.
  47. GHC works on several platforms including Windows, Mac, Linux,
  48. most varieties of Unix, and several different processor architectures.
  49. There are detailed instructions for porting GHC to a new platform.
  50. - GHC has extensive optimisation capabilities, including inter-module
  51. optimisation.
  52. - GHC compiles Haskell code either directly to native code or using LLVM
  53. as a back-end.
  54. GHC can also generate C code as an intermediate target for porting to
  55. new platforms.
  56. The interactive environment compiles Haskell to bytecode,
  57. and supports execution of mixed bytecode/compiled programs.
  58. - Profiling is supported, both by time/allocation and various kinds of heap
  59. profiling.
  60. - GHC comes with several libraries, and thousands more are available on Hackage.
  61. #'
  62. %package bindist
  63. Version: %{version}
  64. Summary: ghc binary tarball to building haskell-platform
  65. License: BSD-like
  66. Group: Applications/Languages
  67. %description bindist
  68. ghc binary tarball to building haskell-platform
  69. %prep
  70. %{__rm} -rf ${RPM_BUILD_ROOT}
  71. %setup -q
  72. %build
  73. ./configure \
  74. --prefix=%{_prefix} --libdir=%{_libdir} \
  75. --docdir=%{_docdir}/%{name}-%{version} \
  76. --with-system-libffi
  77. %{__make} %{?_smp_mflags}
  78. %{__make} binary-dist
  79. %install
  80. %{make_install}
  81. %{__cp} ANNOUNCE LICENSE \
  82. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  83. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_usrsrc}
  84. %{__mv} ghc-%{version}-%{rpmarch}-unknown-linux.tar.bz2 \
  85. ghc-%{version}-%{rpmarch}-vine-linux.tar.bz2
  86. %{__cp} ghc-%{version}-%{rpmarch}-vine-linux.tar.bz2 \
  87. ${RPM_BUILD_ROOT}%{_usrsrc}
  88. %clean
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %post -p %{_syssbindir}/ldconfig
  91. %postun -p %{_syssbindir}/ldconfig
  92. %files
  93. %defattr(-, root, root)
  94. %{_bindir}/
  95. %{_libdir}/ghc-%{version}/
  96. %{_docdir}/ghc-%{version}/
  97. %{_mandir}/man1/
  98. %files bindist
  99. %defattr(-, root, root)
  100. %{_usrsrc}/
  101. %changelog
  102. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
  103. - correct SPEC file
  104. * Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
  105. - update to 7.10.3
  106. - add BuildRequires: texlive-collection-fontutils
  107. - add Requires: libffi
  108. - add Requires: freeglut
  109. - provide binary tarball for building haskell-platform
  110. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
  111. - rebuild with ghc-7.6.3-4
  112. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
  113. - add Patchs to use --with-system-libffi option
  114. * Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
  115. - empty
  116. * Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
  117. - add BuildRequires: dblatex
  118. - add BuildRequires: texlive-collection-bibtexextra
  119. - add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  120. - change BuildRequires from ghc-bootstrap to ghc
  121. * Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
  122. - new package