chromium-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. #% define with_system_icu 1
  7. %endif
  8. %define svn_rev 44472
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 5.0.378.0
  14. Release: 2%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. %{?nosrc:NoSource: 0}
  22. %{?nosrc:NoSource: 1}
  23. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. Source2: repack_chromium_archive.sh
  25. # Script used to create the tar.lzma archive from a checked out source
  26. #Source3: pack_chromium_source.sh
  27. Source3: pack_chromium_source-vine.sh
  28. #Source10: chromium.desktop
  29. Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  36. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  37. Provides: chromium-browser = %{version}
  38. #Obsoletes: chromium-browser < %{version}
  39. ## Start Patches
  40. # Many changes to the gyp system so we can use system libraries
  41. # My first ever patch set. I hope I did well.
  42. Patch3: chromium-gyp-system-02-icu.patch
  43. Patch4: chromium-no-sqlite-debug.patch
  44. Patch5: chromium-gyp-system-04-nss-nspr.patch
  45. Patch7: chromium-codechanges-nss-nspr.patch
  46. Patch8: chromium-codechanges-zlib.patch
  47. Patch9: chromium-drop-sse.patch
  48. Patch10: chromium-fix-wrapper.patch
  49. #Patch11: chromium-fix-home-kde4-path.patch
  50. Patch12: chromium-no-test-sources.patch
  51. Patch13: chromium-no-courgette.patch
  52. Patch14: chromium-master-prefs-path.patch
  53. Patch15: chromium-media-probe.patch
  54. Patch16: chromium-icu-code-changes.patch
  55. Patch17: chromium-system-glew.patch
  56. Patch18: chromium-system-expat.patch
  57. Patch19: chromium-system-zlib.patch
  58. Patch20: chromium-noffmpeg.patch
  59. Patch21: chromium-system-old-ffmpeg-way.patch
  60. Patch22: chromium-libpng14.patch
  61. Patch23: chromium-disable-mmx.patch
  62. # Vine
  63. #Patch40: chromium-5.0.353-no-ffmpeg-vine.patch
  64. ## Gentoo patches
  65. # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
  66. #Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
  67. BuildRequires: gcc gcc-c++
  68. %if %{?_dist_release} == "vl5"
  69. BuildRequires: libstdc++34 libstdc++34-devel
  70. %elseif %{?_dist_release} == "vl6"
  71. BuildRequires: libstdc++ libstdc++-devel
  72. %endif
  73. BuildRequires: libevent
  74. ##!!BuildRequires: pkg-config
  75. BuildRequires: python
  76. ##!!BuildRequires: python-xml
  77. BuildRequires: python-pyxml
  78. BuildRequires: perl bison flex gperf
  79. ##!!BuildRequires: wdiff
  80. ##!!BuildRequires: update-desktop-files
  81. BuildRequires: desktop-file-utils
  82. BuildRequires: lzma
  83. ##!!BuildRequires: mozilla-nss-devel
  84. BuildRequires: nss-devel
  85. ##!!BuildRequires: alsa-devel
  86. BuildRequires: alsa-lib-devel
  87. BuildRequires: gtk2-devel
  88. BuildRequires: glib2-devel
  89. BuildRequires: cairo-devel >= 1.6
  90. ##!!BuildRequires: mozilla-nspr-devel
  91. BuildRequires: nspr-devel
  92. ##!!BuildRequires: gconf2-devel
  93. BuildRequires: GConf2-devel
  94. BuildRequires: freetype2-devel
  95. ##!!BuildRequires: dbus-1-devel
  96. BuildRequires: dbus-devel
  97. BuildRequires: libxslt-devel
  98. BuildRequires: libxml2-devel
  99. BuildRequires: libjpeg-devel
  100. BuildRequires: zlib-devel
  101. BuildRequires: libpng-devel
  102. ##!!BuildRequires: libbz2-devel
  103. BuildRequires: bzip2-devel
  104. %if %{?_dist_release} == "vl6"
  105. BuildRequires: fdupes
  106. %endif
  107. ##!!BuildRequires: libexpat-devel
  108. BuildRequires: expat-devel
  109. BuildRequires: glew-devel
  110. ##!!BuildRequires: Mesa-devel
  111. BuildRequires: mesa-libGLU-devel
  112. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  113. BuildRequires: libevent-devel
  114. ##Vine Linux
  115. BuildRequires: libXScrnSaver-devel
  116. #BuildRequires: gle-devel
  117. #BuildRequires: webkit-gtk-devel
  118. #BuildRequires: scons
  119. %ifarch x86_64
  120. Requires: nspluginwrapper
  121. %endif
  122. ##!!Requires: alsa
  123. Requires: alsa-lib
  124. # shouldn't be required to name all dependencies
  125. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  126. ## Recommends the ffmpeg libraries (available from packman)
  127. #Recommends: libavcodec52 libavformat52 libavutil50
  128. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  129. %description
  130. Chromium is the open-source project behind Google Chrome.
  131. We invite you to join us in our effort to help build a safer, faster,
  132. and more stable way for all Internet users to experience the web,
  133. and to create a powerful platform for developing a new generation of
  134. web applications.
  135. %description -l ja
  136. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  137. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  138. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  139. ウェブアプリケーションの新しい世代を発展させるように
  140. 強力なプラットホームを作成するために、
  141. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  142. %prep
  143. [ -d %{name} ] && %__rm -rf %{name}
  144. lzma -cd %{SOURCE0} | tar xf -
  145. %setup -D -T -n %{name}
  146. # use static libicu
  147. #%if %{?_dist_release} == "vl5"
  148. cd src/third_party || exit 1
  149. %__rm -rf icu || exit 1
  150. tar jxvf %{SOURCE100} || exit 1
  151. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  152. cd - || exit 1
  153. #%endif
  154. # use system libicu only if >= 4.0
  155. %{?with_system_icu:%patch3 -p1}
  156. %patch4 -p1
  157. %patch5 -p1
  158. %patch7 -p1
  159. %patch8 -p1
  160. %patch9 -p1
  161. %patch10 -p1
  162. #%patch11 -p1
  163. %patch12 -p1
  164. %patch13 -p1
  165. %patch14 -p1
  166. %patch15 -p0
  167. %{?with_system_icu:%patch16 -p1}
  168. %patch17 -p1
  169. %patch18 -p1
  170. %patch19 -p1
  171. %patch20 -p1
  172. %patch21 -p1
  173. %patch22 -p1
  174. %ifarch %ix86
  175. %patch23 -p1
  176. %endif
  177. # apply vendor patch after substitution
  178. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  179. %build
  180. ## create make files
  181. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  182. for i in src/build/common.gypi; do
  183. %__sed -i "s|'-march=pentium4',||g" $i
  184. %__sed -i "s|'-msse2',||g" $i
  185. %__sed -i "s|'-mfpmath=sse',||g" $i
  186. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  187. %__sed -i "s|'-m32',||g" $i
  188. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  189. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  190. done
  191. # '
  192. pushd src
  193. ./build/gyp_chromium -f make build/all.gyp \
  194. -Duse_system_ffmpeg=1 \
  195. -Duse_system_zlib=1 \
  196. -Duse_system_libpng=1 \
  197. -Duse_system_bzip2=1 \
  198. -Duse_system_libjpeg=1 \
  199. -Duse_system_libxml=1 \
  200. -Duse_system_libxslt=1 \
  201. -Duse_system_libevent=1 \
  202. %{?with_system_icu:-Duse_system_icu=1} \
  203. %{!?with_system_icu:-Duse_system_icu=0} \
  204. %ifarch %{ix86}
  205. -Dtarget_arch=ia32 \
  206. %endif
  207. %ifarch x86_64
  208. -Dtarget_arch=x64 \
  209. %endif
  210. %if %{?_dist_release} == "vl6"
  211. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  212. %endif
  213. -Drelease_extra_cflags=-fPIC \
  214. ;
  215. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  216. #%__make -r -j5 chrome BUILDTYPE=Release
  217. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  218. popd
  219. %install
  220. %{__rm} -rf %{buildroot}
  221. ## Create install directories
  222. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  223. %{__mkdir_p} %{buildroot}%{_bindir}
  224. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  225. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  226. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  227. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  228. # chromium 'make' deposits us back at the top level build directory
  229. pushd src/out/Release
  230. ls -l
  231. # clean somechromium-codechanges-zlib.patch
  232. # clean debug junk
  233. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  234. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  235. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  236. %{__rm} -f ncdecode_table ncdecode_tablegen
  237. # clean other temporary binaries used in the compilation of chromium
  238. %{__rm} -f protoc xdg-settings
  239. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  240. # Man page
  241. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  242. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  243. # Add startup file with plugins enabled
  244. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  245. #!/bin/bash
  246. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  247. EOF
  248. # # link to browser plugin path. Plugin patch doesn't work. Why?
  249. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  250. # pushd %{buildroot}%{_libdir}/%{name}
  251. # %{__ln_s} %{_libdir}/browser-plugins plugins
  252. # popd
  253. pushd %{buildroot}%{_libdir}/%{name}
  254. %ifarch x86_64
  255. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  256. %else
  257. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  258. %endif
  259. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  260. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  261. #touch %{buildroot}%{_libdir}/libavformat.so.52
  262. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  263. #touch %{buildroot}%{_libdir}/libavutil.so.50
  264. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  265. popd
  266. # Install desktop-related files
  267. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  268. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  269. desktop-file-install --vendor Vine \
  270. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  271. --delete-original \
  272. --mode 644 \
  273. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  274. # Install the master_preferences file
  275. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  276. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  277. ## install o3d plugin
  278. #pushd src/o3d/build/out/Release
  279. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  280. %clean
  281. %{__rm} -rf %{buildroot}
  282. %files
  283. %defattr(-,root,root)
  284. %doc src/AUTHORS src/LICENSE
  285. %dir %{_libdir}/%{name}
  286. %attr(0755,root,root) %{_bindir}/%{name}
  287. %{_mandir}/man1/*
  288. %{_datadir}/applications/*%{name}.desktop
  289. %{_datadir}/pixmaps/%{name}.png
  290. %{_libdir}/%{name}/*
  291. %config %{_sysconfdir}/%{name}
  292. #%{_libdir}/browser-plugins/*
  293. #%exclude %{_libdir}/libavcodec.so.52
  294. #%exclude %{_libdir}/libavutil.so.50
  295. #%exclude %{_libdir}/libavformat.so.52
  296. %changelog
  297. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  298. - unused with_system_icu (for vl6)
  299. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  300. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  301. - updated to snapshot 5.0.378.0 r44472
  302. - used with_system_icu (for vl6)
  303. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  304. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  305. - updated to snapshot 5.0.372.0 r43947
  306. - added BuildRequires: glew-devel
  307. - changed Group tag to Applications/Internet
  308. - added Summary(ja) and %%description -l ja
  309. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  310. - updated to snapshot 5.0.365.0 r42966
  311. - merged 5.0.353.0-4vl5
  312. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  313. - build on Vine Linux 5.1
  314. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  315. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  316. - updated to snapshot 5.0.364.0 r42779
  317. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  318. - updated to snapshot 5.0.359.0 r42116
  319. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  320. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  321. - fixed master_preferences.vine, little
  322. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  323. - fixed to install master_preferences
  324. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  325. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  326. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  327. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  328. - updated to snapshot 5.0.353.0 r41449
  329. * Wed Mar 10 2010 bgmerrell@novell.com
  330. - Add master_preferences source file and install it to /etc/chromium.
  331. - Create a new patch (chromium-master-prefs-path.patch) which tells
  332. chromium to look in /etc/chromium for the master_preferences file
  333. (instead of looking in the default directory, which is the same
  334. directory as the 'chrome' binary).
  335. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  336. - updated to snapshot 5.0.335.0 r39556
  337. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  338. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  339. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  340. - updated to snapshot 5.0.330.0 r39074
  341. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  342. - use_system_ffmpeg
  343. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  344. - added Requires: nspluginwrapper
  345. - fixed a symbolic link of plugins directory with nspluginwrapper
  346. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  347. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  348. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  349. - added BuildRequires: mesa-libGLU-devel
  350. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  351. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  352. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  353. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  354. - Update to 4.0.260
  355. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  356. - Update to 4.0.259
  357. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  358. - Update to 4.0.258
  359. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  360. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  361. changed to having an built-in v8
  362. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  363. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  364. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  365. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  366. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  367. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  368. - update to newer svn snapshot
  369. + Obsoletes fwrite patch (included upstream)
  370. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  371. - update to newer svn snapshot
  372. + Requires newer version of v8
  373. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  374. - do not force SSE on x86 (drop-sse.patch)
  375. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  376. - Update to newer svn snapshot
  377. - Fixed spec file in order to build
  378. - Included patch to build with system zlib
  379. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  380. - package renamed to chromium
  381. - cleaned up spec file
  382. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  383. - v8 is now built as a separate package, and is required
  384. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  385. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  386. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  387. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  388. - initial build
  389. #% changelog
  390. * Sun Jan 24 2010 prusnak@suse.cz
  391. - added vendor to user agent (chromium-vendor.patch.in)
  392. * Sun Nov 29 2009 prusnak@suse.cz
  393. - added --enable-sync to wrapper to enable bookmark sync
  394. * Fri Nov 13 2009 tittiatcoke@gmail.com
  395. - update to 247.0 svn 31928
  396. * Fri Oct 30 2009 tittiatcoke@gmail.com
  397. - update to 229.0 svn 30454
  398. + Fix regression where popups and app frames lost their titlebars.
  399. + Makes it so that when a folder is open on the bookmark bar
  400. and the mouse moves over another folder, the menu for that
  401. folder is shown.
  402. + Lazily create the find bar.
  403. + Polish to the gmail checker sample.
  404. * New, crisper icons that are exactly 19x19
  405. * Add a loading animation at the beginning before Gmail
  406. responds.
  407. * Fix a bug where we sometimes don't update the UI after a
  408. logout/login cycle.
  409. + Refactor widget methods to support desktop notifications,
  410. including GTK stubs.
  411. + Find-in-page should not ding while deleting characters.
  412. + Add SSL wrapper for linux and mac. This allows notifier to
  413. use chrome's SSL layer instead of OpenSSL.
  414. + Add three of the six extensions to PAC that Internet Explorer supports.
  415. + WebSocket support in chromium. (Run with --enable-web-sockets
  416. enables WebSocket features.)
  417. + Do not allow GTK File Chooser dialogs to return directories.
  418. + Fix the notifier SSL layer to make notifications work for
  419. Linux Bookmark sync.
  420. + linux: don't override mouse selection behavior in omnibox
  421. * Sun Oct 25 2009 tittiatcoke@gmail.com
  422. - Update to 224.4 svn 30027
  423. + First cut at new page and browser action docs based
  424. on new API. Deleted old stuff.
  425. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  426. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  427. + Minimize dependency of user scripts
  428. + Fixup the flip_framer eof-handling semantics now that we have
  429. the FIN bit in place
  430. + app depends on x11 because of active_window_watcher_x
  431. + Adding two images for the new Extension managment UI
  432. + Removing hard-coded Chrome Frame output path
  433. + Rearrange clipboard code
  434. + Fix crash bug when attempting to download a url with unsupported scheme,
  435. e.g. 'data:', by 'Alt + Click'
  436. + GTK: Change text for extension download UI
  437. + Ignore invalid urls on command line
  438. + Make dropped tabs animate from where they were dropped.
  439. + Make room for the full width of the tab placeholder.
  440. + Make tab dragging as smooth as glass.
  441. + Remove an annoying NOTIMPLEMNETED
  442. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  443. + If we're in the middle of a drag, don't allow the user to middle
  444. click to close or right click for the context menu
  445. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  446. + Remove +x bit from files that shouldn't have it
  447. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  448. + Adding new image needed for the managment UI
  449. + Fix a race bug where content scripts would not apply to the first page load
  450. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  451. + Fix bubbles deactivating the opaque frame
  452. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  453. + ake all pepper plugins default to windowless and transparent
  454. + Add styles for printing
  455. + Implement the new extension management UI
  456. + Add support for to automation interface load install and load extensions
  457. + GTK: theme the info bar border
  458. + Update V8 to version 1.3.16.1
  459. + Introduce WebSecurityPolicy for security related methods
  460. + New button scheme...borders are separate from the inner contents so
  461. that they can be highlighted / depressed independently
  462. + When opening Chrome maximized with an application window already
  463. running, the Chrome window was not activated
  464. + Fix compatibility problems with FileZilla FTP Server
  465. + Remove the extension shelf on Linux
  466. + Fix the proxy host and port string to start with http:// if it does not already
  467. + Enable HTML5 databases for all extension renderer processes