notification-daemon-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. %define gtk2_version 2.10.0
  2. %define glib2_version 2.8.0
  3. %define dbus_version 0.60
  4. %define libnotify_version 0.4.0
  5. Summary: Notification Daemon
  6. Name: notification-daemon
  7. Version: 0.4.0
  8. Release: 4%{?_dist_release}
  9. URL: http://www.galago-project.org/specs/notification/
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: notification-daemon-0.4.0-ja.po
  14. Patch1: notification-daemon-0.4.0-ja.patch
  15. # patches from ubuntu
  16. Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
  17. Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
  18. Patch105: notification-daemon-0.4.0-spacing.patch
  19. Patch107: notification-daemon-0.4.0-memleak-daemon.patch
  20. Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
  21. # vine theme based on ubuntu engine
  22. Source200: notification-daemon-engine-vine.tar.bz2
  23. Patch200: notification-daemon-0.4.0-vine-theme.patch
  24. Patch201: notification-daemon-0.4.0-default-theme.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Requires: dbus >= %{dbus_version}
  27. Requires: dbus-glib >= %{dbus_version}
  28. Requires(post): GConf2
  29. BuildRequires: glib2-devel >= %{glib2_version}
  30. BuildRequires: dbus-devel >= %{dbus_version}
  31. BuildRequires: dbus-glib-devel >= %{dbus_version}
  32. BuildRequires: libnotify-devel >= %{libnotify_version}
  33. BuildRequires: libsexy-devel
  34. #BuildRequires: libnotify >= %{libnotify_version}
  35. %description
  36. notification-daemon is the server implementation of the freedesktop.org
  37. desktop notification specification.
  38. %prep
  39. %setup -q -a 200
  40. %patch1 -p1 -b .ja
  41. %patch103 -p1
  42. %patch104 -p1
  43. %patch105 -p0
  44. %patch107 -p1
  45. %patch109 -p1
  46. %patch200 -p1
  47. %patch201 -p1
  48. # install japanese message catalog
  49. %{__cp} %{SOURCE1} po/ja.po
  50. %build
  51. autoreconf -f -i
  52. %configure --disable-schemas-install
  53. make %{?_smp_mflags}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  57. %find_lang %name
  58. # remove unpackaged files
  59. rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
  60. # install desktop file
  61. desktop-file-install --delete-original \
  62. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  63. --add-category DesktopSettings \
  64. ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
  65. %pre
  66. if [ "$1" -gt 1 ]; then
  67. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  68. gconftool-2 --makefile-uninstall-rule \
  69. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  70. fi
  71. %post
  72. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  73. gconftool-2 --makefile-install-rule \
  74. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  75. touch --no-create %{_datadir}/icons/hicolor
  76. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  77. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  78. fi
  79. %preun
  80. if [ "$1" -eq 0 ]; then
  81. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  82. gconftool-2 --makefile-uninstall-rule \
  83. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  84. fi
  85. %postun
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  88. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  89. fi
  90. %clean
  91. rm -rf %{buildroot}
  92. %files -f %{name}.lang
  93. %defattr(-,root,root)
  94. %doc COPYING ChangeLog NEWS
  95. %{_bindir}/notification-properties
  96. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  97. %dir %{_libdir}/notification-daemon-1.0
  98. %dir %{_libdir}/notification-daemon-1.0/engines
  99. %{_libdir}/notification-daemon-1.0/engines/*.so
  100. %{_libexecdir}/notification-daemon
  101. %{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
  102. %{_datadir}/applications/notification-properties.desktop
  103. %{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
  104. %{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
  105. %{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
  106. %{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
  107. %{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
  108. %{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
  109. %{_datadir}/notification-daemon/notification-properties.glade
  110. %changelog
  111. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
  112. - add Categories=DesktopSettings for notification-properties.desktop
  113. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
  114. - add Source200, Patch200,201
  115. - add vine theme engine based on ubuntu engine.
  116. - add patch101-109 from ubuntu
  117. - Patch103: fix xinerama stack
  118. - Patch104: dont crash on critical warnings
  119. - Patch105: fix notification spacing
  120. - Patch107: fix memleak
  121. - Patch109: fix crash on theme changing
  122. * Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
  123. - add japanese translation (Source1 and Patch1)
  124. - prperly install/uninstall gconf schemas
  125. - update gtk icon cache with %%post, %%postun
  126. * Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
  127. - new upstream release
  128. - change required gtk2 version to 2.10.0
  129. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
  130. - applied new versioning policy
  131. * Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
  132. - rebuilt with libwnck 2.20.2
  133. * Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
  134. - new upstream release
  135. - rebuilt with libsexy 0.1.10
  136. - added BuildRequores: libsexy-devel
  137. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
  138. - new upstream release
  139. * Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
  140. - initial build for Vine Linux partialy based on FC package.
  141. * Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
  142. - Add patch to fix struct handling in the dbus glib binding for dbus 0.61
  143. so image data works again
  144. * Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
  145. - BuildRequires love, for all you lovers out there.
  146. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
  147. - bump again for double-long bug on ppc(64)
  148. * Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
  149. - remove empty scripts from .spec file
  150. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
  151. - rebuilt for new gcc4.1 snapshot and glibc changes
  152. * Fri Feb 3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
  153. - Add patch to determine whether a compositing manager is running
  154. when drawing a new notification bubble, as long as the CM grabs
  155. the appropriate XSelection.
  156. * Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
  157. - Make it so that marked-up messages appear with markup
  158. * Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
  159. - Provide desktop-notification-daemon, since libnotify requires a
  160. notification deamon, but not this specific one. Other notification
  161. daemons can exist on the system so long as they meet the provides
  162. (and the API of course).
  163. * Mon Jan 9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
  164. - Fix positioning of the notification bubble to not draw off-screen
  165. * Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  166. - Actuall release of 0.3.1
  167. * Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
  168. - Upgrade to upstream 0.3.1
  169. * Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
  170. - inital build