xulrunner-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790
  1. %define nspr_version 4.8
  2. %define nss_version 3.12.3
  3. %define cairo_version 1.8.6
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-1.9.2
  6. %define build_vine6 0
  7. %define build_vine5 0
  8. %if "%{?_dist_release}" == "vl6"
  9. %define build_vine6 1
  10. %define build_vine5 1
  11. %endif
  12. %if "%{?_dist_release}" == "vl5"
  13. %define build_vine5 1
  14. %endif
  15. %if %build_vine6
  16. %define sqlite_version 3.6.21
  17. %endif
  18. %define version_internal 1.9.2
  19. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  20. Summary: XUL Runtime for Gecko Applications
  21. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  22. Name: xulrunner
  23. Version: 1.9.2.3
  24. Release: 1%{?_dist_release}
  25. URL: http://www.mozilla.org/projects/xulrunner/
  26. License: MPLv1.1 or GPLv2+ or LGPLv2+
  27. Group: Applications/Internet
  28. Source0: %{name}-%{version}-source.tar.bz2
  29. Source10: %{name}-mozconfig
  30. Source11: %{name}-mozconfig-vine5
  31. Source12: %{name}-vine-default-prefs.js
  32. Source21: %{name}.sh.in
  33. Source23: %{name}.1
  34. # locale sources
  35. %define MOZ_BUILD_LOCALES "ja"
  36. Source1000: xulrunner-%{version}-ja.tar.bz2
  37. # build patches
  38. Patch0: xulrunner-version.patch
  39. Patch1: mozilla-build.patch
  40. Patch3: mozilla-jemalloc.patch
  41. Patch5: mozilla-jemalloc-526152.patch
  42. Patch7: xulrunner-1.9.2.1-build.patch
  43. Patch8: mozilla-plugin.patch
  44. Patch9: mozilla-build-sbrk.patch
  45. # patches from Fedora
  46. Patch10: mozilla-192-pkgconfig.patch
  47. # Upstream patches
  48. Patch26: mozilla-ps-pdf-simplify-operators.patch
  49. # ---------------------------------------------------
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  51. BuildRequires: nspr-devel >= %{nspr_version}
  52. BuildRequires: nss-devel >= %{nss_version}
  53. BuildRequires: cairo-devel >= %{cairo_version}
  54. BuildRequires: libpng-devel
  55. BuildRequires: libjpeg-devel
  56. BuildRequires: bzip2-devel
  57. BuildRequires: zlib-devel
  58. BuildRequires: lcms-devel
  59. BuildRequires: libIDL-devel
  60. BuildRequires: gtk2-devel
  61. BuildRequires: gnome-vfs2-devel
  62. BuildRequires: libgnome-devel
  63. BuildRequires: libgnomeui-devel
  64. BuildRequires: pango-devel
  65. BuildRequires: freetype2-devel >= 2.1.9
  66. BuildRequires: libXt-devel
  67. BuildRequires: libXrender-devel
  68. %if %{build_vine6}
  69. BuildRequires: sqlite3-devel >= %{sqlite_version}
  70. %endif
  71. BuildRequires: libnotify-devel >= %{libnotify_version}
  72. BuildRequires: startup-notification-devel
  73. BuildRequires: alsa-lib-devel
  74. BuildRequires: lcms-devel
  75. BuildRequires: zip
  76. # For -sqlite.patch
  77. BuildRequires: autoconf213
  78. Requires: nspr >= %{nspr_version}
  79. Requires: nss >= %{nss_version}
  80. Provides: gecko-libs = %{version}
  81. %description
  82. XULRunner provides the XUL Runtime environment for Gecko applications.
  83. %package devel
  84. Summary: Development files for Gecko
  85. Group: Development/Libraries
  86. Obsoletes: mozilla-devel
  87. Obsoletes: firefox-devel < 2.1
  88. Obsoletes: xulrunner-devel-unstable
  89. Provides: gecko-devel = %{version}
  90. Provides: gecko-devel-unstable = %{version}
  91. Requires: xulrunner = %{version}-%{release}
  92. Requires: nspr-devel >= %{nspr_version}
  93. Requires: nss-devel >= %{nss_version}
  94. Requires: cairo-devel >= %{cairo_version}
  95. Requires: libjpeg-devel
  96. Requires: zip
  97. Requires: bzip2-devel
  98. Requires: zlib-devel
  99. Requires: lcms-devel
  100. Requires: libIDL-devel
  101. Requires: gtk2-devel
  102. Requires: gnome-vfs2-devel
  103. Requires: libgnome-devel
  104. Requires: libgnomeui-devel
  105. Requires: pango-devel
  106. Requires: freetype2-devel >= 2.1.9
  107. Requires: libXt-devel
  108. Requires: libXrender-devel
  109. %if %{build_vine6}
  110. Requires: sqlite3-devel >= %{sqlite_version}
  111. %endif
  112. Requires: startup-notification-devel
  113. Requires: alsa-lib-devel
  114. %description devel
  115. Gecko development files.
  116. #---------------------------------------------------------------------
  117. %prep
  118. %setup -q -c -b 1000
  119. cd %{tarballdir}
  120. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  121. %{P:%%PATCH0} > version.patch
  122. %{__patch} -p1 -b --suffix .version < version.patch
  123. %patch1 -p1 -b .build
  124. %patch3 -p1 -b .jemalloc
  125. %patch5 -p1 -b .jemalloc-526152
  126. %patch7 -p2 -b .del
  127. %patch8 -p1 -b .plugin
  128. %patch9 -p2 -b .sbrk
  129. %patch10 -p1 -b .pkgconfig
  130. %patch26 -p1 -b .ps-pdf-simplify-operators
  131. %{__rm} -f .mozconfig
  132. %if %{build_vine6}
  133. %{__cp} %{SOURCE10} .mozconfig
  134. %else
  135. %{__cp} %{SOURCE11} .mozconfig
  136. %endif
  137. #---------------------------------------------------------------------
  138. %build
  139. cd %{tarballdir}
  140. INTERNAL_GECKO=%{version_internal}
  141. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  142. # Mozilla builds with -Wall with exception of a few warnings which show up
  143. # everywhere in the code; so, don't override that.
  144. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  145. export CFLAGS=$MOZ_OPT_FLAGS
  146. export CXXFLAGS=$MOZ_OPT_FLAGS
  147. export PREFIX='%{_prefix}'
  148. export LIBDIR='%{_libdir}'
  149. MOZ_SMP_FLAGS=-j1
  150. %ifnarch ppc ppc64 s390 s390x
  151. [ -z "$RPM_BUILD_NCPUS" ] && \
  152. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  153. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  154. %endif
  155. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  156. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  157. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  158. # build locales
  159. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  160. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  161. for dir in $LOCALEDIRS
  162. do
  163. for lang in %{MOZ_BUILD_LOCALES} ; do
  164. make -C $dir/locales AB_CD=$lang
  165. done
  166. done
  167. #---------------------------------------------------------------------
  168. %install
  169. cd %{tarballdir}
  170. %{__rm} -rf $RPM_BUILD_ROOT
  171. INTERNAL_GECKO=%{version_internal}
  172. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  173. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  174. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  175. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  176. #DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  177. DESTDIR=$RPM_BUILD_ROOT make install
  178. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  179. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  180. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  181. %{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
  182. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  183. # set up our default preferences
  184. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  185. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  186. %{__rm} vl-default-prefs
  187. # Start script install
  188. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  189. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  190. $RPM_BUILD_ROOT%{_bindir}/%{name}
  191. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  192. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  193. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  194. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  195. cd -
  196. # install locales
  197. for lang in %{MOZ_BUILD_LOCALES} ; do
  198. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  199. done
  200. # Prepare our devel package
  201. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  202. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  203. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  204. %{__cp} -rL dist/include/* \
  205. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  206. # Copy pc files (for compatibility with 1.9.1)
  207. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  208. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  209. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  210. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  211. # Fix multilib devel conflicts...
  212. %ifarch x86_64 ia64 s390x ppc64
  213. %define mozbits 64
  214. %else
  215. %define mozbits 32
  216. %endif
  217. function install_file() {
  218. genheader=$*
  219. mv ${genheader}.h ${genheader}%{mozbits}.h
  220. cat > ${genheader}.h << EOF
  221. // This file exists to fix multilib conflicts
  222. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  223. #include "${genheader}64.h"
  224. #else
  225. #include "${genheader}32.h"
  226. #endif
  227. EOF
  228. }
  229. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  230. install_file "mozilla-config"
  231. popd
  232. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  233. install_file "jsautocfg"
  234. popd
  235. %{__install} -p -c -m 755 dist/bin/xpcshell \
  236. dist/bin/xpidl \
  237. dist/bin/xpt_dump \
  238. dist/bin/xpt_link \
  239. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  240. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  241. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  242. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  243. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  244. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  245. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  246. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  247. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  248. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  249. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  250. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  251. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  252. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  253. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  254. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  255. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  256. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  257. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  258. for i in *.so; do
  259. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  260. done
  261. popd
  262. # GRE stuff
  263. %ifarch x86_64 ia64 ppc64 s390x
  264. %define gre_conf_file gre64.conf
  265. %else
  266. %define gre_conf_file gre.conf
  267. %endif
  268. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  269. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  270. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  271. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  272. # Library path
  273. %ifarch x86_64 ia64 ppc64 s390x
  274. %define ld_conf_file xulrunner-64.conf
  275. %else
  276. %define ld_conf_file xulrunner-32.conf
  277. %endif
  278. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  279. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  280. ${MOZ_APP_DIR}
  281. EOF
  282. # Copy over the LICENSE
  283. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  284. # Use the system hunspell dictionaries
  285. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  286. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  287. # ghost files
  288. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  289. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  290. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  291. #---------------------------------------------------------------------
  292. %clean
  293. %{__rm} -rf $RPM_BUILD_ROOT
  294. #---------------------------------------------------------------------
  295. %post
  296. /sbin/ldconfig
  297. %postun
  298. /sbin/ldconfig
  299. %preun
  300. # is it a final removal?
  301. if [ $1 -eq 0 ]; then
  302. %{__rm} -rf ${MOZ_APP_DIR}/components
  303. fi
  304. %files
  305. %defattr(-,root,root,-)
  306. %{_bindir}/xulrunner
  307. %dir /etc/gre.d
  308. /etc/gre.d/%{gre_conf_file}
  309. %dir %{mozappdir}
  310. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  311. %doc %attr(644, root, root) %{mozappdir}/README.txt
  312. %{mozappdir}/chrome
  313. %{mozappdir}/dictionaries
  314. %dir %{mozappdir}/components
  315. %ghost %{mozappdir}/components/compreg.dat
  316. %ghost %{mozappdir}/components/xpti.dat
  317. %{mozappdir}/components/*.so
  318. %{mozappdir}/components/*.xpt
  319. %attr(644, root, root) %{mozappdir}/components/*.js
  320. %{mozappdir}/defaults
  321. %{mozappdir}/greprefs
  322. %dir %{mozappdir}/icons
  323. %attr(644, root, root) %{mozappdir}/icons/*
  324. %{mozappdir}/modules
  325. %{mozappdir}/plugins
  326. %{mozappdir}/res
  327. %{mozappdir}/*.so
  328. %{mozappdir}/mozilla-xremote-client
  329. %{mozappdir}/run-mozilla.sh
  330. %{mozappdir}/regxpcom
  331. %{mozappdir}/xulrunner
  332. %{mozappdir}/xulrunner-bin
  333. %{mozappdir}/xulrunner-stub
  334. %{mozappdir}/platform.ini
  335. %{mozappdir}/dependentlibs.list
  336. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  337. # XXX See if these are needed still
  338. %{mozappdir}/updater*
  339. %exclude %{mozappdir}/update.locale
  340. %exclude %{mozappdir}/components/components.list
  341. %files devel
  342. %defattr(-,root,root,-)
  343. %dir %{_datadir}/idl/%{name}*%{version_internal}
  344. %{_datadir}/idl/%{name}*%{version_internal}/*
  345. %{_includedir}/%{name}*%{version_internal}
  346. %dir %{_libdir}/%{name}-sdk-*
  347. %dir %{_libdir}/%{name}-sdk-*/sdk
  348. %{_libdir}/%{name}-sdk-*/*
  349. %{_libdir}/%{name}-sdk-*/sdk/*
  350. %{_libdir}/pkgconfig/*.pc
  351. %{mozappdir}/xpcshell
  352. %{mozappdir}/xpidl
  353. %{mozappdir}/xpt_dump
  354. %{mozappdir}/xpt_link
  355. #---------------------------------------------------------------------
  356. %changelog
  357. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  358. - update to 1.9.2.3 (sync with firefox-3.6.3)
  359. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  360. - update to 1.9.2.2 (sync with firefox-3.6.2)
  361. - add patch7,9 for fix build failure
  362. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  363. - enable libnotify support
  364. - add ac_add_options --enable-libnotify
  365. - disable Necko wifi monitor
  366. - add ac_add_options --disable-necko-wifi
  367. - remove BR: wireless-tools-devel
  368. - fix %%files devel
  369. - add patch3,5 to fix jemalloc alignment assertion
  370. - add Patch8 to fix mozilla-plugin.pc
  371. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  372. - add BR: libnotify-devel, wireless-tools-devel
  373. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  374. - update to 1.9.2 (sync with firefox-3.6)
  375. - obsoletes xulrunner-devel-unstable
  376. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  377. - use internal sqlite3 on vine5
  378. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  379. - update to 1.9.1.7
  380. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  381. - update to 1.9.1.6
  382. - build with sqlite3-3.6.21
  383. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  384. - update to 1.9.1.5
  385. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  386. - update to 1.9.1.3
  387. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  388. - really update to 1.9.1.2 (<BTS:0748>)
  389. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  390. - update to 1.9.1.2 (sync with firefox-3.5.2)
  391. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  392. - update to 1.9.1.1 (sync with firefox-3.5.1)
  393. - add missing Requires to -devel
  394. - add missing BR
  395. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  396. - enable-system-cairo
  397. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  398. - update to 1.9.1 (based on firefox 3.5)
  399. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  400. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  401. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  402. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  403. - remove old patches
  404. - require nspr >= 4.8
  405. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  406. - new upstream release
  407. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  408. - update mozconfig
  409. - disable-system-cairo for stability
  410. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  411. - new upstream release
  412. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  413. - new upstream release
  414. - add ja locale
  415. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  416. - new upstream release
  417. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  418. - new upstream release
  419. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  420. - add Patch3
  421. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  422. - update to xulrunner 1.9.0.2 byild 6
  423. - build with gnome-2.24
  424. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  425. - new upstream release
  426. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  427. - initial build for Vine Linux
  428. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  429. - Update to 1.9 final
  430. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  431. - Simplify PS/PDF operators
  432. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  433. - Upstream patch to fsync() less
  434. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  435. - Ensure we enable startup notification; add BR and modify config
  436. (bug #445543)
  437. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  438. - Some files moved to mozilla-filesystem; kill them and add the Req
  439. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  440. - Clean up the %%files list and get rid of the executable bit on some files
  441. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  442. - Fix font scaling
  443. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  444. - Enabled phishing protection (#443403)
  445. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  446. - Changed "__ppc64__" to "__powerpc64__",
  447. "__ppc64__" doesn't work anymore
  448. - Added fix for #443725 - Critical hanging bug with fix
  449. available upstream (mozbz#429903)
  450. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  451. - Fixed multilib issues, added starting script instead of a symlink
  452. to binary (#436393)
  453. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  454. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  455. - Re-enable system cairo
  456. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  457. - Spec cleanups
  458. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  459. - Beta 5
  460. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  461. - Beta 5 RC2
  462. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  463. - Update to latest trunk (2008-03-27)
  464. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  465. - Update to latest trunk (2008-03-26)
  466. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  467. - Update to latest trunk (2008-03-25)
  468. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  469. - Update to latest trunk (2008-03-24)
  470. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  471. - Update to latest trunk (2008-03-20)
  472. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  473. - Update to latest trunk (2008-03-17)
  474. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  475. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  476. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  477. - Update to latest trunk (2008-03-16)
  478. - Add patch to negate a11y slowdown on some pages (#431162)
  479. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  480. - Update to latest trunk (2008-03-15)
  481. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  482. - Avoid conflicts between gecko debuginfo packages
  483. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  484. - Update to latest trunk (2008-03-12)
  485. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  486. - Update to latest trunk (2008-03-11)
  487. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  488. - Update to latest trunk (2008-03-10)
  489. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  490. - Update to latest trunk (2008-03-09)
  491. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  492. - Update to latest trunk (2008-03-07)
  493. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  494. - Update to latest trunk (2008-03-06)
  495. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  496. - Update to latest trunk (2008-03-04)
  497. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  498. - Update to latest trunk (2008-03-02)
  499. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  500. - Update to latest trunk (2008-03-01)
  501. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  502. - Update to latest trunk (2008-02-29)
  503. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  504. - Update to latest trunk (2008-02-28)
  505. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  506. - Update to latest trunk (2008-02-27)
  507. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  508. - Update to latest trunk (2008-02-26)
  509. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  510. - Update to latest trunk (2008-02-23)
  511. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  512. - Update to latest trunk (2008-02-22)
  513. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  514. - Update to latest trunk (2008-02-21)
  515. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  516. - Update to latest trunk (2008-02-20)
  517. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  518. - Update to latest trunk (2008-02-17)
  519. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  520. - Update to latest trunk (2008-02-15)
  521. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  522. - Update to latest trunk (2008-02-14)
  523. - Use system hunspell
  524. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  525. - Update to latest trunk (2008-02-11)
  526. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  527. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  528. you know, debuginfo.
  529. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  530. - Update to latest trunk (2008-02-10)
  531. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  532. - Update to latest trunk (2008-02-09)
  533. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  534. - Update to latest trunk (2008-02-06)
  535. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  536. - Update to latest trunk (2008-01-30)
  537. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  538. - rebuild agains new nss
  539. - enabled gnome vfs
  540. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  541. - fixed stable pkg-config files (#429654)
  542. - removed sqlite patch
  543. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  544. - Update to latest trunk (2008-01-21)
  545. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  546. - Update to latest trunk (2008-01-15)
  547. - Now with system extensions directory support
  548. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  549. - Update to latest trunk (2008-01-13)
  550. - Use CFLAGS instead of configure arguments
  551. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  552. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  553. - Provide gecko-devel-unstable as well
  554. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  555. - divided devel package to devel and devel-unstable
  556. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  557. - removed fedora specific pkg-config files
  558. - updated to the latest trunk (2008-01-07)
  559. - removed unnecessary patches
  560. - fixed idl dir (#427965)
  561. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  562. - Re-enable camellia256 support now that NSS supports it
  563. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  564. - updated to the latest trunk (2008-01-03)
  565. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  566. - Don't Provide webclient (xulrunner is not itself a webclient)
  567. - Don't Obsolete old firefox, only firefox-devel
  568. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  569. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  570. - added java and plugin subdirs to plugin includes
  571. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  572. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  573. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  574. - updated to Beta 2.
  575. - moved SDK to xulrunner-sdk
  576. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  577. - fixed mozilla-plugin.pc (#412971)
  578. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  579. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  580. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  581. - added xulrunner/js include dir to xulrunner-js
  582. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  583. - update to beta 1
  584. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  585. - packed all gecko libraries (#389391)
  586. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  587. - registered xulrunner libs system-wide
  588. - added xulrunner-gtkmozembed.pc
  589. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  590. - added proper nss/nspr dependencies
  591. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  592. - more build fixes, use system nss libraries
  593. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  594. - build fixes
  595. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  596. - updated to the latest trunk
  597. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  598. - build fixes for ppc/ppc64
  599. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  600. - removed conflicts with the current gecko-based apps
  601. - added updated ppc64 patch
  602. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  603. - build fixes
  604. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  605. - Initial cut at XULRunner 1.9 Alpha 7
  606. - Temporarily revert camellia 256 support since our nss doesn't support it yet