html-helper-mode-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname html-helper-mode
  4. %define origver 2.19.1.1
  5. %define release 5%{?_dist_release}
  6. # Main
  7. Summary: Major mode for editing HTML (for Emacsen)
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: %{release}
  11. License: GPL2
  12. Group: Applications/Editors/Emacs
  13. URL: http://www.santafe.edu/~nelson/tools/
  14. Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
  15. Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
  16. Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
  17. Source3: http://www.santafe.edu/~nelson/tools/configuring.html
  18. Source4: http://www.santafe.edu/~nelson/tools/differences.html
  19. Source5: http://www.santafe.edu/~nelson/tools/documentation.html
  20. Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
  21. Source7: hhm.dot.emacs
  22. Source8: HHM-MK
  23. Source9: html-helper-mode-install.sh
  24. Source10: html-helper-mode-remove.sh
  25. Buildroot: %{_tmppath}/%{name}-root
  26. PreReq: emacsen
  27. Requires: emacsen
  28. %prereq_ge emacsen-common
  29. BuildArchitectures: noarch
  30. #Obsoletes: %{name}-2.19.1.1-3
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. NOTE:
  35. It require following,
  36. so please get and install them before to install it.
  37. =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  38. Emacs:
  39. emacsen and emacsen-common
  40. =====================================================
  41. What's html-helper-mode
  42. ========================
  43. html-helper-mode makes it easier to write HTML documents.
  44. This mode handles inserting HTML codes in a variety of ways
  45. (keybindings, completion in the buffer).
  46. It also supports indentation, timestamps, skeletons for new documents,
  47. hilit19 patterns, and a variety of other things.
  48. Initialization
  49. ===============
  50. Please refer the following file:
  51. "/usr/doc/%{name}-%{version}/hhm.dot.emacs"
  52. "/usr/doc/%{name}-%{version}/*.html"
  53. %description -l ja
  54. 注意:
  55. 以下が必要ですので、
  56. インストール前にそれらをインストールして下さい。
  57. =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
  58. Emacs:
  59. emacsen と emacsen-common
  60. ================================================
  61. html-helper-mode とは
  62. ======================
  63. html-helper-mode は、HTML ドキュメントの作成を簡単にします。
  64. このモードでは、HTML コードの挿入に多様な方法が使えます。
  65. また、INDENTATION、タイムスタンプ等をサポートします。
  66. 初期設定
  67. =========
  68. 下記を参考にしてください:
  69. "/usr/doc/%{name}-%{version}/hhm.dot.emacs"
  70. "/usr/doc/%{name}-%{version}/*.html"
  71. # '
  72. %prep
  73. %setup -q -T -c %{name}-%{version}
  74. cp %SOURCE0 ./
  75. cp %SOURCE1 ./
  76. cp %SOURCE2 ./
  77. cp %SOURCE3 ./
  78. cp %SOURCE4 ./
  79. cp %SOURCE5 ./
  80. cp %SOURCE6 ./
  81. cp %SOURCE7 ./
  82. cp %SOURCE8 ./
  83. %build
  84. # byte-compile
  85. #emacs-%{emacsver} -batch -l HHM-MK
  86. %install
  87. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  88. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  89. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  90. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  91. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  92. #
  93. # install el files
  94. #
  95. cp -a html-helper-mode.el tempo.el HHM-MK \
  96. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  97. #
  98. # install script( bytecompile el and install elc , remove )
  99. #
  100. %_installemacsenscript %{origname} %{SOURCE9}
  101. %_removeemacsenscript %{origname} %{SOURCE10}
  102. %post
  103. #
  104. # bytecompile and install
  105. #
  106. if [ "$1" = 2 ]; then
  107. %_emacsenPackageRemove %{origname}
  108. fi
  109. %_addemacsenlist %{origname}
  110. %_emacsenPackageInstall %{origname}
  111. %preun
  112. if [ "$1" = 0 ]; then
  113. %_emacsenPackageRemove %{origname}
  114. %_removeemacsenlist %{origname}
  115. fi
  116. %clean
  117. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  118. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  119. %files
  120. %defattr(-,root,root)
  121. %doc *.html hhm.dot.emacs
  122. %{_datadir}/emacs/site-lisp/%{origname}/
  123. /usr/lib/emacsen-common/packages/install/%{origname}
  124. /usr/lib/emacsen-common/packages/remove/%{origname}
  125. %changelog
  126. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
  127. - spec in utf8
  128. - applied new versioning policy
  129. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
  130. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  131. - s/Copyright/License/
  132. * Wed Jan 2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
  133. - emacsenize
  134. - rewrite Summary and %%description for emacesnize
  135. * Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
  136. - 2.19.1.1-4vl1
  137. - rebuid for Vine Linux 2.1/emacs-20.7
  138. * Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
  139. - rebuid for Vine Linux 2.0
  140. * Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  141. - Released as version "html-helper-mode-emacs20-2.19.1.1-3".
  142. Changed from "html-helper-mode-emacs20-2.19.1.1-2".
  143. - Changed emacs version, "20.4" => "20.5".
  144. - Revised some, the definition part of data.
  145. * Thu Dec 2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  146. - Released as version "html-helper-mode-emacs20-2.19.1.1-2".
  147. Changed from "html-helper-mode-emacs20-2.19.1.1-1".
  148. - Added source file, "HHM-MK".
  149. - Revised some, the definition part of data.
  150. - Revised some, part of "%description, %build".
  151. * Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  152. - Released as version "html-helper-mode-emacs20-2.19.1.1-1".
  153. # $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $