perl-Perl-Critic-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-Perl-Critic
  4. Version: 1.120
  5. Release: 1%{?_dist_release}
  6. Summary: Critique Perl source code for best-practices
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Perl-Critic/
  10. Source0: http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  14. # Build process
  15. BuildRequires: perl(Module::Build) >= 0.34
  16. BuildRequires: perl(Task::Weaken)
  17. # Module requirements
  18. BuildRequires: aspell-en
  19. Requires: aspell
  20. BuildRequires: perl(B::Keywords) >= 1.05
  21. BuildRequires: perl(Carp)
  22. BuildRequires: perl(charnames)
  23. BuildRequires: perl(Config::Tiny) >= 2
  24. BuildRequires: perl(Email::Address) >= 1.889
  25. BuildRequires: perl(English)
  26. BuildRequires: perl(Exception::Class) >= 1.23
  27. BuildRequires: perl(Exporter)
  28. BuildRequires: perl(File::Basename)
  29. BuildRequires: perl(File::Find)
  30. BuildRequires: perl(File::Path)
  31. BuildRequires: perl(File::Spec)
  32. BuildRequires: perl(File::Spec::Unix)
  33. BuildRequires: perl(File::Temp)
  34. BuildRequires: perl(Getopt::Long)
  35. BuildRequires: perl(IO::String)
  36. BuildRequires: perl(List::MoreUtils) >= 0.19
  37. BuildRequires: perl(List::Util)
  38. BuildRequires: perl(Module::Pluggable) >= 3.1
  39. Requires: perl(Module::Pluggable) >= 3.1
  40. BuildRequires: perl(overload)
  41. BuildRequires: perl(Perl::Tidy)
  42. BuildRequires: perl(Pod::Parser)
  43. Requires: perl(Pod::Parser)
  44. BuildRequires: perl(Pod::PlainText)
  45. BuildRequires: perl(Pod::Select)
  46. BuildRequires: perl(Pod::Spell) >= 1
  47. BuildRequires: perl(Pod::Usage)
  48. BuildRequires: perl(PPI) >= 1.215
  49. Requires: perl(PPI) >= 1.215
  50. BuildRequires: perl(PPIx::Regexp) >= 0.010
  51. BuildRequires: perl(PPIx::Utilities::Statement) >= 1.001
  52. BuildRequires: perl(Readonly) >= 1.03
  53. BuildRequires: perl(Scalar::Util)
  54. BuildRequires: perl(strict)
  55. BuildRequires: perl(String::Format) >= 1.13
  56. BuildRequires: perl(Text::ParseWords) >= 3
  57. BuildRequires: perl(version) >= 0.77
  58. BuildRequires: perl(warnings)
  59. # Optional module requirements
  60. BuildRequires: perl(File::HomeDir)
  61. Requires: perl(File::HomeDir)
  62. BuildRequires: perl(File::Which)
  63. Requires: perl(File::Which)
  64. BuildRequires: perl(Readonly::XS)
  65. Requires: perl(Readonly::XS)
  66. BuildRequires: perl(Term::ANSIColor) >= 2.02
  67. Requires: perl(Term::ANSIColor) >= 2.02
  68. # Main test suite
  69. BuildRequires: perl(Test::Deep)
  70. BuildRequires: perl(Test::Memory::Cycle)
  71. BuildRequires: perl(Test::More)
  72. # Author tests: not run if we're bootstrapping
  73. %if 0%{!?perl_bootstrap:1}
  74. BuildRequires: perl(Devel::EnforceEncapsulation)
  75. BuildRequires: perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
  76. BuildRequires: perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
  77. BuildRequires: perl(Test::Kwalitee)
  78. BuildRequires: perl(Test::Perl::Critic)
  79. BuildRequires: perl(Test::Pod) >= 1.00
  80. BuildRequires: perl(Test::Pod::Coverage) >= 1.04
  81. BuildRequires: perl(Test::Without::Module)
  82. %endif
  83. # don't "provide" private Perl libs
  84. %{?perl_default_filter}
  85. Vendor: Project Vine
  86. Distribution: Vine Linux
  87. Packager: shaolin
  88. %description
  89. Perl::Critic is an extensible framework for creating and applying coding
  90. standards to Perl source code. Essentially, it is a static source code
  91. analysis engine. Perl::Critic is distributed with a number of
  92. Perl::Critic::Policy modules that attempt to enforce various coding
  93. guidelines. Most Policy modules are based on Damian Conway's book Perl
  94. Best Practices. However, Perl::Critic is not limited to PBP and will
  95. even support Policies that contradict Conway. You can enable, disable,
  96. and customize those Polices through the Perl::Critic interface. You can
  97. also create new Policy modules that suit your own tastes.
  98. %package -n perl-Test-Perl-Critic-Policy
  99. Summary: A framework for testing your custom Policies
  100. Group: Development/Libraries
  101. License: GPL+ or Artistic
  102. %description -n perl-Test-Perl-Critic-Policy
  103. This module provides a framework for function-testing your custom
  104. Perl::Critic::Policy modules. Policy testing usually involves feeding it a
  105. string of Perl code and checking its behavior. In the old days, those strings
  106. of Perl code were mixed directly in the test script. That sucked.
  107. %prep
  108. %setup -q -n Perl-Critic-%{version}
  109. find . -type f -exec chmod -c -x {} ';'
  110. %build
  111. perl Build.PL installdirs=vendor
  112. ./Build
  113. %install
  114. ./Build install destdir=%{buildroot} create_packlist=0
  115. %{_fixperms} %{buildroot}
  116. %check
  117. LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
  118. %files
  119. %doc Changes LICENSE README TODO.pod examples/ extras/ tools/
  120. %{_bindir}/perlcritic
  121. %{perl_vendorlib}/Perl/
  122. %{_mandir}/man1/perlcritic.1*
  123. %{_mandir}/man3/Perl::Critic*.3pm*
  124. %files -n perl-Test-Perl-Critic-Policy
  125. %{perl_vendorlib}/Test/
  126. %{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
  127. %changelog
  128. * Fri Nov 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.120-1
  129. - updated to 1.120
  130. - built with perl 5.16.3
  131. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-2
  132. - rebuild
  133. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
  134. - initial build for Vine Linux
  135. * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
  136. - drop %%defattr, no longer needed
  137. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
  138. - update to 1.117
  139. New Policies:
  140. - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
  141. 'my $x += 1'
  142. Policy Changes:
  143. - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
  144. (CPAN RT#68498)
  145. - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
  146. (CPAN RT#71093)
  147. - ControlStructures::ProhibitMutatingListFunctions now understands that
  148. tr///r (introduced in 5.13.7) does not change its operand
  149. - ControlStructures::ProhibitMutatingListFunctions now understands that
  150. '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
  151. - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
  152. like grep { eval $_ } (CPAN RT#69489)
  153. - Modules::RequireExplicitPackage now has configuraion option
  154. allow_import_of, to allow the import of specified modules before the
  155. package statement (CPAN RT#72660)
  156. - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
  157. that [A-Za-z_] matches \w. RT #69322.
  158. - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
  159. an 'if' or 'elsif' if the regular expression is bound to its operand with
  160. the '!~' operator (CPAN RT#69867)
  161. - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
  162. in the replacement portion of the regular expression if /e is asserted
  163. (CPAN RT#72086)
  164. - RegularExpressions::RequireDotMatchAnything,
  165. RegularExpressions::RequireExtendedFormatting and
  166. RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
  167. 'use re "/modifiers"' (CPAN RT#72151)
  168. - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
  169. - Variables::ProhibitPunctuationVars now recognizes bracketed variables
  170. embedded in interpolated strings (e.g. "${$}"); for the purpose of the
  171. 'allow' configuration, these are considered equivalent to the unbracketed
  172. form (CPAN RT#72910)
  173. Other Changes:
  174. - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
  175. - Perl::Critic::Violation source() method now returns the line containing
  176. the violation (not the first line) when the statement containing the
  177. violation spans multiple lines
  178. - this release by THALJEF -> update source URL
  179. - drop stopwords patch, now included upstream
  180. * Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
  181. - reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
  182. * Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
  183. - completely disable author tests to avoid Kwalitee META complaints
  184. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
  185. - Perl mass rebuild
  186. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
  187. - Perl mass rebuild
  188. * Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
  189. - move BR: perl(Test::Perl::Critic) to author test section where it belongs
  190. - run the author tests if we're not bootstrapping
  191. * Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
  192. - update to 1.116
  193. - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
  194. document contains an explicit 'use n.nnn;' where the version is before
  195. 5.005 (CPAN RT#59112)
  196. - Documentation::RequirePodSections no longer blows up on code having POD but
  197. no =head1 (CPAN RT#67231)
  198. - RegularExpressions::ProhibitUnusedCapture should more reliably find things
  199. like s/(a)/${1}2/ (CPAN RT#67273)
  200. - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
  201. now treat versions passed as the second argument of a 'package' statement
  202. the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
  203. - Variables::RequireLexicalLoopIterators does not report violations if the
  204. document contains an explicit 'use n.nnn;' where the version is before
  205. 5.004 (CPAN RT#67760)
  206. * Fri Apr 1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
  207. - update to 1.115
  208. - fatal error in RegularExpressions::ProhibitUnusedCapture here document
  209. check (CPAN RT#67116)
  210. - internal POD error in Documentation::RequirePodLinksIncludeText
  211. (CPAN RT#67012)
  212. * Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
  213. - update to 1.114
  214. - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
  215. (CPAN RT#65569)
  216. - clarified relation of severity numbers to names in Perl::Critic POD
  217. (CPAN RT#66017)
  218. - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
  219. necessary with PPI 1.208 (CPAN RT#65514)
  220. - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
  221. deal with the case where the open() and the corresponding close() are not
  222. in the same scope (CPAN RT#64437)
  223. - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
  224. things (CPAN RT#38942)
  225. - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
  226. into account, so that (e.g.)
  227. if ( /(a)/ || /(b)/ ) {
  228. say $1;
  229. }
  230. is not a violation (CPAN RT#38942)
  231. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  232. 'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
  233. block; this was fixed by PPI 1.215 (CPAN RT#61301)
  234. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  235. 'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
  236. block; this was fixed by PPI 1.215 (CPAN RT#64132)
  237. - bump PPI version requirement to 1.215
  238. - BR/R: perl(Pod::Parser)
  239. - BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
  240. - BR: perl(Pod::Spell) >= 1
  241. - BR: perl(Text::ParseWords) >= 3
  242. - add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
  243. - drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
  244. - split Test::Perl::Critic::Policy off into its own package
  245. - add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
  246. - add version 1.889 requirement for perl(Email::Address)
  247. - add version 0.19 requirement for perl(List::MoreUtils)
  248. - add version 0.010 requirement for perl(PPIx::Regexp)
  249. - add version 1.001 requirement for perl(PPIx::Utilities::Statement)
  250. - add version 0.77 requirement for perl(version)
  251. - drop unused buildreq perl(Test::Spelling)
  252. - drop bogus buildreqs perl(lib) and perl(base)
  253. - add option for building with author tests enabled (--with authortests)
  254. - add patch with words not in Fedora dictionaries for spell check tests
  255. - split buildreqs into separate sections for build process, the module, the
  256. main test suite and the author tests
  257. * Mon Mar 7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
  258. - update to 1.113
  259. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
  260. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  261. * Mon Jan 3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
  262. - update
  263. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
  264. - rebuild to fix problems with vendorarch/lib (#661697)
  265. * Fri Aug 6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
  266. - update
  267. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
  268. - mass rebuild with perl-5.12.0
  269. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
  270. - rebuild against perl 5.10.1
  271. * Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
  272. - use the new filtering macros (verified that the resulting provides
  273. and requires are the same)
  274. - add version to perl(PPI) require (#541020)
  275. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
  276. - new upstream version
  277. - update build requires
  278. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
  279. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  280. * Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
  281. - "neaten" filtering
  282. - auto-update to 1.098 (by cpan-spec-update 0.01)
  283. - added a new br on perl(strict) (version 0)
  284. - added a new br on perl(Scalar::Util) (version 0)
  285. - added a new br on perl(File::Temp) (version 0)
  286. - added a new br on perl(Pod::Usage) (version 0)
  287. - added a new br on perl(File::Find) (version 0)
  288. - added a new br on perl(PPI::Token::Whitespace) (version 1.203)
  289. - added a new br on perl(charnames) (version 0)
  290. - added a new br on perl(PPI::Document::File) (version 1.203)
  291. - added a new br on perl(File::Spec::Unix) (version 0)
  292. - added a new br on perl(List::Util) (version 0)
  293. - added a new br on perl(lib) (version 0)
  294. - added a new br on perl(Getopt::Long) (version 0)
  295. - added a new br on perl(Exporter) (version 0)
  296. - added a new br on perl(Test::More) (version 0)
  297. - added a new br on perl(overload) (version 0)
  298. - added a new br on perl(base) (version 0)
  299. - added a new br on perl(version) (version 0)
  300. - added a new br on perl(Carp) (version 0)
  301. - added a new br on perl(warnings) (version 0)
  302. - added a new br on perl(PPI::Document) (version 1.203)
  303. - added a new br on perl(File::Basename) (version 0)
  304. - added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
  305. - added a new br on perl(File::Spec) (version 0)
  306. - added a new br on perl(File::Path) (version 0)
  307. - added a new br on perl(Pod::PlainText) (version 0)
  308. - added a new br on perl(Pod::Select) (version 0)
  309. - added a new br on perl(PPI::Node) (version 1.203)
  310. - added a new br on perl(English) (version 0)
  311. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
  312. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  313. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
  314. - update to 1.092
  315. * Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
  316. - update to 1.082
  317. - resolve BZ#431577
  318. - add t/ examples/ extras/ tools/, and filter
  319. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
  320. - Rebuild for perl 5.10 (again)
  321. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
  322. - add missing BR: perl-Exception-Class
  323. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
  324. - bump to 1.080
  325. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
  326. - rebuild for new perl
  327. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
  328. - Update to 1.053.
  329. * Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  330. - Update to 1.05.
  331. * Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  332. - Update to 1.03.
  333. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
  334. - Bumping release (forgot to commit sources and .cvsignore changes).
  335. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
  336. - Update to 1.01.
  337. - New build requirement: perl(Test::Memory::Cycle).
  338. * Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
  339. - perl(Set::Scalar) is no longer required.
  340. * Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
  341. - Update to 0.23.
  342. - New requirement: perl(B::Keywords).
  343. - Author tests coverage improved.
  344. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
  345. - Enabled author tests.
  346. - BR perl(HomeDir).
  347. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
  348. - Update to 0.22.
  349. * Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
  350. - Update to 0.21.
  351. - New BR: perl(Set::Scalar).
  352. * Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
  353. - First build.