silversearcher-ag-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. %define pkg_name the_silver_searcher
  2. %define pkg_version 2.2.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: ag: The silver searcher
  5. Summary(ja): ag: 高速検索プログラム
  6. Name: silversearcher-ag
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: Apache License 2.0
  10. Group: Applications/Accessories
  11. URL: https://github.com/ggreer/the_silver_searcher
  12. Source: %{pkg_name}-%{pkg_version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: pcre-devel xz-devel zlib-devel
  15. Requires: pcre xz zlib
  16. Conflicts: the_silver_searcher
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: ara_t
  20. %description
  21. The Silver Searcher
  22. An attempt to make something better than ack
  23. (which itself is better than grep).
  24. Why use Ag?
  25. * It searches code about 3–5x faster than ack.
  26. * It ignores file patterns from your .gitignore and .hgignore.
  27. * If there are files in your source repo you don't want to search,
  28. just add their patterns to a .agignore file. *cough* extern *cough*
  29. * The command name is 33% shorter than ack!
  30. How is it so fast?
  31. * Searching for literals (no regex) uses Boyer-Moore-Horspool strstr.
  32. * Files are mmap()ed instead of read into a buffer.
  33. * If you're building with PCRE 8.21 or greater,
  34. regex searches use the JIT compiler.
  35. * Ag calls pcre_study() before executing the regex on a jillion files.
  36. * Instead of calling fnmatch() on every pattern in your ignore files,
  37. non-regex patterns are loaded into an array and binary searched.
  38. * Ag uses Pthreads to take advantage of multiple CPU cores and
  39. search files in parallel.
  40. %description -l ja
  41. The Silver Searcher: 高速検索プログラム
  42. * ackより3-5倍高速
  43. * .gitignore、.hgignoreに記載されているものを検索対象から除外
  44. * 検索対象から除外したいファイルは.agignoreに記載
  45. * agというコマンド名で、ackと比べてコマンドが短い(33%減!)
  46. %prep
  47. %{__rm} -rf ${RPM_BUILD_ROOT}
  48. %setup -q -n %{pkg_name}-%{pkg_version}
  49. ./build.sh
  50. %{configure}
  51. %build
  52. %{__make} %{?_smp_mflags}
  53. %install
  54. %{make_install}
  55. %clean
  56. %{__rm} -rf ${RPM_BUILD_ROOT}
  57. %files
  58. %defattr(-, root, root)
  59. %{_bindir}/
  60. %{_datadir}/
  61. %changelog
  62. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.0-1
  63. - new upstream release
  64. - add Conflicts: the_silver_searcher
  65. * Tue Aug 29 2017 Toshiaki Ara <ara_t@384.jp> 2.1.0-1
  66. - new upstream release
  67. * Wed Jun 07 2017 Toshiaki Ara <ara_t@384.jp> 2.0.0-1
  68. - new upstream release
  69. * Fri May 05 2017 Toshiaki Ara <ara_t@384.jp> 1.0.3-1
  70. - new upstream release
  71. * Tue Dec 06 2016 Toshiaki Ara <ara_t@384.jp> 1.0.2-1
  72. - new upstream release
  73. * Mon Nov 28 2016 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
  74. - new upstream release
  75. * Mon Oct 10 2016 Toshiaki Ara <ara_t@384.jp> 0.33.0-1
  76. - update to 0.33.0
  77. * Tue May 17 2016 Toshiaki Ara <ara_t@384.jp> 0.32.0-1
  78. - update to 0.32.0
  79. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.31.0-3
  80. - correct SPEC file
  81. * Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 0.31.0-2
  82. - add LICENSE
  83. * Tue Sep 22 2015 Toshiaki Ara <ara_t@384.jp> 0.31.0-1
  84. - new package