incron-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. Summary: Inotify cron system
  2. Name: incron
  3. Version: 0.5.10
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2
  7. URL: http://inotify.aiken.cz
  8. Source0: http://inotify.aiken.cz/download/incron/%{name}-%{version}.tar.bz2
  9. Source1: incrond.init
  10. #Patch0: incron-gcc44.patch
  11. Patch1: incron-gcc47.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. Requires(post): /sbin/chkconfig
  14. Requires(preun): /sbin/chkconfig, /sbin/service
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: tomop
  18. %description
  19. This program is an "inotify cron" system.
  20. It consists of a daemon and a table manipulator.
  21. You can use it a similar way as the regular cron.
  22. The difference is that the inotify cron handles
  23. filesystem events rather than time periods.
  24. %prep
  25. %setup -q
  26. #%patch0 -p1 -b .orig
  27. %patch1 -p0 -b .gcc47
  28. %build
  29. make %{?_smp_mflags} CXXFLAGS="%{optflags}"
  30. %install
  31. rm -rf %{buildroot}
  32. #install files manually since source Makefile tries to do it as root
  33. install -D -p incrond %{buildroot}%{_sbindir}/incrond
  34. install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
  35. install -d %{buildroot}%{_localstatedir}/spool/%{name}
  36. install -d %{buildroot}%{_sysconfdir}/%{name}.d
  37. install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
  38. install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
  39. # install manpages
  40. make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
  41. %post
  42. if [ $1 -eq 1 ]; then
  43. /sbin/chkconfig --add incrond
  44. fi
  45. %preun
  46. if [ $1 -eq 0 ]; then
  47. /sbin/service %{name} stop >/dev/null 2>&1 || :
  48. /sbin/chkconfig --del incrond
  49. fi
  50. %postun
  51. if [ $1 -ge 1 ]; then
  52. /sbin/service incrond condrestart >/dev/null 2>&1 || :
  53. fi
  54. %clean
  55. rm -rf %{buildroot}
  56. %files
  57. %defattr(-,root,root,-)
  58. %attr(4755,root,root) %{_bindir}/incrontab
  59. %{_sbindir}/incrond
  60. %{_initdir}/incrond
  61. %config(noreplace) %{_sysconfdir}/%{name}.conf
  62. %{_mandir}/man1/incrontab.1.gz
  63. %{_mandir}/man5/incrontab.5.gz
  64. %{_mandir}/man5/incron.conf.5.gz
  65. %{_mandir}/man8/incrond.8.gz
  66. %dir %{_localstatedir}/spool/%{name}
  67. %dir %{_sysconfdir}/%{name}.d
  68. %doc COPYING CHANGELOG README TODO LICENSE-GPL
  69. %changelog
  70. * Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
  71. - rebuilt with current environment.
  72. * Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
  73. - new upstream release.
  74. - built for Vine Linux.
  75. * Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
  76. - Migrate to systemd, BZ 789688.
  77. - gcc47 patch.
  78. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  80. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  82. * Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
  83. - Upstream released new version
  84. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  86. * Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
  87. - Upstream released new version
  88. - GCC 4.4 fixes
  89. - Drop GCC 4.3 patch, fixed upstream
  90. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  92. * Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
  93. - Sync with upstream
  94. * Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
  95. - Sync with upstream
  96. * Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
  97. - Update to new upstream version
  98. - Upstream fixed permissions on pidfile
  99. - New manpage for incron.conf
  100. - Upstream fixed example conf file
  101. * Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
  102. - Updated to new upstream version
  103. - Upstream fixed the incorrect encoding of the LICENSE-GPL file
  104. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
  105. - Updated to new upstream version
  106. - Changed the service name in the scriptlets
  107. - Added a configuration file
  108. - Included GPL License
  109. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
  110. - First try at packaging it up