ldns-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %{?!with_python: %global with_python 1}
  2. %{?!enable_gost: %global enable_gost 0}
  3. %if %{with_python}
  4. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  5. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  6. %endif
  7. %if %{enable_gost}
  8. %define subdir_conf_opt --disable-rpath --disable-static
  9. %else
  10. %define subdir_conf_opt --disable-rpath --disable-static --disable-gost
  11. %endif
  12. Summary: Lowlevel DNS(SEC) library with API
  13. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  14. Name: ldns
  15. Version: 1.6.16
  16. Release: 1%{?_dist_release}
  17. License: BSD
  18. Url: http://www.nlnetlabs.nl/%{name}/
  19. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  20. Group: System Environment/Libraries
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  23. BuildRequires: perl, libpcap-devel
  24. %if %{enable_gost}
  25. BuildRequires: openssl-devel >= 1.0.0
  26. %else
  27. BuildRequires: openssl-devel
  28. %endif
  29. Requires: libpcap, openssl
  30. Distribution: Vine Linux
  31. Vendor: Project Vine
  32. Packager: iwaim
  33. %if %{with_python}
  34. BuildRequires: python-devel, swig
  35. %endif
  36. %description
  37. ldns is a library with the aim to simplify DNS programing in C. All
  38. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  39. level API which allows a programmer to (for instance) create or sign
  40. packets.
  41. %package devel
  42. Summary: Development package that includes the ldns header files
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The devel package contains the ldns library and the include files
  47. %if %{with_python}
  48. %package python
  49. Summary: Python extensions for ldns
  50. Group: Applications/System
  51. Requires: %{name} = %{version}-%{release}
  52. %description python
  53. Python extensions for ldns
  54. %endif
  55. %prep
  56. %setup -q
  57. %build
  58. %configure --disable-rpath --disable-static \
  59. %if %{with_python}
  60. --with-pyldns \
  61. %endif
  62. %if !%{enable_gost}
  63. --disable-gost \
  64. %endif
  65. --with-sha2
  66. (cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  67. (cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  68. make %{?_smp_mflags}
  69. ( cd drill ; make %{?_smp_mflags} )
  70. ( cd examples ; make %{?_smp_mflags} )
  71. make %{?_smp_mflags} doc
  72. %install
  73. rm -rf %{buildroot}
  74. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  75. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  76. %if %{with_python}
  77. # remove execute perms from python files
  78. chmod a-x %{buildroot}%{python_sitearch}/*py
  79. %endif
  80. # don't package building script in doc
  81. rm doc/doxyparse.pl
  82. #remove doc stubs
  83. rm -rf doc/.svn
  84. #remove double set of man pages
  85. rm -rf doc/man
  86. # remove .la files
  87. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
  88. (cd drill ; make DESTDIR=%{buildroot} install)
  89. (cd examples; make DESTDIR=%{buildroot} install)
  90. %clean
  91. rm -rf %{buildroot}
  92. %files
  93. %defattr(-,root,root)
  94. %{_libdir}/libldns*so.*
  95. %{_bindir}/drill
  96. %{_bindir}/ldnsd
  97. #%{_bindir}/ldns-*
  98. %{_bindir}/ldns-chaos
  99. %{_bindir}/ldns-compare-zones
  100. %{_bindir}/ldns-[d-z]*
  101. %doc README LICENSE
  102. %{_mandir}/*/*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %{_libdir}/libldns*so
  106. %{_bindir}/ldns-config
  107. %dir %{_includedir}/ldns
  108. %{_includedir}/ldns/*.h
  109. %doc doc Changelog README
  110. %if %{with_python}
  111. %files python
  112. %defattr(-,root,root)
  113. %{python_sitearch}/*
  114. %endif
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %changelog
  118. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
  119. - new upstream release
  120. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
  121. - new upstream release
  122. - move python files to sitearch from sitelib
  123. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
  124. - rebuild with python-2.7.2
  125. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
  126. - new upstream release
  127. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  128. - new upstream release
  129. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
  130. - new upstream release
  131. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
  132. - new upstream release
  133. - add enable_gost flag: default disable
  134. - defined subdir_conf_opt rpm macro
  135. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  136. - new upstream release
  137. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  138. - new upstream release
  139. - drop unnecessary installfix patch (Patch1): upstream merged
  140. - drop unnecessary rpathfix patch (Patch2): upstream merged
  141. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  142. - rebuild with libpcap 1.1.1 on VineSeed
  143. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  144. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  145. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  146. - Fix missing _ldns.so causing ldns-python to not work
  147. - Patch for installing ldns-python files
  148. - Patch for rpath in ldns-python
  149. - Don't install .a file for ldns-python
  150. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  151. - Upgraded to 1.6.4.
  152. - Added ldns-python sub package
  153. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  154. - Upgraded to 1.6.3, which has minor bugfixes
  155. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  156. - Upgraded to 1.6.2. This fixes various bugs.
  157. (upstream released mostly to default with sha2 for the imminent
  158. signed root, but we already enabled that in our builds)
  159. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  160. - rebuilt with new openssl
  161. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  162. - Added openssl dependancy back in, since we get more functionality
  163. when using openssl. Especially in 'drill'.
  164. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  165. - Updated to 1.6.1
  166. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  168. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  169. - Fixed the ssl patch so it can now compile --without-ssl
  170. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  171. - Added patch to compile with --without-ssl
  172. - Removed openssl dependancies
  173. - Recompiled with --without-ssl
  174. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  175. - Updated to 1.6.0
  176. - (did not yet compile with --without-ssl due to compile failures)
  177. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  178. - Updated to 1.6.0
  179. - Compile without openssl
  180. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  181. - Memory management bug when generating a sha256 key, see:
  182. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  183. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  185. * Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  186. - Updated to new version, 1.5.0 had a bug preventing
  187. zone signing.
  188. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  189. - Updated to new version
  190. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  191. - fixed configure flags
  192. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  193. - rebuild with new openssl
  194. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  195. - Updated to 1.4.0
  196. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  197. - enable SHA2 functionality
  198. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  199. - re-tag (don't do builds while renaming local repo dirs)
  200. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  201. - Updated to latest release
  202. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  203. - Autorebuild for GCC 4.3
  204. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  205. - Rebuild for new libcrypto
  206. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  207. - Upgraded to 1.2.2. Removed no longer needed race workaround
  208. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  209. - Try to fix racing ln -s statements in parallel builds
  210. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  211. - Added patch for ldns-read-zone that does not put @. in RRDATA
  212. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  213. - Use install -p to work around multilib conflicts for .h files
  214. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  215. - Updated to 1.2.1
  216. - Removed patches that got moved into upstream
  217. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  218. - Patch for ldns-key2ds to write to stdout
  219. - Again remove extra set of man pages from doc
  220. - own /usr/include/ldns (bug 233858)
  221. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  222. - Added sha256 DS record patch to ldns-key2ds
  223. - Minor tweaks for proper doc/man page installation.
  224. - Workaround for parallel builds
  225. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  226. - Own the /usr/include/ldns directory (bug #233858)
  227. - Removed obsoleted patch
  228. - Remove files form previous libtool run accidentally packages by upstream
  229. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  230. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  231. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  232. - Fixed changelog typo in date
  233. - Rebuild requested for PT_GNU_HASH support from gcc
  234. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  235. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  236. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  237. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  238. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  239. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  240. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  241. * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  242. - added a make clean for 2.3.3 since .o files were left behind upstream,
  243. causing failure on ppc platform
  244. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  245. - minor cleanups
  246. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  247. - reworked for svn version
  248. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  249. - Initial version