ocaml-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322
  1. Name: ocaml
  2. Summary: The Objective Caml compiler and programming environment
  3. Summary(ja): Objective Caml コンパイラとプログラミング環境
  4. Version: 3.12.0
  5. Release: 1%{?_dist_release}
  6. Source0: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-%{version}.tar.bz2
  7. Source1: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.html.tar.gz
  8. Source2: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.ps.gz
  9. Source3: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.info.tar.gz
  10. Source4: ocaml-info-entry
  11. # Vine Source(s)
  12. Source10: caml-mode-install.sh
  13. Source11: caml-mode-remove.sh
  14. License: QPL/LGPL
  15. Group: Development/Languages
  16. URL: http://caml.inria.fr/
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: ncurses-devel gdbm-devel emacsen
  19. BuildRequires: libX11-devel
  20. BuildRequires: tk tcl expect thread
  21. Requires(post): install-info
  22. Requires(preun): install-info
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: inagaki
  26. %define debug_package %{nil}
  27. %description
  28. Objective Caml is a high-level, strongly-typed, functional and
  29. object-oriented programming language from the ML family of languages.
  30. This package comprises two batch compilers (a fast bytecode compiler
  31. and an optimizing native-code compiler), an interactive toplevel system,
  32. parsing tools (Lex,Yacc,Camlp4), a replay debugger, a documentation generator,
  33. and a comprehensive library.
  34. %description -l ja
  35. Object Caml は ML 系言語の方言で、高水準で強い型付けを備えた関数型と
  36. オブジェクト指向を併せ持ったプログラミング言語です。
  37. このパッケージには、2 つのバッチコンパイラ (コンパイル速度が高速な
  38. バイトコードコンパイラと最適化を行なうネイティブコードコンパイラ)、
  39. トップレベル対話環境、構文解析ツール (Lex, Yac, Camlp4)、リプレイ
  40. デバッガ、ドキュメント生成ツール、そして広範囲に渡るライブラリが含まれて
  41. います。
  42. %package labltk
  43. Summary: Tk bindings for Objective Caml
  44. Summary(ja): Objective Caml の Tk バインディング
  45. Group: Development/Languages
  46. Requires: ocaml = %{version}-%{release}
  47. Requires: tk tcl
  48. Obsoletes: labltk <= %{version}
  49. %description labltk
  50. A library for interfacing Objective Caml with the scripting language
  51. Tcl/Tk. It include the OCamlBrowser code editor / library browser.
  52. %package camlp4
  53. Summary: Pre-Processor-Pretty-Printer for OCaml
  54. Group: Development/Languages
  55. Requires: ocaml = %{version}-%{release}
  56. Obsoletes: camlp4 <= %{version}
  57. %description camlp4
  58. Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
  59. file and printing some result on standard output.
  60. %package mode
  61. Summary: Emacs mode for Objective Caml
  62. Summary(ja): Objective Caml の Emacs mode
  63. Group: Applications/Editors/Emacs
  64. Requires: ocaml = %{version}-%{release}
  65. Requires(post): emacs, emacsen-common
  66. Requires(preun): emacs, emacsen-common
  67. Obsoletes: ocaml-emacs <= %{version}
  68. %description mode
  69. Emacs mode for Objective Caml.
  70. %description -l ja mode
  71. Objective Caml 用の Emacs mode です.
  72. %prep
  73. %setup -q -T -b 0
  74. %setup -q -T -D -a 1
  75. %setup -q -T -D -a 3
  76. cp %{SOURCE2} refman.ps.gz
  77. cp %{SOURCE4} infoman/ocaml-info-entry
  78. %build
  79. ./configure -cc "%{__cc} %{optflags}" -with-pthread \
  80. -bindir %{_bindir} \
  81. -libdir %{_libdir}/ocaml \
  82. -mandir %{_mandir} \
  83. -prefix %{_prefix}
  84. make world opt opt.opt
  85. (cd infoman; gzip -cd ocaml.info.gz >> ocaml-info-entry; mv ocaml-info-entry ocaml.info; gzip -f ocaml.info)
  86. # for dumpobj, objinfo
  87. (cd tools; make dumpobj; make objinfo; cd ..)
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. make install BINDIR=$RPM_BUILD_ROOT%{_bindir} LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml MANDIR=$RPM_BUILD_ROOT%{_mandir}
  91. mv $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
  92. sed -e "s|^%{buildroot}||" $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig > $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
  94. (mkdir -p $RPM_BUILD_ROOT%{_infodir}; cd infoman; cp ocaml*.gz $RPM_BUILD_ROOT%{_infodir})
  95. # for dumpobj, objinfo
  96. (cd tools; install dumpobj objinfo $RPM_BUILD_ROOT%{_bindir})
  97. # for Emacs Lisp
  98. make -C emacs install install-ocamltags BINDIR=$RPM_BUILD_ROOT%{_bindir} \
  99. EMACSDIR=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/caml-mode
  100. # emacsen-common-ize
  101. mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/install
  102. mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/remove
  103. %_installemacsenscript caml-mode %{SOURCE10}
  104. %_removeemacsenscript caml-mode %{SOURCE11}
  105. # Disable build root strip policy:
  106. # executables generated by ocamlc -custom MUST NOT BE STRIPPED
  107. # But now that we have dynamic loading of C code, none of the executables
  108. # in the distribution is generated by ocamlc -custom, so leave default.
  109. # %define __spec_install_post /usr/lib/rpm/brp-compress
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post
  113. /sbin/install-info %{_infodir}/ocaml.info %{_infodir}/dir
  114. %post mode
  115. if [ "$1" = 2 ]; then
  116. %_emacsenPackageRemove caml-mode
  117. fi
  118. %_addemacsenlist caml-mode
  119. %_emacsenPackageInstall caml-mode
  120. %preun
  121. if [ $1 = 0 ]; then
  122. /sbin/install-info --delete %{_infodir}/ocaml.info %{_infodir}/dir
  123. fi
  124. %preun mode
  125. if [ "$1" = 0 ]; then
  126. %_emacsenPackageRemove caml-mode
  127. %_removeemacsenlist caml-mode
  128. fi
  129. %files
  130. %defattr(-, root, root)
  131. %doc README LICENSE refman.ps.gz htmlman
  132. %{_bindir}/*
  133. %{_mandir}/man1/*
  134. %{_mandir}/man3/*
  135. %{_libdir}/ocaml
  136. %{_infodir}/*
  137. ### in ocaml-camlp4
  138. %exclude %{_bindir}/camlp4*
  139. %exclude %{_bindir}/mkcamlp4
  140. %exclude %{_libdir}/ocaml/camlp4/
  141. ### in ocaml-labltk
  142. %exclude %{_bindir}/labltk
  143. %exclude %{_bindir}/ocamlbrowser
  144. %exclude %{_libdir}/ocaml/labltk/
  145. %exclude %{_libdir}/ocaml/stublibs/dlllabltk.so
  146. ### in ocaml-mode
  147. %exclude %{_bindir}/ocamltags
  148. %files camlp4
  149. %defattr(-, root, root, 0755)
  150. %{_bindir}/camlp4*
  151. %{_bindir}/mkcamlp4
  152. %dir %{_libdir}/ocaml/
  153. %{_libdir}/ocaml/camlp4/
  154. %files labltk
  155. %defattr(-, root, root, 0755)
  156. %doc otherlibs/labltk/examples_*tk
  157. %{_bindir}/labltk
  158. %{_bindir}/ocamlbrowser
  159. %dir %{_libdir}/ocaml/
  160. %dir %{_libdir}/ocaml/stublibs/
  161. %{_libdir}/ocaml/labltk/
  162. %{_libdir}/ocaml/stublibs/dlllabltk.so
  163. %files mode
  164. %defattr(-, root, root, 0755)
  165. %doc emacs/README
  166. %{_bindir}/ocamltags
  167. %dir %{_datadir}/emacs/
  168. %dir %{_datadir}/emacs/site-lisp/caml-mode
  169. %{_datadir}/emacs/site-lisp/caml-mode/*.el
  170. #{_datadir}/emacs/site-lisp/caml-mode/*.elc
  171. %{_prefix}/lib/emacsen-common/packages/install/caml-mode
  172. %{_prefix}/lib/emacsen-common/packages/remove/caml-mode
  173. %changelog
  174. * Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.12.0-1
  175. - new upstream release
  176. * Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.0-2
  177. - rebuilt with new tool chain
  178. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.0-1
  179. - new upstream release
  180. - spec in UTF-8
  181. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl5
  182. - new upstream release for VineSeed
  183. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl4
  184. - new upstream release
  185. * Wed Feb 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.1-0vl1
  186. - new upstream release
  187. * Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl2
  188. - rebuilt with VineSeed
  189. * Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl1
  190. - new upstream release
  191. * Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl2
  192. - rebuilt for VinePlus/4.0
  193. * Mon Nov 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl1
  194. - new upstream release
  195. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.2-0vl4
  196. - changed ocaml-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  197. * Wed Aug 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> - 3.09.2-0vl3
  198. - add BuildRequires: XOrg-devel, ncurses-devel, gdbm-devel, emacsen
  199. - use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
  200. * Wed Jun 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl2
  201. - rebuilt for VineSeed Plus
  202. * Wed Jun 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl1
  203. - new upstream release
  204. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl3
  205. - rebuilt for VineSeed Plus
  206. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl2
  207. - rebuilt for VinePlus/3.0
  208. - added BuildRequires: expect, thread
  209. * Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl1
  210. - new upstream release
  211. * Sat Nov 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl2
  212. - rebuild for VineSeed Plus
  213. * Thu Nov 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl1
  214. - new upstream release
  215. * Tue Oct 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl3
  216. - rebuild with VineSeed Plus
  217. * Mon Oct 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl2
  218. - rebuild with VinePlus/3.0
  219. - added dumpobj, objinfo
  220. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl1
  221. - new upstream release
  222. - split to caml4p, labltk, mode packages
  223. * Thu Mar 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.3-0vl1
  224. - new upstream release
  225. * Sat Dec 4 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.2-0vl1
  226. - new upstream release
  227. * Fri Oct 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.1-0vl1
  228. - new upstream release
  229. * Fri Aug 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl4
  230. - fixed typo based on 3.08.0-0vl3
  231. * Thu Aug 12 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl3
  232. - Modified typo: %%descriptin -l ja into %description -l ja
  233. * Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl3
  234. - rebuild for VinePlus/3.0 and VineSeedPlus
  235. - updated Japanese description
  236. - merged VinePlus/2.6 spec file
  237. * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl2
  238. - Modified the character code of this file into euc-jp.
  239. * Tue Jul 21 2004 by IKEDA Katsumi <ikeda@rg8.so-net.ne.jp> 3.08.0-0vl1
  240. - new upstream release.
  241. - Modified Copyright.
  242. - Added Summary(ja), %%descriptin -l ja, Prereq and %%clean.
  243. - Added %%post and %%preun for running /sbin/install-info.
  244. * Wed Apr 7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.07-2vl2
  245. - rebuild for VineSeed
  246. - s/Copyright/License/
  247. * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
  248. - 3.07-2vl1
  249. - Modified %Vendor and %BuildRoot.
  250. - Add %Distribution.