rsync-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. %bcond_with systemd
  2. %define ver 3.2.5
  3. #define prerelease pre2
  4. Summary: A program for synchronizing files over a network.
  5. Summary(ja): ネットワーク越しにファイルを同期させるプログラム
  6. Name: rsync
  7. Version: %{ver}%{?prerelease:~%{prerelease}}
  8. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  9. Group: network
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. License: GPLv3+
  14. URL: https://rsync.samba.org/
  15. Source: https://download.samba.org/pub/rsync/src%{?prerelease:-previews}/rsync-%{ver}%{?prerelease:%{prerelease}}.tar.gz
  16. Source1: https://download.samba.org/pub/rsync/src%{?prerelease:-previews}/rsync-patches-%{ver}%{?prerelease:%{prerelease}}.tar.gz
  17. Source2: rsyncd.socket
  18. Source3: rsyncd.service
  19. Source4: rsyncd.conf
  20. Source5: rsyncd.sysconfig
  21. Source6: rsyncd@.service
  22. Source100: rsync.xinetd
  23. #Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
  24. Patch1: rsync-3.2.2-runtests.patch
  25. # security fixes
  26. # none
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: libacl-devel libattr-devel popt-devel
  29. BuildRequires: lz4-devel openssl-devel libzstd-devel
  30. BuildRequires: acl attr
  31. %description
  32. Rsync uses a quick and reliable algorithm to very quickly bring
  33. remote and host files into sync. Rsync is fast because it just
  34. sends the differences in the files over the network (instead of
  35. sending the complete files). Rsync is often used as a very powerful
  36. mirroring process or just as a more capable replacement for the
  37. rcp command. A technical report which describes the rsync algorithm
  38. is included in this package.
  39. Install rsync if you need a powerful mirroring program.
  40. %description -l ja
  41. rsync は高速で信頼性の高いアルゴリズムを使い,遠隔ホスト上のファイルと
  42. 高速に同期させることが出来ます.rsync が高速に動作するのは,ネットワーク
  43. 上に流れるデータがファイルの差分だけだからです (ファイル全体をやりとり
  44. するのではなく).rsync は強力なミラリングツールとしても,rcp コマンドの
  45. 代替としても使うことが出来ます.rsync のアルゴリズムに関する技術情報は
  46. このパッケージに同梱されています.
  47. 強力なミラープログラムが必要ならば rsync をインストールして下さい.
  48. %package daemon
  49. Summary: Service for anonymous access to rsync
  50. Group: servers
  51. BuildArch: noarch
  52. Requires: %{name} = %{version}-%{release}
  53. %if %{with systemd}
  54. %{?systemd_requires}
  55. %else
  56. Requires: xinetd
  57. %endif
  58. %description daemon
  59. Rsync can be used to offer read only access to anonymous clients. This
  60. package provides the anonymous rsync service.
  61. %debug_package
  62. %prep
  63. %setup -q -n rsync-%{ver}%{?prerelease:%{prerelease}}
  64. %setup -q -b 1 -n rsync-%{ver}%{?prerelease:%{prerelease}}
  65. %patch1 -p1 -b .runtests
  66. # security fixes
  67. # none
  68. %build
  69. %configure --disable-xxhash
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. %makeinstall
  74. install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/rsyncd.conf
  75. %if %{with systemd}
  76. install -D -m644 %{SOURCE3} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.service
  77. install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.socket
  78. install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
  79. install -D -m644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyncd
  80. %else
  81. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
  82. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT/etc/xinetd.d/rsync
  83. %endif
  84. %check
  85. make check
  86. chmod -x support/*
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %if %{with systemd}
  90. %post daemon
  91. %systemd_post rsyncd.service
  92. %preun daemon
  93. %systemd_preun rsyncd.service
  94. %postun daemon
  95. %systemd_postun_with_restart rsyncd.service
  96. %endif
  97. %files
  98. %defattr(-,root,root)
  99. %license COPYING
  100. %doc README* tech_report.tex support/
  101. %doc NEWS* TODO
  102. %{_bindir}/%{name}
  103. %{_bindir}/%{name}-ssl
  104. %config(noreplace) %{_sysconfdir}/rsyncd.conf
  105. %{_mandir}/man1/%{name}.1*
  106. %{_mandir}/man1/%{name}-ssl.1*
  107. %{_mandir}/man5/rsyncd.conf.5*
  108. %files daemon
  109. %if %{with systemd}
  110. %{_unitdir}/rsyncd.socket
  111. %{_unitdir}/rsyncd.service
  112. %{_unitdir}/rsyncd@.service
  113. %config(noreplace) %{_sysconfdir}/sysconfig/rsyncd
  114. %else
  115. %config(noreplace) /etc/xinetd.d/rsync
  116. %endif
  117. %changelog
  118. * Fri Sep 09 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.5-1
  119. - updated to 3.2.5.
  120. * Wed Aug 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.5~pre2-1
  121. - updated to 3.2.5pre2.
  122. - dropped Patch0.
  123. * Mon Oct 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-2
  124. - rebuilt with openssl-3.0.0.
  125. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  126. - updated to 3.2.3.
  127. - re-impoerted all patches from rawhide.
  128. - added systemd support (disabled as default).
  129. * Wed Oct 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  130. - updated to 3.1.2.
  131. - imported Patch1-3 from rawhide.
  132. - dropped Patch100-130.
  133. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.2-1
  134. - update to 3.1.2
  135. - add patch100-130 to fix security issue from debian
  136. - use make reconfigure in build section
  137. * Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-2
  138. - added Patch100 to fix CVE-2014-9512
  139. * Fri Nov 07 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-1
  140. - new upstream release
  141. - deleted Patch100 to merge source
  142. * Wed Jun 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.1.0-2
  143. - add Patch100 to fix CVE-2014-2855
  144. * Sat Nov 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.0-1
  145. - new upstream release
  146. * Fri Jan 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.9-1
  147. - new upstream release
  148. * Sun May 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.8-1
  149. - new upstream release with security fixes
  150. - drop patch100 (is included in new release)
  151. * Sat Apr 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.7-2
  152. - add Patch100 for fix CVE-2011-1097 (filelist)
  153. - change specfile name (-vl)
  154. * Sat Jan 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.7-1
  155. - new upstream release
  156. * Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.6-1
  157. - new upstream release
  158. - changed License tag
  159. - added Patch0 from Debian
  160. - added BuildRequires: libattr-devel popt-devel
  161. - added patch -p1 -i patches/copy-devices.diff in %setup
  162. (to enable --copy-devices parameter)
  163. * Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.4-2
  164. - added BuildRequires: libacl-devel (to enable ACL)
  165. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
  166. - new upstream release
  167. - add rsync-patches (replaces patch1,2)
  168. use xattr.patch and acls.patch for backword compatibility
  169. * Sun Apr 13 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.2-1
  170. - new upstream release
  171. - add patch1,2 for backward compatibility from fc
  172. - new versioning policy
  173. * Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.9-0vl2
  174. - add Patch10 for CVE-2007-4091
  175. (rsync "f_name()" Function Directory Name Handling Off-By-One Vulnerability)
  176. * Wed Jan 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.9-0vl1
  177. - new upstream release
  178. - add Vendor/Distribution tag
  179. * Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  180. - new upstream release
  181. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  182. - new upstream release
  183. - drop obsolete patch1 which is merged in upstream.
  184. * Tue Aug 17 2004 SATO Masakiyo <info@pocomoco.net> 2.6.2-0vl2
  185. - added patch1 for a path-sanitizing bug
  186. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  187. - new upstream release
  188. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  189. - new upstream release
  190. * Fri Dec 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-0vl1
  191. - new upstream release
  192. - security fix
  193. * Mon Apr 21 2003 IWAI Masaharu <iwai@alib.jp> 2.5.6-0vl1
  194. - new upstream release
  195. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  196. - new upstream release
  197. * Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 2.5.4-0vl1
  198. - updated to 2.5.4, which contains additional fix for zlib double-free bug.
  199. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5.3-0vl1
  200. - upstream release
  201. * Sat Jan 26 2002 Toru Sagami <sagami@vinelinux.org> 2.5.2-0vl1
  202. - SECURITY FIXES:
  203. * Signedness security patch from Sebastian Krahmer
  204. - added more docs
  205. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  206. - 2.5.1-0vl1
  207. * Sun Dec 2 2001 Yoichi Imai <yoichi@silver-forest.com>
  208. - 2.5.0-0vl1
  209. - update to 2.5.0
  210. - edit maxdel.patch for 2.5.0
  211. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  212. - 2.4.6-2vl1
  213. - based on 2.4.6-2 from Rawhide
  214. - added Japanese summary and description
  215. * Sat Sep 30 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  216. - add xinetd configuration
  217. * Tue Sep 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  218. - 2.4.6
  219. * Mon Jul 31 2000 Bill Nottingham <notting@redhat.com>
  220. - update to 2.4.4 - fixes yet another problem with rsh transport
  221. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  222. - automatic rebuild
  223. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  224. - rebuild in new build env.
  225. * Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
  226. - update to 2.4.3
  227. * Tue Apr 4 2000 Bill Nottingham <notting@redhat.com>
  228. - update to 2.4.2
  229. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  230. - fix maxdelete behavior so it isn't sent to older servers.
  231. * Mon Jan 31 2000 Jeff Johnson <jbj@redhat.com>
  232. - update to 2.4.1.
  233. * Fri Dec 17 1999 Bill Nottingham <notting@redhat.com>
  234. - update to 2.3.2
  235. * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
  236. - add "max. delete" patch to limit damage when server is hosed.
  237. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  238. - update to 2.3.1.
  239. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  240. - auto rebuild in the new build environment (release 2)
  241. * Tue Mar 16 1999 Jeff Johnson <jbj@redhat.com>
  242. - update to 2.3.0.
  243. * Sat Mar 13 1999 Jeff Johnson <jbj@redhat.com>
  244. - update to 2.3.0 beta.
  245. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  246. - update to 2.2.1
  247. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  248. - updated to 2.1.1
  249. * Mon Aug 17 1998 Erik Troan <ewt@redhat.com>
  250. - updated to 2.1.0
  251. * Thu Aug 06 1998 Erik Troan <ewt@redhat.com>
  252. - buildrooted and attr-rophied
  253. - removed tech-report.ps; the .tex should be good enough
  254. * Mon Aug 25 1997 John A. Martin <jam@jamux.com>
  255. - Built 1.6.3-2 after finding no rsync-1.6.3-1.src.rpm although there
  256. was an ftp://ftp.redhat.com/pub/contrib/alpha/rsync-1.6.3-1.alpha.rpm
  257. showing no packager nor signature but giving
  258. "Source RPM: rsync-1.6.3-1.src.rpm".
  259. - Changes from 1.6.2-1 packaging: added '$RPM_OPT_FLAGS' to make, strip
  260. to '%build', removed '%prefix'.
  261. * Thu Apr 10 1997 Michael De La Rue <miked@ed.ac.uk>
  262. - rsync-1.6.2-1 packaged. (This entry by jam to credit Michael for the
  263. previous package(s).)