coreutils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744
  1. Summary: The GNU core utilities: a set of tools commonly used in shell scripts
  2. Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
  3. Name: coreutils
  4. Version: 9.0
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: system
  8. Url: https://www.gnu.org/software/coreutils/
  9. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  10. Source101: coreutils-DIR_COLORS
  11. Source102: coreutils-DIR_COLORS.lightbgcolor
  12. Source103: coreutils-DIR_COLORS.256color
  13. Source105: coreutils-colorls.sh
  14. Source106: coreutils-colorls.csh
  15. # Vine sources
  16. Source1000: coreutils-8.10-ja.po
  17. # chmod: fix exit status when ignoring symlinks
  18. Patch1: coreutils-9.0-chmod-symlink.patch
  19. # disable the test-lock gnulib test prone to deadlock
  20. Patch100: coreutils-8.26-test-lock.patch
  21. # require_selinux_(): use selinuxenabled(8) if available
  22. Patch105: coreutils-8.26-selinuxenable.patch
  23. # downstream changes to default DIR_COLORS
  24. Patch102: coreutils-8.32-DIR_COLORS.patch
  25. #do display processor type for uname -p/-i based on uname(2) syscall
  26. Patch103: coreutils-8.2-uname-processortype.patch
  27. #df --direct
  28. Patch104: coreutils-df-direct.patch
  29. #add note about mkdir --mode behaviour into info documentation(#610559)
  30. Patch107: coreutils-8.4-mkdir-modenote.patch
  31. # sh-utils
  32. #add info about TZ envvar to date manpage
  33. Patch703: sh-utils-2.0.11-dateman.patch
  34. Patch713: coreutils-4.5.3-langinfo.patch
  35. # (sb) lin18nux/lsb compliance - multibyte functionality patch
  36. Patch800: coreutils-i18n.patch
  37. #getgrouplist() patch from Ulrich Drepper.
  38. Patch908: coreutils-getgrouplist.patch
  39. #SELINUX Patch - implements Redhat changes
  40. #(upstream did some SELinux implementation unlike with RedHat patch)
  41. #Patch950: coreutils-selinux.patch
  42. # do not make coreutils-single depend on /usr/bin/coreutils
  43. %global __requires_exclude ^%{_bindir}/coreutils$
  44. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  45. BuildRequires: gettext libtermcap-devel bison
  46. BuildRequires: texinfo >= 4.3
  47. BuildRequires: autoconf >= 2.58, automake >= 1.11.2
  48. BuildRequires: libcap-devel
  49. BuildRequires: libattr-devel
  50. BuildRequires: libacl-devel
  51. BuildRequires: gmp-devel
  52. # Require a C library that doesn't put LC_TIME files in our way.
  53. Conflicts: glibc < 2.2
  54. Provides: fileutils = %version, sh-utils = %version, stat, textutils = %version
  55. Obsoletes: fileutils sh-utils stat textutils
  56. Provides: mktemp = %version
  57. Obsoletes: mktemp
  58. %description
  59. These are the GNU core utilities. This package is the combination of
  60. the old GNU fileutils, sh-utils, and textutils packages.
  61. %description -l ja
  62. このパッケージには GNU のコアユーティリティが収録されています。
  63. コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
  64. sh-utils, textutils を統合したパッケージです。
  65. %debug_package
  66. %prep
  67. %autosetup -N
  68. # will be regenerated in the build directories
  69. rm -f src/fs.h
  70. # will be further modified by coreutils-8.32-DIR_COLORS.patch
  71. sed src/dircolors.hin \
  72. -e 's| 00;36$| 01;36|' \
  73. > DIR_COLORS
  74. sed src/dircolors.hin \
  75. -e 's| 01;31$| 00;31|' \
  76. -e 's| 01;35$| 00;35|' \
  77. > DIR_COLORS.lightbgcolor
  78. # apply all patches
  79. %autopatch -p1
  80. (echo ">>> Fixing permissions on tests") 2>/dev/null
  81. find tests -name '*.sh' -perm 0644 -print -exec chmod 0755 '{}' '+'
  82. (echo "<<< done") 2>/dev/null
  83. autoreconf -fiv
  84. # copy updated ja.po
  85. #mv po/ja.po po/ja.po.orig
  86. #cp -f %{SOURCE1000} po/ja.po
  87. %build
  88. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
  89. # Upstream suggests to build with -Dlint for static analyzers:
  90. # https://lists.gnu.org/archive/html/coreutils/2018-06/msg00110.html
  91. # ... and even for production binary RPMs:
  92. # https://lists.gnu.org/archive/html/bug-gnulib/2020-05/msg00130.html
  93. # There is currently no measurable performance drop or other known downside.
  94. CFLAGS="$CFLAGS -Dlint"
  95. # make mknod work again in chroot without /proc being mounted (#1811038)
  96. export ac_cv_func_lchmod="no"
  97. %{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
  98. %configure --enable-largefile \
  99. --enable-install-program=arch \
  100. --enable-no-install-program=kill,uptime \
  101. --with-tty-group \
  102. DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
  103. %__make all %{?_smp_mflags}
  104. # XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
  105. sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
  106. %install
  107. rm -rf $RPM_BUILD_ROOT
  108. %__make DESTDIR=$RPM_BUILD_ROOT install
  109. # man pages are not installed with make install
  110. %__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
  111. # let be compatible with old fileutils, sh-utils and textutils packages :
  112. mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
  113. for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
  114. link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
  115. stty sync touch true uname unlink
  116. do
  117. mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
  118. done
  119. # chroot was in /usr/sbin :
  120. mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
  121. # {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
  122. for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
  123. mkdir -p $RPM_BUILD_ROOT/etc/profile.d
  124. install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
  125. install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
  126. install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
  127. install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
  128. install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
  129. # These come from util-linux and/or procps.
  130. for i in hostname uptime kill ; do
  131. rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
  132. done
  133. %find_lang %name
  134. # Add the %%lang(xyz) ownership for the LC_TIME dirs as well...
  135. grep LC_TIME %name.lang | cut -d'/' -f1-6 | sed -e 's/) /) %%dir /g' >>%name.lang
  136. # (sb) Deal with Installed (but unpackaged) file(s) found
  137. rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
  138. %check
  139. # this test will fail on non-real filesystem (overlayfs, etc.).
  140. perl -pi -e 's|^.*inotify-dir-recreate.*$|\\|' tests/local.mk
  141. make check %{?_smp_mflags}
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. %files -f %{name}.lang
  145. %defattr(-,root,root)
  146. %config(noreplace) %{_sysconfdir}/DIR_COLORS*
  147. %config(noreplace) %{_sysconfdir}/profile.d/*
  148. %license COPYING
  149. %doc ABOUT-NLS NEWS README THANKS TODO
  150. /bin/*
  151. %{_bindir}/*
  152. %{_libexecdir}/coreutils
  153. %{_infodir}/coreutils*
  154. %{_mandir}/man*/*
  155. %{_sbindir}/chroot
  156. %changelog
  157. * Tue Oct 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0-1
  158. - new upstream release.
  159. - re-imported fedora patches.
  160. - dropped scriptlets.
  161. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.32-1
  162. - new upstream release.
  163. - updated all patches.
  164. * Fri May 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.25-1
  165. - update to 8.25
  166. - remove Patch1,102
  167. - import patches from fedora package
  168. - update Patch104,800
  169. - add Patch801,803,804
  170. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.23-1
  171. - update to 8.23
  172. - add Patch1 (coreutils-8.23-chroot-chdir.patch) from fedora
  173. - update Patch100,104,800
  174. - remove Requires: util-linux (BTS:2854)
  175. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.20-2
  176. - rebuild with VineSeed environment
  177. * Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
  178. - update to 8.20
  179. * Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
  180. - update ja.po
  181. - add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
  182. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
  183. - update to 8.10
  184. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
  185. - rebuilt against curent toolchain
  186. - spec in UTF-8
  187. * Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
  188. - new upstream release
  189. - drop obsolete patches
  190. - import some patched from fedora-devel
  191. - add Obsoletes/Provides mktemp
  192. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
  193. - new upstream release
  194. * Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
  195. - new upstream release
  196. * Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
  197. - new upstream release
  198. - drop opsolete patches
  199. - import some patches from FC
  200. * Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
  201. - now readlink is kept as it is, since tetex-3.0 don't have readlink.
  202. * Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
  203. - updated ja.po
  204. * Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
  205. - remove selinux related pam-module from /etc/pam.d/su
  206. * Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
  207. - update ja.po
  208. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
  209. - initial build for Vine Linux
  210. - some modifications are merged from fileutils-4.1-10.1vl4
  211. - disable make check
  212. * Sat Feb 5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
  213. - Undo last change (bug #145266).
  214. * Fri Feb 4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
  215. - Special case for ia32e in uname (bug #145266).
  216. * Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
  217. - Fixed zh_CN translation (bug #144845). Patch from Mitrophan Chin.
  218. * Tue Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
  219. - Fix to only setdefaultfilecon if not overridden by command line
  220. * Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
  221. - Change install to restorecon if it can
  222. * Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
  223. - Fixed small bug in i18n patch.
  224. * Mon Dec 6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
  225. - Don't set fs uid until after pam_open_session (bug #77791).
  226. * Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
  227. - Fixed colorls.csh (bug #139988). Patch from Miloslav Trmac.
  228. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com>
  229. - Updated URL (bug #138279).
  230. * Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
  231. - Handle the return code of function calls in runcon.
  232. * Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
  233. - Prevent compiler warning in coreutils-i18n.patch (bug #136090).
  234. * Tue Oct 5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
  235. - getgrouplist() patch from Ulrich Drepper.
  236. - The selinux patch should be applied last.
  237. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
  238. - Mv runuser to /sbin
  239. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
  240. - Fix runuser man page.
  241. * Mon Oct 4 2004 Tim Waugh <twaugh@redhat.com>
  242. - Fixed build.
  243. * Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
  244. - Add runuser as similar to su, but only runable by root
  245. * Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
  246. - chown(1) patch from Ulrich Drepper.
  247. * Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
  248. - SELinux patch fix: don't display '(null)' if getfilecon() fails
  249. (bug #131196).
  250. * Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
  251. - Fixed colorls.csh quoting (bug #102412).
  252. - Fixed another join LSB test failure (bug #121153).
  253. * Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
  254. - Fixed sort -t LSB test failure (bug #121154).
  255. - Fixed join LSB test failure (bug #121153).
  256. * Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
  257. - Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
  258. - SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
  259. * Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
  260. - Added 'konsole' TERM to DIR_COLORS (bug #129544).
  261. * Wed Aug 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
  262. - Added 'gnome' TERM to DIR_COLORS (bug #129112).
  263. - Worked around a bash bug #129128.
  264. - Fixed an i18n patch bug in cut (bug #129114).
  265. * Tue Aug 3 2004 Tim Waugh <twaugh@redhat.com>
  266. - Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
  267. (bug #128948).
  268. * Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
  269. - Fixed field extraction in sort (bug #127694).
  270. * Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
  271. - Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
  272. * Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
  273. - Move pam-xauth to after pam-selinux
  274. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  275. - rebuilt
  276. * Mon Jun 7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
  277. - Fix ls -Z (bug #125447).
  278. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  279. - Build requires bison (bug #125290).
  280. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
  281. - Fix selinux patch causing problems with ls --format=... (bug #125238).
  282. * Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
  283. - Change su to use pam_selinux open and pam_selinux close
  284. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
  285. - Don't call access() on symlinks about to be removed (bug #124699).
  286. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
  287. - Fix ja translation (bug #124862).
  288. * Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
  289. - rebuild
  290. * Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
  291. - Mention pam in the info for su (bug #122592).
  292. - Remove wheel group rant again (bug #122886).
  293. - Change default behaviour for chgrp/chown (bug #123263). Patch from
  294. upstream.
  295. * Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
  296. - compiling su PIE
  297. * Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
  298. - Build requires new versions of autoconf and automake (bug #123098).
  299. * Tue May 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
  300. - Fix join -t (bug #122435).
  301. * Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
  302. - Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
  303. * Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
  304. - Add ls -LZ fix
  305. - Fix chcon to handle "."
  306. * Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
  307. - Apply upstream fix for non-zero seconds for --date="10:00 +0100".
  308. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
  309. - If preserve fails, report as warning unless user requires preserve
  310. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
  311. - Make mv default to preserve on context
  312. * Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
  313. - 5.2.1.
  314. * Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
  315. - Add '-Z' to 'ls --help' output (bug #118108).
  316. * Fri Mar 5 2004 Tim Waugh <twaugh@redhat.com>
  317. - Fix deref-args test case for rebuilding under SELinux (bug #117556).
  318. * Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
  319. - kill(1) offloaded to util-linux altogether.
  320. * Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
  321. - Ship the real '[', not a symlink.
  322. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
  323. - Apply Paul Eggert's chown patch (bug #116536).
  324. - Merged chdir patch into pam patch where it belongs.
  325. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
  326. - Fixed i18n patch bug causing sort -M not to work (bug #116575).
  327. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
  328. - Reinstate kill binary, just not its man page (bug #116463).
  329. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
  330. - Updated ls-stat patch.
  331. * Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
  332. - fix chcon to ignore . and .. directories for recursing
  333. * Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
  334. - Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
  335. - 5.2.0.
  336. * Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
  337. - More AFS patch tidying.
  338. * Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
  339. - fix chcon to handle -h qualifier properly, eliminate potential crash
  340. * Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
  341. - Stop 'sort -g' leaking memory (i18n patch bug #115620).
  342. - Don't ship kill, since util-linux already does.
  343. - Tidy AFS patch.
  344. * Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
  345. - 5.1.3.
  346. - Patches ported forward or removed.
  347. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
  348. - rebuilt
  349. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
  350. - Change /etc/pam.d/su to remove preservuser and add multiple
  351. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
  352. - Change is_selinux_enabled to is_selinux_enabled > 0
  353. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
  354. - Add pam_selinux to pam file to allow switching of roles within selinux
  355. * Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
  356. - The textutils-2.0.17-mem.patch is no longer needed.
  357. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
  358. - Fixed autoconf test causing builds to fail.
  359. * Tue Dec 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
  360. - Fix copying to non xattr files
  361. * Thu Dec 4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
  362. - Fix column widths problems in ls.
  363. * Tue Dec 2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
  364. - Speed up md5sum by disabling speed-up asm.
  365. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
  366. - Try again
  367. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
  368. - Fix move on non SELinux kernels
  369. * Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
  370. - Fixed useless acl dependencies (bug #106141).
  371. * Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
  372. - Fix id -Z
  373. * Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
  374. - Turn on SELinux
  375. - Fix chcon error handling
  376. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
  377. - Turn off SELinux
  378. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
  379. - Turn on SELinux
  380. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
  381. - Turn off SELinux
  382. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
  383. - Turn on SELinux
  384. * Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  385. - allow compiling without pam support
  386. * Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
  387. - Make split(1) handle large files (bug #106700).
  388. * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
  389. - Turn off SELinux
  390. * Wed Oct 8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
  391. - Cleanup SELinux patch
  392. * Fri Oct 3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
  393. - Restrict ACL support to only those programs needing it (bug #106141).
  394. - Fix default PATH for LSB (bug #102567).
  395. * Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
  396. - Turn off SELinux
  397. * Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
  398. - Turn on SELinux
  399. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
  400. - Turn off SELinux
  401. * Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
  402. - Only call getfilecon if the user requested it.
  403. - build with selinux
  404. * Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
  405. - Documentation fix (bug #102697).
  406. * Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
  407. - Made su use pam again (oops).
  408. - Fixed another i18n bug causing sort --month-sort to fail.
  409. - Don't run dubious stty test, since it fails when backgrounded
  410. (bug #102033).
  411. - Re-enable make check.
  412. * Fri Aug 8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
  413. - Don't run 'make check' for this build (build environment problem).
  414. - Another uninitialized variable in i18n (from bug #98683).
  415. * Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
  416. - Internationalize runcon
  417. - Update latest chcon from NSA
  418. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
  419. - Re-enable make check.
  420. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
  421. - Don't run 'make check' for this build (build environment problem).
  422. * Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
  423. - Actually use the ACL patch (bug #100519).
  424. * Fri Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
  425. - Convert to SELinux
  426. * Mon Jun 9 2003 Tim Waugh <twaugh@redhat.com>
  427. - Removed samefile patch. Now the test suite passes.
  428. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  429. - rebuilt
  430. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
  431. - Both kon and kterm support colours (bug #83701).
  432. - Fix 'ls -l' alignment in zh_CN locale (bug #88346).
  433. * Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
  434. - Prevent file descriptor leakage in du (bug #90563).
  435. - Build requires recent texinfo (bug #90439).
  436. * Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
  437. - Allow obsolete options unless POSIXLY_CORRECT is set.
  438. * Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
  439. - Fold bug was introduced by i18n patch; fixed there instead.
  440. * Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
  441. - fix segfault in fold (#88683)
  442. * Sat Apr 5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
  443. - 5.0.
  444. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
  445. - Use _smp_mflags.
  446. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
  447. - Remove overwrite patch.
  448. - No longer seem to need nolibrt, errno patches.
  449. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
  450. - No longer seem to need danglinglink, prompt, lug, touch_errno patches.
  451. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
  452. - 4.5.11.
  453. - Use packaged readlink.
  454. * Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
  455. - 4.5.10.
  456. - Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
  457. - Drop fr_fix, LC_TIME, preserve, regex patches.
  458. * Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
  459. - Fixed another i18n patch bug (bug #82032).
  460. * Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
  461. - Fix sort(1) efficiency in multibyte encoding (bug #82032).
  462. * Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
  463. - Ship readlink(1) (bug #84200).
  464. * Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
  465. - Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
  466. * Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
  467. - Require glibc >= 2.2 (bug #84090).
  468. * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
  469. - fix group (#84095)
  470. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
  471. - rebuilt
  472. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
  473. - Fix rm(1) man page.
  474. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
  475. - Fix re_compile_pattern check.
  476. - Fix su hang (bug #81653).
  477. * Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
  478. - Fix memory size calculation.
  479. * Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
  480. - Fix mv error message (bug #79809).
  481. * Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
  482. - added PreReq on grep
  483. * Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
  484. - Fix cp --preserve with multiple arguments.
  485. * Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
  486. - Turn on colorls for screen (bug #78816).
  487. * Mon Dec 9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
  488. - Fix mv (bug #79283).
  489. - Add patch27 (nogetline).
  490. * Sun Dec 1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
  491. - use the su.pamd from sh-utils since it works properly with multilib systems
  492. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
  493. - Fix test suite quoting problems.
  494. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
  495. - Fix scriplets.
  496. - Fix i18n patch so it doesn't break uniq.
  497. - Fix several other patches to either make the test suite pass or
  498. not run the relevant tests.
  499. - Run 'make check'.
  500. - Fix file list.
  501. * Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
  502. - Adapted for Red Hat Linux.
  503. - Self-host for help2man.
  504. - Don't ship readlink just yet (maybe later).
  505. - Merge patches from fileutils and sh-utils (textutils ones are already
  506. merged it seems).
  507. - Keep the binaries where the used to be (in particular, id and stat).
  508. * Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
  509. - LI18NUX/LSB compliance (patch800)
  510. - Installed (but unpackaged) file(s) - /usr/share/info/dir
  511. * Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
  512. - new release
  513. - rediff patch 180
  514. - merge patch 150 into 180
  515. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
  516. - move su back to /bin
  517. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
  518. - patch 0 : lg locale is illegal and must be renamed lug (pablo)
  519. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
  520. - fix conflict with procps
  521. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
  522. - patch 105 : fix install -s
  523. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
  524. - fix build
  525. - don't chmode two times su
  526. - build with large file support
  527. - fix description
  528. - various spec cleanups
  529. - fix chroot installation
  530. - fix missing /bin/env
  531. - add old fileutils, sh-utils & textutils ChangeLogs
  532. * Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
  533. - initial release (merge fileutils, sh-utils & textutils)
  534. - obsoletes/provides: sh-utils/fileutils/textutils
  535. - fileutils stuff go in 1xx range
  536. - sh-utils stuff go in 7xx range
  537. - textutils stuff go in 5xx range
  538. - drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
  539. most of them)
  540. - rediff patches 103, 105, 111, 113, 180, 706
  541. - temporary disable patch 3 & 4
  542. - fix fileutils url