gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.8.1
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. BuildRequires: python-devel
  13. BuildRequires: zlib-devel
  14. Requires: install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Takemikaduchi
  18. %description
  19. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  20. and other languages, by executing them in a controlled fashion and
  21. printing their data.
  22. %description -l ja
  23. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  24. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  25. %prep
  26. %setup -q
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS"
  29. rm -fr dejagnu tcl expect
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --sysconfdir=%{_sysconfdir} \
  33. --mandir=%{_mandir} \
  34. --infodir=%{_infodir} \
  35. %{_target_platform}
  36. make
  37. make info
  38. cp gdb/NEWS .
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  42. # The above is broken, do this for now:
  43. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  44. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  45. # These are part of binutils
  46. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  47. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  48. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  49. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  51. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
  52. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  53. rm -rf $RPM_BUILD_ROOT%{_includedir}
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  58. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  59. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  63. %preun
  64. if [ $1 = 0 ]; then
  65. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  67. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  68. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING COPYING.LIB README NEWS
  77. %{_bindir}/*
  78. %{_mandir}/*/*
  79. %{_datadir}/gdb/syscalls
  80. %{_datadir}/gdb/python/gdb
  81. %{_datadir}/gdb/system-gdbinit/elinos.py
  82. %{_datadir}/gdb/system-gdbinit/wrs-linux.py
  83. %{_infodir}/annotate.info*
  84. %{_infodir}/gdb.info*
  85. %{_infodir}/stabs.info*
  86. %exclude %{_infodir}/dir
  87. %ifarch %{ix86} x86_64
  88. %{_libdir}/libinproctrace.so
  89. %endif
  90. ## don't include the files in include, they are part of binutils
  91. #%{_includedir}/*
  92. #%{_infodir}/bfd.info*
  93. #%{_infodir}/configure.info*
  94. #%{_infodir}/standard.info*
  95. #%{_libdir}/*
  96. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  97. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  98. %changelog
  99. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
  100. - new upstream release
  101. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
  102. - new upstream release
  103. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
  104. - new upstream release
  105. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  106. - new upstream release
  107. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  108. - new upstream release
  109. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  110. - new upstream release
  111. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  112. - add BuildRequires: python-devel, zlib-devel
  113. - fix %%files
  114. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  115. - updated gdb to 7.2
  116. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  117. - updated gdb to 7.0.1
  118. - rebuilt with new environment
  119. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  120. - applied new versioning policy, spec in utf-8
  121. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  122. - rebuild with expat-2.0.1
  123. - add BuildRequires: expat-devel
  124. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  125. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  126. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  127. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  128. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  129. - new upstream release
  130. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  131. - new upstream release
  132. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  133. - new upstream release
  134. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  135. - Oops, spec was written in Shift-JIS. Fixed.
  136. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  137. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  138. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  139. - added mainframe patch from developerworks
  140. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  141. - Add changelogs to the previous patch
  142. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  143. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  144. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  145. - 5.2.1
  146. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  147. - compile on mainframe
  148. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  149. - Rebuild
  150. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  151. - Rebuild
  152. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  153. - 5.2
  154. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  155. - 5.1.92. Hopefully identical to 5.2 final
  156. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  157. - 5.1.91. 5.2 expected in a week
  158. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  159. - Update to current
  160. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  161. - Update to current
  162. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  163. - Update to current
  164. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  165. - Update to current
  166. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  167. - Update to current 5.2 branch
  168. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  169. - 5.1.1
  170. - add URL
  171. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  172. - automated rebuild
  173. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  174. - Fix some thread+fpu problems
  175. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  176. - 5.1
  177. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  178. - 5.0.94. Almost there....
  179. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  180. - Add patch from jakub@redhat.com to improve handling of DWARF
  181. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  182. - 5.0.93
  183. - handle missing info pages in post/pre scripts
  184. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  185. - 5.0.92
  186. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  187. - New snapshot
  188. - Use the 5.0.91 versioning from the snapshot
  189. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  190. - New snapshot
  191. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  192. - New snapshot
  193. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  194. - New snapshot
  195. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  196. - Don't buildrequire compat-glibc (#51690)
  197. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  198. - New snapshot, from the stable branch eventually leading to gdb 5.1
  199. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  200. - s/Copyright/License/
  201. - Add texinfo to BuildRequires
  202. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  203. - New snapshot
  204. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  205. - New snapshot
  206. - Add ncurses-devel to buildprereq
  207. - Remove perl from buildprereq, as gdb changed the way
  208. version strings are generated
  209. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  210. - New snapshot
  211. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  212. - New snapshot - this had thread fixes for curing #39070
  213. - New way of specifying version
  214. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  215. - New tarball
  216. - Kevin's patch is now part of gdb
  217. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  218. - Add patch from kevinb@redhat.com to fix floating point + thread
  219. problem (#24310)
  220. - remove old workarounds
  221. - new snapshot
  222. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  223. - New snapshot
  224. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  225. - on ia64, there are no old headers :)
  226. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  227. - build with old headers, new compiler
  228. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  229. - new snapshot
  230. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  231. - new snapshot which should fix some more IA64 problems (#29151)
  232. - remove IA64 patch, it's now integrated
  233. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  235. - use perl instead of patch for fixing the version string
  236. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  237. - don't use kgcc anymore
  238. - mark it as our own version
  239. - new snapshot
  240. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  241. - Link with ncurses 5.x even though we're using kgcc.
  242. No need to drag in requirements on ncurses4 (Bug #24445)
  243. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  244. - new snapshot
  245. * Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  246. - new snapshot
  247. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  248. - new snapshot
  249. - new alpha patch - it now compiles everywhere. Finally.
  250. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  251. - new snapshot
  252. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  253. - new CVS snapshot
  254. - disable the patches
  255. - don't use %%configure, as it confuses the autoconf script
  256. - enable SPARC, disable Alpha
  257. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  258. - added patch from GDB team for C++ symbol handling
  259. * Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  260. - upgrade to CVS snapshot
  261. - excludearch SPARC, build on IA61
  262. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  263. - rebuild
  264. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  265. - automatic rebuild
  266. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  267. - rebuild
  268. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  269. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  270. and %%{_tmppath}
  271. - the install scripts for info are broken(they don't care about
  272. you specify in the installstep), work around that.
  273. - don't build for IA64
  274. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  275. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  276. - added the NEWS file to the %%doc files
  277. - don't delete files which doesn't get installed (readline, texinfo)
  278. - let build system handle stripping and gzipping
  279. - don't delete libmmalloc
  280. - apply patch from jakub@redhat.com to make it build on SPARC
  281. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  282. - rebuilt against new ncurses
  283. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  284. - rebuild for sparc baud rates > 38400.
  285. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  286. - fix core file handling on i386 with glibc 2.1.3 headers
  287. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  288. - fix reading registers from core on sparc.
  289. - hack around build problems on i386 with glibc 2.1.3 headers
  290. * Thu Oct 7 1999 Jim Kingdon
  291. - List files to install in /usr/info specifically (so we don't pick up
  292. things like info.info from GDB snapshots).
  293. * Thu Oct 7 1999 Jim Kingdon
  294. - Update GDB to 19991004 snapshot. This eliminates the need for the
  295. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  296. * Mon Aug 23 1999 Jim Kingdon
  297. - Omit readline manpage.
  298. * Sat Aug 7 1999 Jim Kingdon
  299. - Remove H.J. Lu's patches (they had been commented out).
  300. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  301. from code fusion CD-ROM).
  302. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  303. - merge H.J. Lu's patches into 4.18.
  304. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  305. - updated the kern22 patch with stuff from davem
  306. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  307. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  308. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  309. - auto rebuild in the new build environment (release 3)
  310. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  311. - Sparc fiddles for Red Hat 6.0.