kimono-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253
  1. %global monodir /usr/lib/mono
  2. %global _kde4_version 4.12.5
  3. Name: kimono
  4. Summary: .NET/Mono KDE bindings
  5. Summary(ja): KDE の .NET/Mono バインディング
  6. Version: 4.12.5
  7. Release: 1%{?_dist_release}
  8. # most items are pure GPLv2+
  9. # plasma bindings mix LGPLv2+ and GPLv2+ (combined result is GPLv2+ too)
  10. License: GPLv2+
  11. Group: System Environment/Libraries
  12. URL: https://projects.kde.org/projects/kde/kdebindings/csharp/kimono
  13. Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
  14. BuildRequires: kdelibs4-devel >= %{version}
  15. BuildRequires: kdepimlibs-devel >= %{version}
  16. BuildRequires: akonadi-devel
  17. BuildRequires: mono-devel
  18. BuildRequires: monodoc
  19. BuildRequires: qyoto-devel >= %{version}
  20. BuildRequires: smokekde-devel >= %{version}
  21. Requires: qyoto >= %{_kde4_version}
  22. Requires: smokekde >= %{_kde4_version}
  23. %{?mono_arches:ExclusiveArch: %{mono_arches}}
  24. %description
  25. %{summary}.
  26. %package akonadi
  27. Summary: Akonadi runtime support for %{name}
  28. Summary(ja): %{name} の Akonadi ランタイムサポート
  29. Group: System Environment/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: smokekde-akonadi >= %{version}
  32. %description akonadi
  33. %{summary}.
  34. %prep
  35. %setup -q
  36. %build
  37. mkdir -p %{_target_platform}
  38. pushd %{_target_platform}
  39. %cmake \
  40. -DCMAKE_BUILD_TYPE=release \
  41. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  42. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  43. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  44. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  45. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  46. ..
  47. popd
  48. make %{?_smp_mflags} -C %{_target_platform}
  49. %install
  50. rm -rf $RPM_BUILD_ROOT
  51. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  52. %clean
  53. rm -rf $RPM_BUILD_ROOT
  54. %files
  55. %defattr(-,root,root,-)
  56. %doc ChangeLog COPYING.GPLv2 COPYING.LGPLv2
  57. %{_libdir}/kde4/kimonopluginfactory.so
  58. %{_libdir}/libkhtml-sharp.so
  59. %{_libdir}/libkimono.so
  60. %{_libdir}/libktexteditor-sharp.so
  61. %{_libdir}/libnepomuk-sharp.so
  62. %{_libdir}/libplasma-sharp.so
  63. %{_libdir}/libsoprano-sharp.so
  64. %{monodir}/qyoto/kde-dotnet.dll
  65. %{monodir}/qyoto/khtml-dll.dll
  66. %{monodir}/qyoto/ktexteditor-dotnet.dll
  67. %{monodir}/qyoto/nepomuk-dll.dll
  68. %{monodir}/qyoto/plasma-dll.dll
  69. %{monodir}/qyoto/soprano.dll
  70. %{monodir}/gac/kde-dotnet/
  71. %{monodir}/gac/khtml-dll/
  72. %{monodir}/gac/ktexteditor-dotnet/
  73. %{monodir}/gac/nepomuk-dll/
  74. %{monodir}/gac/plasma-dll/
  75. %{monodir}/gac/soprano/
  76. %{_datadir}/kde4/apps/plasma_scriptengine_kimono/
  77. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  78. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  79. %files akonadi
  80. %defattr(-,root,root,-)
  81. %{_libdir}/libakonadi-sharp.so
  82. %{monodir}/qyoto/akonadi.dll
  83. %{monodir}/gac/akonadi/
  84. %changelog
  85. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
  86. - splitted from kdebindings
  87. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  88. - new upstream release
  89. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  90. - updated to 4.6.1
  91. - added BR: kdesdk-devel
  92. - disabled attica plugins temporaly
  93. - rebuilt with mono-2.10.1
  94. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  95. - rebuilt with rpm-4.8.1 for pkg-config
  96. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  97. - new upstream release
  98. - added Patch50
  99. - added more japanese summaries
  100. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  101. - new upstream release
  102. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  103. - new upstream release
  104. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  105. - new upstream release
  106. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  107. - new upstream release
  108. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  109. - new upstream release
  110. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  111. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  112. - built with new toolchain
  113. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  114. - new upstream release
  115. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  116. - merged 4.3.1-2 %changelog
  117. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  118. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  119. - use %%{_prefix}/lib for mono-dll (for x86_64)
  120. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  121. - new upstream release
  122. - built with PyQt4-4.6
  123. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  124. - define %%{mono_dir} to specify mono library install path
  125. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  126. - new upstream release
  127. - fixed ruby modules installation path
  128. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  129. - new upstream release
  130. - spilt sub package based on Fedora
  131. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  132. - applied new versioning policy
  133. - added Patch1
  134. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  135. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  136. - added --with-qt-libraries option
  137. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  138. - rebuild for VineSeed
  139. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  140. - new upstream release
  141. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  142. - rebuild for VineSeed
  143. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  144. - new upstream release
  145. - update Patch0
  146. - drop Patch1
  147. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  148. - new upstream release
  149. - add Patch1
  150. - add --enable-libsuffix option
  151. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  152. - rebuild for VineSeed
  153. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  154. - new upstream release
  155. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  156. - rebuild for VineSeed
  157. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  158. - new upstream release
  159. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  160. - rebuild for VineSeed
  161. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  162. - new upstream release
  163. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  164. - rebuild for VineSeed
  165. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  166. - new upstream release
  167. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  168. - rebuild for VineSeed
  169. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  170. - new upstream release
  171. - renew BuildPrereq and build section
  172. - renew %%files
  173. - enable python
  174. - change spec to make main and devel package
  175. - add BuildPrereq: ruby ruby-devel
  176. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  177. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  178. - build for VineSeed
  179. - disable python and mozilla
  180. - objprelink (i386 only)
  181. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  182. - 2.2.2
  183. - build kmozilla binding only on x86/alpha
  184. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  185. - Make sure %%{name}-kmozilla isn't built on ia64
  186. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  187. - Move python bindings to separate package
  188. - Add perl bindings
  189. - Shut up rpmlint
  190. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  191. - 2.1
  192. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  193. - initial RPM