subversion-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550
  1. %define neon_version 0.25.5
  2. %define swig_version 3.0.0
  3. %define apache_version 2.4
  4. %define apache_dir /usr
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.8.9
  12. Release: 3%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: iwaim, daisuke
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch3: subversion-1.7.0-rpath.patch
  24. #Patch4: subversion-1.7.2-ruby19.patch
  25. BuildRequires: apache2-devel >= %{apache_version}
  26. BuildRequires: apr-devel, apr-util-devel
  27. BuildRequires: autoconf >= 2.53
  28. BuildRequires: libdb-devel
  29. BuildRequires: expat-devel
  30. BuildRequires: gdbm-devel
  31. BuildRequires: libtool >= 1.4.2
  32. BuildRequires: neon-devel >= %{neon_version}
  33. BuildRequires: openssl-devel
  34. BuildRequires: python
  35. BuildRequires: python-devel
  36. BuildRequires: swig >= %{swig_version}
  37. BuildRequires: texinfo
  38. BuildRequires: zlib-devel
  39. BuildRequires: openldap-devel
  40. BuildRequires: ruby >= 2.1.2-6
  41. BuildRequires: ruby-devel >= 2.1.2-6
  42. BuildRequires: perl >= 5.8.0
  43. BuildRequires: sqlite3-devel
  44. BuildRequires: krb5-devel
  45. BuildRequires: keyutils-libs-devel
  46. BuildRequires: dbus-devel
  47. BuildRequires: libgnome-keyring-devel
  48. BuildRequires: libserf-devel
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. %define __perllib_requires %{SOURCE3}
  51. %description
  52. Subversion is a concurrent version control system which enables one
  53. or more users to collaborate in developing and maintaining a
  54. hierarchy of files and directories while keeping a history of all
  55. changes. Subversion only stores the differences between versions,
  56. instead of every complete file. Subversion is intended to be a
  57. compelling replacement for CVS.
  58. %package devel
  59. Group: Development/Libraries
  60. Summary: Development package for Subversion developers.
  61. Requires: subversion = %{version}-%{release}
  62. Requires: apr-devel, apr-util-devel
  63. %description devel
  64. The subversion-devel package includes the static libraries and include files
  65. for developers interacting with the subversion package.
  66. %package mod_dav_svn
  67. Group: System Environment/Daemons
  68. Summary: Apache server module for Subversion server.
  69. Requires: apache2 >= %{apache_version}
  70. Requires: subversion = %{version}-%{release}
  71. %description mod_dav_svn
  72. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  73. the Apache directories and configuration.
  74. %package tools
  75. Group: Development/Tools
  76. Summary: Tools for Subversion
  77. BuildRequires: perl >= 5.8.0
  78. Requires: perl >= 5.8.0
  79. Requires: subversion = %{version}-%{release}
  80. %description tools
  81. Tools for Subversion.
  82. %package perl
  83. Group: Development/Libraries
  84. Summary: Perl bindings to the Subversion libraries
  85. Requires: subversion = %{version}-%{release}
  86. Requires: perl >= 5.8.0
  87. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  88. %description perl
  89. This package includes the Perl bindings to the Subversion libraries.
  90. %package ruby
  91. Group: Development/Libraries
  92. Summary: Ruby bindings to the Subversion libraries
  93. Requires: subversion = %{version}-%{release}
  94. Requires: ruby >= 2.0
  95. %description ruby
  96. This package includes the Ruby bindings to the Subversion libraries.
  97. %package python
  98. Group: Development/Libraries
  99. Summary: Python bindings to the Subversion libraries
  100. Requires: subversion = %{version}-%{release}, python
  101. %description python
  102. This package includes the Python bindings to the Subversion libraries.
  103. %prep
  104. %setup -q
  105. %patch3 -p1 -b .rpath
  106. %build
  107. PATH=/usr/bin:$PATH ./autogen.sh --release
  108. # fix shebang lines, #111498
  109. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  110. # override weird -shrext from ruby
  111. export svn_cv_ruby_link="%{__cc} -shared"
  112. export svn_cv_ruby_sitedir_libsuffix=""
  113. export svn_cv_ruby_sitedir_archsuffix=""
  114. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  115. export LIBTOOL=/usr/bin/libtool
  116. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  117. --with-swig --with-serf=%{_prefix} \
  118. --with-ruby-sitedir=%{rarchdir} \
  119. --with-apxs=%{_bindir}/apxs \
  120. --disable-mod-activation \
  121. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  122. --with-gnome-keyring \
  123. --with-berkeley-db \
  124. --disable-mod-activation \
  125. --disable-static
  126. make %{?_smp_mflags} all tools
  127. make swig-py swig-py-lib %{swigdirs}
  128. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  129. %install
  130. echo %{rarchdir}
  131. rm -rf $RPM_BUILD_ROOT
  132. make install \
  133. install-swig-py \
  134. install-swig-pl-lib \
  135. install-swig-rb \
  136. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  137. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  138. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  139. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  140. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  141. # Add subversion.conf configuration file into apache2/conf.d directory.
  142. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  143. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  144. # Remove unpackaged files
  145. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  146. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  147. $RPM_BUILD_ROOT%{_libdir}/*.la
  148. # The SVN build system is broken w.r.t. DSO support; it treats
  149. # normal libraries as DSOs and puts them in $libdir, whereas they
  150. # should go in some subdir somewhere, and be linked using -module,
  151. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  152. # since nothing should ever link against them directly.
  153. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  154. # remove stuff produced with Perl modules
  155. find $RPM_BUILD_ROOT -type f \
  156. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  157. -print0 | xargs -0 rm -f
  158. # make Perl modules writable so they get stripped
  159. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  160. xargs -0 chmod 755
  161. # unnecessary libraries for swig bindings
  162. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  163. # Remove unnecessary ruby libraries
  164. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  165. # Trim what goes in docdir
  166. rm -rf tools/*/*.in tools/test-scripts
  167. # Rename authz_svn INSTALL doc for docdir
  168. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  169. # Install bash completion
  170. install -Dpm 644 tools/client-side/bash_completion \
  171. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  172. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  173. ln -s svn \
  174. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  175. done
  176. # Install tools ex diff*
  177. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  178. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  179. for f in svn-populate-node-origins-index svn-rep-sharing-stats \
  180. svnauthz-validate svnmucc svnraisetreeconflict; do
  181. echo %{_bindir}/$f
  182. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  183. %find_lang %{name}
  184. cat %{name}.lang exclude.tools.files >> %{name}.files
  185. %clean
  186. rm -rf $RPM_BUILD_ROOT
  187. %post -p /sbin/ldconfig
  188. %postun -p /sbin/ldconfig
  189. %post perl -p /sbin/ldconfig
  190. %postun perl -p /sbin/ldconfig
  191. %post ruby -p /sbin/ldconfig
  192. %postun ruby -p /sbin/ldconfig
  193. %post python -p /sbin/ldconfig
  194. %postun python -p /sbin/ldconfig
  195. %post tools -p /sbin/ldconfig
  196. %postun tools -p /sbin/ldconfig
  197. %files
  198. %defattr(-,root,root)
  199. %doc BUGS CHANGES COMMITTERS LICENSE NOTICE INSTALL README
  200. %doc subversion/LICENSE
  201. %{_bindir}/*
  202. %{_libdir}/libsvn_*.so.*
  203. %{_localedir}/*/*/subversion.mo
  204. %{_mandir}/man*/*
  205. %{_datadir}/bash-completion/completions/*
  206. %dir %{_sysconfdir}/subversion
  207. %exclude %{_mandir}/man*/*::*
  208. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  209. %exclude %{_libdir}/libsvn_swig_py*.so.*
  210. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  211. %files devel
  212. %defattr(-,root,root)
  213. %{_includedir}/subversion-1
  214. %{_libdir}/libsvn*.so
  215. %exclude %{_libdir}/libsvn_swig_perl*
  216. %exclude %{_libdir}/libsvn_swig_py*
  217. %exclude %{_libdir}/libsvn_swig_ruby*
  218. %files mod_dav_svn
  219. %defattr(-,root,root)
  220. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  221. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  222. %files tools -f tools.files
  223. %defattr(-,root,root)
  224. %files perl
  225. %defattr(-,root,root,-)
  226. %{perl_vendorarch}/auto/SVN
  227. %{perl_vendorarch}/SVN
  228. %{_libdir}/libsvn_swig_perl*
  229. %{_mandir}/man*/*::*
  230. %files ruby
  231. %defattr(-,root,root,-)
  232. %{_libdir}/libsvn_swig_ruby*
  233. %{rarchdir}/svn
  234. %files python
  235. %defattr(-,root,root,-)
  236. %{_libdir}/libsvn_swig_py*
  237. %{python_sitearch}/libsvn
  238. %{python_sitearch}/svn
  239. %changelog
  240. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  241. - build with Perl 5.16
  242. - using %%__perllib_requires
  243. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  244. - rebuild with ruby-2.1.2-6
  245. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  246. - update to 1.8.9
  247. - remove unneeded explisit dependency
  248. - add BR: apache2-devel >= 2.4
  249. - add BR: libdb-devel instead of db4-devel
  250. - add R: apache2 > 2.4 to mod_dav_svn
  251. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  252. - update to 1.8.8
  253. - add BR: libserf-devel to handle http* scheme
  254. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  255. - update to 1.7.7
  256. - rebuild with ruby-1.9.3
  257. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  258. - new upstream release
  259. - update License
  260. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  261. - drop deplibs patch (Patch1)
  262. - drop obsolete patch files: Patch6, 10
  263. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  264. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  265. - add configure option with-gnome-keyring
  266. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  267. - fix Packager name
  268. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  269. - build with perl 5.12.3
  270. - add Requires: perl(:MODULE_COMPAT_...)
  271. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  272. - new upstream release with security fix
  273. - add Vendor/Distri tags
  274. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  275. - new upstream release
  276. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  277. - fix <BTS:VineLinux:941>
  278. - using rpm macro: rarchdir
  279. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  280. - using rpm macros: perl_vendorarch and python_sitearch
  281. - add BuildRequires: sqlite3-devel krb5-devel
  282. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  283. - new upstream release
  284. - update URL
  285. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  286. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  287. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  288. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  289. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  290. - new upstream release
  291. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  292. - new upstream release
  293. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  294. - rebuilt with python-2.5.2
  295. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  296. - new upstream release
  297. - rebuild with neon-0.28.2
  298. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  299. - added Patch6, 8, 9, 10 from Fedora Core
  300. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  301. - Correct install location of java stuff (#433295)
  302. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  303. - fix build with new glibc open()-as-macro
  304. - build all swig code in %%build, not %%install
  305. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  306. - build /usr/bin/* as PIEs
  307. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  308. - rebuild with expat-2.0.1
  309. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  310. - new upstream release
  311. - add Patch10 to build with neon.
  312. 1.3.2-0vl5 does not support neon..
  313. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  314. - rebuild with new neon
  315. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  316. - rebuilt with new toolchain and db4-4.3.x
  317. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  318. - modified %%files section for lib64 architecture
  319. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  320. - new upstream release
  321. - rebuild with new openldap-2.3.24
  322. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  323. - new upstream release
  324. - change Group to Develoment/Tools
  325. - build with apr-1.2.7/apr-util-1.2.7
  326. - require apr/apr-util instead of apache2-apr
  327. - build with swig-1.3.29
  328. - split {perl,python,ruby} related files to subpackage.
  329. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  330. - new upstream release
  331. - add noreplace option for config file
  332. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  333. - fix Requires and BuildPreReq.
  334. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  335. - new upstream release.
  336. - add swig-runtime to 'BuildPreReq:'.
  337. - fix %%files.
  338. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  339. - require neon version 0.24.7 for ra_dav
  340. - add BuildPreReq: openldap-devel
  341. - replace BuildPreReq: httpd to BuildPreReq: apache2
  342. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  343. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  344. - new upstream release
  345. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  346. - new upstream release
  347. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  348. - new upstream release
  349. - clean up specfile.
  350. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  351. - new upstream release
  352. - build with apache2-2.0.47
  353. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  354. - build Vine Linux
  355. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  356. - Enabled RA_DAV checking.
  357. Now requires httpd package to build because of RA_DAV tests.
  358. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  359. - Created tools package to hold the tools.
  360. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  361. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  362. version of APR/APR-UTILS as of 2003.01.15.
  363. - Added svnversion command.
  364. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  365. - Create a svnadmin.static which is copied to svnadmin-version-release
  366. when the package is erased, so users can still dump/load their repositories
  367. even after they have upgraded the RPM package.
  368. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  369. - SWIG now builds so we can use cvs2svn.
  370. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  371. - Made cvs2svn conditional (at least until we can get it to build consistently
  372. and work).
  373. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  374. - Added SWIG dependencies to add cvs2svn capabilities.
  375. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  376. - Now requires neon-0.22.0.
  377. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  378. - Took out loading mod_dav_svn from subversion.spec file and put it in
  379. subversion.conf file which goes into the apache conf directory.
  380. - Simplify what gets put into httpd.conf to only the include for the
  381. subversion.conf file.
  382. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  383. me to do this).
  384. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  385. - Updated to APR/APR-UTIL 2002-08-08.
  386. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  387. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  388. - Previous version had a few problems because of missing apache error/ files.
  389. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  390. - Updated to apache-2.0.40-0.3.
  391. - Updated to subversion-0.13.1-2318.
  392. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  393. - Updated for RedHat 7.3 (autoconf253).
  394. - Added a bunch of pre-requisites I didn't know were needed because I built a
  395. new machine that didn't have them already installed.
  396. - Fixed installation of man and info documentation pages.
  397. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  398. - Back to apache-libapr* stuff, hopefully to stay.
  399. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  400. - Fixed expat.patch to not have to make so many changes by writing a small
  401. shell script that changes libexpat to -lexpat.
  402. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  403. - Updated to neon-0.19.2.
  404. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  405. - Back to using apr and apr-util separately from apache.
  406. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  407. - Updated to APR and APR-UTIL 2002.02.11.
  408. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  409. - Took out a (now non-existant) documentation file.
  410. - Moved SPEC file changelog to after all package definitions.
  411. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  412. - Updated to neon-0.18.5.
  413. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  414. apache-apr-utils, and apache-apr-utils-devel.
  415. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  416. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  417. - Now builds without the separate APR package as it is built into and
  418. "exported" from apache-2.0.31-0.3.
  419. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  420. - Took out patches to install procedure now not required because of fixes
  421. in rev 1130.
  422. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  423. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  424. program was added.
  425. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  426. - Release M5-r340: Added the subversion-server package.
  427. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  428. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  429. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  430. - Release M3-r117: Initial Version.