swig-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %define tcl 0
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高レベル言語から利用するためのツール
  5. Name: swig
  6. Version: 3.0.2
  7. Release: 1%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: perl, python-devel, pcre-devel
  14. BuildRequires: ruby-devel
  15. BuildRequires: lua-devel
  16. %if %{tcl}
  17. BuildRequires: tcl-devel
  18. %endif
  19. %if %{guile}
  20. BuildRequires: guile-devel
  21. %endif
  22. BuildRequires: autoconf, automake, gawk, nkf
  23. Obsoletes: swig-runtime
  24. %description
  25. Simplified Wrapper and Interface Generator (SWIG) is a software
  26. development tool for connecting C, C++ and Objective C programs with a
  27. variety of high-level programming languages. SWIG is primarily used
  28. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  29. Eiffel and Guile. SWIG is normally used to create high-level
  30. interpreted programming environments, systems integration, and as a
  31. tool for building user interfaces
  32. %package doc
  33. Summary: Documentation files for SWIG
  34. Summary(ja): Documentation files for SWIG
  35. License: BSD
  36. Group: Development/Tools
  37. BuildArch: noarch
  38. %description doc
  39. This package contains documentation for SWIG and useful examples
  40. %prep
  41. %setup -q -n swig-%{version}
  42. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  43. # (specific req/prov filtering). Before you remove this hack make sure you don't
  44. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  45. cat << \EOF > %{name}-prov
  46. #!/bin/sh
  47. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  48. EOF
  49. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  50. chmod +x %{__perl_provides}
  51. cat << \EOF > %{name}-req
  52. #!/bin/sh
  53. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  54. EOF
  55. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  56. chmod +x %{__perl_requires}
  57. for all in CHANGES README; do
  58. iconv -f ISO88591 -t UTF8 < $all > $all.new
  59. touch -r $all $all.new
  60. mv -f $all.new $all
  61. done
  62. %build
  63. ./autogen.sh
  64. %configure
  65. make %{?_smp_mflags}
  66. # Test suite is currently broken
  67. #make check
  68. %install
  69. rm -rf %{buildroot}
  70. make clean-examples
  71. pushd Examples/
  72. # Remove all arch dependent files in Examples/
  73. find -type f -name 'Makefile.in' | xargs rm -f --
  74. # We don't want to ship files below.
  75. rm -rf test-suite
  76. find -type f -name '*.dsp' | xargs rm -f --
  77. find -type f -name '*.dsw' | xargs rm -f --
  78. # Convert files to UNIX format
  79. for all in `find -type f`; do
  80. nkf --unix $all
  81. chmod -x $all
  82. done
  83. popd
  84. make DESTDIR=%{buildroot} install
  85. %clean
  86. rm -rf %{buildroot}
  87. %files
  88. %defattr(-,root,root,-)
  89. %{_bindir}/*
  90. %{_datadir}/swig
  91. %{_mandir}/man1/ccache-swig.1*
  92. %doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
  93. %doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
  94. %files doc
  95. %defattr(-,root,root,-)
  96. %doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  97. %changelog
  98. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  99. - update to 3.0.2
  100. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  101. - update to 3.0.0
  102. - add BR: ruby-devel, lua-devel
  103. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  104. - update to 2.0.8
  105. - build with pcre-8.31
  106. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  107. - rebuild with python-2.7.2
  108. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  109. - update to 2.0.4
  110. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  111. - add missing man file(s) to the filelist
  112. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  113. - new upstream release
  114. - rebuild with new toolchain
  115. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  116. - new upstream release
  117. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  118. - new upstream release
  119. - removed php-devel and ruby-devel from BuildPreReq:.
  120. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  121. - new upstream release
  122. - use %%configure
  123. - remove runtime subpackage
  124. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  125. - 1.3.21-0vl2
  126. - un-libtoolize (tarball have already been libtoolized).
  127. - fix %%clean.
  128. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  129. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  130. - 1.3.21-0vl1
  131. - update version
  132. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  133. - 1.3.20-0vl1
  134. - update version
  135. * Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  136. - update version
  137. * Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  138. - update version
  139. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  140. - import to Vine Linux
  141. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  142. - BM.
  143. - Clean up specs.
  144. - 1.3a3.
  145. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  146. - Use makeinstall macros.
  147. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  148. - Provides: swig
  149. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  150. - rebuild with new perl
  151. - cleanup
  152. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  153. - Rebuilt on kenobi
  154. - Don't use prefix
  155. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  156. - First RPM for Mandrake