xulrunner-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846
  1. %define nspr_version 4.8.7
  2. %define nss_version 3.12.9
  3. %define cairo_version 1.10.2-2
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-2.0
  6. %define libjpeg-turbo_version 1.1.0
  7. %define build_vine6 0
  8. %define build_vine5 0
  9. %if "%{?_dist_release}" == "vl6"
  10. %define build_vine6 1
  11. %define build_vine5 1
  12. %endif
  13. %if "%{?_dist_release}" == "vl5"
  14. %define build_vine5 1
  15. %endif
  16. %if %build_vine6
  17. %define sqlite_version 3.7.5
  18. %endif
  19. %define version_internal 2.0
  20. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  21. # Separated plugins are supported on x86(64) only
  22. %ifarch %{ix86} x86_64
  23. %define separated_plugins 1
  24. %else
  25. %define separated_plugins 0
  26. %endif
  27. Summary: XUL Runtime for Gecko Applications
  28. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  29. Name: xulrunner
  30. Version: 2.0.1
  31. Release: 2%{?_dist_release}
  32. URL: http://www.mozilla.org/projects/xulrunner/
  33. License: MPLv1.1 or GPLv2+ or LGPLv2+
  34. Group: Applications/Internet
  35. Source0: %{name}-%{version}.source.tar.bz2
  36. Source10: %{name}-mozconfig
  37. Source11: %{name}-mozconfig-vine5
  38. Source12: %{name}-vine-default-prefs.js
  39. Source21: %{name}.sh.in
  40. Source23: %{name}.1
  41. # locale sources
  42. %define MOZ_BUILD_LOCALES "ja"
  43. Source1000: xulrunner-%{version}-ja.tar.bz2
  44. # build patches
  45. Patch0: xulrunner-version.patch
  46. Patch1: mozilla-build.patch
  47. Patch7: xulrunner-1.9.2.1-build.patch
  48. #Patch8: mozilla-plugin.patch
  49. Patch9: mozilla-build-sbrk.patch
  50. Patch10: mozilla-libjpeg-turbo.patch
  51. # patches from Fedora
  52. Patch100: mozilla-193-pkgconfig.patch
  53. # Upstream patches
  54. Patch130: xulrunner-omnijar.patch
  55. # ---------------------------------------------------
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  57. BuildRequires: nspr-devel >= %{nspr_version}
  58. BuildRequires: nss-devel >= %{nss_version}
  59. BuildRequires: cairo-devel >= %{cairo_version}
  60. BuildRequires: libpng-devel
  61. BuildRequires: libjpeg-turbo-devel >= %{libjpeg-turbo_version}
  62. BuildRequires: bzip2-devel
  63. BuildRequires: zlib-devel
  64. BuildRequires: lcms-devel
  65. BuildRequires: libIDL-devel
  66. BuildRequires: gtk2-devel
  67. BuildRequires: gnome-vfs2-devel
  68. BuildRequires: libgnome-devel
  69. BuildRequires: libgnomeui-devel
  70. BuildRequires: pango-devel
  71. BuildRequires: freetype2-devel >= 2.1.9
  72. BuildRequires: libXt-devel
  73. BuildRequires: libXrender-devel
  74. %if %{build_vine6}
  75. BuildRequires: sqlite3-devel >= %{sqlite_version}
  76. %endif
  77. BuildRequires: libnotify-devel >= %{libnotify_version}
  78. BuildRequires: startup-notification-devel
  79. BuildRequires: alsa-lib-devel
  80. BuildRequires: lcms-devel
  81. BuildRequires: zip
  82. # For -sqlite.patch
  83. BuildRequires: autoconf213
  84. BuildRequires: libvpx-devel
  85. Requires: nspr >= %{nspr_version}
  86. Requires: nss >= %{nss_version}
  87. Provides: gecko-libs = %{version}
  88. %description
  89. XULRunner provides the XUL Runtime environment for Gecko applications.
  90. %package devel
  91. Summary: Development files for Gecko
  92. Group: Development/Libraries
  93. Obsoletes: mozilla-devel
  94. Obsoletes: firefox-devel < 2.1
  95. Obsoletes: xulrunner-devel-unstable
  96. Provides: gecko-devel = %{version}
  97. Provides: gecko-devel-unstable = %{version}
  98. Requires: xulrunner = %{version}-%{release}
  99. Requires: nspr-devel >= %{nspr_version}
  100. Requires: nss-devel >= %{nss_version}
  101. Requires: cairo-devel >= %{cairo_version}
  102. Requires: libjpeg-turbo-devel >= %{libjpeg-turbo_version}
  103. Requires: zip
  104. Requires: bzip2-devel
  105. Requires: zlib-devel
  106. Requires: lcms-devel
  107. Requires: libIDL-devel
  108. Requires: gtk2-devel
  109. Requires: gnome-vfs2-devel
  110. Requires: libgnome-devel
  111. Requires: libgnomeui-devel
  112. Requires: pango-devel
  113. Requires: freetype2-devel >= 2.1.9
  114. Requires: libXt-devel
  115. Requires: libXrender-devel
  116. %if %{build_vine6}
  117. Requires: sqlite3-devel >= %{sqlite_version}
  118. %endif
  119. Requires: startup-notification-devel
  120. Requires: alsa-lib-devel
  121. %description devel
  122. Gecko development files.
  123. #---------------------------------------------------------------------
  124. %prep
  125. %setup -q -c -b 1000
  126. cd %{tarballdir}
  127. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  128. %{P:%%PATCH0} > version.patch
  129. %{__patch} -p1 -b --suffix .version < version.patch
  130. %patch1 -p2 -b .build
  131. %patch7 -p2 -b .del
  132. %patch9 -p2 -b .sbrk
  133. %patch10 -p2 -b .libjpeg-turbo
  134. %patch100 -p2 -b .pkgconfig
  135. %patch130 -p1 -b .omnijar
  136. %{__rm} -f .mozconfig
  137. %if %{build_vine6}
  138. %{__cp} %{SOURCE10} .mozconfig
  139. %else
  140. %{__cp} %{SOURCE11} .mozconfig
  141. %endif
  142. %if !%{?separated_plugins}
  143. echo "ac_add_options --disable-ipc" >> .mozconfig
  144. %endif
  145. #---------------------------------------------------------------------
  146. %build
  147. cd %{tarballdir}
  148. INTERNAL_GECKO=%{version_internal}
  149. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  150. # Mozilla builds with -Wall with exception of a few warnings which show up
  151. # everywhere in the code; so, don't override that.
  152. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  153. export CFLAGS=$MOZ_OPT_FLAGS
  154. export CXXFLAGS=$MOZ_OPT_FLAGS
  155. export PREFIX='%{_prefix}'
  156. export LIBDIR='%{_libdir}'
  157. MOZ_SMP_FLAGS=-j1
  158. %ifnarch ppc ppc64 s390 s390x
  159. [ -z "$RPM_BUILD_NCPUS" ] && \
  160. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  161. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  162. %endif
  163. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  164. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  165. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  166. # build locales
  167. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  168. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  169. for dir in $LOCALEDIRS
  170. do
  171. for lang in %{MOZ_BUILD_LOCALES} ; do
  172. make -C $dir/locales AB_CD=$lang
  173. done
  174. done
  175. #---------------------------------------------------------------------
  176. %install
  177. cd %{tarballdir}
  178. %{__rm} -rf $RPM_BUILD_ROOT
  179. INTERNAL_GECKO=%{version_internal}
  180. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  181. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  182. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  183. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  184. # set up our default preferences
  185. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  186. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  187. %{__rm} vl-default-prefs
  188. DESTDIR=$RPM_BUILD_ROOT make install
  189. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  190. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  191. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  192. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  193. # Start script install
  194. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  195. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  196. $RPM_BUILD_ROOT%{_bindir}/%{name}
  197. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  198. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  199. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  200. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  201. cd -
  202. # install locales
  203. #for lang in %{MOZ_BUILD_LOCALES} ; do
  204. # %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  205. #done
  206. # Prepare our devel package
  207. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  208. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  209. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  210. %{__cp} -rL dist/include/* \
  211. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  212. # Copy pc files (for compatibility with 1.9.1)
  213. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  214. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  215. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  216. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  217. # Fix multilib devel conflicts...
  218. %ifarch x86_64 ia64 s390x ppc64
  219. %define mozbits 64
  220. %else
  221. %define mozbits 32
  222. %endif
  223. function install_file() {
  224. genheader=$*
  225. mv ${genheader}.h ${genheader}%{mozbits}.h
  226. cat > ${genheader}.h << EOF
  227. // This file exists to fix multilib conflicts
  228. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  229. #include "${genheader}64.h"
  230. #else
  231. #include "${genheader}32.h"
  232. #endif
  233. EOF
  234. }
  235. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  236. install_file "mozilla-config"
  237. install_file "jsautocfg"
  238. install_file "js-config"
  239. popd
  240. %{__install} -p -c -m 755 dist/bin/xpcshell \
  241. dist/bin/xpidl \
  242. dist/bin/xpt_dump \
  243. dist/bin/xpt_link \
  244. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  245. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  246. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  247. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  248. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  249. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  250. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  251. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  252. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  253. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  254. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  255. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  256. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  257. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  258. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  259. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  260. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  261. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  262. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  263. for i in *.so; do
  264. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  265. done
  266. popd
  267. # GRE stuff
  268. %ifarch x86_64 ia64 ppc64 s390x
  269. %define gre_conf_file gre64.conf
  270. %else
  271. %define gre_conf_file gre.conf
  272. %endif
  273. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  274. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  275. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  276. sed -i -e "s/\[%{version}\]/\[$INTERNAL_GECKO\]/g" $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  277. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  278. # Library path
  279. %ifarch x86_64 ia64 ppc64 s390x
  280. %define ld_conf_file xulrunner-64.conf
  281. %else
  282. %define ld_conf_file xulrunner-32.conf
  283. %endif
  284. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  285. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  286. ${MOZ_APP_DIR}
  287. EOF
  288. # Copy over the LICENSE
  289. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  290. # Use the system hunspell dictionaries
  291. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  292. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  293. # ghost files
  294. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  295. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  296. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  297. #---------------------------------------------------------------------
  298. %clean
  299. %{__rm} -rf $RPM_BUILD_ROOT
  300. #---------------------------------------------------------------------
  301. %post
  302. /sbin/ldconfig
  303. %postun
  304. /sbin/ldconfig
  305. %preun
  306. # is it a final removal?
  307. if [ $1 -eq 0 ]; then
  308. %{__rm} -rf ${MOZ_APP_DIR}/components
  309. fi
  310. %files
  311. %defattr(-,root,root,-)
  312. %{_bindir}/xulrunner
  313. %dir /etc/gre.d
  314. /etc/gre.d/%{gre_conf_file}
  315. %dir %{mozappdir}
  316. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  317. %doc %attr(644, root, root) %{mozappdir}/README.txt
  318. %{mozappdir}/chrome
  319. %{mozappdir}/chrome.manifest
  320. %{mozappdir}/dictionaries
  321. %dir %{mozappdir}/components
  322. %ghost %{mozappdir}/components/compreg.dat
  323. %ghost %{mozappdir}/components/xpti.dat
  324. %{mozappdir}/components/*.so
  325. #%{mozappdir}/components/*.xpt
  326. %{mozappdir}/components/*.manifest
  327. #%attr(644, root, root) %{mozappdir}/components/*.js
  328. %{mozappdir}/defaults
  329. %dir %{mozappdir}/icons
  330. %attr(644, root, root) %{mozappdir}/icons/*
  331. %{mozappdir}/omni.jar
  332. #%{mozappdir}/modules
  333. %{mozappdir}/plugins
  334. #%{mozappdir}/res
  335. %{mozappdir}/*.so
  336. %{mozappdir}/mozilla-xremote-client
  337. %{mozappdir}/run-mozilla.sh
  338. %{mozappdir}/xulrunner
  339. %{mozappdir}/xulrunner-bin
  340. %{mozappdir}/xulrunner-stub
  341. %if %{?separated_plugins}
  342. %{mozappdir}/plugin-container
  343. %endif
  344. %{mozappdir}/platform.ini
  345. %{mozappdir}/dependentlibs.list
  346. #%{mozappdir}/greprefs.js
  347. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  348. # XXX See if these are needed still
  349. %{mozappdir}/updater*
  350. %exclude %{mozappdir}/update.locale
  351. %files devel
  352. %defattr(-,root,root,-)
  353. %{_datadir}/idl/%{name}*%{version_internal}
  354. %{_includedir}/%{name}*%{version_internal}
  355. %{_libdir}/%{name}-sdk-*/
  356. %{_libdir}/pkgconfig/*.pc
  357. %{mozappdir}/xpcshell
  358. %{mozappdir}/xpidl
  359. %{mozappdir}/xpt_dump
  360. %{mozappdir}/xpt_link
  361. #---------------------------------------------------------------------
  362. %changelog
  363. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
  364. - modify gre.conf to promote internal gecko version.
  365. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
  366. - update to 2.0.1 (sync with firefox-4.0.1)
  367. * Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
  368. - update to 2.0 (sync with firefox-4.0)
  369. - BR: libjpeg-turbo-devel >= 1.1.0
  370. - BR: nspr-devel >= 4.8.7
  371. - BR: nss-devel >= 3.12.9
  372. - BR: cairo-devel >= 1.10.2-2
  373. - add Patch130 to use omni.jar (upstream patch)
  374. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
  375. - update to 1.9.2.15 (sync with firefox-3.6.15)
  376. * Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
  377. - update to 1.9.2.14 (sync with firefox-3.6.14)
  378. * Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
  379. - update to 1.9.2.13 (sync with firefox-3.6.13)
  380. * Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
  381. - update to 1.9.2.11 (sync with firefox-3.6.11)
  382. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  383. - rebuild with rpm-4.8.1 for pkg-config file
  384. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  385. - update to 1.9.2.9 (sync with firefox-3.6.9)
  386. - add patch10 to build with libjpeg-turbo
  387. - build with sqlite-3.7.2
  388. - BR: nspr >= 4.8.6
  389. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  390. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  391. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  392. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  393. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  394. - enable ipc only on ix86/x86_64 arches
  395. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  396. - update to 1.9.2.4 (sync with firefox-3.6.4)
  397. - add patch10 to fix build failure
  398. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  399. - update to 1.9.2.3 (sync with firefox-3.6.3)
  400. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  401. - update to 1.9.2.2 (sync with firefox-3.6.2)
  402. - add patch7,9 for fix build failure
  403. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  404. - enable libnotify support
  405. - add ac_add_options --enable-libnotify
  406. - disable Necko wifi monitor
  407. - add ac_add_options --disable-necko-wifi
  408. - remove BR: wireless-tools-devel
  409. - fix %%files devel
  410. - add patch3,5 to fix jemalloc alignment assertion
  411. - add Patch8 to fix mozilla-plugin.pc
  412. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  413. - add BR: libnotify-devel, wireless-tools-devel
  414. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  415. - update to 1.9.2 (sync with firefox-3.6)
  416. - obsoletes xulrunner-devel-unstable
  417. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  418. - use internal sqlite3 on vine5
  419. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  420. - update to 1.9.1.7
  421. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  422. - update to 1.9.1.6
  423. - build with sqlite3-3.6.21
  424. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  425. - update to 1.9.1.5
  426. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  427. - update to 1.9.1.3
  428. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  429. - really update to 1.9.1.2 (<BTS:0748>)
  430. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  431. - update to 1.9.1.2 (sync with firefox-3.5.2)
  432. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  433. - update to 1.9.1.1 (sync with firefox-3.5.1)
  434. - add missing Requires to -devel
  435. - add missing BR
  436. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  437. - enable-system-cairo
  438. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  439. - update to 1.9.1 (based on firefox 3.5)
  440. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  441. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  442. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  443. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  444. - remove old patches
  445. - require nspr >= 4.8
  446. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  447. - new upstream release
  448. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  449. - update mozconfig
  450. - disable-system-cairo for stability
  451. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  452. - new upstream release
  453. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  454. - new upstream release
  455. - add ja locale
  456. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  457. - new upstream release
  458. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  459. - new upstream release
  460. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  461. - add Patch3
  462. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  463. - update to xulrunner 1.9.0.2 byild 6
  464. - build with gnome-2.24
  465. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  466. - new upstream release
  467. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  468. - initial build for Vine Linux
  469. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  470. - Update to 1.9 final
  471. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  472. - Simplify PS/PDF operators
  473. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  474. - Upstream patch to fsync() less
  475. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  476. - Ensure we enable startup notification; add BR and modify config
  477. (bug #445543)
  478. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  479. - Some files moved to mozilla-filesystem; kill them and add the Req
  480. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  481. - Clean up the %%files list and get rid of the executable bit on some files
  482. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  483. - Fix font scaling
  484. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  485. - Enabled phishing protection (#443403)
  486. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  487. - Changed "__ppc64__" to "__powerpc64__",
  488. "__ppc64__" doesn't work anymore
  489. - Added fix for #443725 - Critical hanging bug with fix
  490. available upstream (mozbz#429903)
  491. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  492. - Fixed multilib issues, added starting script instead of a symlink
  493. to binary (#436393)
  494. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  495. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  496. - Re-enable system cairo
  497. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  498. - Spec cleanups
  499. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  500. - Beta 5
  501. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  502. - Beta 5 RC2
  503. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  504. - Update to latest trunk (2008-03-27)
  505. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  506. - Update to latest trunk (2008-03-26)
  507. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  508. - Update to latest trunk (2008-03-25)
  509. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  510. - Update to latest trunk (2008-03-24)
  511. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  512. - Update to latest trunk (2008-03-20)
  513. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  514. - Update to latest trunk (2008-03-17)
  515. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  516. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  517. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  518. - Update to latest trunk (2008-03-16)
  519. - Add patch to negate a11y slowdown on some pages (#431162)
  520. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  521. - Update to latest trunk (2008-03-15)
  522. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  523. - Avoid conflicts between gecko debuginfo packages
  524. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  525. - Update to latest trunk (2008-03-12)
  526. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  527. - Update to latest trunk (2008-03-11)
  528. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  529. - Update to latest trunk (2008-03-10)
  530. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  531. - Update to latest trunk (2008-03-09)
  532. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  533. - Update to latest trunk (2008-03-07)
  534. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  535. - Update to latest trunk (2008-03-06)
  536. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  537. - Update to latest trunk (2008-03-04)
  538. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  539. - Update to latest trunk (2008-03-02)
  540. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  541. - Update to latest trunk (2008-03-01)
  542. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  543. - Update to latest trunk (2008-02-29)
  544. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  545. - Update to latest trunk (2008-02-28)
  546. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  547. - Update to latest trunk (2008-02-27)
  548. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  549. - Update to latest trunk (2008-02-26)
  550. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  551. - Update to latest trunk (2008-02-23)
  552. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  553. - Update to latest trunk (2008-02-22)
  554. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  555. - Update to latest trunk (2008-02-21)
  556. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  557. - Update to latest trunk (2008-02-20)
  558. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  559. - Update to latest trunk (2008-02-17)
  560. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  561. - Update to latest trunk (2008-02-15)
  562. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  563. - Update to latest trunk (2008-02-14)
  564. - Use system hunspell
  565. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  566. - Update to latest trunk (2008-02-11)
  567. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  568. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  569. you know, debuginfo.
  570. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  571. - Update to latest trunk (2008-02-10)
  572. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  573. - Update to latest trunk (2008-02-09)
  574. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  575. - Update to latest trunk (2008-02-06)
  576. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  577. - Update to latest trunk (2008-01-30)
  578. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  579. - rebuild agains new nss
  580. - enabled gnome vfs
  581. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  582. - fixed stable pkg-config files (#429654)
  583. - removed sqlite patch
  584. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  585. - Update to latest trunk (2008-01-21)
  586. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  587. - Update to latest trunk (2008-01-15)
  588. - Now with system extensions directory support
  589. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  590. - Update to latest trunk (2008-01-13)
  591. - Use CFLAGS instead of configure arguments
  592. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  593. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  594. - Provide gecko-devel-unstable as well
  595. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  596. - divided devel package to devel and devel-unstable
  597. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  598. - removed fedora specific pkg-config files
  599. - updated to the latest trunk (2008-01-07)
  600. - removed unnecessary patches
  601. - fixed idl dir (#427965)
  602. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  603. - Re-enable camellia256 support now that NSS supports it
  604. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  605. - updated to the latest trunk (2008-01-03)
  606. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  607. - Don't Provide webclient (xulrunner is not itself a webclient)
  608. - Don't Obsolete old firefox, only firefox-devel
  609. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  610. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  611. - added java and plugin subdirs to plugin includes
  612. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  613. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  614. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  615. - updated to Beta 2.
  616. - moved SDK to xulrunner-sdk
  617. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  618. - fixed mozilla-plugin.pc (#412971)
  619. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  620. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  621. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  622. - added xulrunner/js include dir to xulrunner-js
  623. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  624. - update to beta 1
  625. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  626. - packed all gecko libraries (#389391)
  627. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  628. - registered xulrunner libs system-wide
  629. - added xulrunner-gtkmozembed.pc
  630. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  631. - added proper nss/nspr dependencies
  632. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  633. - more build fixes, use system nss libraries
  634. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  635. - build fixes
  636. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  637. - updated to the latest trunk
  638. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  639. - build fixes for ppc/ppc64
  640. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  641. - removed conflicts with the current gecko-based apps
  642. - added updated ppc64 patch
  643. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  644. - build fixes
  645. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  646. - Initial cut at XULRunner 1.9 Alpha 7
  647. - Temporarily revert camellia 256 support since our nss doesn't support it yet