ghc-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %define pkg_name ghc
  2. %define pkg_version 8.0.1
  3. # %define pkg_subversion b
  4. %define pkg_release 1%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define rpmarch i386
  7. %endif
  8. %ifarch x86_64
  9. %define rpmarch x86_64
  10. %endif
  11. Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
  12. Name: %{pkg_name}
  13. Version: %{pkg_version}
  14. Release: %{pkg_release}
  15. License: BSD-like
  16. Group: Applications/Languages
  17. URL: https://www.haskell.org/ghc
  18. # Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
  19. Source0: %{name}-%{version}-src.tar.xz
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: ghc
  22. BuildRequires: gmp-devel
  23. BuildRequires: libffi-devel
  24. BuildRequires: ncurses-devel readline-devel freeglut-devel
  25. BuildRequires: gtk2-devel
  26. BuildRequires: python-sphinx
  27. Requires: gmp-devel
  28. Requires: libffi-devel
  29. Requires: freeglut
  30. Conflicts: ghc-bootstrap
  31. Conflicts: haskell-platform-base
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: ara_t
  35. %description
  36. The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
  37. compiler and interactive environment for the functional language Haskell.
  38. Highlights:
  39. - GHC supports the entire Haskell 2010 language plus a wide variety of
  40. extensions.
  41. - GHC has particularly good support for concurrency and parallelism,
  42. including support for Software Transactional Memory (STM).
  43. - GHC generates fast code, particularly for concurrent programs.
  44. - Take a look at GHC's performance on The Computer Language Benchmarks Game.
  45. GHC works on several platforms including Windows, Mac, Linux,
  46. most varieties of Unix, and several different processor architectures.
  47. There are detailed instructions for porting GHC to a new platform.
  48. - GHC has extensive optimisation capabilities, including inter-module
  49. optimisation.
  50. - GHC compiles Haskell code either directly to native code or using LLVM
  51. as a back-end.
  52. GHC can also generate C code as an intermediate target for porting to
  53. new platforms.
  54. The interactive environment compiles Haskell to bytecode,
  55. and supports execution of mixed bytecode/compiled programs.
  56. - Profiling is supported, both by time/allocation and various kinds of heap
  57. profiling.
  58. - GHC comes with several libraries, and thousands more are available on Hackage.
  59. #'
  60. %prep
  61. %{__rm} -rf ${RPM_BUILD_ROOT}
  62. %setup -q
  63. %build
  64. ./configure \
  65. --prefix=%{_prefix} \
  66. --libdir=%{_libdir} \
  67. --docdir=%{_docdir}/%{name}-%{version} \
  68. --with-system-libffi
  69. %{__make} %{?_smp_mflags}
  70. %install
  71. %{make_install}
  72. %{__cp} ANNOUNCE LICENSE \
  73. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  74. %clean
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %post -p %{_syssbindir}/ldconfig
  77. %postun -p %{_syssbindir}/ldconfig
  78. %files
  79. %defattr(-, root, root)
  80. %{_bindir}/
  81. %{_libdir}/ghc-%{version}/
  82. %{_docdir}/ghc-%{version}/
  83. %{_mandir}/man1/
  84. %changelog
  85. * Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
  86. - update to 8.0.1
  87. - add Requires: libffi-devel
  88. - add Requires: freeglut
  89. - add BuildRequires: python-sphinx for building HTML documents
  90. - add Conflicts: ghc-bootstrap
  91. - add Conflicts: haskell-platform-base
  92. - delete BuildRequires: hscolour
  93. - delete bindist subpackage
  94. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
  95. - add Requires: gmp-devel
  96. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
  97. - correct SPEC file
  98. * Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
  99. - update to 7.10.3
  100. - add BuildRequires: texlive-collection-fontutils
  101. - add Requires: libffi
  102. - add Requires: freeglut
  103. - provide binary tarball for building haskell-platform
  104. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
  105. - rebuild with ghc-7.6.3-4
  106. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
  107. - add Patchs to use --with-system-libffi option
  108. * Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
  109. - empty
  110. * Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
  111. - add BuildRequires: dblatex
  112. - add BuildRequires: texlive-collection-bibtexextra
  113. - add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  114. - change BuildRequires from ghc-bootstrap to ghc
  115. * Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
  116. - new package