python-pillow-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596
  1. %global with_python3 1
  2. %global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  3. %global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  4. %global srcname pillow
  5. # bootstrap building docs (pillow is required by docutils, docutils are
  6. # required by sphinx; pillow build-requires sphinx)
  7. %global with_docs 0
  8. Name: python-%{srcname}
  9. Version: 8.2.0
  10. Release: 1%{?_dist_release}
  11. Summary: Python image processing library
  12. Group: programming
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # License: see http://www.pythonware.com/products/pil/license.htm
  16. License: MIT
  17. URL: http://python-pillow.github.io/
  18. Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
  19. BuildRequires: freetype2-devel
  20. BuildRequires: gcc
  21. BuildRequires: ghostscript
  22. BuildRequires: lcms2-devel
  23. #BuildRequires: libimagequant-devel
  24. BuildRequires: libjpeg-devel
  25. #BuildRequires: libraqm-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libwebp-devel
  28. BuildRequires: openjpeg2-devel
  29. BuildRequires: tk-devel
  30. BuildRequires: zlib-devel
  31. %if 0%{?with_python3}
  32. BuildRequires: python3-rpm-macros
  33. BuildRequires: python3-cffi
  34. BuildRequires: python3-devel
  35. BuildRequires: python3-numpy
  36. #BuildRequires: python3-olefile
  37. BuildRequires: python3-qt5
  38. BuildRequires: python3-setuptools
  39. %if 0%{?with_docs}
  40. BuildRequires: python3-sphinx
  41. BuildRequires: python3-sphinx_rtd_theme
  42. %endif
  43. BuildRequires: python3-tkinter
  44. %endif
  45. %global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
  46. %description
  47. Python image processing library, fork of the Python Imaging Library (PIL)
  48. This library provides extensive file format support, an efficient
  49. internal representation, and powerful image processing capabilities.
  50. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  51. devel (development) and doc (documentation).
  52. %if 0%{?with_python3}
  53. %package -n python3-%{srcname}
  54. Summary: Python 3 image processing library
  55. Group: programming
  56. Requires: ghostscript
  57. %{?python_provide:%python_provide python3-%{srcname}}
  58. Provides: python3-imaging = %{version}-%{release}
  59. %description -n python3-%{srcname}
  60. Python image processing library, fork of the Python Imaging Library (PIL)
  61. This library provides extensive file format support, an efficient
  62. internal representation, and powerful image processing capabilities.
  63. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  64. devel (development) and doc (documentation).
  65. %package -n python3-%{srcname}-devel
  66. Summary: Development files for %{srcname}
  67. Group: programming
  68. Requires: python3-devel, libjpeg-devel, zlib-devel
  69. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  70. %{?python_provide:%python_provide python3-%{srcname}-devel}
  71. Provides: python3-imaging-devel = %{version}-%{release}
  72. %description -n python3-%{srcname}-devel
  73. Development files for %{srcname}.
  74. %package -n python3-%{srcname}-doc
  75. Summary: Documentation for %{srcname}
  76. Group: documentation
  77. BuildArch: noarch
  78. Requires: python3-%{srcname} = %{version}-%{release}
  79. %{?python_provide:%python_provide python3-%{srcname}-doc}
  80. Provides: python3-imaging-doc = %{version}-%{release}
  81. Obsoletes: python-%{srcname}-doc < 5.4.1-4
  82. %description -n python3-%{srcname}-doc
  83. Documentation for %{srcname}.
  84. %package -n python3-%{srcname}-tk
  85. Summary: Tk interface for %{srcname}
  86. Group: programming
  87. Requires: python3-tkinter
  88. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  89. %{?python_provide:%python_provide python3-%{srcname}-tk}
  90. Provides: python3-imaging-tk = %{version}-%{release}
  91. %description -n python3-%{srcname}-tk
  92. Tk interface for %{name}.
  93. %package -n python3-%{srcname}-qt
  94. Summary: Qt %{srcname} image wrapper
  95. Group: programming
  96. Requires: python3-qt5
  97. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  98. %{?python_provide:%python_provide python3-%{srcname}-qt}
  99. Provides: python3-imaging-qt = %{version}-%{release}
  100. %description -n python3-%{srcname}-qt
  101. Qt %{srcname} image wrapper.
  102. %endif
  103. %debug_package
  104. %prep
  105. %autosetup -p1 -n Pillow-%{version}
  106. %build
  107. %if 0%{?with_python3}
  108. # Build Python 3 modules
  109. %py3_build
  110. %ifarch x86_64
  111. %if 0%{?with_docs}
  112. PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
  113. rm -f docs/_build_py3/html/.buildinfo
  114. %endif
  115. %endif
  116. %endif
  117. %install
  118. %if 0%{?with_python3}
  119. # Install Python 3 modules
  120. install -d %{buildroot}/%{py3_incdir}/Imaging
  121. install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
  122. %py3_install
  123. %endif
  124. %check
  125. %if 0%{?with_python3}
  126. # Check Python 3 modules
  127. ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
  128. cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
  129. cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
  130. pushd build/%py3_libbuilddir
  131. PYTHONPATH=$PWD %{__python3} selftest.py
  132. popd
  133. %endif
  134. %if 0%{?with_python3}
  135. %files -n python3-%{srcname}
  136. %doc README.rst CHANGES.rst
  137. %license docs/COPYING
  138. %{python3_sitearch}/*
  139. # These are in subpackages
  140. %exclude %{python3_sitearch}/PIL/_imagingtk*
  141. %exclude %{python3_sitearch}/PIL/ImageTk*
  142. %exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
  143. %exclude %{python3_sitearch}/PIL/ImageQt*
  144. %exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
  145. %exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  146. %exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
  147. %files -n python3-%{srcname}-devel
  148. %{py3_incdir}/Imaging/
  149. %ifarch x86_64
  150. %files -n python3-%{srcname}-doc
  151. %if 0%{?with_docs}
  152. %doc docs/_build_py3/html
  153. %endif
  154. %endif
  155. %files -n python3-%{srcname}-tk
  156. %{python3_sitearch}/PIL/_imagingtk*
  157. %{python3_sitearch}/PIL/ImageTk*
  158. %{python3_sitearch}/PIL/SpiderImagePlugin*
  159. %{python3_sitearch}/PIL/__pycache__/ImageTk*
  160. %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  161. %files -n python3-%{srcname}-qt
  162. %{python3_sitearch}/PIL/ImageQt*
  163. %{python3_sitearch}/PIL/__pycache__/ImageQt*
  164. %endif
  165. %changelog
  166. * Wed Jun 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.2.0-1
  167. - new upstream release.
  168. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.1.2-1
  169. - new upstream release.
  170. * Tue Jan 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.1.0-1
  171. - new upstream release.
  172. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-2
  173. - built with python-3.8.
  174. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
  175. - new upstream release.
  176. - dropped python2 support.
  177. * Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
  178. - new upstream release.
  179. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  180. - initial build for Vine Linux.
  181. * Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
  182. - Remove optional build dependency on python2-cffi
  183. * Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
  184. - Update to 6.2.0
  185. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
  186. - Rebuilt for Python 3.8
  187. * Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
  188. - Drop python2-pillow-qt, python2-pillow-tk
  189. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  191. * Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
  192. - Update to 6.1.0
  193. * Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
  194. - Fix broken Python/C interop on s390x
  195. * Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
  196. - Update to 6.0.0
  197. * Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  198. - Drop python2-pillow-doc
  199. * Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
  200. - Fix python3 conditional
  201. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  203. * Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
  204. - Update to 5.4.1
  205. * Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
  206. - Update to 5.3.0
  207. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  209. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
  210. - Rebuilt for Python 3.7
  211. * Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
  212. - Update to 5.2.0
  213. * Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
  214. - Fix the tkinter dependency
  215. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
  216. - Rebuilt for Python 3.7
  217. * Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
  218. - Update to 5.1.1
  219. * Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
  220. - Update to 5.1.0
  221. * Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
  222. - Add missing BR: gcc
  223. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
  224. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  225. * Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
  226. - Update to 5.0.0
  227. * Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
  228. - Update to 4.3.0
  229. * Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
  230. - Cleanup spec file conditionals
  231. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
  232. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  233. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  235. * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
  236. - Rebuild due to bug in RPM (RHBZ #1468476)
  237. * Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
  238. - Update to 4.2.1
  239. * Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
  240. - Update to 4.2.0
  241. * Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
  242. - Update to 4.1.1
  243. * Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
  244. - Update to 4.1.0
  245. * Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
  246. - Fix some __pycache__ files in wrong subpackage (#1422606)
  247. * Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
  248. - Rebuild (libwebp)
  249. * Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
  250. - Update to 4.0.0
  251. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
  252. - Enable docs build
  253. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
  254. - Rebuild for Python 3.6
  255. * Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
  256. - Update to 3.4.2
  257. * Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
  258. - Update to 3.4.1
  259. * Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
  260. - Update to 3.4.0
  261. * Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
  262. - Update to 3.3.1
  263. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
  264. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  265. * Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
  266. - Update to 3.3.0
  267. - Modernize spec
  268. * Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
  269. - Update to 3.2.0
  270. * Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
  271. - Fix broken python3-pillow package description
  272. * Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
  273. - Fix provides
  274. * Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
  275. - Update to 3.1.1
  276. - Fixes CVE-2016-0740, CVE-2016-0775
  277. * Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
  278. - Fix executable files in doc package bringing in python 2 for the python3 doc
  279. packages
  280. * Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
  281. - Update to 3.1.0
  282. * Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
  283. - Build with docs
  284. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
  285. - Rebuilt for libwebp soname bump
  286. * Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
  287. - Rebuilt for Python3.5 rebuild with docs
  288. * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
  289. - Rebuilt for Python3.5 rebuild without docs
  290. * Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
  291. - Update to 3.0.0
  292. * Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
  293. - Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
  294. * Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
  295. - Update to 2.9.0
  296. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
  297. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  298. * Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
  299. - Update to 2.8.2
  300. * Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
  301. - Update to 2.8.1
  302. * Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
  303. - Update to 2.8.0
  304. * Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
  305. - Update to 2.7.0
  306. - Drop sane subpackage, is in python-sane now
  307. - Fix python3 headers directory
  308. - Drop Obsoletes: python3-pillow on python3-pillow-qt
  309. * Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
  310. - Update to 2.6.1
  311. * Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
  312. - Update to 2.6.0
  313. * Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
  314. - Rebuilding again to resolve transient build error that caused BZ#1131723
  315. * Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
  316. - Rebuilding to resolve transient build error that caused BZ#1131723
  317. * Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
  318. - Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
  319. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
  320. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  321. * Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
  322. - Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
  323. * Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
  324. - Reenable jpeg2k tests on big endian arches
  325. * Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
  326. - Update to 2.5.1
  327. * Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
  328. - Update to 2.5.0
  329. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
  330. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  331. * Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
  332. - Rebuild with docs enabled
  333. - Update python-pillow_openjpeg-2.1.0.patch
  334. * Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
  335. - Rebuild against openjpeg-2.1.0
  336. * Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
  337. - skip jpeg2k tests on big endian arches (#1100762)
  338. * Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
  339. - Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
  340. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
  341. - Set with_docs to 1 to build docs.
  342. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
  343. - Bootstrap building sphinx docs because of circular dependency with sphinx.
  344. * Fri May 9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
  345. - Rebuild for Python 3.4
  346. * Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
  347. - Add patch: Have the tempfile use a suffix with a dot
  348. * Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
  349. - Enable Jpeg2000 support
  350. - Enable webp support also on s390* archs, bug #962091 is now fixed
  351. - Add upstream patch for ghostscript detection
  352. * Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
  353. - Update to 2.4.0
  354. * Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
  355. - Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
  356. * Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
  357. - python-pillow does not provide python3-imaging
  358. (python3-pillow does)
  359. * Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
  360. - Add missing ghostscript Requires and BuildRequires
  361. * Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
  362. - Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
  363. * Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
  364. - Rebuild with docs enabled
  365. - Change lcms BR to lcms2
  366. * Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
  367. - Update to 2.3.0
  368. - Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
  369. * Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
  370. - Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
  371. * Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
  372. - Update to 2.2.1
  373. - Really enable webp on ppc, but leave disabled on s390
  374. * Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
  375. - Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
  376. - Renable webp support on bigendian arches
  377. * Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
  378. - Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
  379. * Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
  380. - Build without webp support on ppc* archs (#988767)
  381. * Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
  382. - Update to 2.1.0
  383. - Run tests in builddir, not installroot
  384. - Build python3-pillow docs with python3
  385. - python-pillow_endian.patch upstreamed
  386. * Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
  387. - Build without webp support on s390* archs
  388. Resolves: rhbz#962059
  389. * Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
  390. - Conditionaly disable build of python3 parts on RHEL system
  391. * Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
  392. - Add patch to fix test failure on big-endian
  393. * Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
  394. - Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
  395. appropriate since qt support didn't exist in the previous python-pillow
  396. package so there's no reason to drag in python-pillow-qt when updating
  397. python-pillow.
  398. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
  399. - Update to latest git
  400. - python-pillow_quantization.patch now upstream
  401. - python-pillow_endianness.patch now upstream
  402. - Add subpackage for ImageQt module, with correct dependencies
  403. - Add PyQt4 and numpy BR (for generating docs / running tests)
  404. * Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
  405. - Reenable tests on bigendian, add patches for #928927
  406. * Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
  407. - Update to latest git
  408. - disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
  409. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
  410. - python-pillow_tempfile.patch now upstream
  411. - Add python3-imaging provides (bug #924867)
  412. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
  413. - Update to latest git
  414. - Remove python-pillow-disable-test.patch, gcc is now fixed
  415. - Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
  416. * Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
  417. - Update to 2.0.0 git snapshot
  418. - Enable python3 packages
  419. - Add libwebp-devel BR for Pillow 2.0.0
  420. * Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
  421. - Add ARM support
  422. * Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
  423. - add s390* and ppc* to arch detection
  424. * Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
  425. - Update to latest git snapshot
  426. - 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
  427. - Pillow-1.7.8-selftest.patch now upstream
  428. * Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
  429. - Really remove -fno-strict-aliasing
  430. - Place comment on how to retreive source just above the Source0 line
  431. * Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
  432. - Rebuild without -fno-strict-aliasing
  433. - Add patch for upstream issue #52
  434. * Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
  435. - Initial RPM package