OpenImageIO-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %bcond_with external_pugixml
  2. %global subname oiio
  3. Name: OpenImageIO
  4. Version: 2.2.11.1
  5. Release: 1%{?_dist_release}
  6. Summary: Library for reading and writing images
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://sites.google.com/site/openimageio/home
  12. Source0: https://github.com/OpenImageIO/oiio/archive/v%{version}.tar.gz#/oiio-%{version}.tar.gz
  13. # Images for test suite
  14. #Source1: oiio-images.tar.gz
  15. BuildRequires: cmake
  16. BuildRequires: git
  17. BuildRequires: txt2man
  18. BuildRequires: qt5-qtbase-devel
  19. BuildRequires: fmt-devel
  20. BuildRequires: robin-map-devel
  21. BuildRequires: libboost-devel
  22. BuildRequires: libboost-python3
  23. BuildRequires: libboost-filesystem
  24. #BuildRequires: glew-devel
  25. BuildRequires: OpenEXR-devel
  26. BuildRequires: python3-devel
  27. BuildRequires: python3-rpm-macros
  28. # BuildRequires: openssl-devel
  29. BuildRequires: libpng-devel libtiff-devel openjpeg2-devel giflib-devel
  30. BuildRequires: libwebp-devel
  31. BuildRequires: Field3D-devel
  32. BuildRequires: hdf5-devel
  33. BuildRequires: zlib-devel
  34. BuildRequires: jasper-devel
  35. BuildRequires: LibRaw-devel
  36. %if %{with external_pugixml}
  37. BuildRequires: pugixml-devel
  38. %endif
  39. BuildRequires: pybind11-devel
  40. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  41. # If an ABI incompatible update is done in one, the other also needs to be
  42. # rebuilt.
  43. BuildRequires: OpenColorIO-devel
  44. Obsoletes: python-OpenImageIO
  45. # We don't want to provide private python extension libs
  46. %{?filter_setup:
  47. %filter_provides_in %{python3_sitearch}/.*\.so$
  48. %filter_setup
  49. }
  50. %description
  51. OpenImageIO is a library for reading and writing images, and a bunch of related
  52. classes, utilities, and applications. Main features include:
  53. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  54. writing 2D images that is format agnostic.
  55. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  56. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  57. PNM/PPM/PGM/PBM, Field3d.
  58. - An ImageCache class that transparently manages a cache so that it can access
  59. truly vast amounts of image data.
  60. %package -n python3-%{name}
  61. Summary: Python 3 bindings for %{name}
  62. Group: programming
  63. Requires: %{name} = %{version}-%{release}
  64. %description -n python3-%{name}
  65. Python3 bindings for %{name}.
  66. %package utils
  67. Summary: Command line utilities for %{name}
  68. Group: graphics
  69. Requires: %{name} = %{version}-%{release}
  70. %description utils
  71. Command-line tools to manipulate and get information on images using the
  72. %{name} library.
  73. %package iv
  74. Summary: %{name} based image viewer
  75. Group: graphics
  76. Requires: %{name} = %{version}-%{release}
  77. %description iv
  78. A really nice image viewer, iv, based on %{name} classes (and so will work
  79. with any formats for which plugins are available).
  80. %package devel
  81. Summary: Documentation for %{name}
  82. Group: programming
  83. Requires: %{name} = %{version}-%{release}
  84. %description devel
  85. Development files for package %{name}
  86. %debug_package
  87. %prep
  88. %setup -q -n oiio-%{version}
  89. %if %{with external_pugixml}
  90. # Remove bundled pugixml
  91. rm -f src/include/OpenImageIO/pugixml.hpp \
  92. src/include/OpenImageIO/pugiconfig.hpp \
  93. src/libutil/OpenImageIO/pugixml.cpp
  94. %endif
  95. # Remove bundled tbb
  96. %{__rm} -rf src/include/tbb
  97. # Install test images
  98. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  99. #tar --strip-components=1 -xzf %{SOURCE1}
  100. %build
  101. %{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
  102. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  103. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  104. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  105. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  106. -DBUILDSTATIC=OFF \
  107. -DLINKSTATIC=OFF \
  108. -DPYTHON_VERSION=%{python3_version} \
  109. -DINSTALL_DOCS:BOOL=FALSE \
  110. -DINSTALL_FONTS:BOOL=FALSE \
  111. %if %{with external_pugixml}
  112. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  113. %endif
  114. -DUSE_TBB:BOOL=FALSE \
  115. -DUSE_OPENSSL:BOOL=TRUE \
  116. -DSTOP_ON_WARNING:BOOL=FALSE \
  117. -DJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
  118. -DVERBOSE=TRUE \
  119. ../../
  120. %{__make} %{?_smp_mflags}
  121. popd
  122. %install
  123. pushd build/linux
  124. %{make_install}
  125. popd
  126. # # Move man pages to the right directory
  127. # mkdir -p %{buildroot}%{_mandir}/man1
  128. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  129. %post -p %{_syssbindir}/ldconfig
  130. %postun -p %{_syssbindir}/ldconfig
  131. %files
  132. %license LICENSE*
  133. %doc CHANGES.md CONTRIBUTING.md README.md
  134. %{_libdir}/libOpenImageIO.so.*
  135. %{_libdir}/libOpenImageIO_Util.so.*
  136. %files -n python3-%{name}
  137. %{python3_sitearch}/OpenImageIO*.so
  138. %files utils
  139. %exclude %{_bindir}/iv
  140. %{_bindir}/*
  141. # %exclude %{_mandir}/man1/iv.1.gz
  142. # %{_mandir}/man1/*.1.gz
  143. %files iv
  144. %{_bindir}/iv
  145. # %{_mandir}/man1/iv.1.gz
  146. %files devel
  147. %doc src/doc/*.pdf
  148. %{_libdir}/libOpenImageIO.so
  149. %{_libdir}/libOpenImageIO_Util.so
  150. %dir %{_libdir}/pkgconfig
  151. %{_libdir}/pkgconfig/OpenImageIO.pc
  152. %dir %{_datadir}/cmake
  153. %dir %{_datadir}/cmake/Modules
  154. %dir %{_libdir}/cmake/OpenImageIO
  155. %{_datadir}/cmake/Modules/FindOpenImageIO.cmake
  156. %{_libdir}/cmake/OpenImageIO/*
  157. %{_includedir}/*
  158. %changelog
  159. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.11.1-1
  160. - new upstream release.
  161. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9.0-1
  162. - new upstream release.
  163. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
  164. - new upstream release.
  165. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
  166. - new upstream release.
  167. - built with boost-1.72.0.
  168. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
  169. - new upstream release.
  170. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  171. - update to 1.8.17
  172. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  173. - update to 1.8.16
  174. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  175. - drop BuildRequires: openssl-devel
  176. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  177. - update to 1.7.19
  178. - using macro
  179. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  180. - rebuild with hdf5-1.8.20
  181. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  182. - update to 1.7.17
  183. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  184. - rebuilt with LibRaw-0.17.2.
  185. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  186. - rebuild with gcc-5.4.0
  187. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  188. - new upstream release
  189. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  190. - new upstream release
  191. - remove Patch0
  192. - create python-%%{name} subpackage
  193. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  194. - rebuild with glew-1.13.0
  195. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  196. - initial build for Vine Linux
  197. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  198. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  199. - rebuild (openexr)
  200. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  201. - Update to latest upstream release.
  202. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  203. - Update to latest upstream release.
  204. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  205. - Rebuild for Field3D 1.4.3.
  206. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  207. - Rebuild for pugixml 1.4
  208. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  209. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  210. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  211. - Update to latest upstream release.
  212. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  214. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  215. - Rebuild for boost 1.55.0
  216. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  217. - rebuild for boost 1.55.0
  218. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  219. - Update to latest upstream release.
  220. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  221. - Update to latest upstream release.
  222. - Add libgif as build requirement.
  223. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  224. - rebuild (openexr)
  225. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  226. - rebuilt for GLEW 1.10
  227. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  228. - Update to latest upstream release.
  229. - Fix ppc builds (BZ#1021977).
  230. - Add conditionals to build requirements for EPEL 6.
  231. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  232. - Update to latest upstream release.
  233. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  234. - rebuild (ilmbase/openexr)
  235. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  236. - Update to latest upstream release.
  237. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  238. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  239. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  240. - Rebuild for boost 1.54.0