chromium-vl.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. %define with_system_icu 1
  7. %endif
  8. %define v8_ver 3.0.12
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 10.0.651.0
  14. Release: 1%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. #Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. #Source0: %{name}-%{version}.svn%{svn_rev}.tar.xz
  19. Source0: %{name}-%{version}.tar.xz
  20. ## The following are included for source reasons only
  21. # Custom build tools for chromium, hammer is a fancy front-end for scons
  22. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  23. # # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. # Source2: repack_chromium_archive.sh
  25. # # Script used to create the tar.lzma archive from a checked out source
  26. # Source3: pack_chromium_source.sh
  27. # Script used to create the %{name}-%{version}.tar.xz archive from
  28. # a official tarball:
  29. # http://build.chromium.org/official/chromium-10.0.644.0.tar.bz2
  30. Source3: pack_chromium_source-vine.sh
  31. # Official ffmpeg headers
  32. Source8: ffmpeg-0.6-headers.tar.xz
  33. #Source10: chromium.desktop
  34. #Source10: chromium-vine.desktop
  35. # Patch template which adds vendor to user agent
  36. ##!!Source20: chromium-vendor.patch.in
  37. Source20: chromium-vendor-vine.patch.in
  38. # Set default prefs
  39. ##!!Source30: master_preferences
  40. Source30: master_preferences.vine
  41. #Source31: default_bookmarks.html
  42. #Source31: default_bookmarks.html.vine
  43. Source99: chrome-wrapper
  44. ##!!Source100: chromium-browser.sh
  45. Source100: chromium-browser-vine.sh
  46. ##!!Source101: chromium-browser.desktop
  47. Source101: chromium-browser-vine.desktop
  48. Source102: chromium-browser.xml
  49. Source103: chromium-browser-rpmlintrc
  50. %{?nosrc:NoSource: 0}
  51. %{?nosrc:NoSource: 1}
  52. Provides: chromium-browser = %{version}
  53. ##Provides: chromium-based-browser = %{version}
  54. ##Obsoletes: chromium-browser < %{version}
  55. ## Start Patches
  56. # Many changes to the gyp systems so we can use system libraries
  57. # My first ever patch set. I hope I did well.
  58. Patch3: chromium-gyp-system-icu.patch
  59. Patch4: chromium-no-sqlite-debug.patch
  60. Patch5: chromium-gyp-system-04-nss-nspr.patch
  61. Patch7: chromium-codechanges-nss-nspr.patch
  62. Patch8: chromium-codechanges-zlib.patch
  63. Patch12: chromium-no-test-sources.patch
  64. Patch13: chromium-no-courgette.patch
  65. Patch14: chromium-master-prefs-path.patch
  66. Patch17: chromium-system-glew.patch
  67. Patch18: chromium-system-expat.patch
  68. Patch19: chromium-system-zlib.patch
  69. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  70. Patch21: chromium-7.0.542.0-media-probe.patch
  71. Patch23: chromium-disable-mmx.patch
  72. Patch25: tcmalloc-factory.patch
  73. Patch26: chromium-remoting-build-fix.diff
  74. Patch28: chromium-7.0.500.0-system-speex.patch
  75. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  76. Patch30: chromium-7.0.510.0-fstat.patch
  77. Patch32: chromium-7.0.542.0-system-libvpx.patch
  78. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  79. # Shared Library patches
  80. Patch60: chromium-sharedlibfixes.patch
  81. #Patch61: chromium-shared-chromiumthreading.patch
  82. Patch62: chromium-norpath.patch
  83. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  84. # Patches for MeeGo Netbook
  85. Patch80: chromium-browser-window-focus.patch
  86. Patch81: chromium-20100319-default-browser-setting.patch
  87. Patch82: chromium-20100506-expose-chromium-browser-api.patch
  88. Patch83: chromium-fix-toolbar-icon-size.patch
  89. Patch98: chromium-gyp-external-icu.patch
  90. # Vine
  91. BuildRequires: gcc gcc-c++
  92. %if %{?_dist_release} == "vl5"
  93. BuildRequires: libstdc++34 libstdc++34-devel
  94. %elseif %{?_dist_release} == "vl6"
  95. BuildRequires: libstdc++ libstdc++-devel
  96. %endif
  97. BuildRequires: libevent
  98. ##!!BuildRequires: pkg-config
  99. BuildRequires: python
  100. ##!!BuildRequires: python-xml
  101. BuildRequires: python-pyxml
  102. BuildRequires: perl bison flex gperf
  103. ##!!BuildRequires: wdiff
  104. ##!!BuildRequires: update-desktop-files
  105. BuildRequires: lzma
  106. ##!!BuildRequires: mozilla-nss-devel
  107. BuildRequires: nss-devel
  108. ##!!BuildRequires: alsa-devel
  109. BuildRequires: alsa-lib-devel
  110. BuildRequires: gtk2-devel
  111. BuildRequires: glib2-devel
  112. BuildRequires: cairo-devel >= 1.6
  113. ##!!BuildRequires: mozilla-nspr-devel
  114. BuildRequires: nspr-devel
  115. ##!!BuildRequires: gconf2-devel
  116. BuildRequires: GConf2-devel
  117. BuildRequires: freetype2-devel
  118. ##!!BuildRequires: dbus-1-devel
  119. BuildRequires: dbus-devel
  120. BuildRequires: libxslt-devel
  121. BuildRequires: libxml2-devel
  122. BuildRequires: libjpeg-devel
  123. BuildRequires: zlib-devel
  124. ##!!BuildRequires: libbz2-devel
  125. BuildRequires: bzip2-devel
  126. BuildRequires: cups-devel
  127. %if %{?_dist_release} == "vl6"
  128. BuildRequires: fdupes
  129. %endif
  130. ##!!BuildRequires: libexpat-devel
  131. BuildRequires: expat-devel
  132. BuildRequires: libpng-devel
  133. BuildRequires: sqlite3-devel
  134. BuildRequires: gnutls-devel
  135. BuildRequires: desktop-file-utils
  136. BuildRequires: v8-devel = %{v8_ver}
  137. BuildRequires: libvpx-devel >= 0.9.5
  138. %if %{?_dist_release} == "vl5"
  139. BuildRequires: gnome-keyring-devel
  140. %elseif %{?_dist_release} == "vl6"
  141. BuildRequires: libgnome-keyring-devel
  142. %endif
  143. BuildRequires: python-devel
  144. BuildRequires: glew-devel
  145. ##!!BuildRequires: Mesa-devel
  146. BuildRequires: mesa-libGLU-devel
  147. BuildRequires: hunspell-devel
  148. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  149. BuildRequires: libevent-devel
  150. #BuildRequires: libjingle-devel >= 0.4.0-7
  151. #BuildRequires: srtp-devel
  152. BuildRequires: speex-devel
  153. ##Vine Linux
  154. Requires: v8 = %{v8_ver}
  155. BuildRequires: libpaper-devel
  156. BuildRequires: libXScrnSaver-devel
  157. BuildRequires: libXtst-devel
  158. BuildRequires: libXdamage-devel
  159. BuildRequires: libXt-devel
  160. #BuildRequires: gle-devel
  161. #BuildRequires: webkit-gtk-devel
  162. #BuildRequires: scons
  163. %ifarch x86_64
  164. Requires: nspluginwrapper
  165. %endif
  166. ##!!Requires: alsa
  167. Requires: alsa-lib
  168. Requires: xdg-utils
  169. # shouldn't be required to name all dependencies
  170. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  171. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  172. %description
  173. Chromium is the open-source project behind Google Chrome.
  174. We invite you to join us in our effort to help build a safer, faster,
  175. and more stable way for all Internet users to experience the web,
  176. and to create a powerful platform for developing a new generation of
  177. web applications.
  178. %description -l ja
  179. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  180. ウェブを体験しているすべてのインターネットユーザに対して
  181. より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
  182. そして、ウェブアプリケーションの新しい世代を発展させ、
  183. 強力なプラットホームを作成するために、
  184. 私たちの取り組みにぜひ参加してください。
  185. %package devel
  186. Summary: Header file for chromium browser
  187. Group: Development/Libraries
  188. Requires: chromium = %{version}-%{release}
  189. %description devel
  190. This package contains the header files and pc file of chromium browser for
  191. applications which will use chromium browser APIs.
  192. %prep
  193. %setup -q
  194. #%patch60 -p1
  195. #%patch61 -p1
  196. %patch62 -p1
  197. %patch63 -p1
  198. %patch80 -p1
  199. #%patch81 -p1
  200. %patch82 -p1
  201. %patch83 -p1
  202. # use system libicu only if >= 4.0
  203. %{?with_system_icu:%patch3 -p1}
  204. %patch4 -p1
  205. %patch5 -p1
  206. %patch7 -p1
  207. %patch8 -p1
  208. %patch12 -p1
  209. %patch13 -p1
  210. %patch14 -p1
  211. %patch17 -p1
  212. %patch18 -p1
  213. %patch19 -p1
  214. %patch20 -p1
  215. %patch21 -p1
  216. %patch25 -p1
  217. %ifarch %ix86
  218. %patch23 -p1
  219. %endif
  220. %patch26 -p1
  221. %patch28 -p1
  222. %patch29 -p1
  223. %patch30 -p1
  224. %patch32 -p1
  225. %patch34 -p1
  226. pushd src/third_party/ffmpeg/
  227. %__tar Jxf %{SOURCE8} || exit 1
  228. ## built header file: avconfig.h
  229. [ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
  230. cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
  231. /* Generated by ffconf */
  232. #ifndef AVUTIL_AVCONFIG_H
  233. #define AVUTIL_AVCONFIG_H
  234. #define AV_HAVE_BIGENDIAN 0
  235. #endif /* AVUTIL_AVCONFIG_H */
  236. EOF
  237. popd
  238. %__rm -rf src/third_party/libvpx/ src/third_party/speex/
  239. # apply vendor patch after substitution
  240. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  241. %build
  242. ## create make files
  243. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  244. for i in src/build/common.gypi; do
  245. %__sed -i "s|'-march=pentium4',||g" $i
  246. %__sed -i "s|'-msse2',||g" $i
  247. %__sed -i "s|'-mfpmath=sse',||g" $i
  248. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  249. %__sed -i "s|'-m32',||g" $i
  250. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  251. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  252. done
  253. # '
  254. pushd src
  255. ./build/gyp_chromium -f make build/all.gyp \
  256. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  257. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  258. -Duse_system_ffmpeg=1 \
  259. -Duse_system_zlib=1 \
  260. -Duse_system_libpng=1 \
  261. -Duse_system_bzip2=1 \
  262. -Duse_system_libbz2=1 \
  263. -Duse_system_libjpeg=1 \
  264. -Duse_system_libxml=1 \
  265. -Duse_system_libxslt=1 \
  266. -Duse_system_libevent=1 \
  267. -Duse_system_vpx=1 \
  268. -Dproprietary_codecs=1 \
  269. -Dlibrary=shared_library \
  270. -Djavascript_engine=v8 \
  271. -Dlinux_fpic=1 \
  272. %{?with_system_icu:-Duse_system_icu=1} \
  273. %{!?with_system_icu:-Duse_system_icu=0} \
  274. %ifarch %{ix86}
  275. -Dtarget_arch=ia32 \
  276. -Ddisable_sse2=1 \
  277. %endif
  278. %ifarch x86_64
  279. -Dtarget_arch=x64 \
  280. %endif
  281. %if %{?_dist_release} == "vl6"
  282. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  283. %endif
  284. -Drelease_extra_cflags=-fPIC \
  285. ;
  286. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  287. #%__make -r -j5 chrome BUILDTYPE=Release
  288. %__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  289. popd
  290. %install
  291. %{__rm} -rf %{buildroot}
  292. %__mkdir -p %{buildroot}%{_bindir}
  293. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  294. # x86_64 capable systems need this
  295. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  296. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  297. %__mkdir -p %{buildroot}%{_mandir}/man1/
  298. pushd src/out/Release
  299. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  300. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  301. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  302. %__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
  303. %__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
  304. #%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
  305. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  306. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  307. %if %{?_dist_release} == "vl6"
  308. fdupes %{buildroot}%{_mandir}/man1/
  309. %endif
  310. popd
  311. # devel package install
  312. mkdir -p %{buildroot}%{_libdir}/chromium/include
  313. pushd src
  314. find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  315. find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  316. find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  317. find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  318. find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  319. find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  320. find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  321. find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  322. find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  323. find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  324. find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  325. find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  326. find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  327. popd
  328. find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
  329. %if %{?_dist_release} == "vl6"
  330. fdupes %{buildroot}%{_libdir}/chromium/include
  331. %endif
  332. %__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
  333. cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
  334. Name: Chromium browser
  335. Description: Chromium browser development package
  336. Version: 1.0.1
  337. Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
  338. Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
  339. EOF
  340. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  341. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  342. %__mkdir_p %{buildroot}%{_datadir}/applications/
  343. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  344. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  345. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  346. # # link to browser plugin path. Plugin patch doesn't work. Why?
  347. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  348. # pushd %{buildroot}%{_libdir}/%{name}
  349. # %{__ln_s} %{_libdir}/browser-plugins plugins
  350. # popd
  351. pushd %{buildroot}%{_libdir}/%{name}
  352. %ifarch x86_64
  353. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  354. %else
  355. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  356. %endif
  357. ## support ffmpeg libs
  358. touch %{buildroot}%{_libdir}/libavcodec.so.52
  359. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  360. touch %{buildroot}%{_libdir}/libavformat.so.52
  361. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  362. touch %{buildroot}%{_libdir}/libavutil.so.50
  363. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  364. popd
  365. # Install the master_preferences file
  366. %__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
  367. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  368. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  369. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
  370. %clean
  371. %{__rm} -rf %{buildroot}
  372. %files
  373. %defattr(-,root,root,-)
  374. %config %{_sysconfdir}/%{name}
  375. %dir %{_datadir}/gnome-control-center
  376. %dir %{_datadir}/gnome-control-center/default-apps
  377. %{_bindir}/chromium
  378. %{_libdir}/chromium/chromium
  379. # These unique permissions are intentional and necessary for the sandboxing
  380. #%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
  381. %{_libdir}/chromium/plugins/
  382. %{_libdir}/chromium/resources/
  383. %{_libdir}/chromium/xdg-settings
  384. %{_mandir}/man1/chrom*
  385. %{_datadir}/pixmaps/chromium-browser.png
  386. %{_datadir}/applications/*.desktop
  387. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  388. %{_libdir}/chromium/libavcodec.so.52
  389. %{_libdir}/chromium/libavutil.so.50
  390. %{_libdir}/chromium/libavformat.so.52
  391. %exclude %{_libdir}/libavcodec.so.52
  392. %exclude %{_libdir}/libavutil.so.50
  393. %exclude %{_libdir}/libavformat.so.52
  394. ## libs
  395. %dir %{_libdir}/chromium/
  396. %{_libdir}/chromium/chrome.pak
  397. %{_libdir}/chromium/resources.pak
  398. %{_libdir}/chromium/locales/
  399. %{_libdir}/chromium/lib*.so
  400. %files devel
  401. %defattr(-,root,root,-)
  402. %{_libdir}/chromium/include/
  403. %{_libdir}/pkgconfig/chromium-browser.pc
  404. %changelog
  405. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
  406. - updated to 10.0.651.0 with v8 3.0.12
  407. - added BuildRequires:
  408. - libpaper-devel
  409. - python-devel
  410. - added built header file: libavutil/avconfig.h %%prep
  411. - unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
  412. * Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
  413. - updated to 10.0.622.0
  414. - added BuildRequires: libXt-devel
  415. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
  416. - updated to 10.0.605.0
  417. - added BuildRequires:
  418. - libXdamage-devel
  419. - hunspell-devel
  420. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  421. - updated to 9.0.598
  422. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  423. - updated to 9.0.593
  424. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  425. - updated to 9.0.582
  426. - added Requires: xdg-utils
  427. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  428. - updated to 9.0.578
  429. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  430. - updated to 9.0.569
  431. * Mon Oct 25 2010 tittiatcoke@gmail.com
  432. - Update to 9.0.564 build
  433. * Added specific patches for MeeGo.
  434. * We are now using shared libraries for Chromium
  435. * Spec-file cleanup (Thanks to prusnak)
  436. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  437. - updated to snapshot 8.0.556
  438. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  439. - updated to snapshot 8.0.551
  440. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  441. - updated to snapshot 7.0.527
  442. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  443. - updated to snapshot 7.0.519
  444. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  445. - updated to snapshot 7.0.513
  446. - updated chromium-vendor-vine.patch.in
  447. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  448. - updated to snapshot 7.0.507
  449. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  450. - updated to snapshot 7.0.498
  451. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  452. - updated to snapshot 6.0.493
  453. - used with_system_icu (for vl6)
  454. - added BuildRequires: libicu-devel
  455. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  456. - build for Vine Linux 5.x
  457. - add BuildRequires: gnome-keyring-devel
  458. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  459. - updated to snapshot 6.0.454
  460. - added BuildRequires:
  461. - sqlite3-devel
  462. - gnutls-devel
  463. - libgnome-keyring-devel
  464. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  465. - updated to snapshot 6.0.431.0 r49253
  466. - added BuildRequires: cups-devel
  467. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  468. - updated to snapshot 6.0.405.0 r47263
  469. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  470. - unused with_system_icu (for vl6)
  471. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  472. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  473. - updated to snapshot 5.0.378.0 r44472
  474. - used with_system_icu (for vl6)
  475. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  476. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  477. - updated to snapshot 5.0.372.0 r43947
  478. - added BuildRequires: glew-devel
  479. - changed Group tag to Applications/Internet
  480. - added Summary(ja) and %%description -l ja
  481. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  482. - updated to snapshot 5.0.365.0 r42966
  483. - merged 5.0.353.0-4vl5
  484. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  485. - build on Vine Linux 5.1
  486. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  487. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  488. - updated to snapshot 5.0.364.0 r42779
  489. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  490. - updated to snapshot 5.0.359.0 r42116
  491. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  492. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  493. - fixed master_preferences.vine, little
  494. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  495. - fixed to install master_preferences
  496. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  497. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  498. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  499. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  500. - updated to snapshot 5.0.353.0 r41449
  501. * Wed Mar 10 2010 bgmerrell@novell.com
  502. - Add master_preferences source file and install it to /etc/chromium.
  503. - Create a new patch (chromium-master-prefs-path.patch) which tells
  504. chromium to look in /etc/chromium for the master_preferences file
  505. (instead of looking in the default directory, which is the same
  506. directory as the 'chrome' binary).
  507. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  508. - updated to snapshot 5.0.335.0 r39556
  509. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  510. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  511. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  512. - updated to snapshot 5.0.330.0 r39074
  513. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  514. - use_system_ffmpeg
  515. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  516. - added Requires: nspluginwrapper
  517. - fixed a symbolic link of plugins directory with nspluginwrapper
  518. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  519. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  520. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  521. - added BuildRequires: mesa-libGLU-devel
  522. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  523. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  524. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  525. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  526. - Update to 4.0.260
  527. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  528. - Update to 4.0.259
  529. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  530. - Update to 4.0.258
  531. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  532. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  533. changed to having an built-in v8
  534. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  535. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  536. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  537. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  538. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  539. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  540. - update to newer svn snapshot
  541. + Obsoletes fwrite patch (included upstream)
  542. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  543. - update to newer svn snapshot
  544. + Requires newer version of v8
  545. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  546. - do not force SSE on x86 (drop-sse.patch)
  547. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  548. - Update to newer svn snapshot
  549. - Fixed spec file in order to build
  550. - Included patch to build with system zlib
  551. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  552. - package renamed to chromium
  553. - cleaned up spec file
  554. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  555. - v8 is now built as a separate package, and is required
  556. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  557. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  558. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  559. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  560. - initial build
  561. #% changelog
  562. * Sun Jan 24 2010 prusnak@suse.cz
  563. - added vendor to user agent (chromium-vendor.patch.in)
  564. * Sun Nov 29 2009 prusnak@suse.cz
  565. - added --enable-sync to wrapper to enable bookmark sync
  566. * Sun Nov 29 2009 tittiatcoke@gmail.com
  567. - Update to 4.0.260
  568. * Fri Nov 27 2009 tittiatcoke@gmail.com
  569. - Update to 4.0.259
  570. * Thu Nov 26 2009 tittiatcoke@gmail.com
  571. - Update to 4.0.258
  572. * Tue Nov 24 2009 tittatcoke@gmai.com
  573. - In order to complete prevent the wrong v8 version to be used,
  574. the Chromium build has been changed to having an built-in v8
  575. * Tue Nov 24 2009 dbuck@example.com
  576. - Re-base patches.
  577. - Fixed a few patch errors.
  578. - Rename some patches to better correspond with function.
  579. - Removed some patches.
  580. - Minor SPEC changes.
  581. - I changed the v8 requirement to be exact, instead of greater than a specific version.
  582. * Fri Nov 13 2009 tittiatcoke@gmail.com
  583. - update to 247.0 svn 31928
  584. * Fri Oct 30 2009 tittiatcoke@gmail.com
  585. - update to 229.0 svn 30454
  586. + Fix regression where popups and app frames lost their titlebars.
  587. + Makes it so that when a folder is open on the bookmark bar
  588. and the mouse moves over another folder, the menu for that
  589. folder is shown.
  590. + Lazily create the find bar.
  591. + Polish to the gmail checker sample.
  592. * New, crisper icons that are exactly 19x19
  593. * Add a loading animation at the beginning before Gmail
  594. responds.
  595. * Fix a bug where we sometimes don't update the UI after a
  596. logout/login cycle.
  597. + Refactor widget methods to support desktop notifications,
  598. including GTK stubs.
  599. + Find-in-page should not ding while deleting characters.
  600. + Add SSL wrapper for linux and mac. This allows notifier to
  601. use chrome's SSL layer instead of OpenSSL.
  602. + Add three of the six extensions to PAC that Internet Explorer supports.
  603. + WebSocket support in chromium. (Run with --enable-web-sockets
  604. enables WebSocket features.)
  605. + Do not allow GTK File Chooser dialogs to return directories.
  606. + Fix the notifier SSL layer to make notifications work for
  607. Linux Bookmark sync.
  608. + linux: don't override mouse selection behavior in omnibox
  609. * Sun Oct 25 2009 tittiatcoke@gmail.com
  610. - Update to 224.4 svn 30027
  611. + First cut at new page and browser action docs based
  612. on new API. Deleted old stuff.
  613. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  614. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  615. + Minimize dependency of user scripts
  616. + Fixup the flip_framer eof-handling semantics now that we have
  617. the FIN bit in place
  618. + app depends on x11 because of active_window_watcher_x
  619. + Adding two images for the new Extension managment UI
  620. + Removing hard-coded Chrome Frame output path
  621. + Rearrange clipboard code
  622. + Fix crash bug when attempting to download a url with unsupported scheme,
  623. e.g. 'data:', by 'Alt + Click'
  624. + GTK: Change text for extension download UI
  625. + Ignore invalid urls on command line
  626. + Make dropped tabs animate from where they were dropped.
  627. + Make room for the full width of the tab placeholder.
  628. + Make tab dragging as smooth as glass.
  629. + Remove an annoying NOTIMPLEMNETED
  630. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  631. + If we're in the middle of a drag, don't allow the user to middle
  632. click to close or right click for the context menu
  633. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  634. + Remove +x bit from files that shouldn't have it
  635. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  636. + Adding new image needed for the managment UI
  637. + Fix a race bug where content scripts would not apply to the first page load
  638. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  639. + Fix bubbles deactivating the opaque frame
  640. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  641. + ake all pepper plugins default to windowless and transparent
  642. + Add styles for printing
  643. + Implement the new extension management UI
  644. + Add support for to automation interface load install and load extensions
  645. + GTK: theme the info bar border
  646. + Update V8 to version 1.3.16.1
  647. + Introduce WebSecurityPolicy for security related methods
  648. + New button scheme...borders are separate from the inner contents so
  649. that they can be highlighted / depressed independently
  650. + When opening Chrome maximized with an application window already
  651. running, the Chrome window was not activated
  652. + Fix compatibility problems with FileZilla FTP Server
  653. + Remove the extension shelf on Linux
  654. + Fix the proxy host and port string to start with http:// if it does not already
  655. + Enable HTML5 databases for all extension renderer processes
  656. * Sat Oct 24 2009 prusnak@opensuse.org
  657. - don't create desktop files in wrapper
  658. - fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  659. * Tue Oct 20 2009 tittiatcoke@gmail.com
  660. - update to newer svn snapshot
  661. + Obsoletes fwrite patch (included upstream)
  662. * Fri Oct 16 2009 tittiatcoke@gmail.com
  663. - update to newer svn snapshot
  664. + Requires newer version of v8
  665. * Thu Oct 15 2009 prusnak@suse.cz
  666. - do not force SSE on x86 (drop-sse.patch)
  667. * Tue Oct 13 2009 tittiatcoke@gmail.com
  668. - Update to newer svn snapshot
  669. - Fixed spec file in order to build
  670. - Included patch to build with system zlib
  671. * Mon Oct 12 2009 prusnak@suse.cz
  672. - package renamed to chromium
  673. - cleaned up spec file
  674. * Tue Oct 6 2009 dbuck@example.com
  675. - v8 is now built as a separate package, and is required
  676. - included many patches to use system libraries:
  677. v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  678. * Thu Oct 1 2009 dbuck@example.com
  679. - included a newer DEP than is in svn, native_client@823
  680. - things should compile cleanly now
  681. * Mon Aug 31 2009 dbuck@example.com
  682. - initial build