libtevent-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libtevent
  3. Summary: The tevent library
  4. Summary(ja): Tevent ライブラリ
  5. Version: 0.9.37
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv3+
  9. URL: http://tevent.samba.org/
  10. Source: http://samba.org/ftp/tevent/tevent-%{version}.tar.gz
  11. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  12. Patch1: tevent-098-add_abi_scripts_and_fix_exports.patch
  13. BuildRequires: libtalloc-devel >= 2.0.0
  14. BuildRequires: python-devel python-rpm-macros
  15. BuildRequires: python3-devel python3-rpm-macros
  16. BuildRequires: python-talloc-devel
  17. BuildRequires: python3-talloc-devel
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: tomop
  21. %description
  22. Tevent is an event system based on the talloc memory management library.
  23. Tevent has support for many event types, including timers, signals, and
  24. the classic file descriptor events.
  25. Tevent also provide helpers to deal with asynchronous code providing the
  26. tevent_req (Tevent Request) functions.
  27. %package devel
  28. Summary: Developer tools for the Tevent library
  29. Summary(ja): Tevent ライブラリの開発用ファイル
  30. Group: Development/Libraries
  31. Requires: libtevent = %{version}-%{release}
  32. Requires: libtalloc-devel >= 2.0.0
  33. Requires: pkgconfig
  34. %description devel
  35. Header files needed to develop programs that link against the Tevent library.
  36. %package -n python-tevent
  37. Summary: Python bindings for the Tevent library
  38. Summary(ja): Tevent ライブラリの python バインディング
  39. Group: System Environment/Libraries
  40. Requires: libtevent = %{version}-%{release}
  41. Requires: python-talloc >= 2.0.0
  42. Requires: pkgconfig
  43. %description -n python-tevent
  44. Python bindings for libtevent
  45. %package -n python3-tevent
  46. Summary: Python3 bindings for the Tevent library
  47. Summary(ja): Tevent ライブラリの python3 バインディング
  48. Group: System Environment/Libraries
  49. Requires: libtevent = %{version}-%{release}
  50. Requires: python3-talloc >= 2.0.0
  51. Requires: pkgconfig
  52. %description -n python3-tevent
  53. Python3 bindings for libtevent
  54. %if %{build_compat32}
  55. %package -n compat32-%{name}
  56. Summary: The tevent library
  57. Summary(ja): Tevent ライブラリ
  58. Group: System Environment/Libraries
  59. %description -n compat32-%{name}
  60. Tevent is an event system based on the talloc memory management library.
  61. Tevent has support for many event types, including timers, signals, and
  62. the classic file descriptor events.
  63. Tevent also provide helpers to deal with asynchronous code providing the
  64. tevent_req (Tevent Request) functions.
  65. %endif
  66. %prep
  67. %setup -q -n tevent-%{version}
  68. %build
  69. %configure
  70. %configure --disable-rpath \
  71. --bundled-libraries=NONE \
  72. --builtin-libraries=replace \
  73. --extra-python=%{__python3}
  74. make %{?_smp_mflags} V=1
  75. %check
  76. make %{?_smp_mflags} check
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. #ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so.0
  81. #ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/libtevent.a
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files
  86. %defattr(-,root,root,-)
  87. %{_libdir}/libtevent.so.*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %{_includedir}/tevent.h
  91. %{_libdir}/libtevent.so
  92. %{_libdir}/pkgconfig/tevent.pc
  93. %files -n python-tevent
  94. %{python_sitearch}/_tevent.so
  95. %{python_sitearch}/tevent.py
  96. %files -n python3-tevent
  97. %{python3_sitearch}/tevent.py
  98. %{python3_sitearch}/_tevent.cpython*.so
  99. %if %{build_compat32}
  100. %files -n compat32-%{name}
  101. %defattr(-,root,root,-)
  102. %{_libdir}/libtevent.so.*
  103. %endif
  104. %post
  105. /sbin/ldconfig
  106. %postun
  107. /sbin/ldconfig
  108. %if %build_compat32
  109. %post -n compat32-%{name}
  110. /sbin/ldconfig
  111. %postun -n compat32-%{name}
  112. /sbin/ldconfig
  113. %endif
  114. %changelog
  115. * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.37-1
  116. - new upstream release.
  117. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.36-1
  118. - new upstream release.
  119. - dropped Patch1.
  120. - enabled python3 modules.
  121. * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.32-1
  122. - new upstream release.
  123. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.31-1
  124. - new upstream release.
  125. * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.28-1
  126. - new upstream release.
  127. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.26-1
  128. - new upstream release.
  129. * Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.25-1
  130. - new upstream release.
  131. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-2
  132. - added compat32 package.
  133. * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-1
  134. - new upstream release.
  135. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.22-1
  136. - new upstream release.
  137. * Mon Oct 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.21-2
  138. - moved libtevent to System Environment/Libraries Group
  139. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.21-1
  140. - new upstream release.
  141. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.20-1
  142. - new upstream release.
  143. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.19-1
  144. - new upstream release.
  145. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.17-1
  146. - new upstream release.
  147. - initial build for Vine Linux.
  148. * Fri May 21 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-8
  149. - Run make check during RPM build
  150. - Fix abi_check patch to guarantee script executability
  151. * Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7.1
  152. - Remove all references to ABI compatibility patch
  153. * Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7
  154. - Drop ABI compatibility patch (no longer needed)
  155. * Wed Sep 23 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-5
  156. - Add patch to fix a segfault case
  157. * Wed Sep 16 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-2
  158. - Fix abi compatibility with 0.9.3
  159. * Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-1
  160. - First independent release for tevent 0.9.8