kmid2-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %if %{?_dist_release} == "vl5"
  2. %define kde KDE4
  3. %else
  4. %define kde KDE
  5. %endif
  6. Name: kmid2
  7. Summary: A MIDI/karaoke player for %{kde}
  8. Summary(ja): %{kde} 向け MIDI/カラオケプレーヤー
  9. Version: 2.3.0
  10. Release: 4%{?_dist_release}
  11. Group: Applications/Multimedia
  12. # GPLv2+ for the code and the MMA examples, CC-BY-SA for the MIDI examples
  13. License: GPLv2+ and CC-BY-SA
  14. URL: http://userbase.kde.org/KMid2
  15. Source0: http://downloads.sourceforge.net/project/%{name}/%{version}/kmid-%{version}.tar.bz2
  16. # http://websvn.kde.org/?revision=1134129&view=revision
  17. # Fix a crash in the ALSA backend due to reloadDeviceList (kde#240394)
  18. Patch0: kmid-2.3.0-kde#240394.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: kdelibs4-devel
  21. #BuildRequires: kde-filesystem
  22. BuildRequires: cmake
  23. BuildRequires: alsa-lib-devel
  24. BuildRequires: drumstick-devel >= 0.3
  25. BuildRequires: gettext
  26. BuildRequires: desktop-file-utils
  27. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
  28. #{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
  29. Requires: oxygen-icon-theme
  30. Requires: drumstick >= 0.3
  31. Requires: %{name}-libs = %{version}-%{release}
  32. Obsoletes: kmid < 2.0-1
  33. Provides: kmid = %{version}-%{release}
  34. %description
  35. KMid2 is a MIDI/karaoke file player, with configurable midi mapper, real
  36. Session Management, drag & drop, customizable fonts, etc. It has a very
  37. nice interface which let you easily follow the tune while changing the
  38. color of the lyrics.
  39. It supports output through external synthesizers, AWE, FM and GUS cards.
  40. It also has a keyboard view to see the notes played by each instrument.
  41. %package libs
  42. Summary: Runtime libraries for %{name}
  43. Summary(ja): %{name} のランタイムライブラリ
  44. Group: System Environment/Libraries
  45. License: GPLv2+
  46. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
  47. #{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
  48. %description libs
  49. %{summary}.
  50. %package devel
  51. Summary: Development files for %{name}
  52. Summary(ja): %{name} の開発用ファイル
  53. Group: Development/Libraries
  54. License: GPLv2+
  55. Requires: %{name}-libs = %{version}-%{release}
  56. Obsoletes: kmid-devel < 2.0-1
  57. Provides: kmid-devel = %{version}-%{release}
  58. %description devel
  59. %{summary}.
  60. %prep
  61. %setup -q -n kmid-%{version}
  62. # zap bundled copy of drumstick to guarantee it's never used
  63. rm -rf drumstick
  64. %patch0 -p0 -b .kde#240394
  65. %build
  66. mkdir -p %{_target_platform}
  67. pushd %{_target_platform}
  68. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  69. %cmake \
  70. -DCMAKE_BUILD_TYPE=release \
  71. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  72. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  73. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  74. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  75. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  76. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  77. ..
  78. popd
  79. make %{?_smp_mflags} -C %{_target_platform}
  80. %install
  81. rm -rf %{buildroot}
  82. make install DESTDIR=%{buildroot} -C %{_target_platform}
  83. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/kmid.desktop
  84. %find_lang kmid
  85. %clean
  86. rm -rf %{buildroot}
  87. %post
  88. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  89. update-desktop-database &> /dev/null || :
  90. %postun
  91. update-desktop-database &> /dev/null || :
  92. if [ $1 -eq 0 ] ; then
  93. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  94. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  95. fi
  96. %posttrans
  97. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  98. %post libs -p /sbin/ldconfig
  99. %postun libs -p /sbin/ldconfig
  100. %files -f kmid.lang
  101. %defattr(-,root,root,-)
  102. %doc ChangeLog COPYING README TODO
  103. %{_bindir}/kmid
  104. %{_datadir}/kde4/apps/kmid/
  105. %{_datadir}/applications/kde4/kmid.desktop
  106. %{_datadir}/config.kcfg/*
  107. %{_datadir}/kde4/services/*
  108. %{_datadir}/kde4/servicetypes/*
  109. %{_datadir}/icons/hicolor/*/apps/*
  110. %{_libdir}/kde4/*
  111. %doc %{_docdir}/HTML/*/kmid/
  112. %files libs
  113. %defattr(-,root,root,-)
  114. %{_libdir}/libkmidbackend.so.*
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %{_libdir}/libkmidbackend.so
  118. %{_includedir}/kde4/kmid/
  119. %changelog
  120. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-4
  121. - removed --with-kde from %%find_lang
  122. * Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-3
  123. - Initial build for Vine Linux
  124. * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-2
  125. - Fix crash in ALSA backend due to reloadDeviceList (kde#240394, upstream patch)
  126. * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-1
  127. - Update to 2.3.0 (new versioning scheme)
  128. - BR drumstick-devel >= 0.3
  129. - Requires: drumstick >= 0.3
  130. - Drop obsolete drumstick-version patch
  131. - Examples now partly CC-BY-SA, partly GPLv2+ (instead of CC-BY)
  132. - Use _kde4_version macro
  133. - Add -devel and -libs subpackages
  134. - Package COPYING
  135. * Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-2
  136. - Requires: drumstick >= 0.2.99-0.3
  137. * Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-1
  138. - Update to 0.2.1
  139. - Drop upstreamed timidity-pulseaudio patch
  140. - Drop dont-translate-output-names patch, should not be needed anymore
  141. - BR drumstick-devel >= 0.2.99-0.3 (0.2.1 needs the 20100208 snapshot)
  142. - relax drumstick version check in CMakeLists.txt as 0.3 is not out yet
  143. * Fri Feb 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-3
  144. - Don't translate output names, breaks autospawning sequencers
  145. * Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-2
  146. - Support PulseAudio when autospawning TiMidity++ (-OO -opulse switches)
  147. * Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-1
  148. - Update to 0.2.0
  149. - The examples with copyright issues have been dropped by upstream
  150. - BR drumstick-devel instead of aseqmm-devel
  151. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-4
  152. - Fix the kde4-config output parsing for 4.4 ("KDE Development Platform:")
  153. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-3
  154. - Correctly require at least the kdelibs version used for building
  155. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-2
  156. - Remove nonsense Requires: kdelibs4 >= %%{version}, as %%{version} is 0.1.1
  157. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-1
  158. - First Fedora package, replaces kmid