python-qt5-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604
  1. %{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
  2. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  3. %{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
  4. %global __python3 /usr/bin/python3
  5. # prevent anything matching from being scanned for provides
  6. %define filter_provides_in(P) %{expand: \
  7. %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
  8. }
  9. # prevent anything matching from being scanned for requires
  10. %define filter_requires_in(P) %{expand: \
  11. %global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
  12. }
  13. # filter anything matching out of the provides stream
  14. %define filter_from_provides() %{expand: \
  15. %global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
  16. }
  17. # filter anything matching out of the requires stream
  18. %define filter_from_requires() %{expand: \
  19. %global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
  20. }
  21. # actually set up the filtering bits
  22. %define filter_setup %{expand: \
  23. %global _use_internal_dependency_generator 0 \
  24. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
  25. %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
  26. %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
  27. }
  28. %global with_python3 1
  29. %global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  30. %global with_python2 1
  31. %global python2_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  32. # enable/disable individual modules
  33. # drop power64, it's not supported yet (than)
  34. %ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
  35. %global webengine 1
  36. %endif
  37. %global webkit 1
  38. %global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  39. Summary: PyQt5 is Python bindings for Qt5
  40. Name: python-qt5
  41. Version: 5.6
  42. Release: 6%{?_dist_release}
  43. # all BSD, except for GPLv2+ dbus bindings and examples
  44. License: BSD and GPLv2+
  45. Url: http://www.riverbankcomputing.com/software/pyqt/
  46. %if 0%{?snap:1}
  47. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt5/PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}.tar.gz
  48. %else
  49. Source0: http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-%{version}/PyQt5_gpl-%{version}.tar.gz
  50. %endif
  51. Source1: macros.pyqt5
  52. # wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
  53. Source2: pyuic5.sh
  54. ## upstream patches
  55. ## upstreamable patches
  56. Patch0: python-qt5_sipdir.patch
  57. Patch1: PyQt5_gpl-5.6-dbus_ftbfs.patch
  58. BuildRequires: chrpath
  59. BuildRequires: findutils
  60. BuildRequires: pkgconfig(dbus-1)
  61. BuildRequires: pkgconfig(dbus-python)
  62. BuildRequires: pkgconfig(phonon4qt5)
  63. BuildRequires: pkgconfig(Qt5Core) >= 5.5
  64. BuildRequires: pkgconfig(Enginio)
  65. BuildRequires: pkgconfig(Qt5Bluetooth)
  66. BuildRequires: pkgconfig(Qt5DBus)
  67. BuildRequires: pkgconfig(Qt5Declarative)
  68. BuildRequires: pkgconfig(Qt5Designer)
  69. BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
  70. BuildRequires: pkgconfig(Qt5Location)
  71. BuildRequires: pkgconfig(Qt5Nfc)
  72. BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
  73. BuildRequires: pkgconfig(Qt5Positioning)
  74. BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
  75. BuildRequires: pkgconfig(Qt5Script)
  76. BuildRequires: pkgconfig(Qt5Sensors)
  77. BuildRequires: pkgconfig(Qt5SerialPort)
  78. BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
  79. BuildRequires: pkgconfig(Qt5X11Extras)
  80. BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
  81. BuildRequires: pkgconfig(Qt5WebChannel)
  82. BuildRequires: pkgconfig(Qt5WebSockets)
  83. BuildRequires: python-devel python
  84. BuildRequires: sip-devel >= 4.18
  85. %if 0%{?with_python3}
  86. BuildRequires: python3-devel python3
  87. BuildRequires: python3-sip-devel >= 4.18
  88. BuildRequires: dbus-python3
  89. %endif # with_python3
  90. # when split out
  91. %if 0%{?webengine} || 0%{?webkit}
  92. Obsoletes: python-qt5 < 5.5.1-10
  93. %endif
  94. Requires: %{name}-rpm-macros = %{version}-%{release}
  95. Requires: dbus-python
  96. BuildRequires: qt5-qtbase-private-devel
  97. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  98. %{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
  99. %filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
  100. %if 0%{?with_python3}
  101. %filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
  102. %endif
  103. %filter_setup
  104. Provides: PyQt5 = %{version}-%{release}
  105. Provides: PyQt5%{?_isa} = %{version}-%{release}
  106. Provides: python-PyQt5 = %{version}-%{release}
  107. Provides: python-PyQt5%{?_isa} = %{version}-%{release}
  108. Provides: python2-PyQt5 = %{version}-%{release}
  109. Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
  110. Provides: python2-qt5 = %{version}-%{release}
  111. Provides: python2-qt5%{?_isa} = %{version}-%{release}
  112. %description
  113. PyQt5 is Python bindings for Qt5.
  114. %package devel
  115. Summary: Development files for %{name}
  116. Requires: %{name}%{?_isa} = %{version}-%{release}
  117. Requires: qt5-qtbase-devel
  118. Requires: sip-devel
  119. Provides: PyQt5-devel = %{version}-%{release}
  120. Provides: python2-PyQt5-devel = %{version}-%{release}
  121. %description devel
  122. Files needed to build other bindings for C++ classes that inherit from any
  123. of the Qt5 classes (e.g. KDE or your own).
  124. %package rpm-macros
  125. Summary: RPM macros %{name}
  126. # when split out
  127. Conflicts: python-qt5 < 5.6
  128. Conflicts: python3-qt5 < 5.6
  129. BuildArch: noarch
  130. %description rpm-macros
  131. %{summary}.
  132. %package -n python3-qt5
  133. Summary: Python 3 bindings for Qt5
  134. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  135. %{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  136. # when split out
  137. %if 0%{?webengine} || 0%{?webkit}
  138. Obsoletes: python3-qt5 < 5.5.1-10
  139. %endif
  140. Provides: python3-PyQt5 = %{version}-%{release}
  141. Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
  142. Requires: %{name}-rpm-macros = %{version}-%{release}
  143. Requires: dbus-python3
  144. %description -n python3-qt5
  145. %{summary}.
  146. %package -n python3-qt5-devel
  147. Summary: Python 3 bindings for Qt5
  148. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  149. Requires: qt5-qtbase-devel
  150. Requires: python3-sip-devel
  151. Provides: python3-PyQt5-devel = %{version}-%{release}
  152. %description -n python3-qt5-devel
  153. Files needed to build other bindings for C++ classes that inherit from any
  154. of the Qt5 classes
  155. %package doc
  156. Summary: Developer documentation for %{name}
  157. Provides: PyQt5-doc = %{version}-%{release}
  158. BuildArch: noarch
  159. %description doc
  160. %{summary}.
  161. %if 0%{?webengine}
  162. %package webengine
  163. Summary: Python bindings for Qt5 WebEngine
  164. BuildRequires: pkgconfig(Qt5WebEngine)
  165. Obsoletes: python-qt5 < 5.5.1-10
  166. Requires: %{name}%{?_isa} = %{version}-%{release}
  167. %description webengine
  168. %package -n python3-qt5-webengine
  169. Summary: Python bindings for Qt5 WebEngine
  170. Obsoletes: python3-webengine < 5.5.1-13
  171. Obsoletes: python3-qt5 < 5.5.1-10
  172. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  173. %description -n python3-qt5-webengine
  174. %endif
  175. %if 0%{?webkit}
  176. %package webkit
  177. Summary: Python bindings for Qt5 Webkit
  178. BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
  179. Obsoletes: python3-webkit < 5.5.1-12
  180. Obsoletes: python-qt5 < 5.5.1-10
  181. Requires: %{name}%{?_isa} = %{version}-%{release}
  182. %description webkit
  183. %package -n python3-qt5-webkit
  184. Summary: Python bindings for Qt5 Webkit
  185. Obsoletes: python3-qt5 < 5.5.1-10
  186. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  187. %description -n python3-qt5-webkit
  188. %endif
  189. %prep
  190. %setup -q -n PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}
  191. %patch0 -p1
  192. %patch1 -p1
  193. %build
  194. PATH=%{_qt5_bindir}:$PATH ; export PATH
  195. # Python 2 build:
  196. %if 0%{?with_python2}
  197. mkdir %{_target_platform}
  198. pushd %{_target_platform}
  199. %{__python} ../configure.py \
  200. --assume-shared \
  201. --confirm-license \
  202. --qmake=%{_qt5_qmake} \
  203. --qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci \
  204. --verbose \
  205. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  206. QMAKE_CXXFLAGS_RELEASE="%{optflags}" \
  207. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  208. make %{?_smp_mflags}
  209. popd
  210. %endif # with_python2
  211. # Python 3 build:
  212. %if 0%{?with_python3}
  213. mkdir %{_target_platform}-python3
  214. pushd %{_target_platform}-python3
  215. %{__python3} ../configure.py \
  216. --assume-shared \
  217. --confirm-license \
  218. --qmake=%{_qt5_qmake} \
  219. --no-qsci-api \
  220. --verbose \
  221. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  222. QMAKE_CXXFLAGS_RELEASE="%{optflags}" \
  223. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  224. make %{?_smp_mflags}
  225. popd
  226. %endif # with_python3
  227. %install
  228. # Python 3 build:
  229. %if 0%{?with_python3}
  230. make install DESTDIR=%{buildroot} INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
  231. # ensure .so modules are executable for proper -debuginfo extraction
  232. for i in %{buildroot}%{python3_sitearch}/PyQt5/*.so %{buildroot}%{python3_dbus_dir}/pyqt5.so ; do
  233. chmod a+rx $i
  234. done
  235. %endif # with_python3
  236. # Python 2 build:
  237. %if 0%{?with_python2}
  238. make install DESTDIR=%{buildroot} INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  239. # ensure .so modules are executable for proper -debuginfo extraction
  240. for i in %{buildroot}%{python_sitearch}/PyQt5/*.so %{buildroot}%{python2_dbus_dir}/pyqt5.so ; do
  241. chmod a+rx $i
  242. done
  243. %endif # with_python2
  244. # remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
  245. rm -rfv %{buildroot}%{python_sitearch}/PyQt5/uic/port_v3/
  246. # remove Python2 code from Python3 directory (for when/if we support python3 here)
  247. rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
  248. # rpm macros
  249. install -p -m644 -D %{SOURCE1} \
  250. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  251. sed -i \
  252. -e "s|@@NAME@@|%{name}|g" \
  253. -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
  254. -e "s|@@VERSION@@|%{version}|g" \
  255. -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
  256. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  257. %if 0%{?with_python3}
  258. # install pyuic5 wrapper to handle both/either python2/python3
  259. rm -fv %{buildroot}%{_bindir}/pyuic5
  260. install -p -m755 -D %{SOURCE2} \
  261. %{buildroot}%{_bindir}/pyuic5
  262. sed -i \
  263. -e "s|@PYTHON3@|%{__python3}|g" \
  264. -e "s|@PYTHON2@|%{__python}|g" \
  265. %{buildroot}%{_bindir}/pyuic5
  266. %endif
  267. %if 0%{?with_python2}
  268. %files
  269. %doc NEWS README
  270. %license LICENSE
  271. %{python2_dbus_dir}/pyqt5.so
  272. %{_qt5_plugindir}/PyQt5/
  273. %dir %{python_sitearch}/PyQt5/
  274. %{python_sitearch}/PyQt5/__init__.py*
  275. %{python_sitearch}/PyQt5/Enginio.so
  276. %{python_sitearch}/PyQt5/Qt.so
  277. %{python_sitearch}/PyQt5/QtBluetooth.so
  278. %{python_sitearch}/PyQt5/QtCore.so
  279. %{python_sitearch}/PyQt5/QtDBus.so
  280. %{python_sitearch}/PyQt5/QtDesigner.so
  281. %{python_sitearch}/PyQt5/QtGui.so
  282. %{python_sitearch}/PyQt5/QtHelp.so
  283. %{python_sitearch}/PyQt5/QtLocation.so
  284. %{python_sitearch}/PyQt5/QtMultimedia.so
  285. %{python_sitearch}/PyQt5/QtMultimediaWidgets.so
  286. %{python_sitearch}/PyQt5/QtNetwork.so
  287. %{python_sitearch}/PyQt5/QtNfc.so
  288. %{python_sitearch}/PyQt5/QtOpenGL.so
  289. %{python_sitearch}/PyQt5/QtPositioning.so
  290. %{python_sitearch}/PyQt5/QtPrintSupport.so
  291. %{python_sitearch}/PyQt5/QtQml.so
  292. %{python_sitearch}/PyQt5/QtQuick.so
  293. %{python_sitearch}/PyQt5/QtQuickWidgets.so
  294. %{python_sitearch}/PyQt5/QtSensors.so
  295. %{python_sitearch}/PyQt5/QtSerialPort.so
  296. %{python_sitearch}/PyQt5/QtSql.so
  297. %{python_sitearch}/PyQt5/QtSvg.so
  298. %{python_sitearch}/PyQt5/QtTest.so
  299. %{python_sitearch}/PyQt5/QtWebChannel.so
  300. %{python_sitearch}/PyQt5/QtWebSockets.so
  301. %{python_sitearch}/PyQt5/QtWidgets.so
  302. %{python_sitearch}/PyQt5/QtX11Extras.so
  303. %{python_sitearch}/PyQt5/QtXml.so
  304. %{python_sitearch}/PyQt5/QtXmlPatterns.so
  305. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
  306. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
  307. %{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
  308. %{python_sitearch}/PyQt5/uic/
  309. %{_qt5_plugindir}/designer/libpyqt5.so
  310. %if 0%{?webengine}
  311. %files webengine
  312. %{python_sitearch}/PyQt5/QtWebEngineCore.*
  313. %{python_sitearch}/PyQt5/QtWebEngineWidgets.*
  314. %endif
  315. %if 0%{?webkit}
  316. %files webkit
  317. %{python_sitearch}/PyQt5/QtWebKit.*
  318. %{python_sitearch}/PyQt5/QtWebKitWidgets.*
  319. %endif
  320. %files rpm-macros
  321. %{rpm_macros_dir}/macros.pyqt5
  322. %files devel
  323. %{_bindir}/pylupdate5
  324. %{_bindir}/pyrcc5
  325. %{_bindir}/pyuic5
  326. %{_datadir}/sip/PyQt5/
  327. %endif
  328. %if 0%{?with_python3}
  329. %files -n python3-qt5
  330. %doc NEWS README
  331. %license LICENSE
  332. %{python3_dbus_dir}/pyqt5.so
  333. %{python3_sitearch}/PyQt5
  334. %if 0%{?webengine}
  335. %exclude %{python3_sitearch}/PyQt5/QtWebEngineCore.*
  336. %exclude %{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
  337. %endif
  338. %if 0%{?webkit}
  339. %exclude %{python3_sitearch}/PyQt5/QtWebKit.*
  340. %exclude %{python3_sitearch}/PyQt5/QtWebKitWidgets.*
  341. %endif
  342. %if 0%{?webengine}
  343. %files -n python3-qt5-webengine
  344. %{python3_sitearch}/PyQt5/QtWebEngineCore.*
  345. %{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
  346. %endif
  347. %if 0%{?webkit}
  348. %files -n python3-qt5-webkit
  349. %{python3_sitearch}/PyQt5/QtWebKit.*
  350. %{python3_sitearch}/PyQt5/QtWebKitWidgets.*
  351. %endif
  352. %files -n python3-qt5-devel
  353. %{_bindir}/pylupdate5
  354. %{_bindir}/pyrcc5
  355. %{_bindir}/pyuic5
  356. %{_datadir}/python3-sip/PyQt5/
  357. %endif # with_python3
  358. %files doc
  359. %doc doc/*
  360. %doc examples/
  361. # avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
  362. %dir %{_qt5_datadir}/qsci/
  363. %dir %{_qt5_datadir}/qsci/api/
  364. %dir %{_qt5_datadir}/qsci/api/python/
  365. %doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
  366. %changelog
  367. * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
  368. - initial build for Vine Linux.
  369. * Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
  370. - BR: qt5-qtbase-private-devel
  371. - python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
  372. * Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
  373. - rebuild (qt5)
  374. * Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
  375. - drop ppc ppc64 ppc64le, it's not supported yet
  376. * Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
  377. - -rpm-macros: Conflicts: python(3)-qt5 < 5.6
  378. * Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
  379. - PyQt5-5.6
  380. * Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
  381. - rebuild (sip), re-enable -webengine for secondary archs
  382. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
  383. - limit -webengine support to just primary archs (for now)
  384. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
  385. - -rpm-macros subpkg
  386. * Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
  387. - rebuild (qt5-qtenginio)
  388. * Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
  389. - -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
  390. * Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
  391. - add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
  392. * Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
  393. - python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
  394. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
  395. - fix python3-qt5-webengine name
  396. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
  397. - fix python3-qt5-webkit name
  398. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
  399. - use safer subdir builds
  400. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
  401. - -webengine,-webkit subpkgs
  402. * Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
  403. - Enabled QtWebEngine for Fedora >= 24
  404. * Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
  405. - rebuild
  406. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
  407. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  408. * Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
  409. - explicitly set CFLAGS,CXXFLAGS,LFLAGS
  410. * Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
  411. - %%description: mention PyQt5
  412. * Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
  413. - rebuild (qt5), Provides: python2-qt5
  414. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
  415. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  416. * Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
  417. - rebuild (qt5)
  418. * Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
  419. - 5.5.1
  420. - enable qtenginio, fix pyuic5 wrapper, use %%license
  421. * Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
  422. - rebuild (qt5)
  423. * Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
  424. - 5.5
  425. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
  426. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  427. * Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
  428. - 5.4.2
  429. * Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
  430. - wrong python release used in pyuic5 launch script (#1193107)
  431. - -doc: add qsci doc QyQt5.api content
  432. - enable Qt5WebChannel/Qt5WebSockets support
  433. * Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  434. - Add patch to fix python3 sip installation dir (#1228432)
  435. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  436. - Rebuilt for GCC 5 C++11 ABI change
  437. * Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
  438. - rebuild (sip)
  439. * Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
  440. - 5.4.1
  441. * Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
  442. - rebuild (sip)
  443. * Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
  444. - +macros.pyqt5
  445. * Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
  446. - -devel: restore dep on base pkg
  447. * Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
  448. - python3-qt5-devel subpkg
  449. * Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
  450. - ensure .so modules are executable (for proper -debuginfo extraction)
  451. * Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
  452. - 5.4
  453. * Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
  454. - restore python3 support
  455. * Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
  456. - pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
  457. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
  458. - try to determine dbus-python install paths dynamically (#1161121)
  459. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
  460. - Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
  461. - python2_sitelib should be python2_sitearch (#1161121)
  462. * Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  463. - PyQt-gpl-5.3.2
  464. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  465. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  466. * Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
  467. - PyQt-gpl-5.3.1
  468. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
  469. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  470. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
  471. - python3: (Build)Requires: python3-dbus
  472. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
  473. - PyQt-gpl-5.3
  474. - +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
  475. * Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  476. - rebuild (f21-python)
  477. - +Qt5Positioning,Qt5Sensors support
  478. * Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  479. - PyQt-5.2.1
  480. * Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
  481. - Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
  482. * Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
  483. - python3-qt5 support
  484. * Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
  485. - Provides: PyQt5
  486. * Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
  487. - BR: python2-devel, use %%__python2 macro
  488. * Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
  489. - PyQt-5.2