texlive-collection-langhungarian-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
  3. ## tlpdb2rpmspec collection-langhungarian
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %bcond_with firstbuild
  8. %define tex_destdir %{_datadir}
  9. %define texmf %{tex_destdir}/texmf
  10. %define texlive_src %{tex_destdir}/texlive-sources
  11. %define build_tex_destdir %{buildroot}%{tex_destdir}
  12. %define build_texmf %{buildroot}%{texmf}
  13. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  14. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  15. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  16. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  17. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  18. %define vartexfonts %{_var}/lib/texmf/fonts
  19. Summary: TeX Live: Hungarian
  20. Summary(ja): TeX Live: Hungarian
  21. Name: texlive-collection-langhungarian
  22. Version: 2011
  23. Release: 1%{?_dist_release}
  24. License: LPPL, GPL+
  25. Group: Applications/Publishing
  26. URL:http://www.tug.org/texlive/
  27. Requires: texlive = %{version}
  28. Requires: texlive-collection-basic = %{version}
  29. Requires(post): texlive = %{version}
  30. Requires(postun): texlive = %{version}
  31. BuildRequires: texlive-sources = %{version}
  32. BuildArch: noarch
  33. Buildroot: %{_tmppath}/%{name}-%{version}-root
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: munepi
  37. %description
  38. The TeX Live software distribution offers a complete TeX system for a
  39. variety of Unix, Macintosh, Windows and other platforms. It
  40. encompasses programs for editing, typesetting, previewing and printing
  41. of TeX documents in many different languages, and a large collection
  42. of TeX macros and font libraries.
  43. The distribution includes extensive general documentation about TeX,
  44. as well as the documentation for the included software packages.
  45. This package is a collection of Hungarian:
  46. Support for typesetting Hungarian.
  47. This package contains the following CTAN packages:
  48. magyar: Hungarian language definition for Babel.
  49. hyphen-hungarian: Hungarian hyphenation patterns.
  50. %description -l ja
  51. TeX Live ソフトウェアディストリビューションは、
  52. さまざまな Unix, Macintosh, Windows、および
  53. 他のプラットホームに対して完全な TeX システムを提供します。
  54. 多くの異なった言語を含む TeX ドキュメントの
  55. 編集、組版、閲覧、印刷するためのプログラム、
  56. そして、TeX マクロやフォントライブラリの大きなコレクションを
  57. 同梱しています。
  58. このディストリビューションは
  59. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  60. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  61. このパッケージは以下のようなパッケージ集です。
  62. Hungarian:
  63. Support for typesetting Hungarian.
  64. このパッケージは以下の CTAN パッケージを含んでいます:
  65. magyar: Hungarian language definition for Babel.
  66. hyphen-hungarian: Hungarian hyphenation patterns.
  67. %package doc
  68. Summary: TeX Live: Documentation files of %{name}
  69. Group: Applications/Publishing
  70. Requires: %{name} = %{version}-%{release}
  71. %description doc
  72. This package contains documentation files of %{name}.
  73. %prep
  74. %build
  75. %install
  76. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  77. PREF=%{buildroot}%{tex_destdir}
  78. manifest=(
  79. texmf-dist/doc/latex/magyar/magyar.ldf
  80. )
  81. %__mkdir_p ${PREF}/texmf-dist
  82. for i in "${manifest[@]}"; do
  83. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  84. done
  85. ## make symlinks of core script utils
  86. mk_symlinks=(
  87. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  88. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  89. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  90. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  91. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  92. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  93. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  94. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  95. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  96. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  97. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  98. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  99. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  100. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  101. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  102. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  103. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  104. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  105. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  106. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  107. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  108. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  109. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  110. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  111. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  112. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  113. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  114. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  115. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  116. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  117. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  118. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  119. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  120. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  121. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  122. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  123. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  124. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  125. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  126. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  127. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  128. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  129. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  130. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  131. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  132. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  133. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  134. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  135. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  136. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  137. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  138. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  139. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  140. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  141. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  142. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  143. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  144. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  145. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  146. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  147. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  148. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  149. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  150. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  151. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  152. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  153. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  154. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  155. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  156. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  157. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  158. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  159. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  160. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  161. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  162. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  163. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  164. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  165. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  166. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  167. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  168. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  169. )
  170. %__mkdir_p %{buildroot}%{_bindir}
  171. pushd %{buildroot}%{_bindir}
  172. for i in "${mk_symlinks[@]}"; do
  173. tlc=$(echo $i | cut -f 1 -d",")
  174. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  175. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  176. [ "%{name}" = "$tlc" ] || continue
  177. [ -f $rlnk ] || exit 1
  178. %__ln_s $rlnk $lnk || exit 1
  179. done
  180. popd
  181. ## Files list
  182. find %{buildroot} -type f -or -type l | \
  183. %__sed -e "s|%{buildroot}||g" > filelist.full
  184. find %{buildroot}%{texmf}-dist -type d | \
  185. %__sed -e "s|^%{buildroot}|%dir |" \
  186. -e "s|$|/|" >> filelist.full
  187. ## subpackages
  188. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  189. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  190. %__mv -f filelist.tmp filelist.full
  191. %clean
  192. %__rm -rf %{buildroot}
  193. %post
  194. %{exec_texhash}
  195. rpm -q --quiet texlive-common || exit 0
  196. echo -n " "
  197. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  198. exit 0
  199. %postun
  200. if [ "$1" = 0 ]; then
  201. %{exec_texhash}
  202. fi
  203. exit 0
  204. %files -f filelist.full
  205. %defattr(-,root,root,-)
  206. %files -f filelist.doc doc
  207. %defattr(-,root,root,-)
  208. %changelog
  209. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  210. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langhungarian
  211. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  212. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langhungarian
  213. - make symlinks of core script utils (texlive-collection-binextra,
  214. texlive-collection-context, texlive-collection-fontutils,
  215. texlive-collection-langgreek, texlive-collection-langindic,
  216. texlive-collection-latex, texlive-collection-latexextra,
  217. texlive-collection-latexrecommended, texlive-collection-pictures,
  218. texlive-collection-pstricks, texlive-collection-science)
  219. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  220. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langhungarian
  221. - improved %%post
  222. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  223. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langhungarian
  224. - removed arch dependent binaries (texlive-collection-latexextra)
  225. - fixed perl path
  226. - improved updmap process in %%post and %%postun
  227. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  228. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhungarian