123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174 |
- %define pkgname gstreamer-plugins-ffmpeg
- %define name self-build-%{pkgname}
- %define version 0.10.13
- %define release 2%{?_dist_release}
- %define sourceurl0 http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
- Summary: Package to automatically build %{pkgname} rpm package
- Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
- Name: %{name}
- Version: %{version}
- Release: %{release}
- Source0: %{pkgname}-vl.spec
- Source1: gst-ffmpeg-0.10.13_gcc47.patch
- License: GPLv2+ and LGPLv2+
- Group: Restricted Software
- Requires(post): self-build-setup >= 0.9.9
- # (build)requies of target package.
- Requires: gstreamer >= 0.10.0
- Requires: gstreamer-plugins-base >= 0.10.0
- Requires(post): gstreamer-devel >= 0.10.0
- Requires(post): gstreamer-plugins-base-devel >= 0.10.0
- Requires(post): liboil-devel
- Requires(post): bzip2-devel
- Requires(post): self-build-ffmpeg
- BuildArch: noarch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Packager: munepi
- %description
- GStreamer is a streaming media framework, based on graphs of filters which
- operate on media data. Applications using this library can do anything
- from real-time sound processing to playing videos, and just about anything
- else media-related. Its plugin-based architecture means that new data
- types or processing capabilities can be added simply by installing new
- plugins.
- This package provides FFmpeg-based GStreamer plug-ins.
- If you install this package, it automaticaly downloads source
- code, compile it, and create rpm packages of
- %{pkgname}-%{version}.
- And the created rpm packages are automatically installed
- if installation is executed by apt-get command or synaptic
- package manager.
- [Note]
- This package requires many other packages to compile
- targetsoftware. So it consume more disk space than usual.
- Also installation takes logner time because of compilation.
- (This will take a few minutes to quarter or half of an hour,
- depends on building environment)
- [About self-build package]
- For some kind of software, distributing of binary package
- may viorate the patent or law. Therefore we chose self-build
- packge, create binary package on your machine, for such kind
- of softwares instead of distributing binary package.
- Please obey the national law when you use the created binary
- packages. And if you want to use the softwares using patented
- thechnology, it may be required to get a permission, make an
- agreement or purchas a license. Please consider it with your
- purpose or way of use and take appropriate action.
- %description -l ja
- GStreamer はメディアデータ操作用の filter graph をベースにし
- たストリーミングメディアフレームワークです。 このライブラリを
- 使用すればアプリケーションは、サウンドのリアルタイム処理から
- ビデオ再生まで、メディアに関係する全ての機能が利用できます。
- また Gstremer はプラグイン方式を採用していることから、新しい
- 種類のデータや機能への対応が、プラグインを追加することで簡単
- に実現できます。
- このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
- ます。
- このパッケージをインストールすると、自動的にソースコードをダ
- ウンロードしてコンパイルし、%{pkgname}-%{version}
- の rpm パッケージを作成します。
- また apt-get コマンドや synaptic パッケージマネージャから実行
- した場合は、作成された rpm パッケージのインストールも自動的に
- 行います。
- [注意]
- コンパイルに必要な多くの関連パッケージを要求するので通常より
- ディスクの領域を多く消費します。
- またインストール時にコンパイルを行うため、通常より時間がかか
- る場合があります。(環境にもよりますが数分から数十分程度)
- [self-build パッケージについて]
- ソフトウェアによってはバイナリパッケージの配布が特許や法律に
- 違反する可能性があるものがあります。その為、このような問題が
- 懸念されるソフトウェアについてはバイナリパッケージを直接配布
- せずに、ユーザの環境でバイナリを作成する self-build パッケー
- ジという方法を採っています。
- 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
- アのライセンス、および利用する国の各種法令に従ってください。
- また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
- センスの購入などが必要となる場合がありますので、利用する目的
- や形態に応じて各自で判断し適切な対応を取ってください。
- %prep
- [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %posttrans
- /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 126000
- %files
- %defattr(-,root,root)
- %{_datadir}/%{name}/*
- %changelog
- * Tue Oct 22 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.13-2
- - added Source1 to build with gcc-4.7 or later.
- * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
- - new upstream release
- * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
- - new upstream release
- * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
- - dropped --with-system-ffmpeg in configure options
- (gstreamer-plugins-ffmpeg-vl.spec)
- * Sun Feb 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-2
- - added Requires(post): self-build-ffmpeg
- - already used system ffmpeg
- * Sat Jul 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-1
- - new upstream release
- * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
- - new upstream release
- - renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
- * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
- - new upstream release
- * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
- - new upstream release
- * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
- - added BuildArch: noarch
- - avoided to execute self-build-rpm.sh on RPM transaction
- - moved %%post actions to %%posttrans
- * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
- - new upstream release
- - corrected %%description
- * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
- - initial build
- ### end of file
|