graphviz-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308
  1. Name: graphviz
  2. Summary: Graph Visualization Tools
  3. Version: 2.26.3
  4. Release: 2%{?_dist_release}
  5. Group: Applications/Graphics
  6. License: CPL
  7. URL: http://www.graphviz.org/
  8. Source: http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
  9. Patch10: %{name}-%{version}_dont_regard_tiger_as_the_only_ppc.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: bison
  12. BuildRequires: cairo-devel
  13. BuildRequires: expat-devel
  14. BuildRequires: flex
  15. BuildRequires: fontconfig-devel
  16. BuildRequires: freetype2-devel
  17. BuildRequires: gd-devel
  18. BuildRequires: gtk2-devel
  19. BuildRequires: guile-devel
  20. BuildRequires: libjpeg-turbo-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  24. BuildRequires: libXaw-devel
  25. BuildRequires: libXext-devel
  26. BuildRequires: m4
  27. BuildRequires: perl
  28. BuildRequires: python-devel
  29. BuildRequires: ruby-devel
  30. BuildRequires: swig
  31. BuildRequires: tcl >= 8.4
  32. BuildRequires: tk >= 8.4
  33. BuildRequires: zlib-devel
  34. Requires: urw-fonts
  35. # only for this release
  36. BuildConflicts: graphviz-devel
  37. %description
  38. A collection of tools and tcl packages for the manipulation and layout
  39. of graphs (as in nodes and edges, not as in barcharts).
  40. %package devel
  41. Group: Development/Libraries
  42. Summary: Development tools for version %{version} of %{name}
  43. Requires: %{name} = %{version}
  44. %description devel
  45. The %{name}-devel package contains the header files
  46. and man3 pages necessary for developing programs
  47. using version %{version} of the %{name} libraries.
  48. %package doc
  49. Summary: PDF and HTML documents for graphviz
  50. Group: Applications/Documentation
  51. %description doc
  52. Provides some additional PDF and HTML documentation for graphviz.
  53. %package guile
  54. Group: Applications/Graphics
  55. Summary: Guile extension for graphviz
  56. Requires: %{name} = %{version}-%{release}, guile
  57. %description guile
  58. Guile extension for graphviz.
  59. %package perl
  60. Group: Applications/Graphics
  61. Summary: Perl extension for graphviz
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  64. %description perl
  65. Perl extension for graphviz.
  66. %package python
  67. Group: Applications/Graphics
  68. Summary: Python extension for graphviz
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: python
  71. %description python
  72. Python extension for graphviz.
  73. %package ruby
  74. Group: Applications/Multimedia
  75. Summary: Ruby extension for graphviz
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: ruby
  78. %description ruby
  79. Ruby extension for graphviz.
  80. %package tcl
  81. Group: Applications/Graphics
  82. Summary: Tcl extension & tools for graphviz
  83. Requires: tcl >= 8.4, tk >= 8.4
  84. Requires: %{name} = %{version}
  85. %description tcl
  86. Various tcl packages (extensions) for the graphviz tools.
  87. %prep
  88. %setup -q
  89. %patch10 -p1
  90. # using archdir instead of sitearchdir for Vine
  91. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  92. autoreconf -f -i
  93. %build
  94. # XXX ix86 only used to have -ffast-math, let's use everywhere
  95. %{expand: %%define optflags %{optflags} -ffast-math}
  96. %configure \
  97. --with-x \
  98. --disable-static \
  99. --with-mylibgd \
  100. --with-ipsepcola \
  101. --with-pangocairo \
  102. --with-gdk-pixbuf \
  103. --without-mylibgd \
  104. --without-ming \
  105. --disable-sharp \
  106. --enable-guile \
  107. --enable-io \
  108. --disable-java \
  109. --disable-lua \
  110. --disable-ocaml \
  111. --enable-perl \
  112. --disable-php \
  113. --enable-python \
  114. --disable-r \
  115. --enable-ruby \
  116. --enable-tcl
  117. make %{?_smp_mflags}
  118. %install
  119. rm -rf $RPM_BUILD_ROOT __doc
  120. make DESTDIR=$RPM_BUILD_ROOT \
  121. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  122. pkgconfigdir=%{_libdir}/pkgconfig \
  123. install
  124. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  125. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  126. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  127. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  128. %clean
  129. rm -rf $RPM_BUILD_ROOT
  130. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  131. %post
  132. /sbin/ldconfig
  133. %{_bindir}/dot -c
  134. # if there is no dot after everything else is done, then remove config
  135. %postun
  136. if [ $1 -eq 0 ]; then
  137. rm -f %{_libdir}/graphviz/config || :
  138. fi
  139. /sbin/ldconfig
  140. %files
  141. %defattr(-,root,root)
  142. %doc AUTHORS COPYING ChangeLog NEWS README
  143. %{_bindir}/*
  144. %dir %{_datadir}/%{name}
  145. %{_datadir}/%{name}/lefty
  146. %{_mandir}/man1/*
  147. %{_mandir}/man7/*
  148. %dir %{_libdir}/%{name}
  149. %{_libdir}/*.so.*
  150. %{_libdir}/%{name}/*.so.*
  151. %exclude %{_libdir}/graphviz/*/*
  152. %files devel
  153. %defattr(-,root,root)
  154. %{_includedir}/%{name}
  155. %{_libdir}/*.so
  156. %{_libdir}/%{name}/*.so
  157. %{_libdir}/pkgconfig/*.pc
  158. %{_datadir}/%{name}/graphs
  159. %{_mandir}/man3/*.3.gz
  160. %files doc
  161. %defattr(-,root,root,-)
  162. %doc __doc/*
  163. %files guile
  164. %defattr(-,root,root,-)
  165. %{_libdir}/graphviz/guile/
  166. %{_mandir}/man3/gv.3guile*
  167. %files perl
  168. %defattr(-,root,root,-)
  169. %{_libdir}/graphviz/perl/
  170. %{perl_vendorarch}/*
  171. %{_mandir}/man3/gv.3perl*
  172. %files python
  173. %defattr(-,root,root,-)
  174. %{_libdir}/graphviz/python/
  175. %{_libdir}/python*/*
  176. %{_mandir}/man3/gv.3python*
  177. %files ruby
  178. %defattr(-,root,root,-)
  179. %{_libdir}/graphviz/ruby/
  180. %{rarchdir}/*
  181. %{_mandir}/man3/gv.3ruby*
  182. %files tcl
  183. %defattr(-,root,root)
  184. %{_libdir}/%{name}/tcl/*
  185. %{_libdir}/tcl*/*
  186. %{_datadir}/%{name}/demo
  187. # hack to include gv.3tcl only if available
  188. # always includes tcldot.3tcl, gdtclft.3tcl
  189. %{_mandir}/man3/*.3tcl*
  190. %{_mandir}/man3/tkspline.3tk*
  191. %changelog
  192. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  193. - add Patch10 to avoid build failure on ppc
  194. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  195. - new upstream release
  196. - built with rpm-4.8.1
  197. - split doc, guile, perl, python, ruby subpackage
  198. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  199. - rebuild with libtool-2.2.6a
  200. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  201. - new upstream release
  202. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  203. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  204. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  205. - new upstream release
  206. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  207. - new upstream release
  208. - build with expat-2.0.1
  209. - add man7
  210. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  211. - rebuild with tcl/tk-8.4.16
  212. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  213. - new upstream release
  214. - add BuildPrereq: swig
  215. - delete BuildPrereq: gd-progs gd-devel
  216. - add --with-mylibgd and --disable-FEATURE to configure option
  217. - update %%files
  218. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  219. - added BuildPrereq: ruby-devel
  220. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  221. - new upstream release
  222. - add BuildPrereq: libtool-ltdl-devel
  223. - move pkgconfig files to %%{_libdir}/pkgconfig
  224. - add --disable-rpath --disable-static to configure option
  225. - add %%post to every package
  226. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  227. - new upstream release
  228. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  229. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  230. - update %%files
  231. - remove lines about Vine2.6
  232. - change License to CPL
  233. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  234. - source upgrade
  235. - remove patch0 and commented lines
  236. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  237. - build for VineSeed
  238. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  239. - source upgrade
  240. - change spec to build both VineSeed and Vine2.5/2.6
  241. - add BuildPrereq: expat-devel and Requires: libexpat
  242. - add patch0 to build against freetype2-2.1.7
  243. - stop using autogen.sh script
  244. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  245. - add graphviz-tcl package (VineSeed)
  246. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  247. - rebuild for new Vine
  248. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  249. - import from offical site (src.rpm)