qt5-qtwebengine-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639
  1. %global qt_module qtwebengine
  2. %global _hardened_build 1
  3. # define to build docs, need to undef this for bootstrapping
  4. # where qt5-qttools builds are not yet available
  5. # only primary archs (for now), allow secondary to bootstrap
  6. %ifarch %{arm} %{ix86} x86_64
  7. %global docs 1
  8. %endif
  9. %if 0
  10. # need libvpx >= 1.4.0
  11. %global use_system_libvpx 1
  12. %endif
  13. %if 0%{?fedora} || 0%{?rhel} > 6
  14. # need libwebp >= 0.4.3
  15. %global use_system_libwebp 1
  16. %endif
  17. #global prerelease rc
  18. # exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
  19. # else)
  20. %global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
  21. # exclude libv8.so (i686, it's static everywhere else)
  22. %global __requires_exclude ^libv8\\.so$
  23. %global qt5_minorver 5.6
  24. %global qt5_version 5.6.3
  25. #global qt5_patchlevel 1
  26. Summary: Qt5 - QtWebEngine components
  27. Name: qt5-qtwebengine
  28. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  29. Release: 1%{?_dist_release}
  30. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  31. # See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
  32. # The other licenses are from Chromium and the code it bundles
  33. License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
  34. URL: http://www.qt.io
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. # cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
  38. # wget http://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-opensource-src-5.6.1-1.tar.xz
  39. # ./clean_qtwebengine.sh 5.6.1-1
  40. Source0: %{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
  41. # cleanup scripts used above
  42. Source1: clean_qtwebengine.sh
  43. Source2: clean_ffmpeg.sh
  44. Source3: get_free_ffmpeg_source_files.py
  45. # some tweaks to linux.pri (system libs, link libpci, run unbundling script)
  46. Patch1: qtwebengine-opensource-src-5.6.3-linux-pri.patch
  47. # quick hack to avoid checking for the nonexistent icudtl.dat and silence the
  48. # resulting warnings - not upstreamable as is because it removes the fallback
  49. # mechanism for the ICU data directory (which is not used in our builds because
  50. # we use the system ICU, which embeds the data statically) completely
  51. Patch2: qtwebengine-opensource-src-5.6.0-no-icudtl-dat.patch
  52. # fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
  53. # ARM flags with our %%qmake_qt5 macro, including for the next patch
  54. Patch3: qtwebengine-opensource-src-5.6.0-beta-fix-extractcflag.patch
  55. # use the system NSPR prtime (based on Debian patch)
  56. # We already depend on NSPR, so it is useless to copy these functions here.
  57. # Debian uses this just fine, and I don't see relevant modifications either.
  58. Patch5: qtwebengine-opensource-src-5.6.3-system-nspr-prtime.patch
  59. # use the system ICU UTF functions
  60. # We already depend on ICU, so it is useless to copy these functions here.
  61. # I checked the history of that directory, and other than the renames I am
  62. # undoing, there were no modifications at all. Must be applied after Patch5.
  63. Patch6: qtwebengine-opensource-src-5.7.0-system-icu-utf.patch
  64. # do not require SSE2 on i686
  65. # cumulative revert of upstream reviews 187423002, 308003004, 511773002 (parts
  66. # relevant to QtWebEngine only), 516543004, 1152053004 and 1161853008, along
  67. # with some custom fixes and improvements
  68. # also build V8 shared and twice on i686 (once for x87, once for SSE2)
  69. Patch7: qtwebengine-opensource-src-5.7.0-no-sse2.patch
  70. # to build with icu > 59
  71. Patch1000: qtwebengine-5.7.1-icu-59.patch
  72. Patch1001: qtwebengine-5.6.3-icu60.patch
  73. # the architectures theoretically supported by the version of V8 used (#1298011)
  74. # You may need some minor patching to build on one of the secondary
  75. # architectures, e.g., to add to the Qt -> Chromium -> V8 arch translations.
  76. # If you cannot get this package to build on your secondary architecure, please:
  77. # * remove your architecture from this list AND
  78. # * put #1298011 onto your ExcludeArch tracker.
  79. ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
  80. BuildRequires: qt5-qtbase-devel >= %{version}
  81. BuildRequires: qt5-qtbase-private-devel
  82. # TODO: check of = is really needed or if >= would be good enough -- rex
  83. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  84. BuildRequires: qt5-qtdeclarative-devel >= %{version}
  85. BuildRequires: qt5-qtxmlpatterns-devel >= %{version}
  86. BuildRequires: qt5-qtlocation-devel >= %{version}
  87. BuildRequires: qt5-qtsensors-devel >= %{version}
  88. BuildRequires: qt5-qtwebchannel-devel >= %{version}
  89. BuildRequires: qt5-qttools-static >= %{version}
  90. BuildRequires: ninja
  91. BuildRequires: bison
  92. BuildRequires: git
  93. BuildRequires: gperf
  94. BuildRequires: libicu-devel
  95. BuildRequires: libjpeg-devel
  96. #BuildRequires: re2-devel
  97. BuildRequires: snappy-devel
  98. %ifarch %{ix86} x86_64
  99. BuildRequires: yasm
  100. %endif
  101. BuildRequires: pkgconfig(expat)
  102. BuildRequires: pkgconfig(gobject-2.0)
  103. BuildRequires: pkgconfig(glib-2.0)
  104. BuildRequires: pkgconfig(fontconfig)
  105. BuildRequires: pkgconfig(freetype2)
  106. BuildRequires: pkgconfig(gl)
  107. BuildRequires: pkgconfig(egl)
  108. BuildRequires: pkgconfig(libpng)
  109. BuildRequires: pkgconfig(libudev)
  110. %if 0%{?use_system_libwebp}
  111. BuildRequires: pkgconfig(libwebp) >= 0.4.3
  112. %endif
  113. BuildRequires: pkgconfig(harfbuzz)
  114. BuildRequires: pkgconfig(jsoncpp)
  115. BuildRequires: pkgconfig(protobuf)
  116. BuildRequires: pkgconfig(libdrm)
  117. BuildRequires: pkgconfig(opus)
  118. BuildRequires: pkgconfig(libevent)
  119. BuildRequires: pkgconfig(zlib)
  120. #BuildRequires: pkgconfig(minizip)
  121. BuildRequires: pkgconfig(libxml-2.0)
  122. BuildRequires: pkgconfig(libxslt)
  123. BuildRequires: pkgconfig(x11)
  124. BuildRequires: pkgconfig(xi)
  125. BuildRequires: libXcursor-devel
  126. BuildRequires: pkgconfig(xext)
  127. BuildRequires: pkgconfig(xfixes)
  128. BuildRequires: pkgconfig(xrender)
  129. BuildRequires: pkgconfig(xdamage)
  130. BuildRequires: pkgconfig(xcomposite)
  131. BuildRequires: pkgconfig(xtst)
  132. BuildRequires: pkgconfig(xrandr)
  133. BuildRequires: pkgconfig(xscrnsaver)
  134. BuildRequires: pkgconfig(libcap)
  135. BuildRequires: pkgconfig(libpulse)
  136. BuildRequires: pkgconfig(alsa)
  137. BuildRequires: pciutils-devel
  138. BuildRequires: pkgconfig(dbus-1)
  139. BuildRequires: pkgconfig(nss)
  140. BuildRequires: pkgconfig(libsrtp)
  141. BuildRequires: perl
  142. BuildRequires: python
  143. %if 0%{?use_system_libvpx}
  144. BuildRequires: pkgconfig(vpx) >= 1.4.0
  145. %endif
  146. # extra (non-upstream) functions needed, see
  147. # src/3rdparty/chromium/third_party/sqlite/README.chromium for details
  148. #BuildRequires: pkgconfig(sqlite3)
  149. ## Various bundled libraries that Chromium does not support unbundling :-(
  150. ## Only the parts actually built are listed.
  151. ## Query for candidates:
  152. ## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
  153. ## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
  154. ## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
  155. ## some false positives where only shim headers are generated for some reason
  156. ## some false positives with dummy placeholder dirs (swiftshader, widevine)
  157. ## some false negatives where a header-only library is bundled (e.g. x86inc)
  158. ## Spot's chromium.spec also has a list that I checked.
  159. # Of course, Chromium itself is bundled. It cannot be unbundled because it is
  160. # not a library, but forked (modified) application code.
  161. # Some security fixes are backported, see:
  162. # http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
  163. Provides: bundled(chromium) = 45
  164. # Bundled in src/3rdparty/chromium/third_party:
  165. # Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
  166. # except where specified otherwise.
  167. Provides: bundled(angle) = 2422
  168. # Google's fork of OpenSSL
  169. # We cannot build against NSS instead because it no longer works with NSS 3.21:
  170. # HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
  171. # completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
  172. # http://kaosx.us/phpBB3/viewtopic.php?t=1235
  173. # https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
  174. # So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
  175. # use the BoringSSL code and the system NSS certificates.
  176. Provides: bundled(boringssl)
  177. Provides: bundled(brotli)
  178. # Don't get too excited. MPEG and other legally problematic stuff is stripped
  179. # out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
  180. # see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
  181. Provides: bundled(ffmpeg) = 2.7
  182. Provides: bundled(iccjpeg)
  183. # bundled as "khronos", headers only
  184. Provides: bundled(khronos_headers)
  185. # bundled as "leveldatabase"
  186. Provides: bundled(leveldb) = r80
  187. Provides: bundled(libjingle) = 9564
  188. %if !0%{?use_system_libvpx}
  189. Provides: bundled(libvpx) = 1.4.0
  190. %endif
  191. %if !0%{?use_system_libwebp}
  192. Provides: bundled(libwebp) = 0.4.3
  193. %endif
  194. Provides: bundled(libXNVCtrl) = 302.17
  195. Provides: bundled(libyuv) = 1444
  196. Provides: bundled(modp_b64)
  197. Provides: bundled(mojo)
  198. # headers only
  199. Provides: bundled(npapi)
  200. Provides: bundled(openmax_dl) = 1.0.2
  201. Provides: bundled(ots)
  202. Provides: bundled(qcms) = 4
  203. Provides: bundled(sfntly) = 0-0.1.svn111
  204. Provides: bundled(skia)
  205. # bundled as "smhasher"
  206. Provides: bundled(SMHasher) = 0-0.1.svn147
  207. Provides: bundled(sqlite) = 3.8.7.4
  208. Provides: bundled(usrsctp) = 0-0.1.svn9045
  209. Provides: bundled(webrtc) = 90
  210. %ifarch %{ix86} x86_64
  211. # header (for assembly) only
  212. Provides: bundled(x86inc) = 0
  213. %endif
  214. # Bundled in src/3rdparty/chromium/base/third_party:
  215. # Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
  216. # numbers, except where specified otherwise.
  217. Provides: bundled(dmg_fp)
  218. Provides: bundled(dynamic_annotations) = 4384
  219. Provides: bundled(superfasthash) = 0
  220. Provides: bundled(symbolize)
  221. # bundled as "valgrind", headers only
  222. Provides: bundled(valgrind.h)
  223. # bundled as "xdg_mime"
  224. Provides: bundled(xdg-mime)
  225. # bundled as "xdg_user_dirs"
  226. Provides: bundled(xdg-user-dirs) = 0.10
  227. # Bundled in src/3rdparty/chromium/net/third_party:
  228. # Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
  229. # numbers, except where specified otherwise.
  230. Provides: bundled(mozilla_security_manager) = 1.9.2
  231. # Bundled in src/3rdparty/chromium/url/third_party:
  232. # Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
  233. # numbers, except where specified otherwise.
  234. # bundled as "mozilla", file renamed and modified
  235. Provides: bundled(nsURLParsers)
  236. # Bundled outside of third_party, apparently not considered as such by Chromium:
  237. # see src/3rdparty/chromium/v8/include/v8_version.h for the version number
  238. Provides: bundled(v8) = 4.5.103.35
  239. # bundled by v8 (src/3rdparty/chromium/v8/src/third_party/fdlibm)
  240. # see src/3rdparty/chromium/v8/src/third_party/fdlibm/README.v8 for the version
  241. Provides: bundled(fdlibm) = 5.3
  242. %{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
  243. %description
  244. %{summary}.
  245. %package devel
  246. Summary: Development files for %{name}
  247. Requires: %{name}%{?_isa} = %{version}-%{release}
  248. Requires: qt5-qtbase-devel%{?_isa}
  249. Requires: qt5-qtdeclarative-devel%{?_isa}
  250. %description devel
  251. %{summary}.
  252. %package examples
  253. Summary: Example files for %{name}
  254. %description examples
  255. %{summary}.
  256. %if 0%{?docs}
  257. %package doc
  258. Summary: API documentation for %{name}
  259. BuildRequires: qt5-qhelpgenerator
  260. BuildRequires: qt5-qdoc
  261. BuildArch: noarch
  262. %description doc
  263. %{summary}.
  264. %endif
  265. %prep
  266. %setup -q -n %{qt_module}-opensource-src-%{qt5_version}
  267. %patch1 -p1 -b .linux-pri
  268. %patch2 -p1 -b .no-icudtl-dat
  269. %patch3 -p1 -b .fix-extractcflag
  270. %patch5 -p1 -b .system-nspr-prtime
  271. %patch6 -p1 -b .system-icu-utf
  272. %patch7 -p1 -b .no-sse2
  273. %patch1000 -p1 -b .icu59
  274. %patch1001 -p1 -b .icu60
  275. # fix // in #include in content/renderer/gpu to avoid debugedit failure
  276. sed -i -e 's!gpu//!gpu/!g' \
  277. src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
  278. # remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
  279. sed -i -e 's!\./!!g' \
  280. src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
  281. src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
  282. # http://bugzilla.redhat.com/1337585
  283. # can't just delete, but we'll overwrite with system headers to be on the safe side
  284. #cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/re2/
  285. #ifnarch x86_64
  286. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  287. sed -i -e 's/=-g$/=-g1/g' src/core/gyp_run.pro
  288. #endif
  289. %build
  290. export STRIP=strip
  291. export NINJAFLAGS="-v %{_smp_mflags}"
  292. export NINJA_PATH=%{_bindir}/ninja-build
  293. export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
  294. export CFLAGS="%{optflags}"
  295. #ifnarch x86_64
  296. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  297. export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
  298. #endif
  299. export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
  300. #ifnarch x86_64
  301. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  302. export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
  303. #endif
  304. mkdir %{_target_platform}
  305. pushd %{_target_platform}
  306. %{qmake_qt5} CONFIG+="webcore_debug v8base_debug force_debug_info" WEBENGINE_CONFIG+="use_system_icu use_system_protobuf" ..
  307. # if we keep these set here, gyp picks up duplicate flags
  308. unset CFLAGS
  309. export CFLAGS
  310. unset CXXFLAGS
  311. export CXXFLAGS
  312. # workaround, disable parallel compilation as it fails to compile in brew
  313. make %{?_smp_mflags}
  314. %if 0%{?docs}
  315. make %{?_smp_mflags} docs
  316. %endif
  317. popd
  318. %install
  319. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  320. %if 0%{?docs}
  321. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  322. %endif
  323. ## .prl/.la file love
  324. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  325. pushd %{buildroot}%{_qt5_libdir}
  326. for prl_file in libQt5*.prl ; do
  327. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  328. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  329. rm -fv "$(basename ${prl_file} .prl).la"
  330. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  331. fi
  332. done
  333. popd
  334. %post -p /sbin/ldconfig
  335. %postun -p /sbin/ldconfig
  336. %files
  337. %{_qt5_libdir}/libQt5*.so.*
  338. %{_qt5_libdir}/qt5/qml/*
  339. %{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
  340. %ifarch %{ix86}
  341. # shared V8 library and its SSE2 version
  342. %{_qt5_libdir}/qtwebengine/
  343. %endif
  344. %{_qt5_plugindir}/designer/libqwebengineview.so
  345. %{_qt5_datadir}/resources/
  346. %dir %{_qt5_translationdir}/qtwebengine_locales
  347. %lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
  348. %lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
  349. %lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
  350. %lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
  351. %lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
  352. %lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
  353. %lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
  354. %lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
  355. %lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
  356. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
  357. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
  358. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
  359. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
  360. %lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
  361. %lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
  362. %lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
  363. %lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
  364. %lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
  365. %lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
  366. %lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
  367. %lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
  368. %lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
  369. %lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
  370. %lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
  371. %lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
  372. %lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
  373. %lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
  374. %lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
  375. %lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
  376. %lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
  377. %lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
  378. %lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
  379. %lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
  380. %lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
  381. %lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
  382. %lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
  383. %lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
  384. %lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
  385. %lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
  386. %lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
  387. %lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
  388. %lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
  389. %lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
  390. %lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
  391. %lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
  392. %lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
  393. %lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
  394. %lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
  395. %lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
  396. %lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
  397. %lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
  398. %lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
  399. %lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
  400. %files devel
  401. %{_qt5_headerdir}/Qt*/
  402. %{_qt5_libdir}/libQt5*.so
  403. %{_qt5_libdir}/libQt5*.prl
  404. %{_qt5_libdir}/cmake/Qt5*/
  405. %{_qt5_libdir}/pkgconfig/Qt5*.pc
  406. %{_qt5_archdatadir}/mkspecs/modules/*.pri
  407. %files examples
  408. %{_qt5_examplesdir}/
  409. %if 0%{?docs}
  410. %files doc
  411. %{_qt5_docdir}/*
  412. %endif
  413. %changelog
  414. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  415. - new upstream release.
  416. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  417. - new upstream release.
  418. - initial build for Vine Linux.
  419. - updated Source1.
  420. * Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
  421. - rebuild (glibc)
  422. * Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  423. - add versioned qt5-qtbase runtime dep
  424. * Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
  425. - Update to 5.6.1
  426. - Rebase linux-pri patch (drop the parts already fixed upstream)
  427. - Drop backported chimera-nss-init patch, already applied upstream
  428. - Rebase no-sse2 patch (the core_module.pro change)
  429. - Add the new designer/libqwebengineview.so plugin to the file list
  430. * Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
  431. - workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
  432. * Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
  433. - rebuild (pciutuils)
  434. * Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
  435. - BR: git-core
  436. * Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
  437. - rebuild for ICU 57.1
  438. * Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
  439. - drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
  440. * Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
  441. - Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
  442. - Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
  443. - Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
  444. - Work around debugedit failure by removing "./" from #line commands and
  445. changing "//" to "/" in an #include command
  446. * Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
  447. - Avoid checking for the nonexistent icudtl.dat and silence the warnings
  448. * Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
  449. - Update to 5.6.0 (final)
  450. - Drop system-icu54 patch, fixed upstream
  451. * Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
  452. - Update to 5.6.0 RC
  453. - Rebase linux-pri and no-sse2 patches
  454. - Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
  455. - Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
  456. - Tag translations with correct %%lang tags
  457. * Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
  458. - no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
  459. * Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
  460. - Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
  461. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
  462. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  463. * Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
  464. - Build V8 as a shared library on i686 to allow for swappable backends
  465. - Build both the x87 version and the SSE2 version of V8 on i686
  466. - Add the private library directory to the file list on i686
  467. - Add Provides/Requires filtering for libv8.so (i686) and for plugins
  468. * Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
  469. - Do not require SSE2 on i686
  470. * Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
  471. - Drop nss321 backport (and the related nss-headers patch), it did not help
  472. - Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
  473. - Update License accordingly (add "OpenSSL")
  474. - Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
  475. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
  476. - Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
  477. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
  478. - Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
  479. * Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
  480. - Unbundle prtime.cc, use the system NSPR instead (which is already required)
  481. - Unbundle icu_utf.cc, use the system ICU instead (which is already required)
  482. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
  483. - linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
  484. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
  485. - Build against the system libvpx also on F23 (1.4.0), worked in Copr
  486. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
  487. - Use the system libvpx on F24+ (1.5.0)
  488. - Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
  489. * Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
  490. - Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
  491. - Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
  492. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
  493. - Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
  494. - Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
  495. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
  496. - Use more specific BuildRequires for docs (thanks to rdieter)
  497. - Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
  498. * Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
  499. - Fix License tag
  500. - Use %%_qt5_examplesdir macro
  501. - Add Provides: bundled(*) for all the bundled libraries that I found
  502. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
  503. - linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
  504. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
  505. - linux-pri patch: Add missing newline at the end of the log line
  506. - Use export for NINJA_PATH (fixes system ninja-build use)
  507. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
  508. - Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
  509. - BR yasm only on x86 (i686, x86_64)
  510. - Add dot at the end of %%description
  511. - Rebase no-format patch
  512. - Replace unbundle-gyp.patch with new linux-pri.patch
  513. - Use system ninja-build instead of the bundled one
  514. - Run the unbundling script replace_gyp_files.py in linux.pri rather than here
  515. - Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
  516. * Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
  517. - Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
  518. pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
  519. pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
  520. pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
  521. perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
  522. - Add missing explicit BRs on pkgconfig(x11), pkgconfig(xext),
  523. pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
  524. - Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
  525. - Fix BR python-devel to python
  526. - Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
  527. - Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
  528. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
  529. - Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
  530. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
  531. - Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
  532. - Remove unused BR v8-devel (cannot currently be unbundled)
  533. * Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
  534. - Update to 5.5.1
  535. - Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
  536. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
  537. - Update with unbundle flags. Adapted from original 5.4 Suse package
  538. - Disable vpx and sqlite as unbundle due some compilation issues
  539. - Enable verbose build
  540. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
  541. - Initial spec
  542. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  543. - Update for official RC1 released packages