lz4-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. Name: lz4
  2. Version: 1.8.0
  3. Release: 2%{?_dist_release}
  4. Summary: Extremely fast compression algorithm
  5. License: GPLv2+ and BSD
  6. URL: https://lz4.github.io/lz4/
  7. Source0: https://github.com/Cyan4973/lz4/archive/v%{version}/%{name}-%{version}.tar.gz
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: tomop
  11. %description
  12. LZ4 is an extremely fast loss-less compression algorithm, providing compression
  13. speed at 400 MB/s per core, scalable with multi-core CPU. It also features
  14. an extremely fast decoder, with speed in multiple GB/s per core, typically
  15. reaching RAM speed limits on multi-core systems.
  16. %package libs
  17. Summary: Libaries for lz4
  18. %description libs
  19. This package contains the libaries for lz4.
  20. %package devel
  21. Summary: Development files for lz4
  22. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  23. %description devel
  24. This package contains the header(.h) and library(.so) files required to build
  25. applications using liblz4 library.
  26. %package static
  27. Summary: Static library for lz4
  28. %description static
  29. LZ4 is an extremely fast loss-less compression algorithm. This package
  30. contains static libraries for static linking of applications.
  31. %prep
  32. %autosetup
  33. echo '#!/bin/sh' > ./configure
  34. chmod +x ./configure
  35. %build
  36. %configure
  37. %make_build
  38. %install
  39. %configure
  40. %make_install LIBDIR=%{_libdir} PREFIX=%{_prefix} INSTALL="install -p"
  41. # Someone thinks that plain Makefiles are good for bigger projects than hello world..
  42. mkdir -p %{buildroot}%{_mandir}/man1
  43. mv %{buildroot}%{_mandir}/*.1 %{buildroot}%{_mandir}/man1/
  44. %post libs -p /sbin/ldconfig
  45. %postun libs -p /sbin/ldconfig
  46. %files
  47. %license programs/COPYING
  48. %doc NEWS
  49. %{_bindir}/lz4
  50. %{_bindir}/lz4c
  51. %{_bindir}/lz4cat
  52. %{_bindir}/unlz4
  53. %{_mandir}/man1/lz4.1*
  54. %{_mandir}/man1/lz4c.1*
  55. %{_mandir}/man1/lz4cat.1*
  56. %{_mandir}/man1/unlz4.1*
  57. %files libs
  58. %doc lib/LICENSE
  59. %{_libdir}/liblz4.so.*
  60. %files devel
  61. %doc lib/LICENSE
  62. %{_includedir}/lz4*.h
  63. %{_libdir}/liblz4.so
  64. %{_libdir}/pkgconfig/liblz4.pc
  65. %files static
  66. %doc lib/LICENSE
  67. %{_libdir}/liblz4.a
  68. %changelog
  69. * Fri Sep 08 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.0-2
  70. - initial build for Vine Linux.
  71. * Sat Aug 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.8.0-1
  72. - Update to 1.8.0
  73. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-6
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  75. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-5
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  77. * Sat Jul 08 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.7.5-4
  78. - Split libs properly for multilib
  79. * Sat Mar 4 2017 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.5-3
  80. - Split libs out to a sub package
  81. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  83. * Thu Jan 05 2017 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.5-1
  84. - Update to 1.7.5
  85. * Fri Nov 25 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.4.2-1
  86. - Update to 1.7.4.2 (RHBZ #1397373)
  87. * Sat Nov 19 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.3-1
  88. - Update to 1.7.3 (RHBZ #1395458)
  89. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - r131-2
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  91. * Mon Jul 06 2015 pjp <pjp@fedoraproject.org> - r131-1
  92. - New: Dos/DJGPP target #114.
  93. - Added: Example using lz4frame library #118.
  94. - Changed: liblz4.a no longer compiled with -fPIC by default.
  95. * Thu Jun 18 2015 pjp <pjp@fedoraproject.org> - r130-1
  96. - Fixed: incompatibility sparse mode vs console.
  97. - Fixed: LZ4IO exits too early when frame crc not present.
  98. - Fixed: incompatibility sparse mode vs append mode.
  99. - Performance fix: big compression speed boost for clang(+30%).
  100. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r129-2
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  102. * Wed May 27 2015 pjp <pjp@fedoraproject.org> - r129-1
  103. - New LZ4_compress_fast() API.
  104. - New LZ4 CLI improved performance with multiple files.
  105. - Other bug fix and documentation updates.
  106. * Mon Apr 06 2015 pjp <pjp@fedoraproject.org> - r128-2
  107. - Update files section to install unlz4 & its manual
  108. * Wed Apr 01 2015 pjp <pjp@fedoraproject.org> - r128-1
  109. - lz4cli sparse file support
  110. - Restored lz4hc compression ratio
  111. - lz4 cli supports long commands
  112. - Introduced lz4-static sub package BZ#1208203
  113. * Thu Jan 08 2015 pjp <pjp@fedoraproject.org> - r127-2
  114. - Bump dist to override an earlier build.
  115. * Wed Jan 07 2015 pjp <pjp@fedoraproject.org> - r127-1
  116. - Fixed a bug in LZ4 HC streaming mode
  117. - New lz4frame API integrated into liblz4
  118. - Fixed a GCC 4.9 bug on highest performance settings
  119. * Thu Nov 13 2014 pjp <pjp@fedoraproject.org> - r124-1
  120. - New LZ4 HC Streaming mode
  121. * Tue Sep 30 2014 pjp <pjp@fedoraproject.org> - r123-1
  122. - Added experimental lz4frame API.
  123. - Fix s390x support.
  124. * Sat Aug 30 2014 pjp <pjp@fedoraproject.org> - r122-1
  125. - new release
  126. - Fixed AIX & AIX64 support (SamG)
  127. - Fixed mips 64-bits support (lew van)
  128. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r121-3
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  130. * Fri Aug 08 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - r121-2
  131. - fix destdir
  132. * Fri Aug 08 2014 pjp <pjp@fedoraproject.org> - r121-1
  133. - new release
  134. - Added a pkg-config file.
  135. - Fixed a LZ4 streaming crash bug.
  136. * Thu Jul 03 2014 pjp <pjp@fedoraproject.org> - r119-1
  137. - new release
  138. - Fixed a high Address allocation issue in 32-bits mode.
  139. * Sat Jun 28 2014 pjp <pjp@fedoraproject.org> - r118-1
  140. - new release
  141. - install libraries under appropriate _libdir directories.
  142. * Sat Jun 14 2014 pjp <pjp@fedoraproject.org> - r117-3
  143. - Move shared library object to -devel package.
  144. * Sat Jun 07 2014 pjp <pjp@fedoraproject.org> - r117-2
  145. - Skip static library from installation.
  146. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r117-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  148. * Fri Jun 06 2014 pjp <pjp@fedoraproject.org> - r117-1
  149. - new release
  150. - added lz4c & lz4cat manual pages.
  151. * Sun Apr 13 2014 pjp <pjp@fedoraproject.org> - r116-1
  152. - new release 116
  153. - added lz4cat utility for posix systems
  154. * Sat Mar 15 2014 pjp <pjp@fedoraproject.org> - r114-1
  155. - new release r114
  156. - added RPM_OPT_FLAGS to CFLAGS
  157. - introduced a devel package to build liblz4
  158. * Thu Jan 02 2014 pjp <pjp@fedoraproject.org> - r110-1
  159. - new release r110
  160. * Sun Nov 10 2013 pjp <pjp@fedoraproject.org> - r108-1
  161. - new release r108
  162. * Wed Oct 23 2013 pjp <pjp@fedoraproject.org> - r107-1
  163. - new release r107
  164. * Mon Oct 07 2013 pjp <pjp@fedoraproject.org> - r106-3
  165. - fixed install section to replace /usr/ with a macro.
  166. -> https://bugzilla.redhat.com/show_bug.cgi?id=1015263#c5
  167. * Sat Oct 05 2013 pjp <pjp@fedoraproject.org> - r106-2
  168. - fixed install section above as suggested in the review.
  169. -> https://bugzilla.redhat.com/show_bug.cgi?id=1015263#c1
  170. * Sun Sep 22 2013 pjp <pjp@fedoraproject.org> - r106-1
  171. - Initial RPM release of lz4-r106