akonadi-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236
  1. Summary: PIM Storage Service
  2. Summary(ja): PIM ストレージサービス
  3. Name: akonadi
  4. Version: 1.3.1
  5. Release: 3%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://download.akonadi-project.org/
  9. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. # shrink default initial db size a bit (approx 140mb->28mb)
  12. %define mysql_conf_timestamp 20100209
  13. Patch1: akonadi-1.1.1-mysql_conf.patch
  14. ## upstream patches
  15. BuildRequires: cmake >= 2.6.0
  16. BuildRequires: qt4-devel >= 4.5.0
  17. BuildRequires: automoc4
  18. BuildRequires: MySQL-devel
  19. BuildRequires: MySQL-server
  20. # for xsltproc
  21. BuildRequires: libxslt
  22. BuildRequires: shared-mime-info
  23. BuildRequires: libboost-devel libboost-program-options
  24. BuildRequires: soprano-devel >= 2.3.0
  25. BuildRequires: libICE-devel libXext-devel
  26. # when/if akonadi grows support for other backends, consider splitting
  27. # these similar to how phonon is done currently.
  28. Requires: qt4-MySQL
  29. # not *strictly* required, but we need a functional default configuration
  30. #Requires: mysql-server
  31. Requires(post): /sbin/ldconfig
  32. Requires(postun): /sbin/ldconfig
  33. %description
  34. %{summary}.
  35. Requires an available instance of mysql server at runtime.
  36. Akonadi can spawn a per-user one automatically if the mysql-server
  37. package is installed on the machine.
  38. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  39. %package devel
  40. Summary: Developer files for %{name}
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: qt4-devel >= 4.5.0
  44. Requires: pkgconfig
  45. %description devel
  46. %{summary}.
  47. %prep
  48. %setup -q
  49. %patch1 -p1 -b .mysql_conf
  50. touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  51. %build
  52. %ifarch x86_64
  53. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  54. %endif
  55. mkdir -p %{_target_platform}
  56. pushd %{_target_platform}
  57. %cmake \
  58. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  59. ..
  60. popd
  61. make %{?_smp_mflags} -C %{_target_platform}
  62. %install
  63. rm -rf $RPM_BUILD_ROOT
  64. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  65. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  66. touch -d %{mysql_conf_timestamp} $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post -p /sbin/ldconfig
  70. %posttrans
  71. update-mime-database %{_datadir}/mime &> /dev/null || :
  72. %postun
  73. /sbin/ldconfig ||:
  74. if [ $1 -eq 0 ] ; then
  75. update-mime-database %{_datadir}/mime &> /dev/null ||:
  76. fi
  77. %files
  78. %defattr(-,root,root,-)
  79. %doc AUTHORS lgpl-license
  80. %dir %{_sysconfdir}/akonadi
  81. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  82. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  83. %{_bindir}/akonadi_control
  84. %{_bindir}/akonadictl
  85. %{_bindir}/akonadiserver
  86. %{_libdir}/libakonadi*.so.1*
  87. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  88. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  89. %{_datadir}/mime/packages/akonadi-mime.xml
  90. %{_datadir}/akonadi
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %{_includedir}/akonadi
  94. %{_libdir}/pkgconfig/akonadi.pc
  95. %{_libdir}/libakonadi*.so
  96. %{_libdir}/cmake/Akonadi
  97. %changelog
  98. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  99. - updated Patch1
  100. - added BR: MySQL-server
  101. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  102. - added qmake path to PATH (if x86_64)
  103. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  104. - new upstream release
  105. - built with new toolchain
  106. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  107. - new upstream release
  108. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  109. - use %%cmake macro
  110. - removed MySQL-server from BuildRequires:
  111. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  112. - fixed Requires
  113. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  114. - Initial build for Vine
  115. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  116. - Akonadi 1.2.0
  117. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  119. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  120. - 1.1.95
  121. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  122. - akonadi-1.1.90
  123. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  124. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  125. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  126. - fix rpm file list
  127. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  128. - akonadi-1.1.85
  129. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  130. - akonadi-1.1.2
  131. - optimize scriptlets a bit
  132. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  133. - rev startup patch
  134. - BR: cmake >= 2.6.0
  135. - preserve timestamp's on mysql*.conf's
  136. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  137. - own %%_sysconfig/akonadi/mysql-local.conf
  138. - startup patch: reset conf only when needed, and clear mysql log file on update
  139. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  141. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  142. - shrink default db initial size a bit (approx 140mb->28mb)
  143. - drop extraneous RPATH-cmake baggage
  144. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  145. - 1.1.1
  146. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  147. - 1.1.0
  148. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  149. - 1.0.81
  150. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  151. - restore Requires: mysql-server
  152. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  153. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  154. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  155. - 1.0.80
  156. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  157. - drop Requires: mysql-server (for now), mention in %%description
  158. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  159. - Requires: mysql-server
  160. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  161. - BR: mysql-server
  162. - Requires: qt4-mysql
  163. - cleanup spec
  164. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  165. - 1.0.0
  166. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  167. - akonadi-0.82.0
  168. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  169. - BR automoc, drop automoc hack
  170. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  171. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  172. - restore builtin automoc4 for now
  173. - update file list, require pkgconfig in -devel (.pc file now included)
  174. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  175. - -devel: remove bogus Requires: pkgconfig
  176. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  177. - first Fedora package