asymptote-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define texmf %{_datadir}/texmf
  4. %define build_texmf %{buildroot}%{texmf}
  5. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  6. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
  7. #% define emacs_sitelisp %{_datadir}/emacs/site-lisp
  8. #% define xemacs_sitelisp %{_datadir}/xemacs/site-packages/lisp
  9. %define emacspkg asy-mode
  10. Name: asymptote
  11. Version: 1.70
  12. Release: 4%{?_dist_release}
  13. Summary: Descriptive vector graphics language
  14. Summary(ja): MetaPost に触発されたスクリプトベースのベクターグラフィック言語
  15. Group: Applications/Publishing
  16. License: GPLv3+
  17. URL: http://asymptote.sourceforge.net/
  18. Source0: http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
  19. Source1: asy.gif
  20. Source2: xasy.desktop
  21. Source11: %{emacspkg}-install.sh
  22. Source12: %{emacspkg}-remove.sh
  23. #Source13: %{name}-init.el
  24. #Patch0: asymptote-1.29-settings.patch
  25. Patch0: asymptote-1.70-settings-vine.patch
  26. Patch1: asymptote-1.63-gcc44.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: ncurses-devel
  29. BuildRequires: readline-devel
  30. BuildRequires: fftw3-devel >= 3.0
  31. BuildRequires: gc-devel >= 6.8
  32. BuildRequires: gsl-devel
  33. BuildRequires: tetex
  34. BuildRequires: ghostscript
  35. BuildRequires: texinfo
  36. BuildRequires: ImageMagick
  37. BuildRequires: desktop-file-utils
  38. BuildRequires: freeglut-devel
  39. BuildRequires: zlib-devel
  40. Requires: tetex
  41. Requires(post): desktop-file-utils
  42. Requires(postun): desktop-file-utils
  43. # for /usr/bin/texhash and /sbin/install-info
  44. Requires(post): tetex, info
  45. Requires(postun): tetex, info
  46. %define texpkgdir %{texmf}/tex/latex/%{name}
  47. %description
  48. Asymptote is a powerful descriptive vector graphics language for technical
  49. drawings, inspired by MetaPost but with an improved C++-like syntax.
  50. Asymptote provides for figures the same high-quality level of typesetting
  51. that LaTeX does for scientific text.
  52. This package is custmized for Japanese.
  53. %description -l ja
  54. Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
  55. テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
  56. Asymptote は科学的なテキストに対して LaTeX がしている組版のと
  57. 同じくらい高品質なレベルの図を提供します.
  58. このパッケージは日本語向けにカスタマイズされています.
  59. %package gui
  60. Summary: A graphical interface for Asymptote
  61. Summary(ja): Asymptote のためのグラフィカルインターフェース
  62. Group: Applications/Graphics
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: tkinter
  65. Requires: python-imaging
  66. %description gui
  67. A graphical interface for Asymptote
  68. %package -n %{emacspkg}
  69. Summary: Emacs mode for editing Asymptote source code
  70. Summary(ja): Asymptote ソースコードを編集するための Emacs モード
  71. Group: Applications/Editors/Emacs
  72. Requires: %{name} = %{version}-%{release}
  73. BuildRequires: emacsen
  74. %prereq_ge emacsen-common
  75. %description -n %{emacspkg}
  76. Emacs mode for editing Asymptote source code
  77. %prep
  78. %setup -q
  79. %patch0 -p1
  80. %patch1 -p1 -b .gcc44
  81. %{__sed} -i 's/\r//' doc/CAD1.asy
  82. # convert to UTF-8
  83. iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
  84. mv examples/interpolate1.asy{.utf8,}
  85. %build
  86. %configure \
  87. --enable-gc=system \
  88. --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
  89. --with-latex=%{texmf}/tex/latex
  90. %__make %{?_smp_mflags}
  91. cd doc/
  92. %__make asymptote.pdf
  93. %install
  94. %__rm -rf $RPM_BUILD_ROOT
  95. %__make install-all DESTDIR=$RPM_BUILD_ROOT
  96. %__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
  97. $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
  98. # # Emacs mode and init files
  99. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  100. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  101. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  102. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  103. # ln -s ../../../%{name}/asy-init.el .
  104. # # Xemacs mode and init files
  105. # install -dm 755 $RPM_BUILD_ROOT%{xemacs_sitelisp}/site-start.d
  106. # cd $RPM_BUILD_ROOT%{xemacs_sitelisp}
  107. # ln -s ../../../%{name}/asy-{mode,keywords}.el .
  108. # cd $RPM_BUILD_ROOT%{xemacs_sitelisp}/site-start.d
  109. # ln -s ../../../../%{name}/asy-init.el .
  110. # # Vim syntax file
  111. # for vimver in 63 64 70 71 ; do
  112. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  113. # cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  114. # ln -s ../../../%{name}/asy.vim .
  115. # done
  116. # copy icon to pixmaps dir
  117. mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  118. cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  119. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  120. desktop-file-install --vendor "vine" \
  121. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  122. %{SOURCE2}
  123. # Clean up symlink
  124. rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
  125. cd $RPM_BUILD_ROOT%{_bindir}
  126. ln -s ../share/%{name}/GUI/xasy.py xasy
  127. ## <asy-mode>
  128. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
  129. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  130. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  131. #
  132. # install el files
  133. #
  134. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  135. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  136. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  137. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  138. # ln -s ../../../%{name}/asy-init.el .
  139. %__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
  140. $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
  141. #
  142. # install script (bytecompile el and install elc, remove)
  143. #
  144. %_installemacsenscript %{name} %{SOURCE11}
  145. %_removeemacsenscript %{name} %{SOURCE12}
  146. ## </asy-mode>
  147. %clean
  148. %__rm -rf $RPM_BUILD_ROOT
  149. %post
  150. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
  151. /sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
  152. %{exec_texhash}
  153. %{exec_updmap}
  154. %post -n %{emacspkg}
  155. if [ "$1" = 2 ]; then
  156. %_emacsenPackageRemove %{name}
  157. fi
  158. %_addemacsenlist %{name}
  159. %_emacsenPackageInstall %{name}
  160. %postun
  161. if [ $1 = 0 ]; then
  162. /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
  163. /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
  164. %{exec_texhash}
  165. %{exec_updmap}
  166. fi
  167. %preun -n %{emacspkg}
  168. if [ "$1" = 0 ]; then
  169. %_emacsenPackageRemove %{name}
  170. %_removeemacsenlist %{name}
  171. fi
  172. %files
  173. %defattr(-,root,root,-)
  174. %doc %{_defaultdocdir}/%{name}-%{version}/
  175. %{_bindir}/asy
  176. %{_datadir}/%{name}/
  177. %exclude %{_datadir}/asymptote/GUI/
  178. %{texpkgdir}/
  179. %{_mandir}/man*/asy.*
  180. %{_infodir}/*.info*
  181. #%{_datadir}/vim/vim*/syntax/asy.vim
  182. # Strictly speaking, we shouldn't own these dirs.
  183. # However, we don't require emacs/xemacs, we just enhance them.
  184. # Thus, its ok for dual ownership.
  185. #%{_datadir}/emacs*
  186. #%{_datadir}/xemacs/
  187. %files gui
  188. %{_bindir}/xasy
  189. %{_datadir}/applications/vine-xasy.desktop
  190. %{_datadir}/pixmaps/asy.gif
  191. %{_datadir}/asymptote/GUI/
  192. %{_mandir}/man*/xasy.*
  193. %files -n %{emacspkg}
  194. %defattr(-,root,root)
  195. %{_datadir}/emacs/site-lisp/%{name}
  196. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  197. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  198. %changelog
  199. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
  200. - rebuilt with new toolchain, libsigsegv-2.8
  201. - appled Patch1 again
  202. * Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
  203. - don't apply Patch1 until gcc44 comes to VineSeed
  204. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
  205. - separated Xasy to gui subpackage
  206. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
  207. - initial build based on Fedora Development (fc11) package
  208. - applied asymptote-1.70-settings-vine.patch
  209. * Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
  210. - update to 1.70
  211. * Tue Apr 7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
  212. - update to 1.69
  213. * Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
  214. - update to 1.68
  215. * Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
  216. - update to 1.67
  217. * Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
  218. - update to 1.66
  219. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  221. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
  222. - more gcc44 fixes with BIG_ENDIAN platforms
  223. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
  224. - fix gcc44 issue with BIG_ENDIAN platforms
  225. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
  226. - forgot to put in new source
  227. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
  228. - 1.63
  229. * Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
  230. - 1.60
  231. * Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
  232. - 1.59
  233. * Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
  234. - 1.58
  235. * Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
  236. - 1.57
  237. * Tue Dec 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
  238. - 1.56
  239. * Tue Dec 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
  240. - 1.54
  241. * Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
  242. - 1.52
  243. * Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
  244. - update to 1.51
  245. * Mon Nov 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
  246. - update to 1.49
  247. * Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
  248. - update to 1.47
  249. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
  250. - update to 1.46
  251. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
  252. - add missing BuildRequires
  253. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
  254. - update to 1.44
  255. * Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
  256. - update to 1.43
  257. * Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
  258. - explicitly call "make asymptote.pdf" in doc/
  259. * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
  260. - fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
  261. * Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
  262. - update to 1.42
  263. * Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
  264. - update to 1.41
  265. - enable desktop file for xasy
  266. * Thu Jan 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
  267. - bump to 1.37
  268. - fix gcc43 failures
  269. - drop triggers
  270. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
  271. - Rebuild for selinux ppc32 issue.
  272. * Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
  273. - Update 1.33.
  274. * Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
  275. - Update to 1.32.
  276. - vim-common triggers: correction and improvements (#246131).
  277. * Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
  278. - Update to 1.31.
  279. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  280. - Update to 1.30.
  281. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
  282. - Using "evince" as the default PS and PDF viewers (#244151).
  283. (patch file: asymptote-1.29-settings.patch)
  284. - Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
  285. - Use relative symbolic links in the vim-common triggers.
  286. * Sat Jun 2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
  287. - Add asy-faq to install-info (#155750).
  288. - Add support for vim 7.1.
  289. * Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
  290. - Update to 1.29.
  291. * Tue May 8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
  292. - Update to 1.28.
  293. * Sat May 5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
  294. - Update to 1.27.
  295. * Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
  296. - Update to 1.26.
  297. * Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
  298. - Update to 1.25.
  299. * Sun Apr 1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  300. - Update to 1.24.
  301. * Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
  302. - Update to 1.23.
  303. * Tue Mar 6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  304. - Update to 1.22.
  305. * Sat Mar 3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
  306. - Update to 1.21.
  307. * Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  308. - Update to 1.20.
  309. * Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
  310. - Update to 1.19.
  311. * Sun Nov 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  312. - Update to 1.18.
  313. * Wed Nov 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
  314. - Update to 1.17.
  315. * Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  316. - Update to 1.16.
  317. * Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  318. - Update to 1.15.
  319. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
  320. - Update to 1.13.
  321. * Thu Aug 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
  322. - Update to 1.12.
  323. * Thu Jul 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
  324. - Update to 1.11.
  325. * Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
  326. - Update to 1.10.
  327. * Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
  328. - Update to 1.09.
  329. * Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
  330. - Update to 1.08.
  331. - Also installs the info file.
  332. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
  333. - Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
  334. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
  335. - Group: Development/Tools -> Applications/Publishing (#193154).
  336. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
  337. - Emacs/Xemacs init file (#193154 comment 6).
  338. * Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
  339. - Directories ownership (#193154).
  340. * Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  341. - Update to 1.06.
  342. - Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
  343. * Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  344. - Update to 1.05.
  345. * Sun May 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
  346. - Update to 1.04.
  347. * Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  348. - Update to 1.03.
  349. * Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
  350. - First build.
  351. # vim:set ai ts=4 sw=4 sts=4 et: