perl-MRO-Compat-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. # MRO is part of the Perl core since 5.9.5
  2. %global mro_in_core %(perl -e 'print $] > 5.009005 ? 1 : 0;')
  3. Name: perl-MRO-Compat
  4. Version: 0.12
  5. Release: 1%{?_dist_release}
  6. Summary: Mro::* interface compatibility for Perls < 5.9.5
  7. License: GPL+ or Artistic
  8. Group: Development/Libraries
  9. URL: http://search.cpan.org/dist/MRO-Compat/
  10. Source0: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/MRO-Compat-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. # Build
  14. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.42
  15. # Module
  16. %if ! %{mro_in_core}
  17. BuildRequires: perl(Class::C3) >= 0.20
  18. BuildRequires: perl(Class::C3::XS) >= 0.08
  19. %endif
  20. # Test
  21. BuildRequires: perl(Test::More) >= 0.47
  22. BuildRequires: perl(Test::Pod)
  23. BuildRequires: perl(Test::Pod::Coverage)
  24. # Runtime
  25. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  26. %if ! %{mro_in_core}
  27. Requires: perl(Class::C3) >= 0.20
  28. Requires: perl(Class::C3::XS) >= 0.08
  29. %endif
  30. %description
  31. The "mro" namespace provides several utilities for dealing with method
  32. resolution order and method caching in general in Perl 5.9.5 and higher.
  33. This module provides those interfaces for earlier versions of Perl (back
  34. to 5.6.0 anyways).
  35. It is a harmless no-op to use this module on 5.9.5+. That is to say,
  36. code which properly uses MRO::Compat will work unmodified on both older
  37. Perls and 5.9.5+.
  38. If you're writing a piece of software that would like to use the parts
  39. of 5.9.5+'s mro:: interfaces that are supported here, and you want
  40. compatibility with older Perls, this is the module for you.
  41. %prep
  42. %setup -q -n MRO-Compat-%{version}
  43. # Fix script interpreter
  44. perl -pi -e 's|^#!./perl|#!/usr/bin/perl|' t/15pkg_gen.t
  45. %build
  46. perl Makefile.PL INSTALLDIRS=vendor
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf %{buildroot}
  50. make pure_install DESTDIR=%{buildroot}
  51. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  52. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  53. %{_fixperms} %{buildroot}
  54. %check
  55. make test
  56. %clean
  57. rm -rf %{buildroot}
  58. %files
  59. %defattr(-,root,root,-)
  60. %doc ChangeLog README t/
  61. %{perl_vendorlib}/MRO/
  62. %{_mandir}/man3/MRO::Compat.3pm*
  63. %changelog
  64. * Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
  65. - updated to 0.12
  66. - built with perl 5.16.3
  67. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
  68. - initial build for Vine Linux
  69. * Thu Jan 26 2012 Paul Howarth <paul@city-fan.org> - 0.11-9
  70. - Spec clean-up:
  71. - Only require Class::C3 with perl < 5.9.5
  72. - Require Class::C3::XS for performance and consistency, but only with
  73. perl < 5.9.5
  74. - Use DESTDIR rather than PERL_INSTALL_ROOT
  75. - Make %%files list more explicit
  76. - Classify buildreqs by build/module/test
  77. - Don't use macros for commands
  78. - Use tabs
  79. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-8
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  81. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-7
  82. - Perl mass rebuild
  83. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-6
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  85. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-5
  86. - Rebuild to fix problems with vendorarch/lib (#661697)
  87. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-4
  88. - Mass rebuild with perl-5.12.0
  89. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
  90. - Rebuild against perl 5.10.1
  91. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  93. * Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
  94. - Auto-update to 0.11 (by cpan-spec-update 0.01)
  95. - Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  96. - Altered br on perl(Class::C3) (0.19 => 0.20)
  97. * Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.10-1
  98. - Update to 0.10
  99. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  101. * Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09
  102. - Update to 0.09
  103. * Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.07-1
  104. - Update to 0.07
  105. * Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.05-6
  106. - Rebuild for new perl
  107. * Thu Dec 06 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-5
  108. - Bump
  109. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-4
  110. - Update INstall -> install
  111. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-3
  112. - Add Test::Pod deps
  113. * Tue Dec 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-2
  114. - Make Class::C3 dep explicit
  115. * Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-1
  116. - Specfile autogenerated by cpanspec 1.71