perl-Pod-Eventual-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. Name: perl-Pod-Eventual
  2. Version: 0.094001
  3. Release: 1%{?_dist_release}
  4. Summary: Read a POD document as a series of trivial events
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Pod-Eventual/
  8. Source0: http://www.cpan.org/authors/id/R/RJ/RJBS/Pod-Eventual-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  12. BuildRequires: perl(Mixin::Linewise::Readers) >= 0.102
  13. BuildRequires: perl(Test::Deep)
  14. BuildRequires: perl(Test::More) >= 0.96
  15. BuildRequires: perl(Test::Pod)
  16. #BuildRequires: perl(Test::Pod::Coverage)
  17. # causes circular builddeps
  18. #BuildRequires: perl(Pod::Coverage::TrustPod)
  19. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  20. %{?perl_default_filter}
  21. %description
  22. POD is a pretty simple format to write, but it can be a big pain to deal
  23. with reading it and doing anything useful with it. Most existing POD
  24. parsers care about semantics, like whether a =item occurred after an
  25. =over but before a back, figuring out how to link a L<>, and other things
  26. like that.
  27. Pod::Eventual is much less ambitious and much more stupid. Fortunately, stupid
  28. is often better. (That's what I keep telling myself, anyway.)
  29. Pod::Eventual reads line-based input and produces events describing each POD
  30. paragraph or directive it finds. Once complete events are immediately passed to
  31. the handle_event method. This method should be implemented by Pod::Eventual
  32. subclasses. If it isn't, Pod::Eventual's own handle_event will be called, and
  33. will raise an exception.
  34. %prep
  35. %setup -q -n Pod-Eventual-%{version}
  36. %build
  37. %{__perl} Makefile.PL INSTALLDIRS=vendor
  38. make %{?_smp_mflags}
  39. %install
  40. rm -rf %{buildroot}
  41. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  42. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  43. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  44. %{_fixperms} %{buildroot}/*
  45. %check
  46. make test
  47. %clean
  48. rm -rf %{buildroot}
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc Changes LICENSE META.json README
  52. %{perl_vendorlib}/*
  53. %{_mandir}/man3/*
  54. %changelog
  55. * Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.094001-1
  56. - updated to 0.094001
  57. - built with perl 5.16.3
  58. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.093330-1
  59. - initial build for Vine Linux
  60. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-8
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  62. * Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 0.093330-7
  63. - Perl mass rebuild
  64. * Wed Jul 13 2011 Iain Arnell <iarnell@gmail.com> 0.093330-6
  65. - drop circular Pod::Coverage::TrustPod buildreq
  66. - don't run "release" tests
  67. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-5
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  69. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-4
  70. - 661697 rebuild for fixing problems with vendorach/lib
  71. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-3
  72. - Mass rebuild with perl-5.12.0
  73. * Sat Feb 27 2010 Iain Arnell <iarnell@gmail.com> 0.093330-2
  74. - BR perl(Pod::Coverage::TrustPod)
  75. * Thu Jan 14 2010 Iain Arnell 0.093330-1
  76. - Specfile autogenerated by cpanspec 1.78.