auctex-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define origname auctex
  3. %define emacspkg preview-latex
  4. %define texmf %{_datadir}/texmf
  5. %define build_texmf %{buildroot}%{texmf}
  6. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  7. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
  8. Summary: Enhanced TeX modes for Emacsen
  9. Name: %{origname}
  10. Version: 11.86
  11. Release: 2%{?_dist_release}
  12. Group: Applications/Editors/Emacs
  13. License: GPLv3+
  14. URL: http://www.gnu.org/software/auctex/
  15. Source: http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
  16. Source1: %{origname}-install.sh
  17. Source2: %{origname}-remove.sh
  18. Source3: %{origname}-init.el
  19. Source4: vine-default-%{origname}.el
  20. Source5: %{emacspkg}-install.sh
  21. Source6: %{emacspkg}-remove.sh
  22. Source7: %{emacspkg}-init.el
  23. Source8: vine-default-%{emacspkg}.el
  24. Patch: auctex-11.85-vine.patch
  25. Requires: %{emacspkg} = %{version}-%{release}
  26. BuildRequires: texinfo
  27. %if %{?_dist_release} == "vl5"
  28. BuildRequires: tetex
  29. %else
  30. BuildRequires: texlive
  31. %endif
  32. ## Note: "BR: emacs >= 23.1" need to build auctex
  33. BuildRequires: emacs >= 23.1
  34. %prereq_ge emacsen emacsen-common
  35. Requires(post): /sbin/install-info
  36. Obsoletes: auctex-emacs auctex-xemacs
  37. BuildArch: noarch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: munepi
  42. %description
  43. AUCTeX is an extensible package that supports writing and formatting TeX files
  44. for most variants of Emacs.
  45. AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
  46. Texinfo and basic support for ConTeXt. Documentation can be found under
  47. /usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ. The AUCTeX
  48. manual is available in Emacs info (C-h i d m AUCTeX RET). On the AUCTeX home
  49. page, we provide manuals in various formats.
  50. This version of AUCTeX comes with preview-latex, an addictive productivity
  51. tool providing a fine-grained interactive folding WYSIWYG display in the
  52. source buffer.
  53. If you are AUCTeX user and you install both yatex and auctex on your system,
  54. you may add the following configure in your emacs init file ~/.emacs.el:
  55. ;; I'm AUCTeX user!!!
  56. (setq vine-default-yatex nil)
  57. #'
  58. %package -n %{emacspkg}
  59. Summary: Emacs/LaTeX inline preview
  60. Group: Applications/Editors/Emacs
  61. Requires(post): %{origname} = %{version}-%{release}
  62. BuildRequires: emacsen
  63. %prereq_ge emacsen-common
  64. %description -n %{emacspkg}
  65. AUCTeX is an extensible package that supports writing and formatting TeX files
  66. for most variants of Emacs.
  67. AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
  68. Texinfo and basic support for ConTeXt. Documentation can be found under
  69. /usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ. The AUCTeX
  70. manual is available in Emacs info (C-h i d m AUCTeX RET). On the AUCTeX home
  71. page, we provide manuals in various formats.
  72. This version of AUCTeX comes with preview-latex, an addictive productivity
  73. tool providing a fine-grained interactive folding WYSIWYG display in the
  74. source buffer.
  75. Does your neck hurt from turning between previewer windows and the
  76. source too often? This Elisp/LaTeX package will render your displayed
  77. LaTeX equations right into the editing window where they belong.
  78. %prep
  79. %setup -q -n %{origname}-%{version}
  80. %patch -p1 -b .vine
  81. %build
  82. %configure --with-emacs INSTALL_INFO=: --without-texmf-dir
  83. %__make
  84. ## output auctex.el
  85. %__cp -a auctex.el auctex.el.vine
  86. cat>auctex.el<<EOF
  87. ;;; auctex.el
  88. ;;
  89. ;; This can be used for starting up AUCTeX. The following somewhat
  90. ;; strange trick causes tex-site.el to be loaded in a way that can be
  91. ;; safely undone using (unload-feature 'tex-site).
  92. ;;
  93. ;; (autoload 'TeX-load-hack
  94. ;; "/some/where/tex-site.el")
  95. ;; (TeX-load-hack)
  96. ;;
  97. ;; No any settings provide in this file.
  98. ;;
  99. EOF
  100. ## remove all *.elc
  101. find . -type f -name "*.elc" -exec rm -f {} ';'
  102. %install
  103. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  104. ## install preview package
  105. pushd preview
  106. %__make install-texmf \
  107. previewtexmfdir=%{build_texmf}/tex/latex/preview \
  108. previewdocdir=%{build_texmf}/doc/latex/preview
  109. %__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
  110. %__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
  111. popd
  112. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  113. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
  114. %__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  115. %__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  116. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  117. #
  118. # install el files
  119. #
  120. ## <auctex>
  121. %__install -p -m0644 *.el \
  122. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  123. %__cp -ra images style \
  124. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
  125. %__install -p -m0644 %{SOURCE3} %{SOURCE4} \
  126. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  127. ## </auctex>
  128. ## <preview-latex>
  129. pushd preview
  130. %__install -p -m0644 *.el \
  131. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
  132. %__cp -ra images \
  133. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
  134. popd
  135. %__install -p -m0644 %{SOURCE7} %{SOURCE8} \
  136. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
  137. ## </preview-latex>
  138. #
  139. # install info files
  140. #
  141. %__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
  142. ${RPM_BUILD_ROOT}%{_infodir}/
  143. #
  144. # install script (bytecompile el and install elc, remove)
  145. #
  146. %_installemacsenscript %{origname} %{SOURCE1}
  147. %_removeemacsenscript %{origname} %{SOURCE2}
  148. %_installemacsenscript %{emacspkg} %{SOURCE5}
  149. %_removeemacsenscript %{emacspkg} %{SOURCE6}
  150. %clean
  151. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  152. %post
  153. #
  154. # bytecompile and install
  155. #
  156. if [ "$1" = 2 ]; then
  157. %_emacsenPackageRemove %{origname}
  158. fi
  159. %_addemacsenlist %{origname}
  160. %_emacsenPackageInstall %{origname}
  161. /sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
  162. --section="A much enhanced LaTeX mode for GNU Emacs"
  163. %post -n %{emacspkg}
  164. #
  165. # bytecompile and install
  166. #
  167. if [ "$1" = 2 ]; then
  168. %_emacsenPackageRemove %{emacspkg}
  169. fi
  170. %_addemacsenlist %{emacspkg}
  171. %_emacsenPackageInstall %{emacspkg}
  172. /sbin/install-info \
  173. %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
  174. --section="A much enhanced LaTeX mode for GNU Emacs"
  175. %preun
  176. if [ "$1" = 0 ]; then
  177. %_emacsenPackageRemove %{origname}
  178. %_removeemacsenlist %{origname}
  179. /sbin/install-info --delete \
  180. %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
  181. --section="A much enhanced LaTeX mode for GNU Emacs"
  182. fi
  183. %preun -n %{emacspkg}
  184. if [ "$1" = 0 ]; then
  185. %_emacsenPackageRemove %{emacspkg}
  186. %_removeemacsenlist %{emacspkg}
  187. /sbin/install-info --delete \
  188. %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
  189. --section="A much enhanced LaTeX mode for GNU Emacs"
  190. fi
  191. %files
  192. %defattr(-,root,root)
  193. %doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
  194. %{_infodir}/%{origname}*
  195. %{_datadir}/emacs/site-lisp/%{origname}/
  196. %{emacsen_pkgdir}/install/%{origname}
  197. %{emacsen_pkgdir}/remove/%{origname}
  198. %files -n %{emacspkg}
  199. %defattr(-,root,root)
  200. %doc preview/COPYING preview/ChangeLog{,.1}
  201. %{_infodir}/%{emacspkg}*
  202. %{texmf}/doc/latex/preview/preview.pdf
  203. %{texmf}/tex/latex/preview/*
  204. %{_datadir}/emacs/site-lisp/%{emacspkg}/
  205. %{emacsen_pkgdir}/install/%{emacspkg}
  206. %{emacsen_pkgdir}/remove/%{emacspkg}
  207. %changelog
  208. * Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-2
  209. - fixed requirements
  210. - set BuildRequires: emacs >= 23.1
  211. - set BuildRequires: texlive (for vl6)
  212. * Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
  213. - new versioning release
  214. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
  215. - new versioning release
  216. - dropped old version patches
  217. - changed to GPLv3+ in License tag
  218. - changed to http://www.gnu.org/software/auctex/ in URL tag
  219. - download from http://ftp.gnu.org/pub/gnu/auctex in Source0
  220. - added preview-latex package
  221. - setup vine-default
  222. * Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
  223. - applied new versioning policy, spec in utf-8
  224. - added macro %%emacsen_pkgdir
  225. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
  226. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  227. - s/Copyright/License/
  228. * Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
  229. - ver.up
  230. * Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
  231. - minor fix of tex-jp.el
  232. * Wed Mar 6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
  233. - emasenize
  234. * Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
  235. - 10.0g-0vl1
  236. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  237. - 9.10p-0vl2
  238. - minor modification of spec file
  239. * Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
  240. - 9.10p-0vl1
  241. - change directories
  242. - minor customization
  243. * Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
  244. - 9.10p
  245. * Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
  246. - build auctex for emacs
  247. * Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
  248. - updated to 9.9p
  249. * Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
  250. - first release for 9.8l