riece-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origver 7.0.0
  4. %define origname riece
  5. Summary: Riece is emacs based irc client
  6. Summary(ja): Riece は Emacsen 上で動作する IRC のクライアント
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 2%{?_dist_release}
  10. Source0: http://dl.sv.gnu.org/releases/riece/%{name}-%{version}.tar.gz
  11. Source1: %{name}-install.sh
  12. Source2: %{name}-remove.sh
  13. Source3: %{name}-init.el
  14. Patch0: riece-7.0.0-check-make-local-hook.patch
  15. License: GPL
  16. Group: Applications/Editors/Emacs
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildArch: noarch
  19. Requires(post): emacsen
  20. Requires(post): /sbin/install-info
  21. Requires(preun): emacsen
  22. Requires(preun): /sbin/install-info
  23. %prereq_ge emacsen-common
  24. %prereq_ge flim
  25. %description
  26. Riece is a user interface for IRC (Internet Relay Chat). You should spell it
  27. with the first letter capitalized and pronounce it as /ri:s/.
  28. The features of Riece are as follows:
  29. * Several IRC servers may be used at the same time.
  30. * Many features built upon the extension mechanism called add-on.
  31. Currently 30 such add-ons are available.
  32. * Installation is easy. Riece doesn't depend on other packages.
  33. * Setup is easy. Automatically save/restore the configuration.
  34. * Step-by-step instructions are included.
  35. * Mostly compliant with the latest IRC client protocol (RFC2812).
  36. #'
  37. %description -l ja
  38. Riece は IRC (Internet Relay Chat) の世界でチャットを楽しむためのユーザインタ
  39. ーフェースです。Riece は「りーす」と読みます。
  40. Riece の主な特長は以下の通りです。
  41. * 複数の IRC サーバに同時に接続可能
  42. * アドオンにより機能の追加や取り外しが容易
  43. * 他の elisp パッケージに依存しないため、インストールが簡単
  44. * 設定が簡単で、前回起動時の設定を記録・復元する仕組みを提供
  45. * 段階的な操作説明書が附属
  46. * 最新の IRC のクライアントプロトコル (RFC2812) に準拠
  47. %prep
  48. %setup -q
  49. %patch0 -p1 -b .orig
  50. %build
  51. %configure
  52. %install
  53. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  54. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  55. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  56. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  57. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  58. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  59. #
  60. # install el files
  61. #
  62. cp -a lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  63. #
  64. # build & install info
  65. #
  66. make DESTDIR=${RPM_BUILD_ROOT} install-info
  67. #
  68. # install script( bytecompile el and install elc , remove )
  69. #
  70. %_installemacsenscript %{origname} %{SOURCE1}
  71. %_removeemacsenscript %{origname} %{SOURCE2}
  72. #
  73. # install info file
  74. #
  75. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  76. #
  77. # install site-start script
  78. #
  79. install %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  80. ## remove unpackaged files
  81. %__rm ${RPM_BUILD_ROOT}%{_infodir}/dir
  82. %pre
  83. if (grep -q "Riece: (liece)" /usr/share/info/dir) ; then
  84. cp /usr/share/info/dir /usr/share/info/dir.rpmsave
  85. grep -v "Riece: (liece)" /usr/share/info/dir.rpmsave > /usr/share/info/dir
  86. rm -f /usr/share/info/dir.rpmsave
  87. fi
  88. %post
  89. #
  90. # bytecompile and install
  91. #
  92. if [ "$1" = 2 ]; then
  93. %_emacsenPackageRemove %{origname}
  94. fi
  95. %_addemacsenlist %{origname}
  96. %_emacsenPackageInstall %{origname}
  97. /sbin/install-info %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
  98. --entry="* Riece: (riece-ja). IRC Client On Emacsen" --section="Emacs" ||:
  99. %preun
  100. if [ "$1" = 0 ]; then
  101. %_emacsenPackageRemove %{origname}
  102. %_removeemacsenlist %{origname}
  103. /sbin/install-info --delete %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
  104. --entry="* Riece: (riece-ja). IRC Client On Emacsen" --section="Emacs" ||:
  105. fi
  106. %clean
  107. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  108. %files
  109. %defattr(-,root,root)
  110. %doc AUTHORS COPYING ChangeLog* INSTALL NEWS* README*
  111. %{_datadir}/emacs/site-lisp/%{origname}
  112. %{emacsen_pkgdir}/install/%{origname}
  113. %{emacsen_pkgdir}/remove/%{origname}
  114. %{_infodir}/%{origname}-*.info*
  115. %changelog
  116. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-2
  117. - applied riece-7.0.0-check-make-local-hook.patch
  118. * Wed Nov 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-1
  119. - new upstream release
  120. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.1.0-1
  121. - new upstream release
  122. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-2
  123. - updated riece-install.sh
  124. - *-init.el: changed from hard copy to symbolic link
  125. on /etc/emacs-XX.YY/site-start.d
  126. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-1
  127. - new upstream release
  128. * Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-1
  129. - applied new versioning policy
  130. - spec in UTF-8
  131. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.0-0vl1
  132. - new upstream release
  133. * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl4
  134. - fixed %post script <BTS:VineLinux:177>
  135. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl3
  136. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  137. - s/Copyright/License/
  138. * Sat Sep 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl2
  139. - change BuildArch to noarch
  140. * Fri Sep 9 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl1
  141. - initial build