cabextract-vl.spec 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. %define pkg_major_version 1.2
  2. %define pkg_name cabextract
  3. %define pkg_release 2%{?_dist_release}
  4. %define tarball %(cd %{_sourcedir};ls %{pkg_name}-%{pkg_major_version}.tar.gz | tail -n 1)
  5. ## PAR_define pkg_minor_version %(echo %{tarball} | cut -d '.' -f3 | tr -d 0)
  6. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  7. Summary: A program to extract Microsoft Cabinet files
  8. Summary(ja): Microsoftキャビネットファイルを抽出するプログラム
  9. Name: %{pkg_name}
  10. Version: %{pkg_major_version}
  11. Release: %{pkg_release}
  12. License: GPL
  13. Group: Applications/Archiving
  14. Source: http://www.kyz.uklinux.net/downloads/%{name}-%{version}.tar.gz
  15. URL: http://www.kyz.uklinux.net/cabextract.php
  16. Vendor: Stuart Caie
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Prefix: /usr
  19. #--------------------------------------------------------------------
  20. %description
  21. Cabinet (.CAB) files are a form of archive, which Microsoft use to
  22. distribute their software, and things like Windows Font Packs. The
  23. cabextract program unpacks these files.
  24. %description -l ja
  25. Microsoft社の配布するソフトウェア、例えば Windowsフォントパック等で
  26. 使用されているキャビネット(.CAB)形式のアーカイブファイルがあります。
  27. cabextractプログラムはこれらのファイルの解凍を行います。
  28. #--------------------------------------------------------------------
  29. %prep
  30. %setup
  31. %build
  32. CFLAGS=${RPM_OPT_FLAGS} ./configure --prefix=%{prefix}
  33. make
  34. %install
  35. rm -rf ${RPM_BUILD_ROOT}
  36. %makeinstall
  37. %clean
  38. [ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  39. #--------------------------------------------------------------------
  40. %files
  41. %defattr(0644, root, root, 0755)
  42. %doc AUTHORS ChangeLog NEWS README
  43. %attr(0755, root, root) %{_bindir}/cabextract
  44. %{_mandir}/man1/cabextract.1*
  45. #--------------------------------------------------------------------
  46. %changelog
  47. * Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2-2
  48. - spec in UTF-8
  49. * Mon Mar 24 2008 Seiichirou Babasaki 1.2
  50. - Import cabextract - Packager: Babasaki
  51. - Updated specfile